file-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447
  1. %define __libtoolize :
  2. Summary: A utility for determining file types.
  3. Summary(ja): ファイルの種類を判別するユーティリティー
  4. Name: file
  5. Version: 5.40
  6. Release: 2%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: BSD
  12. URL: http://www.darwinsys.com/file/
  13. # master site is toooooooooooooooooo slow
  14. # Source0: ftp://ftp.astron.com/pub/file/%{name}-%{version}.tar.gz
  15. %define altver %(echo %{version} | sed -e 's/\\./_/')
  16. Source0: https://github.com/file/file/archive/FILE%{altver}.tar.gz#/file-FILE%{altver}.tar.gz
  17. # Addtional magic file for Vine
  18. Source10: magic.printer-j
  19. # Upstream says it's up to distributions to add a way to support local-magic.
  20. Patch0: file-localmagic.patch
  21. # not yet upstream
  22. Patch1: file-4.17-rpm-name.patch
  23. Patch2: file-5.04-volume_key.patch
  24. # Upstream commit 9b0459afab309a82aa4e46f73a4e50dd641f3d39
  25. Patch3: file-5.40-magic-xzip.patch
  26. # Upstream commit f06015040e7ffb3be21bb7622f9f8291b749aaf9
  27. Patch4: file-5.40-magic-unsigned.patch
  28. # Upstream commit 7d9b0f0d853957ad88dae0f440fecd58d2740ca7
  29. Patch5: file-5.40-magic-python.patch
  30. # Vine
  31. Patch1000: file-5.14-magicbuild-fix.patch
  32. Buildroot: %{_tmppath}/%{name}-%{version}-root
  33. #BuildRequires: automake
  34. #BuildRequires: autoconf
  35. BuildRequires: zlib-devel
  36. Obsoletes: file-static
  37. %description
  38. The file command is used to identify a particular file according to the
  39. type of data contained by the file. File can identify many different
  40. file types, including ELF binaries, system libraries, RPM packages, and
  41. different graphics formats.
  42. You should install the file package, since the file command is such a
  43. useful utility.
  44. %description -l ja
  45. file コマンドは、ファイルに含まれるデータの種類によって各ファイルが
  46. どのようなファイルかを判定するために使います。file は ELF バイナリ、シ
  47. ステムライブラリ、RPM パッケージ、そして様々なグラフィックフォーマット
  48. を含む、多くの異なるファイルの種類を見分けることができます。
  49. %package devel
  50. Summary: Libraries and header files for file development
  51. Summary(ja): libmagic の開発用ファイル
  52. Group: programming
  53. Requires: %{name} = %{version}-%{release}
  54. %description devel
  55. The file-devel package contains the header files and libmagic library
  56. necessary for developing programs using libmagic.
  57. %package -n python-magic
  58. Summary: Python bindings for the libmagic API
  59. Group: programming
  60. BuildRequires: python-devel
  61. BuildRequires: python-setuptools
  62. BuildRequires: python-rpm-macros
  63. Requires: %{name} = %{version}-%{release}
  64. %description -n python-magic
  65. This package contains the Python bindings to allow access to the
  66. libmagic API. The libmagic library is also used by the familiar
  67. file(1) command.
  68. %package -n python3-magic
  69. Summary: Python bindings for the libmagic API
  70. Group: programming
  71. BuildRequires: python3-devel
  72. BuildRequires: python3-setuptools
  73. BuildRequires: python3-rpm-macros
  74. Requires: %{name} = %{version}-%{release}
  75. %description -n python3-magic
  76. This package contains the Python bindings to allow access to the
  77. libmagic API. The libmagic library is also used by the familiar
  78. file(1) command.
  79. %debug_package
  80. %prep
  81. %setup -q -n file-FILE%{altver}
  82. autoreconf -ivf
  83. %autopatch -p1
  84. cat %{SOURCE10} >> ./magic/Localstuff
  85. iconv -f iso-8859-1 -t utf-8 < doc/libmagic.man > doc/libmagic.man_
  86. touch -r doc/libmagic.man doc/libmagic.man_
  87. mv doc/libmagic.man_ doc/libmagic.man
  88. %build
  89. autoreconf
  90. CFLAGS="%{optflags} -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" \
  91. %configure --enable-fsect-man5 --disable-rpath
  92. # remove hardcoded library paths from local libtool
  93. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  94. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  95. export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{name}-%{version}/src/.libs
  96. make
  97. cd python
  98. %py_build
  99. %py3_build
  100. %install
  101. rm -rf $RPM_BUILD_ROOT
  102. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  103. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
  104. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  105. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man5
  106. mkdir -p $RPM_BUILD_ROOT%{_datadir}/misc
  107. mkdir -p $RPM_BUILD_ROOT%{_datadir}/file
  108. make install DESTDIR=$RPM_BUILD_ROOT
  109. cat magic/Magdir/* > ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  110. ln -s misc/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  111. ##ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  112. ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/file/magic
  113. cd python
  114. %py_install
  115. %py3_install
  116. %{__install} -d ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  117. # LIBTOOL=/usr/bin/libtool
  118. #ln -s file/magic ${RPM_BUILD_ROOT}%{_datadir}/magic
  119. #ln -s file/magic.mime ${RPM_BUILD_ROOT}%{_datadir}/magic.mime
  120. #ln -s ../magic ${RPM_BUILD_ROOT}%{_datadir}/misc/magic
  121. #{ cd ${RPM_BUILD_ROOT}
  122. # strip .%{_bindir}/file
  123. # cp %SOURCE1 .%{_datadir}/magic.mime
  124. #}
  125. # remove unused files
  126. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  127. %ifarch x86_64
  128. %check
  129. export LD_LIBRARY_PATH=$PWD/src/.libs
  130. make -C tests check
  131. %endif
  132. %clean
  133. rm -rf $RPM_BUILD_ROOT
  134. %files
  135. %defattr(-,root,root)
  136. %license COPYING
  137. %doc ChangeLog README
  138. %{_bindir}/*
  139. %{_libdir}/libmagic.so.*
  140. %{_datadir}/file/*
  141. %{_datadir}/magic*
  142. %{_datadir}/misc/*
  143. %{_mandir}/man[15]/*
  144. %files devel
  145. %defattr(-,root,root,-)
  146. %{_libdir}/*.so
  147. %{_libdir}/pkgconfig/*
  148. %{_includedir}/magic.h
  149. %{_mandir}/man3/*
  150. %files -n python-magic
  151. %defattr(-, root, root, -)
  152. %license python/LICENSE
  153. %doc python/README* python/example.py
  154. %{python_sitelib}/magic.py
  155. %{python_sitelib}/magic.pyc
  156. %{python_sitelib}/magic.pyo
  157. %{python_sitelib}/*egg-info
  158. %files -n python3-magic
  159. %defattr(-, root, root, -)
  160. %license python/LICENSE
  161. %doc python/README* python/example.py
  162. %{python3_sitelib}/*
  163. %changelog
  164. * Thu Aug 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.40-2
  165. - renumbered patches.
  166. - imported Patch3-5 from upstream.
  167. * Wed Apr 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.40-1
  168. - new upstream release.
  169. - dropped ldconfig scriptlets.
  170. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.39-1
  171. - new upstream release.
  172. - dropped Patch14 and 9000: fixed in upstream.
  173. * Sun Oct 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-2
  174. - added Patch9000.
  175. * Sat Oct 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.37-1
  176. - new upstream release.
  177. - added python3 support.
  178. - updated Patch0.
  179. - dropped Patch1, 5-17 and 100: fixed in upstream.
  180. - imported Patch14 from rawhide.
  181. * Thu Jul 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.28-1
  182. - new upstream release.
  183. - dropped Patch200: fixed in upstream.
  184. - updated patches.
  185. - imported Patch15,17 and 100.
  186. * Sat Nov 15 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.20-1
  187. - new upstream release
  188. - update/drop patches based on fc22
  189. * Fri Oct 24 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.14-7
  190. - reflected 6.0 updates and bumped release
  191. * Thu Sep 11 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-6
  192. - drop patch230 (moved to patch320)
  193. - add Patch240 for fix CVE-2014-0207
  194. - add Patch250 for fix CVE-2014-0237
  195. - add Patch260 for fix CVE-2014-0238
  196. - add Patch270 for fix CVE-2014-3478
  197. - add Patch280 for fix CVE-2014-3479
  198. - add Patch290 for fix CVE-2014-3480
  199. - add Patch300 for fix CVE-2014-3487
  200. - add Patch310 for fix CVE-2014-3538
  201. - add Patch320 for fix CVE-2014-3587
  202. These patches are from debian/ubuntu, thanks.
  203. * Thu Aug 28 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-5
  204. - add patch230 for fix CVE-2014-3587 (cdf_read_property_info)
  205. * Thu Mar 27 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-4
  206. - add patch110,220 for fix regression of CVE-2014-2270
  207. * Wed Mar 12 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-3
  208. - add patch210 for fix CVE-2014-2270
  209. * Thu Feb 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-2
  210. - add patch200 for fix CVE-2014-1943
  211. * Sun Jul 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.14-2
  212. - rebuild with VineSeed environment
  213. * Sun Sep 22 2013 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.14-1
  214. - new upstream reelase
  215. - add patch100 to fix build error
  216. - remove -static subpackage and add Obs: file-static
  217. - fix old changelog date...
  218. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.11-1
  219. - new upstream reelase
  220. - drop all local patches
  221. - import fedora patches
  222. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-3
  223. - rebuild with python-2.7.2
  224. * Sun Feb 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.05-2
  225. - rebuild package
  226. - fix Patch100
  227. * Sat Feb 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.05-1
  228. - new upstream release
  229. - updated Vine patches (but Patch100 has not been ported yet...)
  230. - split to devel and static subpackcages
  231. * Mon Sep 27 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.21-3
  232. - rebuilt with rpm-4.8.1
  233. - add environment variable LIBTOOL for make command
  234. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 4.21-2
  235. - spec in utf-8
  236. - removed *.la
  237. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.21-1
  238. - applied new versioning policy
  239. * Tue Dec 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.21-0vl1
  240. - new upstream release
  241. - import debian/fedora patches
  242. - drop obsolete vine magic.
  243. * Thu Jun 14 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl3
  244. - rebuild for VineSeed with new tool chain
  245. * Thu May 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.2
  246. - add patch110 for fix CVE-2007-2799
  247. - add zlib-devel to BuildPreReq tag
  248. * Mon Mar 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.09-0vl2.1
  249. - add patch100 for fix CVE-2007-1536
  250. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.09-0vl2
  251. - changed Group to Applications/System
  252. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.09-0vl1
  253. - new upstream release
  254. - update vine patches
  255. * Wed Sep 10 2003 Tomoya TAKA <taka@vinelinux.org> 4.03-0vl2
  256. - update Patch10, use 'size_t' in src/jcode.[ch]
  257. * Tue Sep 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
  258. - update to 4.03
  259. - update Patch0, 1, 10 for 4.03
  260. - s/Copyright/License/
  261. * Mon May 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-1vl1
  262. - update to 4.02
  263. - update Vine patches for 4.02
  264. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.41-0vl1
  265. - new upstream release
  266. - fixed security bug (http://www.idefense.com/advisory/03.04.03.txt)
  267. - remove unneeded patches.
  268. - update Vine patches for 3.41
  269. * Mon Apr 1 2002 Jun Nishii <jun@vinelinux.org> 3.37-0vl2
  270. - added NPDL2 data [Vine:02348]
  271. * Fri Feb 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.37-0vl1
  272. - update to 3.37
  273. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  274. - 3.35-0vl3
  275. - disable some entries in elf for problems on big-endian archs
  276. * Wed Jun 6 2001 Jun Nishii <jun@vinelinux.org>
  277. - file-3.35-0vl1
  278. - ver.up
  279. - added %doc
  280. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  281. - file-3.33-1vl4
  282. - more fix and clean up jtext patch (file-3.33-vinejtext.patch)
  283. * Thu Jan 11 2001 Jun Nishii <jun@vinelinux.org>
  284. - file-3.33-1vl3
  285. - fix again jtext patch (file-3.33-vinejtext.patch)
  286. - added file-3.33-vinenames.patch to avoid miss-judgement
  287. * Wed Jan 10 2001 Jun Nishii <jun@vinelinux.org>
  288. - file-3.33-1vl2
  289. - update jtext patch (file-3.33-vinejtext.patch)
  290. * Mon Jan 8 2001 Jun Nishii <jun@vinelinux.org>
  291. - file-3.33-1vl1
  292. - modify description-ja and spec
  293. * Sun Jul 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  294. - file-3.28-2vl2
  295. - fixed %files section to handle compressed man pages
  296. * Tue Jun 13 2000 Lisa Sagami <czs14350@nifty.ne.jp>
  297. - marged RH 3.28-2 and Vine 3.27-3vl3
  298. * Wed Feb 16 2000 Cristian Gafton <gafton@redhat.com>
  299. - add ia64 patch from rth
  300. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  301. - handle compressed manpages
  302. - update to 3.28
  303. * Mon Sep 6 1999 Norihito Ohmori <ohmori@flatout.org>
  304. - Japanese Text detection bug fix. (by Toru Hoshina <hoshina@best.com>)
  305. * Fri Aug 27 1999 Norihito Ohmori <ohmori@flatout.org>
  306. - patch dues not apply bug.
  307. * Thu Aug 26 1999 Norihito Ohmori <ohmori@flatout.org>
  308. - not need kcc (Thanks for Toru Hoshina <hoshina@best.com>)
  309. - ASCII data and Shift JIS data detected in Japanese Text Detection bug fix.
  310. * Mon Aug 23 1999 Jeff Johnson <jbj@redhat.com>
  311. - identify ELF stripped files correctly (#4665).
  312. - use SPARC (not sparc) consistently throughout (#4665).
  313. - add entries for MS Office files (#4665).
  314. * Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
  315. - diddle magic so that *.tfm files are identified correctly.
  316. * Tue Jul 6 1999 Jeff Johnson <jbj@redhat.com>
  317. - update to 3.27.
  318. * Mon Mar 22 1999 Preston Brown <pbrown@redhat.com>
  319. - experimental support for realmedia files added
  320. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  321. - auto rebuild in the new build environment (release 5)
  322. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  323. - strip binary.
  324. * Fri Nov 27 1998 Jakub Jelinek <jj@ultra.linux.cz>
  325. - add SPARC V9 magic.
  326. * Tue Nov 10 1998 Jeff Johnson <jbj@redhat.com>
  327. - update to 3.26.
  328. * Mon Aug 24 1998 Jeff Johnson <jbj@redhat.com>
  329. - update to 3.25.
  330. - detect gimp XCF versions.
  331. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  332. - translations modified for de, fr, tr
  333. * Wed Apr 08 1998 Erik Troan <ewt@redhat.com>
  334. - updated to 3.24
  335. - buildrooted
  336. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  337. - built against glibc
  338. * Mon Mar 31 1997 Erik Troan <ewt@redhat.com>
  339. - Fixed problems caused by 64 bit time_t.
  340. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  341. - Improved recognition of Linux kernel images.