fluid-soundfont-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. Name: fluid-soundfont
  2. Version: 3.1
  3. Release: 11%{?_dist_release}
  4. Summary: Pro-quality GM/GS soundfont
  5. Group: Applications/Multimedia
  6. License: MIT
  7. # The original URL (http://www.powermage.com/fluid) seems dead. Therefore we point
  8. # to the Hammersound archives:
  9. URL: http://www.hammersound.com/cgi-bin/soundlink.pl?action=view_category&category=Collections&ListStart=0&ListLength=20
  10. # The Hammersound source gives us a soundfont in a linux-unfriendly .sfArk format.
  11. # In order to convert this to a linux-friendly .sf2 format one needs to use a
  12. # non-free utility sfarkxtc from
  13. # http://www.melodymachine.com
  14. # This page explains how this conversion is done:
  15. # http://vsr.informatik.tu-chemnitz.de/staff/jan/nted/doc/ch01s46.html
  16. # Debian folks already did this and we will borrow their source tarball:
  17. Source0: http://ftp.de.debian.org/debian/pool/main/f/%{name}/%{name}_%{version}.orig.tar.gz
  18. # Some information about the soundfont that can be found in the Hammersound archive:
  19. Source1: Fluid_R3_Readme.pdf
  20. # Optimized cfg files for fluid usage with timidity, written by Saito, one of
  21. # the TiMidity++ developers
  22. Source2: timidity++.cfg
  23. Source3: fluid3gm.cfg
  24. Source4: fluid3gs.cfg
  25. Source5: fluid_altassign.cfg
  26. BuildArch: noarch
  27. BuildRequires: soundfont-utils
  28. %define common_description \
  29. FluidR3 is the third release of Frank Wen's pro-quality GM/GS soundfont.\
  30. The soundfont has lots of excellent samples, including all the GM instruments\
  31. along side with the GS instruments that are recycled and reprogrammed versions\
  32. of the GM presets.
  33. %description
  34. %common_description
  35. %package common
  36. Summary: Common files for FluidR3 soundfont
  37. Group: Applications/Multimedia
  38. %description common
  39. %common_description
  40. This package contains common files shared among all FluidR3 soundfont packages.
  41. %package gm
  42. Summary: Pro-quality General Midi soundfont
  43. Group: Applications/Multimedia
  44. Requires: %{name}-common = %{version}-%{release}
  45. Provides: soundfont2
  46. Provides: soundfont2-default
  47. # If timidity++ is installed it must understand the trysouce configfile keyword
  48. Conflicts: timidity++ <= 2.13.2-30.cvs20111110%{?dist}
  49. %description gm
  50. %common_description
  51. This package contains Fluid General Midi (GM) soundfont in soundfont 2.0 (.sf2)
  52. format.
  53. %package gs
  54. Summary: Pro-quality General Standard Extension soundfont
  55. Group: Applications/Multimedia
  56. Requires: %{name}-common = %{version}-%{release}
  57. Requires: %{name}-gm = %{version}-%{release}
  58. Provides: soundfont2
  59. %description gs
  60. %common_description
  61. This package contains instruments belonging to General Midi's General Standard
  62. (GS) Extension in soundfont 2.0 (.sf2) format.
  63. %package lite-patches
  64. Summary: Pro-quality General Midi soundfont in GUS patch format
  65. Group: Applications/Multimedia
  66. Requires: %{name}-common = %{version}-%{release}
  67. Provides: timidity++-patches = 5
  68. Obsoletes: timidity++-patches < 5
  69. Obsoletes: PersonalCopy-Lite-patches < 5
  70. %description lite-patches
  71. %common_description
  72. This package contains Fluid General Midi (GM) soundfont in Gravis Ultrasound
  73. (GUS) patch (.pat) format.
  74. %prep
  75. %setup -q
  76. cp -a %{SOURCE1} .
  77. %build
  78. unsf -v -s -m FluidR3_GM.sf2
  79. unsf -v -s -m FluidR3_GS.sf2
  80. # Cut the size of the patches subpackage:
  81. for bank in GM-B{8,9,16} Standard{1,2,3,4,5,6,7} Room{1,2,3,4,5,6,7} Power{1,2,3} Jazz{1,2,3,4} Brush{1,2}; do
  82. sed -i "/$bank/d" FluidR3_GM.cfg
  83. rm -fr *$bank*
  84. done
  85. cat FluidR3_GM.cfg FluidR3_GS.cfg > FluidR3.cfg
  86. # The gus patches get used by a lot of different programs and some need the
  87. # path to the patches to be absolute
  88. sed -i 's|FluidR3_GM-|%{_datadir}/soundfonts/%{name}-lite-patches/FluidR3_GM-|g' FluidR3.cfg
  89. sed -i 's|FluidR3_GS-|%{_datadir}/soundfonts/%{name}-lite-patches/FluidR3_GS-|g' FluidR3.cfg
  90. %install
  91. %{__rm} -rf %{buildroot}
  92. # The actual soundfonts:
  93. mkdir -p $RPM_BUILD_ROOT%{_datadir}/soundfonts
  94. install -p -m 644 FluidR3_GM.sf2 $RPM_BUILD_ROOT%{_datadir}/soundfonts
  95. install -p -m 644 FluidR3_GS.sf2 $RPM_BUILD_ROOT%{_datadir}/soundfonts
  96. # Create a symlink to denote that this is the Fedora default soundfont
  97. ln -s FluidR3_GM.sf2 $RPM_BUILD_ROOT%{_datadir}/soundfonts/default.sf2
  98. # timidity++.cfg files for usage of the sf2 files with the real timidity
  99. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
  100. install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}
  101. install -p -m 644 %{SOURCE3} %{SOURCE4} %{SOURCE5} \
  102. $RPM_BUILD_ROOT%{_datadir}/soundfonts
  103. # Gus patches + timidity.cfg, for programs which want the "old" timidity.cfg
  104. mkdir -p $RPM_BUILD_ROOT%{_datadir}/soundfonts/%{name}-lite-patches
  105. cp -a FluidR3_GM-* $RPM_BUILD_ROOT%{_datadir}/soundfonts/%{name}-lite-patches
  106. cp -a FluidR3_GS-* $RPM_BUILD_ROOT%{_datadir}/soundfonts/%{name}-lite-patches
  107. install -p -m 644 FluidR3.cfg $RPM_BUILD_ROOT%{_sysconfdir}/timidity.cfg
  108. %clean
  109. %{__rm} -rf %{buildroot}
  110. %files common
  111. %doc COPYING README *Readme*
  112. %dir %{_datadir}/soundfonts/
  113. %files gm
  114. %{_sysconfdir}/timidity++.cfg
  115. %{_datadir}/soundfonts/FluidR3_GM.sf2
  116. %{_datadir}/soundfonts/default.sf2
  117. %{_datadir}/soundfonts/fluid3gm.cfg
  118. %{_datadir}/soundfonts/fluid_altassign.cfg
  119. %files gs
  120. %{_datadir}/soundfonts/FluidR3_GS.sf2
  121. %{_datadir}/soundfonts/fluid3gs.cfg
  122. %files lite-patches
  123. %config %{_sysconfdir}/timidity.cfg
  124. %{_datadir}/soundfonts/%{name}-lite-patches/
  125. %changelog
  126. * Thu Jan 9 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.1-11
  127. - initial build for Vine Linux
  128. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-11
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  130. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-10
  131. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  132. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-9
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  134. * Mon Apr 30 2012 Hans de Goede <hdegoede@redhat.com> - 3.1-8
  135. - Use trysource for the gs config in timidity++.cfg (rhbz#815611)
  136. * Sat Jan 21 2012 Hans de Goede <hdegoede@redhat.com> - 3.1-7
  137. - Add timidity++.cfg files tweaked for using FluidR3 with timidity++, written
  138. by Saito, one of the TiMidity++ developers
  139. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-6
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  141. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-5
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  143. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1-4
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  145. * Thu Mar 26 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-3
  146. - Add real (non-virtual) Obsoletes: PersonalCopy-Lite-patches < 5
  147. * Mon Mar 23 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-2
  148. - Build lite-patches package by default (remove conditionals)
  149. - Include only mono banks in the lite-patches package
  150. - Create a symlink default.sf2 pointing to FluidR3_GM.sf2
  151. - Add "Provides: soundfont2" to gm and gs packages
  152. - Add "Provides: soundfont2-default" to gm package
  153. - Add "Obsoletes/Provides: timidity++-patches (<)= 5" to the lite-patches package
  154. - Add common subpackage for directory ownership and the doc files
  155. - Update descriptions
  156. * Sun Feb 01 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-1.2
  157. - Attempt to cut down the size of the (lite-)patches subpackage by extracting only
  158. a single layer for each instrument and by removing some banks
  159. * Sat Jan 31 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-1.1
  160. - Mockup for optional GUS-patches subpackages (disabled by default)
  161. * Fri Jan 30 2009 Orcan Ogetbil <oget [DOT] fedora [AT] gmail [DOT] com> 3.1-1
  162. - Initial Fedora build. SPEC file adapted from PersonalCopy-Lite-soundfont