gnome-flashback-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166
  1. %bcond_with systemd
  2. Summary: GNOME Flashback session and helper application
  3. Summary(ja): GNOMEフラッシュバックセッション及びヘルパーアプリケーション
  4. Name: gnome-flashback
  5. Version: 3.36.3
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv3
  10. URL: https://wiki.gnome.org/Projects/GnomeFlashback
  11. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  12. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: glib2-devel
  15. BuildRequires: gettext-devel
  16. BuildRequires: gtk3-devel
  17. BuildRequires: gdk-pixbuf2-devel
  18. BuildRequires: gnome-desktop3-devel
  19. BuildRequires: gnome-panel-devel
  20. BuildRequires: libcanberra-gtk3-devel
  21. BuildRequires: gsettings-desktop-schemas-devel
  22. BuildRequires: polkit-devel
  23. BuildRequires: ibus-devel
  24. BuildRequires: upower-devel
  25. BuildRequires: gnome-bluetooth-devel
  26. BuildRequires: libXrandr-devel
  27. BuildRequires: libXxf86vm-devel
  28. BuildRequires: libxcb-devel
  29. BuildRequires: libX11-devel
  30. BuildRequires: libXext-devel
  31. BuildRequires: libXi-devel
  32. BuildRequires: gdm-devel
  33. BuildRequires: pango-devel
  34. BuildRequires: libxkbfile-devel
  35. BuildRequires: xkeyboard-config
  36. BuildRequires: libXfixes-devel
  37. BuildRequires: pulseaudio-libs-devel
  38. BuildRequires: alsa-lib-devel
  39. BuildRequires: pam-devel
  40. %if %{with systemd}
  41. BuildRequires: systemd-devel
  42. %else
  43. BuildRequires: elogind-devel
  44. %endif
  45. Requires(posttrans,postun): desktop-file-utils
  46. Requires(posttrans,postun): glib2
  47. Requires: metacity
  48. Requires: gnome-panel
  49. Requires: gnome-applets
  50. Requires: gnome-session
  51. %description
  52. Gnome Flashback is a session for Gnome 3 which was initially called
  53. "Gnome Fallback", and shipped as a stand-alone session. It provides
  54. a similar user experience to the Gnome 2.x series sessions.
  55. The differences to the Mate project is that Gnome Flashback uses Gtk+3
  56. and tries to follow the current Gnome development by integrating
  57. recent changes of the Gnome libraries.
  58. %prep
  59. %setup -q
  60. %if !%{with systemd}
  61. sed -i \
  62. -e 's|systemd/sd-journal\.h|elogind/sd-journal\.h|' \
  63. ./gnome-flashback/libdesktop/gf-utils.c
  64. sed -i \
  65. -e 's|systemd/sd-login\.h|elogind/sd-login\.h|' \
  66. ./gnome-flashback/libscreensaver/gf-screensaver-utils.c \
  67. ./gnome-flashback/libscreensaver/gf-unlock-dialog.c
  68. sed -i \
  69. -e 's/libsystemd/libelogind/g' \
  70. ./configure.ac
  71. autoreconf -vif
  72. %endif
  73. %build
  74. %configure \
  75. --disable-static \
  76. %if %{with systemd}
  77. --enable-systemd-session=yes \
  78. %else
  79. --enable-systemd-session=no \
  80. %endif
  81. --with-compiz-session=no
  82. make %{?_smp_mflags}
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  86. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  87. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}
  88. %find_lang %{name} --with-gnome
  89. %clean
  90. rm -rf $RPM_BUILD_ROOT
  91. %postun
  92. if [ $1 -eq 0 ]; then
  93. update-desktop-database -q &> /dev/null ||:
  94. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  95. fi
  96. %posttrans
  97. update-desktop-database -q &> /dev/null ||:
  98. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  99. %files -f %{name}.lang
  100. %defattr(-,root,root,-)
  101. %license COPYING
  102. %doc README NEWS
  103. %{_sysconfdir}/xdg/autostart/gnome-flashback-clipboard.desktop
  104. %{_sysconfdir}/xdg/autostart/gnome-flashback-nm-applet.desktop
  105. %{_sysconfdir}/xdg/menus/gnome-flashback-applications.menu
  106. %{_bindir}/%{name}
  107. %dir %{_libdir}/gnome-panel
  108. %dir %{_libdir}/gnome-panel/modules
  109. %{_libdir}/gnome-panel/modules/system_indicators.so
  110. %{_libexecdir}/gnome-flashback-clipboard
  111. %{_libexecdir}/gnome-flashback-metacity
  112. %{_datadir}/applications/gnome-flashback.desktop
  113. %{_datadir}/desktop-directories/X-GNOME-Flashback-Settings-System.directory
  114. %{_datadir}/desktop-directories/X-GNOME-Flashback-Settings.directory
  115. %{_datadir}/glib-2.0/schemas/*
  116. %{_datadir}/gnome-panel/layouts/gnome-flashback.layout
  117. %{_datadir}/gnome-session/sessions/gnome-flashback-metacity.session
  118. %{_datadir}/xsessions/gnome-flashback-metacity.desktop
  119. %if %{with systemd}
  120. %{_userunitdir}/*
  121. %endif
  122. %changelog
  123. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.36.3-1
  124. - new upstream release.
  125. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-2
  126. - rebuilt with tracker-2.2.2.
  127. * Sun Dec 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.30.0-1
  128. - new upstream release.
  129. * Mon Jul 18 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.1-1
  130. - new upstream release