gnome-initial-setup-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577
  1. %bcond_with systemd
  2. %global nm_version 1.2
  3. %global nma_version 1.0
  4. %global glib_required_version 2.63.1
  5. %global gtk_required_version 3.11.3
  6. %global geoclue_version 2.3.1
  7. Name: gnome-initial-setup
  8. Summary: Bootstrapping your OS
  9. Version: 40.0
  10. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  11. Group: system,desktop-gnome
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: GPLv2+
  15. URL: https://wiki.gnome.org/Design/OS/InitialSetup
  16. %global shortver %(echo %{version} | cut -d . -f 1)
  17. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  18. Source1: vendor.conf
  19. BuildRequires: meson
  20. BuildRequires: gcc
  21. BuildRequires: krb5-devel
  22. BuildRequires: desktop-file-utils
  23. BuildRequires: libpwquality-devel
  24. BuildRequires: NetworkManager-libnm-devel >= %{nm_version}
  25. BuildRequires: pkgconfig(libnma) >= %{nma_version}
  26. BuildRequires: pkgconfig(accountsservice)
  27. BuildRequires: pkgconfig(gnome-desktop-3.0)
  28. BuildRequires: pkgconfig(gstreamer-1.0)
  29. BuildRequires: pkgconfig(cheese)
  30. BuildRequires: pkgconfig(cheese-gtk) >= 3.3.5
  31. BuildRequires: pkgconfig(fontconfig)
  32. BuildRequires: pkgconfig(geocode-glib-1.0)
  33. BuildRequires: pkgconfig(gweather-3.0)
  34. BuildRequires: pkgconfig(goa-1.0)
  35. BuildRequires: pkgconfig(goa-backend-1.0)
  36. BuildRequires: pkgconfig(gtk+-3.0) >= %{gtk_required_version}
  37. BuildRequires: pkgconfig(glib-2.0) >= %{glib_required_version}
  38. BuildRequires: pkgconfig(gio-2.0) >= %{glib_required_version}
  39. BuildRequires: pkgconfig(gio-unix-2.0) >= %{glib_required_version}
  40. BuildRequires: pkgconfig(gdm)
  41. BuildRequires: pkgconfig(iso-codes)
  42. BuildRequires: geoclue2-devel >= %{geoclue_version}
  43. BuildRequires: pkgconfig(packagekit-glib2)
  44. BuildRequires: pkgconfig(webkit2gtk-4.0)
  45. BuildRequires: krb5-devel
  46. BuildRequires: ibus-devel
  47. BuildRequires: rest-devel
  48. BuildRequires: polkit-devel
  49. BuildRequires: libsecret-devel
  50. # gnome-initial-setup is being run by gdm
  51. Requires: gdm
  52. Requires: geoclue2%{?_isa} >= %{geoclue_version}
  53. Requires: glib2%{?_isa} >= %{glib_required_version}
  54. # we install a rules file
  55. Requires: polkit
  56. Requires: libgnomekbd
  57. Requires(pre): shadow-utils
  58. Provides: user(%name)
  59. %description
  60. GNOME Initial Setup is an alternative to firstboot, providing
  61. a good setup experience to welcome you to your system, and walks
  62. you through configuring it. It is integrated with gdm.
  63. %debug_package
  64. %prep
  65. %autosetup -p1
  66. %build
  67. %meson \
  68. -Dparental_controls=disabled \
  69. -Dvendor-conf-file=%{_datadir}/gnome-initial-setup/vendor.conf \
  70. %if %{with systemd}
  71. -Dsystemd=true
  72. %else
  73. -Dsystemd=false
  74. %endif
  75. %meson_build
  76. %install
  77. %meson_install
  78. # Desktop file does not (and probably will not) ever validate, as it uses
  79. # an absolute path /tmp/-style trigger to determine whether to autostart.
  80. # desktop-file-validate %%{buildroot}/%%{_sysconfdir}/xdg/autostart/gnome-welcome-tour.desktop
  81. desktop-file-validate %{buildroot}%{_sysconfdir}/xdg/autostart/gnome-initial-setup-first-login.desktop
  82. desktop-file-validate %{buildroot}%{_sysconfdir}/xdg/autostart/gnome-initial-setup-copy-worker.desktop
  83. mkdir -p %{buildroot}%{_datadir}/gnome-initial-setup
  84. cp %{SOURCE1} %{buildroot}%{_datadir}/gnome-initial-setup/
  85. %if !%{with systemd}
  86. rm -f %{buildroot}/usr/lib/systemd
  87. %endif
  88. %find_lang %{name}
  89. %pre
  90. useradd -rM -d /run/gnome-initial-setup/ -s /sbin/nologin %{name} &>/dev/null || :
  91. %files -f %{name}.lang
  92. %license COPYING
  93. %doc README.md
  94. %{_libexecdir}/gnome-initial-setup
  95. %{_libexecdir}/gnome-initial-setup-copy-worker
  96. %{_sysconfdir}/xdg/autostart/gnome-initial-setup-copy-worker.desktop
  97. %{_sysconfdir}/xdg/autostart/gnome-initial-setup-first-login.desktop
  98. %{_datadir}/applications/gnome-initial-setup.desktop
  99. %{_datadir}/gnome-session/sessions/gnome-initial-setup.session
  100. %{_datadir}/gnome-shell/modes/initial-setup.json
  101. %{_datadir}/polkit-1/rules.d/20-gnome-initial-setup.rules
  102. %if %{with systemd}
  103. %{_userunitdir}/*
  104. %endif
  105. %dir %{_datadir}/gnome-initial-setup
  106. %{_datadir}/gnome-initial-setup/vendor.conf
  107. %changelog
  108. * Fri Apr 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 40.0-1
  109. - new upstream release.
  110. * Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.36.4-2
  111. - initial build for Vine Linux.
  112. * Mon Jul 20 2020 Kalev Lember <klember@redhat.com> - 3.36.4-1
  113. - Update to 3.36.4
  114. * Tue Jun 23 2020 Adam Williamson <awilliam@redhat.com> - 3.36.3-2
  115. - Backport MR #89 to fix 'disabled' timezone page setting timezone
  116. * Mon Jun 01 2020 Kalev Lember <klember@redhat.com> - 3.36.3-1
  117. - Update to 3.36.3
  118. * Mon Apr 27 2020 Kalev Lember <klember@redhat.com> - 3.36.2-1
  119. - Update to 3.36.2
  120. * Sat Mar 28 2020 Kalev Lember <klember@redhat.com> - 3.36.1-1
  121. - Update to 3.36.1
  122. * Fri Mar 06 2020 Kalev Lember <klember@redhat.com> - 3.36.0-1
  123. - Update to 3.36.0
  124. * Mon Mar 02 2020 Kalev Lember <klember@redhat.com> - 3.35.92-1
  125. - Update to 3.35.92
  126. * Mon Feb 17 2020 Kalev Lember <klember@redhat.com> - 3.35.91-1
  127. - Update to 3.35.91
  128. * Tue Feb 04 2020 Kalev Lember <klember@redhat.com> - 3.35.90-1
  129. - Update to 3.35.90
  130. * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.35.3-3
  131. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  132. * Thu Jan 16 2020 Kalev Lember <klember@redhat.com> - 3.35.3-2
  133. - Rebuilt for libgnome-desktop soname bump
  134. * Tue Jan 07 2020 Kalev Lember <klember@redhat.com> - 3.35.3-1
  135. - Update to 3.35.3
  136. * Tue Jan 07 2020 Kalev Lember <klember@redhat.com> - 3.34.3-1
  137. - Update to 3.34.3
  138. * Mon Oct 07 2019 Kalev Lember <klember@redhat.com> - 3.34.1-1
  139. - Update to 3.34.1
  140. * Mon Sep 09 2019 Benjamin Berg <bberg@redhat.com> - 3.34.0-2
  141. - Fix g-i-s starting in GDM
  142. Upstream MR https://gitlab.gnome.org/GNOME/gnome-initial-setup/merge_requests/59
  143. - Resolves: 1750237
  144. * Mon Sep 09 2019 Kalev Lember <klember@redhat.com> - 3.34.0-1
  145. - Update to 3.34.0
  146. * Wed Sep 04 2019 Benjamin Berg <bberg@redhat.com> - 3.33.92-2
  147. - Include upstream patches to fix systemd support
  148. https://gitlab.gnome.org/GNOME/gnome-initial-setup/merge_requests/58
  149. - Resolves: 1746563
  150. * Tue Sep 03 2019 Kalev Lember <klember@redhat.com> - 3.33.92-1
  151. - Update to 3.33.92
  152. * Tue Aug 20 2019 Kalev Lember <klember@redhat.com> - 3.33.91-1
  153. - Update to 3.33.91
  154. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.33.4-3
  155. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  156. * Sun Jul 21 2019 Kalev Lember <klember@redhat.com> - 3.33.4-2
  157. - Rebuilt for libgnome-desktop soname bump
  158. * Mon Jul 15 2019 Kalev Lember <klember@redhat.com> - 3.33.4-1
  159. - Update to 3.33.4
  160. * Mon Jul 08 2019 Kalev Lember <klember@redhat.com> - 3.33.2-2
  161. - Rebuilt for libgweather soname bump
  162. * Tue May 21 2019 Kalev Lember <klember@redhat.com> - 3.33.2-1
  163. - Update to 3.33.2
  164. * Tue Apr 16 2019 Adam Williamson <awilliam@redhat.com> - 3.32.1-2
  165. - Rebuild with Meson fix for #1699099
  166. * Sat Apr 06 2019 Kalev Lember <klember@redhat.com> - 3.32.1-1
  167. - Update to 3.32.1
  168. * Thu Apr 04 2019 Ray Strode <rstrode@redhat.com> - 3.32.0-1
  169. - Update to 3.32.0
  170. * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.30.0-2
  171. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  172. * Sat Sep 22 2018 Kalev Lember <klember@redhat.com> - 3.30.0-1
  173. - Update to 3.30.0
  174. * Fri Sep 07 2018 Kalev Lember <klember@redhat.com> - 3.29.92-1
  175. - Update to 3.29.92
  176. - Drop upstreamed patches reduce-initial-setup-redundancy.patch and
  177. allow-weak-passwords.patch
  178. - Rebase honor-firstboot-disabled.patch
  179. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.28.0-8
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  181. * Mon Apr 30 2018 Adam Williamson <awilliam@redhat.com> - 3.28.0-7
  182. - Drop unnecessary pkgconfig(NetworkManager) BuildRequire
  183. - Run autoreconf to avoid automake version mismatch
  184. * Wed Apr 11 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-6
  185. - Allow setting weak passwords
  186. * Mon Apr 02 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-5
  187. - Move vendor.conf to /usr/share
  188. * Sat Mar 31 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-4
  189. - Forgot to update vendor.conf in the previous build
  190. * Sat Mar 31 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-3
  191. - Update reduce initial setup redundancy patch again
  192. * Sat Mar 31 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.28.0-2
  193. - Update reduce initial setup redundancy patches
  194. * Tue Mar 13 2018 Kalev Lember <klember@redhat.com> - 3.28.0-1
  195. - Update to 3.28.0
  196. * Fri Feb 16 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.27.90-2
  197. - Install vendor.conf to conditionally suppress certain pages
  198. * Fri Feb 16 2018 Michael Catanzaro <mcatanzaro@gnome.org> - 3.27.90-1
  199. - Upgrade to 3.27.90 and add reduce initial setup redundancy patches
  200. * Tue Feb 13 2018 Björn Esser <besser82@fedoraproject.org> - 3.26.0-5
  201. - Rebuild against newer gnome-desktop3 package
  202. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.26.0-4
  203. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  204. * Mon Feb 05 2018 Kalev Lember <klember@redhat.com> - 3.26.0-3
  205. - Rebuilt for libgweather soname bump
  206. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 3.26.0-2
  207. - Rebuilt for switch to libxcrypt
  208. * Thu Sep 14 2017 Kalev Lember <klember@redhat.com> - 3.26.0-1
  209. - Update to 3.26.0
  210. * Thu Sep 07 2017 Kalev Lember <klember@redhat.com> - 3.25.92-1
  211. - Update to 3.25.92
  212. * Mon Jul 31 2017 Kalev Lember <klember@redhat.com> - 3.25.4-1
  213. - Update to 3.25.4
  214. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.3-2
  215. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  216. * Sun Jun 25 2017 Kalev Lember <klember@redhat.com> - 3.25.3-1
  217. - Update to 3.25.3
  218. * Wed May 10 2017 Kalev Lember <klember@redhat.com> - 3.24.2-1
  219. - Update to 3.24.2
  220. * Tue Mar 21 2017 Rui Matos <rmatos@redhat.com> - 3.24.0-1
  221. - Update to 3.24.0
  222. * Tue Mar 14 2017 Florian Müllner <fmuellner@redhat.com> - 3.23.92-1
  223. - Update to 3.23.92
  224. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.23.1-3
  225. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  226. * Tue Jan 31 2017 Rui Matos <rmatos@redhat.com> - 3.23.1-2
  227. - Honor anaconda's firstboot being disabled
  228. * Sun Oct 30 2016 Kalev Lember <klember@redhat.com> - 3.23.1-1
  229. - Update to 3.23.1
  230. * Wed Oct 12 2016 Kalev Lember <klember@redhat.com> - 3.22.1-1
  231. - Update to 3.22.1
  232. * Mon Sep 19 2016 Kalev Lember <klember@redhat.com> - 3.22.0-1
  233. - Update to 3.22.0
  234. * Tue Sep 13 2016 Kalev Lember <klember@redhat.com> - 3.21.92-1
  235. - Update to 3.21.92
  236. * Mon Sep 05 2016 Kalev Lember <klember@redhat.com> - 3.21.91-2
  237. - Build the software sources page
  238. * Sat Sep 03 2016 Kalev Lember <klember@redhat.com> - 3.21.91-1
  239. - Update to 3.21.91
  240. - Update project URL
  241. * Wed Apr 13 2016 Kalev Lember <klember@redhat.com> - 3.20.1-1
  242. - Update to 3.20.1
  243. * Tue Mar 22 2016 Kalev Lember <klember@redhat.com> - 3.20.0-1
  244. - Update to 3.20.0
  245. * Tue Mar 15 2016 Kalev Lember <klember@redhat.com> - 3.19.92-1
  246. - Update to 3.19.92
  247. * Tue Mar 01 2016 Richard Hughes <rhughes@redhat.com> - 3.19.91-1
  248. - Update to 3.19.91
  249. * Tue Feb 16 2016 Richard Hughes <rhughes@redhat.com> - 3.19.2-1
  250. - Update to 3.19.2
  251. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.19.1-2
  252. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  253. * Wed Oct 28 2015 Kalev Lember <klember@redhat.com> - 3.19.1-1
  254. - Update to 3.19.1
  255. * Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 3.18.0-1
  256. - Update to 3.18.0
  257. * Mon Aug 31 2015 Kalev Lember <klember@redhat.com> - 3.17.91-1
  258. - Update to 3.17.91
  259. * Mon Aug 17 2015 Kalev Lember <klember@redhat.com> - 3.17.90-1
  260. - Update to 3.17.90
  261. - Use make_install macro
  262. * Mon Aug 17 2015 Kalev Lember <klember@redhat.com> - 3.17.4-2
  263. - Rebuilt for libcheese soname bump
  264. * Mon Jul 27 2015 David King <amigadave@amigadave.com> - 3.17.4-1
  265. - Update to 3.17.4
  266. * Wed Jul 22 2015 David King <amigadave@amigadave.com> - 3.16.3-3
  267. - Bump for new gnome-desktop3
  268. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.16.3-2
  269. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  270. * Mon May 18 2015 Matthias Clasen <mclasen@redhat.com> - 3.16.3-1
  271. - Update to 3.16.3
  272. * Tue May 12 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-1
  273. - Update to 3.16.2
  274. * Wed Apr 15 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.1-1
  275. - Update to 3.16.1
  276. * Mon Mar 23 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.0-1
  277. - Update to 3.16.0
  278. * Wed Mar 18 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.92-1
  279. - Update to 3.15.92
  280. * Thu Mar 05 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.91.1-1
  281. - Update to 3.15.91.1
  282. * Mon Mar 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.91-1
  283. - Update to 3.15.91
  284. - Use the %%license macro for the COPYING file
  285. * Thu Feb 19 2015 Matthias Clasen <mclasen@redhat.com> - 3.15.90.1-1
  286. - Update to 3.15.90.1
  287. * Tue Dec 16 2014 Rui Matos <rmatos@redhat.com> - 3.14.2.1-2
  288. - Resolves: rhbz#1172363
  289. * Tue Nov 11 2014 Rui Matos <rmatos@redhat.com> - 3.14.2.1-1
  290. - Update to 3.14.2.1
  291. * Mon Nov 10 2014 Rui Matos <rmatos@redhat.com> - 3.14.2-1
  292. - Update to 3.14.2
  293. - Resolves: rhbz#1158442
  294. * Fri Oct 31 2014 Rui Matos <rmatos@redhat.com> - 3.14.1-3
  295. - Resolves: rhbz#1151519
  296. * Tue Oct 21 2014 Rui Matos <rmatos@redhat.com> - 3.14.1-2
  297. - Resolves: rhbz#1154206
  298. * Sat Oct 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-1
  299. - Update to 3.14.1
  300. * Tue Sep 23 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-1
  301. - Update to 3.14.0
  302. * Wed Sep 17 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.7-1
  303. - Update to 3.13.7
  304. * Tue Sep 16 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.6-1
  305. - Update to 3.13.6
  306. * Mon Sep 08 2014 Adam Williamson <awilliam@redhat.com> - 3.13.5-2
  307. - backport upstream patch to offer full list of keyboard layouts (BGO #729208)
  308. * Wed Sep 03 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.5-1
  309. - Update to 3.13.5
  310. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.13.4-3
  311. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  312. * Wed Aug 13 2014 Matthias Clasen <mclasen@redhat.com> - 3.13.4-2
  313. - Drop the yelp focus patch (we've dropped the yelp patch it depends on)
  314. * Fri Jul 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-1
  315. - Update to 3.13.4
  316. * Thu Jul 24 2014 Matthias Clasen <mclasen@redhat.com> - 3.12.1-3
  317. - Fix a memory corruption crash (#1116478)
  318. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.12.1-2
  319. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  320. * Thu May 15 2014 Kalev Lember <kalevlember@gmail.com> - 3.12.1-1
  321. - Update to 3.12.1
  322. * Tue Mar 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.12.0-1
  323. - Update to 3.12.0
  324. * Thu Mar 20 2014 Richard Hughes <rhughes@redhat.com> - 3.11.92-1
  325. - Update to 3.11.92
  326. * Sat Mar 08 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-1
  327. - Update to 3.11.91
  328. * Fri Feb 28 2014 Richard Hughes <rhughes@redhat.com> - 3.11.90-1
  329. - Update to 3.11.90
  330. * Wed Feb 19 2014 Kalev Lember <kalevlember@gmail.com> - 3.10.1.1-5
  331. - Rebuilt for libgnome-desktop soname bump
  332. * Fri Nov 29 2013 Rui Matos <rmatos@redhat.com> - 3.10.1.1-4
  333. - Resolves: rhbz#1035548 - Disables the GOA page in new user mode
  334. * Thu Nov 28 2013 Rui Matos <rmatos@redhat.com> - 3.10.1.1-3
  335. - Resolves: rhbz#1027507 - [abrt] gnome-initial-setup-3.10.1.1-2.fc20: magazine_chain_pop_head
  336. * Fri Nov 1 2013 Matthias Clasen <mclasen@redhat.com> - 3.10.1.1-2
  337. - Fix goa add dialog to not be empty
  338. * Mon Oct 28 2013 Richard Hughes <rhughes@redhat.com> - 3.10.1.1-1
  339. - Update to 3.10.1.1
  340. * Thu Sep 26 2013 Kalev Lember <kalevlember@gmail.com> - 3.10.0.1-1
  341. - Update to 3.10.0.1
  342. * Wed Sep 25 2013 Kalev Lember <kalevlember@gmail.com> - 3.10.0-1
  343. - Update to 3.10.0
  344. * Tue Sep 03 2013 Kalev Lember <kalevlember@gmail.com> - 0.12-7
  345. - Rebuilt for libgnome-desktop soname bump
  346. * Fri Aug 23 2013 Kalev Lember <kalevlember@gmail.com> - 0.12-6
  347. - Rebuilt for gnome-online-accounts soname bump
  348. * Fri Aug 09 2013 Kalev Lember <kalevlember@gmail.com> - 0.12-5
  349. - Rebuilt for cogl 1.15.4 soname bump
  350. * Tue Aug 06 2013 Adam Williamson <awilliam@redhat.com> - 0.12-4
  351. - rebuild for new libgweather
  352. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-3
  353. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  354. * Fri Jun 21 2013 Kalev Lember <kalevlember@gmail.com> - 0.12-2
  355. - Rebuilt for libgweather 3.9.3 soname bump
  356. * Mon Jun 17 2013 Rui Matos <rmatos@redhat.com> - 0.12-1
  357. - Update to 0.12
  358. * Fri Jun 7 2013 Matthias Clasen <mclasen@redhat.com> - 0.11-2
  359. - Require polkit-js-engine
  360. * Tue May 28 2013 Matthias Clasen <mclasen@redhat.com> - 0.11-1
  361. - Update to 0.11
  362. * Tue May 14 2013 Rui Matos <rmatos@redhat.com> - 0.10-1
  363. - Update to 0.10
  364. - Add BuildRequires on polkit-devel
  365. - Update files list
  366. * Thu May 2 2013 Rui Matos <rmatos@redhat.com> - 0.9-2
  367. - Remove unused patches
  368. - Add build requires for ibus
  369. * Tue Apr 16 2013 Matthias Clasen <mclasen@redhat.com> - 0.9-1
  370. - Update to 0.9
  371. * Tue Apr 16 2013 Ray Strode <rstrode@redhat.com> 0.8-4
  372. - Add requires for keyboard viewer app
  373. * Wed Mar 20 2013 Ray Strode <rstrode@redhat.com> 0.8-3
  374. - Add cosimoc fix for gd page transitions
  375. * Wed Mar 20 2013 Ray Strode <rstrode@redhat.com> 0.8-2
  376. - Disable gd page transitions for now since they don't
  377. completely work right (ask adamw).
  378. - Fix crasher when realmd goes away
  379. * Tue Mar 19 2013 Matthias Clasen <mclasen@redhat.com> - 0.8-1
  380. - Update to 0.8
  381. * Tue Mar 12 2013 Matthias Clasen <mclasen@redhat.com> - 0.7-1
  382. - Update to 0.7
  383. * Thu Feb 21 2013 Kalev Lember <kalevlember@gmail.com> - 0.6-4
  384. - Rebuilt for cogl soname bump
  385. * Wed Feb 20 2013 Kalev Lember <kalevlember@gmail.com> - 0.6-3
  386. - Rebuilt for libgnome-desktop soname bump
  387. * Fri Jan 25 2013 Peter Robinson <pbrobinson@fedoraproject.org> 0.6-2
  388. - Rebuild for new cogl
  389. * Wed Jan 16 2013 Matthias Clasen <mclasen@redhat.com> - 0.6-1
  390. - 0.6
  391. * Fri Jan 11 2013 Matthias Clasen <mclasen@redhat.com> - 0.5-1
  392. - 0.5
  393. * Fri Dec 21 2012 Kalev Lember <kalevlember@gmail.com> - 0.4-2
  394. - Rebuilt for libgweather soname bump
  395. * Thu Nov 22 2012 Matthias Clasen <mclasen@redhat.com> - 0.4-1
  396. - 0.4
  397. * Fri Oct 26 2012 Jasper St. Pierre <jstpierre@mecheye.net> - 0.3-3
  398. - Add krb5
  399. * Fri Oct 26 2012 Jasper St. Pierre <jstpierre@mecheye.net> - 0.3-2
  400. - 0.3-2
  401. * Thu Oct 18 2012 Matthias Clsaen <mclasen@redhat.com> - 0.3-1
  402. - 0.3
  403. * Fri Sep 14 2012 Matthias Clasen <mclasen@redhat.com> - 0.2-2
  404. - Add Requires: gdm
  405. * Wed Aug 29 2012 Jasper St. Pierre <jstpierre@mecheye.net> - 0.2-1
  406. - Update to 0.2
  407. * Fri Jun 08 2012 Jasper St. Pierre <jstpierre@mecheye.net> - 0.1
  408. - Initial packaging.