gnome-print-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278
  1. # Note that this is NOT a relocatable package
  2. %define ver 0.37
  3. %define rel 3%{?_dist_release}
  4. %define name gnome-print
  5. %define sover 15
  6. Summary: Gnome Print - Printing libraries for GNOME.
  7. Summary(ja): Gnome Print - GNOME用印刷ライブラリ
  8. Name: %{name}
  9. Version: %{ver}
  10. Release: %{rel}
  11. License: LGPL
  12. Group: Applications/Publishing
  13. Source: ftp://ftp.gnome.org/pub/GNOME/stable/sources/%{name}/%{name}-%{ver}.tar.bz2
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gnome-libs-devel >= 1.4.2-2vl5
  16. BuildRequires: libxml-devel
  17. BuildRequires: gdk-pixbuf-devel
  18. BuildRequires: freetype2-devel
  19. BuildRequires: automake14, autoconf213
  20. Requires: libgnomeprint%{sover} = %{version}
  21. Requires: urw-fonts ghostscript-fonts
  22. #Prereq: libxml urw-fonts ghostscript-fonts
  23. Requires: libxml urw-fonts ghostscript-fonts
  24. Obsoletes: gnome-print-beta < 0.26, gnome-print-bin < 0.26, gnome-print-beta-bin < 0.26, gnome-print-data < 0.26
  25. # RH patches
  26. Patch2: gnome-print-0.30-nofontmaps.patch
  27. # for Vine
  28. Patch50: gnome-print-0.34-fallback.patch
  29. Patch51: gnome-print-0.35-dynamicfallback.patch
  30. Patch52: gnome-print-0.37-ft2build.patch
  31. Patch60: gnome-print-0.37-config.patch
  32. Patch61: gnome-print-0.37-parseTT.patch
  33. %description
  34. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  35. applications and desktop tools to be used in conjunction with a window
  36. manager for the X Window System. GNOME is similar in purpose and scope
  37. to CDE and KDE, but GNOME is based completely on free software.
  38. The gnome-print package contains libraries and fonts that are needed by
  39. GNOME applications wanting to print.
  40. You should install the gnome-print package if you intend on using any of
  41. the GNOME applications that can print. If you would like to develop GNOME
  42. applications that can print you will also need to install the gnome-print
  43. devel package.
  44. %description -l ja
  45. 印刷できるGNOMEアプリケーションを使いたいなら、gnome-printパッケージを
  46. インストールする必要があります。もし印刷できるGNOMEアプリケーションを
  47. 開発したいなら、gnome-print-develパッケージをインストールする必要が
  48. あります。
  49. %package -n libgnomeprint%{sover}
  50. Summary: Printing libraries for GNOME
  51. Summary(ja): GNOME用印刷ライブラリ
  52. Group: System Environment/Libraries
  53. Obsoletes: gnome-print-beta < 0.26
  54. %description -n libgnomeprint%{sover}
  55. This package contains the printing apparatus for GNOME, the complete
  56. graphical desktop environment based entirely on free software.
  57. %package devel
  58. Summary: Libraries and include files for developing GNOME applications.
  59. Summary(ja): GNOME用印刷アプリケーション開発用ライブラリとヘッダファイル
  60. Group: Development/Libraries
  61. Obsoletes: gnome-print-beta-devel < 0.26
  62. Requires: %{name} = %{version}
  63. Requires: libgnomeprint%{sover} = %{version}
  64. Requires: gdk-pixbuf-devel
  65. %description devel
  66. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  67. applications and desktop tools to be used in conjunction with a window
  68. manager for the X Window System. GNOME is similar in purpose and scope
  69. to CDE and KDE, but GNOME is based completely on free software.
  70. The gnome-print-devel package includes the libraries and include files that
  71. you will need when developing applications that use the GNOME printing
  72. facilities.
  73. You should install the gnome-print-devel package if you would like to
  74. develop GNOME applications that will use the GNOME printing facilities.
  75. You don't need to install the gnome-print-devel package if you just want
  76. to use the GNOME desktop enviornment.
  77. %prep
  78. %setup -q
  79. %patch2 -p1 -b .nofontmaps
  80. %patch50 -p1 -b .fallback
  81. %patch51 -p1 -b .dynamic
  82. %patch52 -p1 -b .ft2build
  83. %patch60 -p0 -b .config
  84. %patch61 -p0 -b .parseTT
  85. %build
  86. libtoolize --copy --force
  87. autoheader-2.13
  88. automake-1.4
  89. autoconf-2.13
  90. %configure --disable-static
  91. make LIBTOOL=/usr/bin/libtool
  92. %install
  93. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  94. %makeinstall LIBTOOL=/usr/bin/libtool
  95. ./mkinstalldirs $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
  96. ./mkinstalldirs $RPM_BUILD_ROOT%{_sysconfdir}/gnome/fonts
  97. install -c fonts/*.font $RPM_BUILD_ROOT%{_datadir}/gnome-print/fonts
  98. cat > $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install <<__EOF__
  99. #! /bin/sh
  100. %{_bindir}/gnome-font-install --clean \
  101. --aliases=%{_datadir}/gnome-print/fonts/adobe-urw.font \
  102. --target=%{_sysconfdir}/gnome/fonts/gnome-print-rpm.fontmap \
  103. --recursive \
  104. %{_prefix}/X11R6/lib/X11/fonts \
  105. %{_datadir}/fonts
  106. __EOF__
  107. chmod a+x $RPM_BUILD_ROOT%{_bindir}/vine-update-gnome-font-install
  108. %find_lang %{name}
  109. ## remove unuse files
  110. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  111. %clean
  112. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  113. %post -p %{_bindir}/vine-update-gnome-font-install
  114. %post -n libgnomeprint%{sover} -p /sbin/ldconfig
  115. %postun -n libgnomeprint%{sover} -p /sbin/ldconfig
  116. %files -f %{name}.lang
  117. %defattr(-, root, root)
  118. %doc AUTHORS COPYING ChangeLog NEWS README
  119. %dir %{_datadir}/gnome-print
  120. %dir %{_datadir}/gnome-print/profiles
  121. %dir %{_sysconfdir}/gnome/fonts
  122. %{_datadir}/gnome-print/profiles/*
  123. %{_bindir}/*
  124. %{_datadir}/fonts/afms/adobe/*
  125. %{_datadir}/gnome-print/fonts
  126. %files -n libgnomeprint%{sover}
  127. %defattr(-, root, root)
  128. %{_libdir}/*.so.%{sover}.*
  129. %{_libdir}/*.so.%{sover}
  130. %files devel
  131. %defattr(-, root, root)
  132. %{_libdir}/*.so
  133. #{_libdir}/*.a
  134. #{_libdir}/*.la
  135. %{_libdir}/*.sh
  136. %{_includedir}/*
  137. %changelog
  138. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.37-3
  139. - added Patch60: gnome-print-0.37-config.patch
  140. - added Patch61: gnome-print-0.37-parseTT.patch
  141. * Sat May 2 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-2
  142. - rebuilt with gnome-libs-1.4.2-2vl5 (linking with db-4.6.21)
  143. - removed *.a
  144. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 0.37-1vl5
  145. - applied new versioning policy, spec in utf-8
  146. - removed *.la
  147. * Sat Jun 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl2
  148. - rebuilt with db4-4.3.29
  149. * Mon Oct 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.37-0vl1
  150. - updated to 0.37
  151. - rebuilt with db4-4.2.52
  152. - added Patch52 to build with freetype2
  153. - s/Copyright/License/
  154. - fixed %post, %postun section
  155. * Fri Jan 17 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.35-0vl2
  156. - rebuilt with db4 environment
  157. - added BuildPreReq: automake14, autoconf213
  158. * Wed Mar 20 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.35-0vl1
  159. - New upstream release.
  160. - vine-update-gnome-font-install: added a wrapper script for generating
  161. gnome-print's fontmap. it will helps us if font packages will calls it
  162. with %%post and %%postun.
  163. - %%post: changed calling vine-update-gnome-font-install.
  164. - gnome-print-0.35-dynamicfallback.patch:
  165. generate hash using NAMES file.
  166. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl3
  167. - Fixed fontmap generation.
  168. Note: don't remove --clean option. when gnome-font-install regenerate
  169. fontmap, it don't add the fonts which already exists.
  170. * Wed Dec 26 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.34-0vl2
  171. - added PreReq: freetype2 for gnome-font-install invoked from %%post section
  172. - commented out Requires: %%{name} >= %%{ver} from libgnomeprint15
  173. * Tue Dec 18 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.34-0vl1
  174. - New upstream release.
  175. * Sun Apr 1 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl3
  176. - Added Obsolates to libgnomeprint11.
  177. - Added some build requires.
  178. * Mon Mar 12 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.26-0vl2
  179. - New upstream release.
  180. * Tue Jan 23 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl6
  181. - Fixed -devel conflicts.
  182. * Tue Jan 9 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl5
  183. - Added Conflicts: line in -devel.
  184. * Wed Dec 27 2000 Akira TAGOH <tagoh@gnome.gr.jp> 0.20-0vl4
  185. - separated binary and data packages.
  186. * Fri Sep 15 2000 Jun Nishii <jun@vinelinux.org>
  187. - added prereq urw-fonts
  188. * Wed May 31 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  189. - modified jahack pach to fix threshold value of MB_CUR_MAX for glibc 2.1.3.
  190. * Mon May 30 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  191. - updated to 0.20
  192. * Mon May 29 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  193. - modified jahack patch for satbility of memory allocation.
  194. - modified jahack patch to fix text alignment.
  195. * Sat May 20 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  196. - modified jahack patch for preview.
  197. - added i18n_fix for nls.
  198. - added orignal ja.po.
  199. * Tue May 16 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  200. - updated to 0.19
  201. * Mon May 1 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  202. - updated to 0.18
  203. * Wed Feb 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  204. - updated to 0.12
  205. * Mon Jan 17 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  206. - added "quick hacked" ja patch.
  207. * Tue Nov 23 1999 Norihito Ohmori <ohmori@flatotu.org>
  208. - add Provides: libgnomeprint.so.2
  209. * Sat Oct 13 1999 Kazuhito Nishi <nishi@imasy.or.jp>
  210. - Added Prereq: zlib
  211. * Sun Aug 01 1999 Gregory McLean <gregm@comstar.net>
  212. - Undo my draconian uninstall stuff.
  213. * Tue Jul 20 1999 Gregory McLean <gregm@comstar.net>
  214. - Stab at cleaning up properly when we uninstall.
  215. * Fri Jul 16 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
  216. - fixed typo in spec
  217. * Wed Jul 14 1999 Gregory McLean <gregm@comstar.net>
  218. - Added fonts to the spec.
  219. * Mon Jul 05 1999 Gregory McLean <gregm@comstar.net>
  220. - Fleshed out the descriptions.