gnome-python-desktop-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define glib_version 2.26.0
  3. %define gtk_version 2.22.0
  4. %define pygtk_version 2.22.0
  5. %define gnome_python_version 2.28.0
  6. %define libgnome_keyring_version 2.32.0
  7. %define gnome_panel_version 2.32.0
  8. %define gnome_desktop_version 2.32.0
  9. %define gtksourceview2_version 2.10.5
  10. %define libgtop_version 2.28.2
  11. %define gnome_media_version 2.32.0
  12. %define metacity_version 2.30.3
  13. %define librsvg2_version 2.32.0
  14. %define totem_version 2.32.0
  15. %define libwnck_version 2.30.5
  16. %define bug_buddy_version 2.32.0
  17. %define evolution_data_server_version 2.32.0
  18. ### Abstract ###
  19. Name: gnome-python-desktop
  20. Version: 2.32.0
  21. Release: 2%{?_dist_release}
  22. License: GPL/LGPL
  23. Group: Development/Libraries
  24. Summary: The sources for additional PyGNOME Python extension modules
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Source: gnome-python-desktop-%{version}.tar.bz2
  27. ### Dependencies ###
  28. Requires: gnome-python >= %{gnome_python_version}
  29. ### Build Dependencies ###
  30. BuildRequires: glib2-devel >= %{glib_version}
  31. BuildRequires: gtk2-devel >= %{gtk_version}
  32. BuildRequires: python >= 2.6
  33. BuildRequires: pygtk2-devel >= %{pygtk_version}
  34. BuildRequires: gnome-python-devel >= %{gnome_python_version}
  35. BuildRequires: libgnome-keyring-devel >= %{libgnome_keyring_version}
  36. # BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
  37. BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
  38. BuildRequires: libgnomeprint-devel
  39. BuildRequires: libgnomeprintui-devel
  40. # BuildRequires: evince-devel
  41. BuildRequires: evolution-data-server >= %{evolution_data_server_version}
  42. BuildRequires: gtksourceview-devel >= %{gtksourceview_version}
  43. BuildRequires: libgtop2-devel >= %{libgtop_version}
  44. BuildRequires: gnome-media-devel >= %{gnome_media_version}
  45. BuildRequires: metacity-devel >= %{metacity_version}
  46. # BuildRequires: brasero-devel
  47. BuildRequires: librsvg2-devel >= %{librsvg2_version}
  48. BuildRequires: pycairo-devel
  49. BuildRequires: totem-pl-parser-devel >= %{totem_version}
  50. BuildRequires: totem >= %{totem_version}
  51. BuildRequires: libwnck-devel >= %{libwnck_version}
  52. BuildRequires: bug-buddy >= %{bug_buddy_version}
  53. BuildRequires: libSM-devel
  54. Obsoletes: gnome-python-applet < 2.32.0-2
  55. Obsoletes: gnome-python-brasero < 2.32.0-2
  56. Obsoletes: gnome-python-evince < 2.32.0-2
  57. %description
  58. The gnome-python-desktop package contains the source packages for additional
  59. Python bindings for GNOME. It should be used together with gnome-python.
  60. ## %package -n gnome-python-applet
  61. ## Summary: Python bindings for GNOME Panel applets.
  62. ## Group: Development/Libraries
  63. ## Requires: %{name} = %{version}-%{release}
  64. ## Obsoletes: pygnome-applet
  65. ## %description -n gnome-python-applet
  66. ## This module contains a wrapper that allows GNOME Panel applets to be
  67. ## written in Python.
  68. %package -n gnome-python-bugbuddy
  69. Summary: Python bindings for interacting with bug-buddy
  70. Group: Development/Libraries
  71. Requires: %{name} = %{version}-%{release}
  72. Requires: bug-buddy >= %{bug_buddy_version}
  73. %description -n gnome-python-bugbuddy
  74. This module contains a wrapper that allows the use of bug-buddy via
  75. Python.
  76. %package -n gnome-python-evolution
  77. Summary: Python bindings for interacting with evolution
  78. Group: Development/Libraries
  79. Requires: %{name} = %{version}-%{release}
  80. Requires: evolution-data-server >= %{evolution_data_server_version}
  81. %description -n gnome-python-evolution
  82. This module contains a wrapper that allows the use of evolution via
  83. Python.
  84. %package -n gnome-python-gnomeprint
  85. Summary: Python bindings for interacting with libgnomeprint
  86. Group: Development/Libraries
  87. Requires: %{name} = %{version}-%{release}
  88. Requires: libgnomeprint
  89. Requires: libgnomeprintui
  90. %description -n gnome-python-gnomeprint
  91. This module contains a wrapper that allows the use of libgnomeprint via
  92. Python.
  93. %package -n gnome-python-gtksourceview
  94. Summary: Python bindings for interacting with the gtksourceview library
  95. Group: Development/Libraries
  96. Requires: %{name} = %{version}-%{release}
  97. Requires: gtksourceview >= %{gtksourceview_version}
  98. Requires: gnome-python-gnomeprint
  99. %description -n gnome-python-gtksourceview
  100. This module contains a wrapper that allows the use of gtksourceview via
  101. Python.
  102. %package -n gnome-python-libwnck
  103. Summary: Python bindings for interacting with libwnck
  104. Group: Development/Libraries
  105. Requires: libwnck >= %{libwnck_version}
  106. %description -n gnome-python-libwnck
  107. This module contains a wrapper that allows the use of libwnck via
  108. Python.
  109. %package -n gnome-python-libgtop2
  110. Summary: Python bindings for interacting with libgtop
  111. Group: Development/Libraries
  112. Requires: %{name} = %{version}-%{release}
  113. Requires: libgtop2 >= %{libgtop_version}
  114. %description -n gnome-python-libgtop2
  115. This module contains a wrapper that allows the use of libgtop via
  116. Python.
  117. ## %package -n gnome-python-brasero
  118. ## Summary: Python bindings for interacting with brasero
  119. ## Group: Development/Libraries
  120. ## Requires: %{name} = %{version}-%{release}
  121. ## Requires: brasero-libs
  122. ## %description -n gnome-python-brasero
  123. ## This module contains a wrapper that allows the use of brasero
  124. ## via Python.
  125. %package -n gnome-python-metacity
  126. Summary: Python bindings for interacting with metacity
  127. Group: Development/Libraries
  128. Requires: %{name} = %{version}-%{release}
  129. Requires: metacity >= %{metacity_version}
  130. %description -n gnome-python-metacity
  131. This module contains a wrapper that allows the use of metacity
  132. via Python.
  133. %package -n gnome-python-totem
  134. Summary: Python bindings for interacting with totem
  135. Group: Development/Libraries
  136. Requires: %{name} = %{version}-%{release}
  137. Requires: totem >= %{totem_version}
  138. %description -n gnome-python-totem
  139. This module contains a wrapper that allows the use of totem
  140. via Python.
  141. %package -n gnome-python-rsvg
  142. Summary: Python bindings for interacting with librsvg
  143. Group: Development/Libraries
  144. Requires: librsvg2 >= %{librsvg2_version}
  145. Requires: pycairo
  146. %description -n gnome-python-rsvg
  147. This module contains a wrapper that allows the use of librsvg
  148. via Python.
  149. %package -n gnome-python-gnomedesktop
  150. Summary: Python bindings for interacting with gnome-desktop
  151. Group: Development/Libraries
  152. Requires: %{name} = %{version}-%{release}
  153. Requires: gnome-desktop >= %{gnome_desktop_version}
  154. %description -n gnome-python-gnomedesktop
  155. This module contains a wrapper that allows the use of gnome-desktop
  156. via Python.
  157. %package -n gnome-python-gnomekeyring
  158. Summary: Python bindings for interacting with gnome-keyring
  159. Group: Development/Libraries
  160. Requires: %{name} = %{version}-%{release}
  161. Requires: libgnome-keyring >= %{libgnome_keyring_version}
  162. %description -n gnome-python-gnomekeyring
  163. This module contains a wrapper that allows the use of gnome-keyring
  164. via Python.
  165. ## %package -n gnome-python-evince
  166. ## Summary: Python bindings for interacting with evince
  167. ## Group: Development/Libraries
  168. ## Requires: %{name} = %{version}-%{release}
  169. ## Requires: evince
  170. ## %description -n gnome-python-evince
  171. ## This module contains a wrapper that allows the use of evince
  172. ## via Python.
  173. %prep
  174. %setup -q -n gnome-python-desktop-%{version}
  175. %build
  176. ./waf configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-metacity
  177. ./waf build %{?_smp_mflags}
  178. %install
  179. rm -rf $RPM_BUILD_ROOT
  180. ./waf install --destdir=$RPM_BUILD_ROOT
  181. find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
  182. rm -rf $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/gksu
  183. %clean
  184. rm -rf $RPM_BUILD_ROOT
  185. %files
  186. %defattr(-,root,root,-)
  187. %doc AUTHORS ChangeLog NEWS
  188. %{_libdir}/pkgconfig/gnome-python-desktop-2.0.pc
  189. %{_datadir}/pygtk
  190. ## %files -n gnome-python-applet
  191. ## %defattr(-,root,root,-)
  192. ## %{python_sitearch}/gtk-2.0/gnomeapplet.so
  193. ## %defattr(644,root,root,755)
  194. ## %doc ../gnome-python-desktop-%{version}/examples/applet/*
  195. %files -n gnome-python-bugbuddy
  196. %defattr(-,root,root,-)
  197. %{python_sitearch}/gtk-2.0/bugbuddy.py*
  198. %files -n gnome-python-evolution
  199. %defattr(-,root,root,-)
  200. %dir %{python_sitearch}/gtk-2.0/evolution/
  201. %{python_sitearch}/gtk-2.0/evolution/*
  202. %files -n gnome-python-gnomeprint
  203. %defattr(-,root,root,-)
  204. %{python_sitearch}/gtk-2.0/gnomeprint/
  205. %{_datadir}/gtk-doc/html/pygnomeprint
  206. %{_datadir}/gtk-doc/html/pygnomeprintui
  207. %defattr(644,root,root,755)
  208. %doc ../gnome-python-desktop-%{version}/examples/gnomeprint/*
  209. %files -n gnome-python-gtksourceview
  210. %defattr(-,root,root,-)
  211. %{python_sitearch}/gtk-2.0/gtksourceview.so
  212. %{_datadir}/gtk-doc/html/pygtksourceview
  213. %defattr(644,root,root,755)
  214. %doc ../gnome-python-desktop-%{version}/examples/gtksourceview/*
  215. %files -n gnome-python-libwnck
  216. %defattr(-,root,root,-)
  217. %{python_sitearch}/gtk-2.0/wnck.so
  218. %defattr(644,root,root,755)
  219. %doc ../gnome-python-desktop-%{version}/examples/wnck_example.py
  220. %files -n gnome-python-libgtop2
  221. %defattr(-,root,root,-)
  222. %{python_sitearch}/gtk-2.0/gtop.so
  223. ## %files -n gnome-python-brasero
  224. ## %defattr(-,root,root,-)
  225. #%{python_sitearch}/gtk-2.0/braseroburn.so
  226. #%{python_sitearch}/gtk-2.0/braseromedia.so
  227. ## %defattr(644,root,root,755)
  228. ## %doc ../gnome-python-desktop-%{version}/examples/braseroburn/*
  229. ## %doc ../gnome-python-desktop-%{version}/examples/braseromedia/*
  230. %files -n gnome-python-metacity
  231. %defattr(-,root,root,-)
  232. %{python_sitearch}/gtk-2.0/metacity.so
  233. %files -n gnome-python-totem
  234. %defattr(-,root,root,-)
  235. %{python_sitearch}/gtk-2.0/mediaprofiles.so
  236. %{python_sitearch}/gtk-2.0/totem
  237. %files -n gnome-python-rsvg
  238. %{python_sitearch}/gtk-2.0/rsvg.so
  239. %defattr(644,root,root,755)
  240. %doc ../gnome-python-desktop-%{version}/examples/rsvg/*
  241. %files -n gnome-python-gnomedesktop
  242. %{python_sitearch}/gtk-2.0/gnomedesktop
  243. %files -n gnome-python-gnomekeyring
  244. %{python_sitearch}/gtk-2.0/gnomekeyring.so
  245. %defattr(644,root,root,755)
  246. %doc ../gnome-python-desktop-%{version}/examples/keyring*.py
  247. ## %files -n gnome-python-evince
  248. ## %{python_sitearch}/gtk-2.0/evince.so
  249. %changelog
  250. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-2
  251. - rebuild with python-2.7.2
  252. - drop gnome-python-{applets,brasero,evince} sub packages
  253. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  254. - new upstream release
  255. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
  256. - rebuild with rpm-4.8.1 for pkg-config file
  257. - change BuildRequires: gnome-panel-devel instead of gnome-panel
  258. - change BuildRequires: gnome-media-devel instead of gnome-media
  259. - add BuildRequires: libSM-devel
  260. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  261. - new upstream release
  262. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  263. - new upstream release
  264. - add BuildRequires: totem
  265. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  266. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  267. - rebuild for python-2.6
  268. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  269. - new upstream release
  270. - added gnome-python-brasero, gnome-python-evince package
  271. - remove gnome-python-nautilus-cd-burner package
  272. - used waf instead of configure script
  273. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  274. - new upstream release
  275. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
  276. - new upstream release
  277. - added BuildRequires: pycairo-devel
  278. * Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> - 2.20.0-3
  279. - rebuilt with python-2.5.2
  280. * Wed Apr 16 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.20.0-2
  281. - re-enable BuildRequires: gnome-python-devel
  282. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
  283. - new upstream release
  284. - added gnome-python-evolution subpackage
  285. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.20.0-0vl1
  286. - new upstream release
  287. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.18.0-1vl2
  288. - add BuildRequires: gnome-media
  289. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.18.0-1vl1
  290. - initial build for Vine Linux
  291. * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 2.18.0-1.fc7
  292. - Update to 2.18.0
  293. * Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 2.17.93-1
  294. - Update to 2.17.93
  295. * Sun Feb 25 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.92-1.fc7
  296. - Update to 2.17.92
  297. - Remove patch for GNOME bug #401760 (fixed upstream).
  298. * Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-3.fc7
  299. - Add patch for GNOME bug #401760 (plparser fails to build).
  300. * Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-2.fc7
  301. - Rename spec file to gnome-python2-desktop.spec (RH bug #225832).
  302. * Mon Jan 08 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-1
  303. - Update to 2.17.3
  304. * Sun Jan 07 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.2-1
  305. - Update to 2.17.2
  306. - New gnome-python2-bugbuddy subpackage.
  307. - Update version requirements to match configure.ac.
  308. - Use python_sitearch macro for installing libraries.
  309. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.17.1-2
  310. - rebuild for python 2.5
  311. - BR gnome-python2-devel
  312. * Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.17.1-1
  313. - Update to 2.17.1
  314. * Tue Sep 5 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-1.fc6
  315. - Update to 2.16.0
  316. * Tue Aug 22 2006 Dan Williams <dcbw@redhat.com> - 2.15.90-2.fc6
  317. - Remove unecessary dependencies on gnome-python2-desktop from
  318. -libwnck and -rsvg subpackages (OLPC)
  319. * Fri Aug 4 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.90-1.fc6
  320. - Update to 2.15.90
  321. * Thu Jul 20 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-2
  322. - Rebuild against dbus
  323. * Thu Jul 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-1
  324. - Update to 2.15.4
  325. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4.1
  326. - rebuild
  327. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4
  328. - Create gnomekeyring subpackage
  329. - block out the nautilus-cd stuff
  330. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-2
  331. - Bump for new nautilus-cd-burner
  332. * Tue Jun 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.3-1
  333. - Update to 2.15.3
  334. * Tue May 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.2-1
  335. - Update to 2.15.2
  336. - Add subpackages gnome-python2-rsvg and gnome-python2-gnomedesktop
  337. * Wed May 24 2006 John (J5) Palmieri <johnp@redhat.com> - 2.14.0-2
  338. - Add pygtk2 BR
  339. * Mon Mar 13 2006 Ray Strode <rstrode@redhat.de> 2.14.0-1
  340. - Update to 2.14.0
  341. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.3-2
  342. - Buildrequires: python-devel
  343. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.3-1.1
  344. - bump again for double-long bug on ppc(64)
  345. * Mon Feb 6 2006 John (J5) Palmieri <johnp@redhat.com> - 2.13.3-1
  346. - Initial build.