gnome-sharp2-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208
  1. %define mono_dir %{_prefix}/lib/mono
  2. %define _name gnome-sharp
  3. Summary: .Net Language Bindings for Gnome
  4. Summary(ja): Mono 用 GNOME バインディング
  5. Name: gnome-sharp2
  6. Version: 2.24.2
  7. Release: 1%{?_dist_release}
  8. License: LGPLv2+
  9. Group: System Environment/Libraries
  10. URL: http://gtk-sharp.sf.net
  11. Source: %{_name}-%{version}.tar.bz2
  12. Patch2: gnome-sharp-find_gtkhtml_ver.patch
  13. Patch3: gnome-sharp-2.24.1-TestXfer.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk-sharp2-devel
  16. BuildRequires: gtk-sharp2-gapi
  17. BuildRequires: librsvg2-devel
  18. BuildRequires: mono-devel monodoc
  19. #BuildRequires: vte-devel gtkhtml3-devel
  20. BuildRequires: libSM-devel
  21. BuildRequires: libgnomeui-devel
  22. Provides: gnome-sharp2-devel = %{version}-%{release}
  23. %define env_options export MONO_SHARED_DIR=/tmp
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. %description
  27. This package contains Mono bindings for Gnome.
  28. %package -n gnome-sharp2-complete
  29. Summary: GTK+ and GNOME bindings for Mono (virtual package)
  30. Group: System Environment/Libraries
  31. Requires: art-sharp2 = %{version}-%{release}
  32. Requires: gconf-sharp2 = %{version}-%{release}
  33. Requires: gnome-sharp2 = %{version}-%{release}
  34. Requires: gnome-vfs-sharp2 = %{version}-%{release}
  35. %description -n gnome-sharp2-complete
  36. Gtk# is a library that allows you to build fully native graphical GNOME
  37. applications using Mono. Gtk# is a binding to GTK+, the cross platform
  38. user interface toolkit used in GNOME. It includes bindings for Gtk,
  39. Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas. (Virtual
  40. package which depends on all gtk-sharp2 subpackages)
  41. %package -n gnome-vfs-sharp2
  42. Summary: Mono bindings for gnomevfs
  43. Summary(ja): gnomevfs の Mono バインディング
  44. Group: System Environment/Libraries
  45. Requires: gnome-vfs2
  46. Provides: gnome-vfs-sharp2-devel = %{version}-%{release}
  47. %description -n gnome-vfs-sharp2
  48. This package contains Mono bindings gnomevfs.
  49. %package -n art-sharp2
  50. Summary: Mono bindings for libart
  51. Summary(ja): libart の Mono バインディング
  52. Group: System Environment/Libraries
  53. Requires: libart_lgpl
  54. Provides: art-sharp2-devel = %{version}-%{release}
  55. %description -n art-sharp2
  56. This package contains Mono bindings for libart.
  57. %package -n gconf-sharp2
  58. Summary: Mono bindings for gconf
  59. Summary(ja): GConf の Mono バインディング
  60. Group: System Environment/Libraries
  61. Provides: gconf-sharp2-devel = %{version}-%{release}
  62. %description -n gconf-sharp2
  63. This package contains Mono bindings for gconf and gconf peditors.
  64. %prep
  65. %setup -q -n %{_name}-%{version}
  66. %patch3 -p1 -b .TestXfer
  67. autoreconf -f -i
  68. %build
  69. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  70. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  71. %configure \
  72. --libexecdir=%{_prefix}/lib \
  73. --enable-debug
  74. make
  75. %install
  76. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  77. %makeinstall
  78. ## remove unuse files
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
  80. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
  81. rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %files -n gnome-sharp2-complete
  85. %defattr(-, root, root)
  86. ## This is the 'base' package so we put the common dirs of all in this package
  87. # Otherwise, this package doesn't get created!
  88. %dir %{mono_dir}/gtk-sharp-2.0
  89. %dir %{_prefix}/lib/gtk-sharp-2.0
  90. %files -n gnome-sharp2
  91. %defattr(-,root,root)
  92. %doc COPYING ChangeLog
  93. %{_libdir}/libgnomesharpglue-2.so
  94. %{_libdir}/pkgconfig/gnome-sharp-2.0.pc
  95. %{mono_dir}/gac/*gnome-sharp
  96. %{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
  97. %{_datadir}/gapi-2.0/gnome-api.xml
  98. %files -n gnome-vfs-sharp2
  99. %defattr(-,root,root)
  100. %{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
  101. %{mono_dir}/gac/*gnome-vfs-sharp
  102. %{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
  103. %{_datadir}/gapi-2.0/gnome-vfs-api.xml
  104. %files -n art-sharp2
  105. %defattr(-,root,root)
  106. %{_libdir}/pkgconfig/art-sharp-2.0.pc
  107. %{mono_dir}/gac/*art-sharp
  108. %{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
  109. %{_datadir}/gapi-2.0/art-api.xml
  110. %files -n gconf-sharp2
  111. %defattr(-, root, root)
  112. %{_bindir}/gconfsharp2-schemagen
  113. %{_libdir}/pkgconfig/gconf-sharp-2.0.pc
  114. %{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
  115. %{mono_dir}/gac/*gconf-sharp
  116. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
  117. # Other distros place these in gnome-sharp2??
  118. %{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
  119. %{mono_dir}/gac/*gconf-sharp-peditors
  120. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
  121. %changelog
  122. * Sat Mar 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.24.2-1
  123. - updated to 2.24.2
  124. - built with mono 3.12.1
  125. - remove BR: vte-devel, gtkhtml3-devel
  126. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-8
  127. - rebuild with VineSeed environment
  128. - add BuildRequires: libgnomeui-devel
  129. * Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-7
  130. - add BuildRequires: libSM-devel
  131. * Sat Oct 09 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-6
  132. - added gnome-sharp-2.24.1-TestXfer.patch
  133. - rebuilt with mono-2.8
  134. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.1-5
  135. - build with rpm-4.8.1-1 for pkg-config file
  136. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-4
  137. - rebuilt with new environment
  138. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
  139. - rebuilt with latest rpm to update mono-dependencies
  140. - dropt BR: libgnomedb-devel
  141. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
  142. - changed Group to Development/Libraries
  143. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
  144. - updated to 2.24.1
  145. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
  146. - initial build for VineSeed
  147. - updated gnome-sharp2 to 2.20.0
  148. - added japanese summary
  149. - applied vine versioning policy
  150. - spec in utf-8
  151. * Thu Apr 24 2008 wberrier@suse.de
  152. - Update to 2.12.1
  153. * Bugfix in GLib ref management for Gnome.Program crash in
  154. gnome-sharp
  155. * Thu Apr 3 2008 wberrier@novell.com
  156. - Can now build 2.16 and 2.20 from the same spec
  157. - Update to 2.20.0
  158. - Updated bindings to coincide with gtk# 2.12
  159. - Removed bindings: gtkhtml#, rsvg#, and vte#
  160. * Wed Mar 26 2008 wberrier@novell.com
  161. - Update to 2.16.1
  162. - Allow storage of empty lists in gconf
  163. - Bug fixes:
  164. - [GConf] Impossible to set empty list values (bnc#325516)
  165. - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
  166. * Tue Jul 3 2007 wberrier@suse.de
  167. - Initial package of gnome-sharp2 2.16.0
  168. - (Split from gtk-sharp 2.8.3)