gnutls2-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define source_name gnutls
  3. Summary: GNU TLS Library
  4. Summary(ja): GNU TLS ライブラリ
  5. Name: gnutls2
  6. Version: 2.12.23
  7. Release: 3%{?_dist_release}
  8. License: GPLv3+ and LGPLv2+
  9. # The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
  10. Group: System Environment/Libraries
  11. URL: http://www.gnutls.org/
  12. #Source0: ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz
  13. #Source1: ftp://ftp.gnutls.org/pub/gnutls/devel/%{name}-%{version}.tar.gz.sig
  14. # XXX patent tainted SRP code removed.
  15. Source0: %{source_name}-%{version}.tar.bz2
  16. Source1: libgnutls-config
  17. #patches from fedora development
  18. Patch1: gnutls-2.12.11-rpath.patch
  19. Patch2: gnutls-2.8.6-link-libgcrypt.patch
  20. # Remove nonexisting references from texinfo file
  21. Patch3: gnutls-2.12.2-nosrp.patch
  22. # Skip tests that are expected to fail on libgcrypt build
  23. Patch4: gnutls-2.12.7-dsa-skiptests.patch
  24. Patch100: fix_denial_of_service.patch
  25. Patch110: gnutls-2.12.23_CVE-2014-1959.patch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: libgcrypt-devel >= 1.2.2, zlib-devel libtasn1-devel gmp-devel
  28. BuildRequires: gettext readline-devel libtool
  29. BuildRequires: guile-devel >= 1.8.6
  30. BuildRequires: lzo-devel
  31. BuildRequires: p11-kit-devel >= 0.11
  32. Requires: libgcrypt >= 1.2.2, zlib
  33. Requires: lzo
  34. Requires(post): ldconfig
  35. Requires(postun): ldconfig
  36. Vendor: Project Vine
  37. Distribution: Vine Linux
  38. %description
  39. GnuTLS is a project that aims to develop a library which provides a secure
  40. layer, over a reliable transport layer. Currently the GnuTLS library implements
  41. the proposed standards by the IETF's TLS working group.
  42. #'
  43. %package -n compat32-%{name}
  44. Summary: GNU TLS Library
  45. Summary(ja): GNU TLS ライブラリ
  46. Group: System Environment/Libraries
  47. Requires: compat32-%{name} = %{version}-%{release}
  48. %description -n compat32-%{name}
  49. GnuTLS is a project that aims to develop a library which provides a secure
  50. layer, over a reliable transport layer. Currently the GnuTLS library implements
  51. the proposed standards by the IETF's TLS working group.
  52. #'
  53. %prep
  54. %setup -q -n gnutls-%{version}
  55. %patch1 -p1 -b .rpath
  56. %patch2 -p1 -b .link
  57. %patch3 -p1 -b .nosrp
  58. %patch4 -p1 -b .skiptests
  59. %patch100 -p1 -b .denial
  60. %patch110 -p1 -b .CVE-2014-1959
  61. for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
  62. touch lib/$i
  63. done
  64. %build
  65. #autoreconf
  66. %configure --with-libtasn1-prefix=%{_prefix} \
  67. --with-lzo \
  68. --with-included-libcfg \
  69. --disable-openssl-compatibility \
  70. --disable-srp-authentication \
  71. --disable-static \
  72. --disable-srp-authentication \
  73. --disable-rpath \
  74. --with-libgcrypt
  75. # --with-included-libtasn1 \
  76. # --with-included-opencdk \
  77. # --with-included-lzo \
  78. make
  79. cp lib/COPYING COPYING.LIB
  80. %install
  81. %__rm -rf %{buildroot}
  82. %makeinstall
  83. rm -f $RPM_BUILD_ROOT%{_bindir}/srptool
  84. rm -f $RPM_BUILD_ROOT%{_bindir}/gnutls-srpcrypt
  85. # replace libgnutls*-config
  86. %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-config
  87. %__install -p -m755 %{SOURCE1} %{buildroot}%{_bindir}/libgnutls-extra-config
  88. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/srptool.1
  89. rm -f $RPM_BUILD_ROOT%{_mandir}/man3/*srp*
  90. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  91. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  92. rm -f $RPM_BUILD_ROOT%{_libdir}/libguile*.a
  93. # remove unneeded files
  94. %__rm -f %{buildroot}%{_libdir}/*.la
  95. %find_lang libgnutls
  96. %check
  97. make check
  98. %clean
  99. rm -rf %{buildroot}
  100. %post -p /sbin/ldconfig
  101. %postun -p /sbin/ldconfig
  102. %post -n compat32-%{name} -p /sbin/ldconfig
  103. %postun -n compat32-%{name} -p /sbin/ldconfig
  104. %files -f libgnutls.lang
  105. %defattr(-,root,root,-)
  106. %{_libdir}/libgnutls.so.*
  107. %{_libdir}/libgnutls-extra.so.*
  108. %doc COPYING COPYING.LIB README AUTHORS
  109. %if %{build_compat32}
  110. %files -n compat32-%{name}
  111. %defattr(-,root,root,-)
  112. %{_libdir}/libgnutls*.so.*
  113. %endif
  114. %changelog
  115. * Wed Feb 19 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.12.23-3
  116. - add patch110 for fix CVE-2014-1959
  117. - compat package gnutls2
  118. * Fri Jun 07 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-2
  119. - added Patch100 from upstream to fix CVE-2013-2116
  120. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.23-1
  121. - new upstream release
  122. - fixed a day of the week in %%changelog
  123. * Sat Jan 26 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.22-1
  124. - new upstream release
  125. * Sun Nov 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.21-1
  126. - new upstream release
  127. * Sun Jun 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.20-1
  128. - new upstream release
  129. * Tue May 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.19-1
  130. - new upstream release
  131. * Sun Mar 18 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.18-1
  132. - new upstream release
  133. - changed BuildRequires: p11-kit-devel >= 0.11
  134. * Fri Mar 16 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.17-1
  135. - new upstream release
  136. * Sat Jan 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.16-1
  137. - new upstream release
  138. * Mon Dec 05 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-3
  139. - added BuildRequires: p11-kit-devel
  140. * Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-2
  141. - deleted BuildRequires: nettle-devel
  142. - mistake.. fixed.
  143. * Sun Dec 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.12.14-1
  144. - new upstream release
  145. - synced Fedora development package
  146. - add new sub-package: c++
  147. * Sun Apr 10 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-2
  148. - add Requires: libtasn1-devel for devel subpackage
  149. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 2.10.5-1
  150. - new upstream release
  151. * Sun Dec 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.4-1
  152. - new upstream release
  153. * Tue Nov 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.3-1
  154. - new upstream release
  155. - dropt patch1
  156. * Sat Oct 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.10.2-1
  157. - new upstream release
  158. - added patch1,2,3,4 from Fedora development
  159. - added BuildRequires: gettext readline-devel libtool
  160. - added configure option
  161. --disable-static,--disable-srp-authentication
  162. - dropt *.a files from -devel package again
  163. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.8.6-2
  164. - build with rpm-4.8.1-1 for pkg-config file
  165. * Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.6-1
  166. - new upstream release
  167. - applied new naming policy to spec
  168. * Thu Nov 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.5-1
  169. - new upstream release
  170. * Sat Sep 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.4-1
  171. - new upstream release
  172. * Wed Aug 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.3-1
  173. - new upstream release
  174. * Thu Aug 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.8.2-1
  175. - new upstream release with security fix (handling X.509 CN or SAN fields)
  176. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.8.1-2vl5
  177. - added compat32 package for x86_64 arch support
  178. * Thu Jun 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.1-1vl5
  179. - new upstream release
  180. - added autoreconf
  181. - deleted libguile*.a
  182. - dropt Patch3
  183. - added %post guile, %postun guile
  184. * Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-2
  185. - drop *.a files from -devel package
  186. - build with system lzo
  187. * Sun May 03 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.6-1
  188. - new upstream release with security fixes (CVE-2009-1415,1416,1417)
  189. * Wed Apr 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.5-1vl5
  190. - update to 2.6.5
  191. * Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.4-2
  192. - spec in UTF-8
  193. * Sun Feb 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.4-1vl5
  194. - update to 2.6.4
  195. - modifeid Source0
  196. * Mon Jan 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-2vl5
  197. - add BuildRequires: guile-devel >= 1.8.6
  198. * Tue Jan 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.6.3-1vl5
  199. - update to 2.6.3
  200. - import from fedora developing's 2.6.3
  201. - License tag fixed
  202. - dropped patch0, patch1, patch2
  203. - added patch3
  204. - added BuildRequires: gmp-devel
  205. - add new sub-package: guile
  206. - added %package guile, %description guile, %files guile
  207. * Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl5
  208. - used %%{?_dist_release} macro
  209. * Mon Mar 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.3-2vl1
  210. - update to 1.6.3 (use no-SRP source)
  211. - import from fedora core's 1.6.3-2
  212. - nosrc.tar.bz2 (source0)
  213. - license tag fix
  214. - build with system libtasn1
  215. * Fri Mar 09 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  216. - update to 1.4.5 (use no-SRP source)
  217. - import from fedora core's 1.4.5-1
  218. - nosrc.tar.bz2 (source0)
  219. - drop obsolete cve-2006-4790.patch (patch3)
  220. * Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-2vl1
  221. - [SECURITY] update to 1.4.1 (use no-SRP source)
  222. - import from fedora core's 1.4.1-2
  223. - nosrp.tar.bz2 (source0)
  224. - libgnutls-config (source1)
  225. - nosrc.patch (patch0)
  226. - enable-psk.patch (patch1)
  227. - cve-2006-4790.patch (patch3)
  228. - update required version of libgcrypt (>= 1.2.2)
  229. - add Requires: pkgconfig to -devel package
  230. - add %%check section
  231. - update %%files
  232. - add new sub-package: utils
  233. * Sat May 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.25-0vl1
  234. - [SECURITY FIX] upstream release
  235. - record packet parsing denial of service (CAN-2005-1431)
  236. * Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.24-0vl1
  237. - initial build for Vine Linux
  238. - upstream release
  239. * Wed Mar 2 2005 Warren Togami <wtogami@redhat.com> 1.0.20-6
  240. - gcc4 rebuild
  241. * Tue Jan 4 2005 Ivana Varekova <varekova@redhat.com> 1.0.20-5
  242. - add gnutls Requires zlib-devel (#144069)
  243. * Mon Nov 08 2004 Colin Walters <walters@redhat.com> 1.0.20-4
  244. - Make gnutls-devel Require libgcrypt-devel
  245. * Tue Sep 21 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-3
  246. - rebuild with release++, otherwise unchanged.
  247. * Tue Sep 7 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-2
  248. - patent tainted SRP code removed.
  249. * Sun Sep 5 2004 Jeff Johnson <jbj@redhat.com> 1.0.20-1
  250. - update to 1.0.20.
  251. - add --with-included-opencdk --with-included-libtasn1
  252. - add --with-included-libcfg --with-included-lzo
  253. - add --disable-srp-authentication.
  254. - do "make check" after build.
  255. * Fri Mar 21 2003 Jeff Johnson <jbj@redhat.com> 0.9.2-1
  256. - upgrade to 0.9.2
  257. * Tue Jun 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.4-1
  258. - update to 0.4.4.
  259. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  260. - automated rebuild
  261. * Sat May 25 2002 Jeff Johnson <jbj@redhat.com> 0.4.3-1
  262. - update to 0.4.3.
  263. * Tue May 21 2002 Jeff Johnson <jbj@redhat.com> 0.4.2-1
  264. - update to 0.4.2.
  265. - change license to LGPL.
  266. - include splint annotations patch.
  267. * Tue Apr 2 2002 Nalin Dahyabhai <nalin@redhat.com> 0.4.0-1
  268. - update to 0.4.0
  269. * Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.2-1
  270. - update to 0.3.2
  271. * Thu Jan 10 2002 Nalin Dahyabhai <nalin@redhat.com> 0.3.0-1
  272. - add a URL
  273. * Thu Dec 20 2001 Nalin Dahyabhai <nalin@redhat.com>
  274. - initial package