gprolog-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160
  1. Name: gprolog
  2. Summary: A native Prolog compiler with constraint solving over Finite Domains
  3. Summary(ja): 有限領域の制約解決に適した Prolog コンパイラ
  4. Version: 1.4.4
  5. Release: 1%{?_dist_release}
  6. License: LGPLv3 or GPLv2
  7. Group: Development/Languages
  8. URL: http://www.gprolog.org/
  9. Source0: http://www.gprolog.org/%{name}-%{version}.tar.gz
  10. Buildroot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: sed
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: inagaki
  15. %description
  16. GNU Prolog is a native Prolog compiler with constraint solving over finite
  17. domains (FD) developed by Daniel Diaz (http://cri-dist.univ-paris1.fr/diaz/)
  18. GNU Prolog is a very efficient native compiler producing (small) stand-alone
  19. executables. GNU-Prolog also offers a classical top-level+debugger.
  20. A lot of work has been devoted to the ISO compatibility. GNU Prolog is very
  21. close to the ISO standard.
  22. GNU Prolog also includes a powerful constraint solver over finite domains
  23. with many predefined constraints+heuristics.
  24. More information can be found at http://www.gnu.org/software/prolog
  25. or better at http://www.gprolog.org.
  26. %description -l ja
  27. GNU Prolog は有限領域 (FD) の制約解決に適したネイティブ Prolog コンパイラで、
  28. Daniel Diaz (http://cri-dist.univ-paris1.fr/diaz/) によって開発されました。
  29. GNU Prolog は (小さな) スタンドアロンの実行可能形式を生成する、非常に効率の
  30. 良いネイティブコンパイラです。
  31. 多くの作業が ISO 準拠に向けられました。GNU Prolog は ISO 標準に非常に近いです。
  32. GNU Prolog は多くの定義済の制約条件と発見的手法を用いて、有限領域の問題に
  33. 対して強力な制約解決機能も提供します。
  34. 詳しい情報は http://www.gnu.org/software/prolog や http://www.gprolog.org
  35. (こちらの方が良い)で見つけることができます。
  36. %prep
  37. %setup -q
  38. %build
  39. cd src
  40. # gprolog only acccept -O0 and don't like -fomit-frame-pointer
  41. CFLG="$(echo $RPM_OPT_FLAGS | sed -s "s/\-O2/-O1/g" \
  42. | sed -e "s/\-fomit-frame-pointer//")"
  43. # Based on a gentoo ebuild (??)
  44. CFLG="$CFLG -funsigned-char"
  45. ./configure \
  46. --with-install-dir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version} \
  47. --without-links-dir \
  48. --with-examples-dir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/examples \
  49. --with-doc-dir=dist-doc \
  50. --with-c-flags="$CFLG"
  51. make
  52. %check
  53. cd src
  54. #
  55. export PATH=$RPM_BUILD_ROOT%{_bindir}:$PATH
  56. #
  57. make check
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. rm -rf dist-doc
  61. pushd src
  62. make install-strip
  63. popd
  64. mkdir $RPM_BUILD_ROOT%{_bindir}
  65. pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/bin
  66. for i in *; do
  67. ln -s ../%{_lib}/%{name}-%{version}/bin/$i $RPM_BUILD_ROOT%{_bindir}/$i
  68. done
  69. #rm -rf docs_to_install
  70. #mkdir -p docs_to_install
  71. #mv $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/doc/* docs_to_install
  72. #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/{COPYING,ChangeLog,NEWS,VERSION}
  73. rm -f dist-doc/*.{chm,dvi,ps}
  74. rm -f dist-doc/compil-scheme.pdf
  75. rm -f dist-doc/debug-box.pdf
  76. for file in ChangeLog COPYING NEWS README VERSION gprolog.ico
  77. do
  78. rm -f $RPM_BUILD_ROOT%{_libdir}/gprolog-%{version}/$file
  79. done
  80. popd
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %files
  84. %defattr(-,root,root)
  85. %doc README COPYING ChangeLog NEWS PROBLEMS VERSION gprolog.ico
  86. %doc src/dist-doc/*
  87. %{_bindir}/*
  88. %{_libdir}/%{name}-%{version}/bin
  89. %{_libdir}/%{name}-%{version}/examples
  90. %{_libdir}/%{name}-%{version}/include
  91. %{_libdir}/%{name}-%{version}/lib
  92. %changelog
  93. * Sat Sep 6 2014 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-1
  94. - updated to 1.4.4
  95. - updated summary and description
  96. - updated License to LGPLv3 or GPLv2
  97. * Sun May 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-2
  98. - rebuilt with current VineSeed
  99. - fixed compile option
  100. * Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-1
  101. - updated to 1.3.1
  102. - applied new versioning policy
  103. - spec in UTF-8
  104. * Tue Aug 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl3
  105. - rebuild for VinePlus/3.0 and VineSeedPlus
  106. - updated Japanese Summary and description
  107. - merged VinePlus/2.5 spec file
  108. * Fri Jul 23 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.16-1vl2
  109. - Added Summary(ja) and %%description -l ja.
  110. * Sat Feb 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl2
  111. - merged VinePlus spec file
  112. * Thu Feb 12 2004 by IKEDA Katsumi <ikedak@rg8.so-net.ne.jp>
  113. - 1.2.161vl1
  114. - Modified %Vendor, %Buildroot and %build.
  115. - Add %Distribution.
  116. - Remove %Packager and %Prefix.
  117. - added --with-examples-dir to ./configure
  118. - fixed %files section to exclude %{_libdir}/%{name}-%{version}/doc
  119. * Fri Feb 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl1
  120. - rebuild for Vine Linux
  121. - s/Copyright/License/
  122. - use more rpm macros
  123. * Tue Jul 25 2000 Daniel Diaz <Daniel.Diaz@inria.fr>
  124. - initial specfile