libaio-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302
  1. Summary: Linux-native asynchronous I/O access library
  2. Name: libaio
  3. Version: 0.3.112
  4. Release: 2%{?_dist_release}
  5. Group: system
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: LGPLv2+
  9. URL: https://pagure.io/libaio
  10. Source: https://pagure.io/libaio/archive/libaio-%{version}/libaio-libaio-%{version}.tar.gz
  11. # patches from fedora
  12. Patch2: libaio-remove-nostartfiles-nostdlib-from-build-flags.patch
  13. # patches from debian
  14. Patch100: 0001-Fix-io_pgetevents-syscall-wrapper-on-32-bit-userland.patch
  15. Patch101: 02_libdevdir.patch
  16. Patch102: 0017-harness-Use-destination-strncpy-expression-for-sizeo.patch
  17. Patch103: 0020-harness-Make-the-test-exit-with-a-code-matching-the-.patch
  18. Patch104: 0021-harness-add-support-for-skipping-tests.patch
  19. Patch105: 0022-harness-Add-fallback-code-for-filesystems-not-suppor.patch
  20. Patch106: 0023-harness-Handle-ENOTSUP-from-io_submit-with-RWF_NOWAI.patch
  21. Patch107: 0024-harness-skip-22.p-if-async_poll-isn-t-supported.patch
  22. Patch1000: libaio-fix-test.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. ExclusiveArch: %{ix86} x86_64 ia64 s390 s390x ppc ppc64 ppc64pseries ppc64iseries alpha alphaev6
  25. %description
  26. The Linux-native asynchronous I/O facility ("async I/O", or "aio") has a
  27. richer API and capability set than the simple POSIX async I/O facility.
  28. This library, libaio, provides the Linux-native API for async I/O.
  29. The POSIX async I/O facility requires this library in order to provide
  30. kernel-accelerated async I/O capabilities, as do applications which
  31. require the Linux-native async I/O API.
  32. %package devel
  33. Summary: Development files for Linux-native asynchronous I/O access
  34. Group: programming
  35. Requires: libaio = %{version}-%{release}
  36. %description devel
  37. This package provides header files to include and libraries to link with
  38. for the Linux-native asynchronous I/O facility ("async I/O", or "aio").
  39. %debug_package
  40. %prep
  41. %setup -q -n %{name}-%{name}-%{version} -a 0
  42. mv %{name}-%{name}-%{version} compat-%{name}-%{version}
  43. %patch100 -p1
  44. #patch101 -p1
  45. %patch102 -p1
  46. %patch103 -p1
  47. %patch104 -p1
  48. %patch105 -p1
  49. %patch106 -p1
  50. %patch107 -p1
  51. %patch1000 -p1
  52. pushd compat-%{name}-%{version}
  53. %patch100 -p1
  54. #patch101 -p1
  55. %patch102 -p1
  56. %patch103 -p1
  57. %patch104 -p1
  58. %patch105 -p1
  59. %patch106 -p1
  60. %patch107 -p1
  61. %patch1000 -p1
  62. popd
  63. %build
  64. # This package uses ASMs to implement symbol versioning and is thus
  65. # incompatible with LTO
  66. %define _lto_cflags %{nil}
  67. # A library with a soname of 1.0.0 was inadvertantly released. This
  68. # build process builds a version of the library with the broken soname in
  69. # the compat-libaio-0.3.103 directory, and then builds the library again
  70. # with the correct soname.
  71. %set_build_flags
  72. cd compat-%{name}-%{version}
  73. make soname='libaio.so.1.0.0' libname='libaio.so.1.0.0'
  74. cd ..
  75. make
  76. %install
  77. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  78. cd compat-%{name}-%{version}
  79. install -D -m 755 src/libaio.so.1.0.0 \
  80. %{buildroot}/%{_lib}/libaio.so.1.0.0
  81. cd ..
  82. make DESTDIR=%{buildroot} prefix=/ libdir=/%{_lib} includedir=%{_includedir} install
  83. mkdir -p %{buildroot}/%{_libdir}
  84. rm -f %{buildroot}/%{_lib}/libaio.so
  85. ln -sf ../../%{_lib}/libaio.so.1 %{buildroot}%{_libdir}/libaio.so
  86. find %{buildroot} -name '*.a' -delete
  87. %check
  88. make partcheck
  89. pushd compat-%{name}-%{version}
  90. make partcheck
  91. popd
  92. %clean
  93. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  94. %files
  95. %license COPYING
  96. %doc TODO
  97. %attr(0755,root,root) /%{_lib}/libaio.so.*
  98. %files devel
  99. %attr(0644,root,root) %{_includedir}/*
  100. %{_libdir}/libaio.so
  101. %changelog
  102. * Tue Aug 31 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.112-2
  103. - dropped ldconfig scriptlets.
  104. - fixed tests.
  105. * Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.112-1
  106. - new upstream release.
  107. - dropped Patch1-2.
  108. - imported Patch100-105 from debian.
  109. * Tue Oct 28 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.3.110-1
  110. - new upstream release.
  111. * Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.3.106-4
  112. - rebuild with VineSeed environment
  113. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-3
  114. - rebuilt with current VineSeed
  115. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-2
  116. - changed Group to Development/Libraries
  117. * Mon Sep 29 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.106-1vl5
  118. - applied new versioning policy, spec in utf-8
  119. * Mon Nov 12 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.106-0vl1
  120. - initial build for Vine Linux
  121. * Mon Jul 17 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-3.2
  122. - rebuild
  123. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-3.1
  124. - rebuild
  125. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 0.3.106-3
  126. - rebuild for -devel deps
  127. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.2
  128. - bump again for double-long bug on ppc(64)
  129. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.3.106-2.1
  130. - rebuilt for new gcc4.1 snapshot and glibc changes
  131. * Wed Jan 04 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-2
  132. - Update to the latest sources, which contain the following change:
  133. Add a .proc directive for the ia64_aio_raw_syscall macro. This sounds a lot
  134. like the previous entry, but that one fixed the __ia64_raw_syscall macro,
  135. located in syscall-ia64.h. This macro is in raw_syscall.c, which pretty much
  136. only exists for ia64. This bug prevented the package from building with
  137. newer version of gcc.
  138. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  139. - rebuilt
  140. * Fri Apr 1 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.104-2
  141. - Add Alpha architecture support. (Sergey Tikhonov <tsv@solvo.ru>)
  142. * Wed Mar 16 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-6
  143. - Rebuild with gcc 4.
  144. * Mon Feb 14 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-4
  145. - Build the library twice. Once with the old SONAME and once with the new
  146. one. This fixes the wrong SONAME problem by keeping a library around with
  147. the wrong name (libaio.so.1.0.0) and generating a new one (libaio.so.1.0.1).
  148. * Thu Oct 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.102-1
  149. - update to 102. Fixes build errors on s390:
  150. - S390 asm had a bug; I forgot to update the clobber list. Lucky for me,
  151. newer compilers complain about such things.
  152. - Also update the s390 asm to look more like the new kernel variants.
  153. * Wed Oct 13 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.101-1
  154. - update to 101. Fixes bz 133253 - libaio backwards compatibility severely
  155. broken.
  156. * Tue Sep 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.100-1
  157. - update to 100. Fixes bz 129910. Add pseries and iseries to
  158. exclusivearch.
  159. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  160. - rebuilt
  161. * Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-2
  162. - Apparently the 0.3.93 patch was not meant for 0.3.96. Backed it out.
  163. * Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-1
  164. - Fix compat calls.
  165. - make library .so.1.0.0 and make symlinks properly.
  166. - Fix header file for inclusion in c++ code.
  167. * Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-2
  168. - bah. fix version nr in changelog.
  169. * Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-1
  170. - fix compiler warnings.
  171. * Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-2
  172. - make srpm was using rpm to do a build. changed that to use rpmbuild if
  173. it exists, and fallback to rpm if it doesn't.
  174. * Tue Feb 24 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-1
  175. - Use libc syscall(2) instead of rolling our own calling mechanism. This
  176. change is inspired due to a failure to build with newer gcc, since clobber
  177. lists were wrong.
  178. - Add -fpic to the CFLAGS for all architectures. Should address bz #109457.
  179. - change a #include from <linux/types.h> to <sys/types.h>. Fixes a build
  180. issue on s390.
  181. * Mon Jul 7 2003 Bill Nottingham <notting@redhat.com> 0.3.96-3
  182. - fix paths on lib64 arches
  183. * Wed Jun 18 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.96-2
  184. - optimization in io_getevents from Arjan van de Ven in 0.3.96-1
  185. - deal with ia64 in 0.3.96-2
  186. * Wed May 28 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.95-1
  187. - ppc bugfix from Julie DeWandel
  188. * Tue May 20 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.94-1
  189. - symbol versioning fix from Ulrich Drepper
  190. * Mon Jan 27 2003 Benjamin LaHaise <bcrl@redhat.com>
  191. - bump to 0.3.93-3 for rebuild.
  192. * Mon Dec 16 2002 Benjamin LaHaise <bcrl@redhat.com>
  193. - libaio 0.3.93 test release
  194. - add powerpc support from Gianni Tedesco <gianni@ecsc.co.uk>
  195. - add s/390 support from Arnd Bergmann <arnd@bergmann-dalldorf.de>
  196. * Thu Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
  197. - libaio 0.3.92 test release
  198. - build on x86-64
  199. * Thu Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
  200. - libaio 0.3.91 test release
  201. - build on ia64
  202. - remove libredhat-kernel from the .spec file
  203. * Thu Sep 5 2002 Benjamin LaHaise <bcrl@redhat.com>
  204. - libaio 0.3.90 test release
  205. * Mon Apr 29 2002 Benjamin LaHaise <bcrl@redhat.com>
  206. - add requires initscripts >= 6.47-1 to get boot time libredhat-kernel
  207. linkage correct.
  208. - typo fix
  209. * Thu Apr 25 2002 Benjamin LaHaise <bcrl@redhat.com>
  210. - make /usr/lib/libredhat-kernel.so point to /lib/libredhat-kernel.so.1.0.0
  211. * Mon Apr 15 2002 Tim Powers <timp@redhat.com>
  212. - make the post scriptlet not use /bin/sh
  213. * Fri Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
  214. - add /lib/libredhat-kernel* to %files.
  215. * Fri Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
  216. - make the dummy install as /lib/libredhat-kernel.so.1.0.0 so
  217. that ldconfig will link against it if no other is installed.
  218. * Tue Jan 22 2002 Benjamin LaHaise <bcrl@redhat.com>
  219. - add io_getevents
  220. * Tue Jan 22 2002 Michael K. Johnson <johnsonm@redhat.com>
  221. - Make linker happy with /usr/lib symlink for libredhat-kernel.so
  222. * Mon Jan 21 2002 Michael K. Johnson <johnsonm@redhat.com>
  223. - Added stub library
  224. * Sun Jan 20 2002 Michael K. Johnson <johnsonm@redhat.com>
  225. - Initial packaging