libyaml-vl.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105
  1. Summary: YAML 1.1 parser and emitter written in C
  2. Name: libyaml
  3. Version: 0.2.5
  4. Release: 1%{?_dist_release}
  5. Group: system
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: MIT
  9. URL: https://pyyaml.org/
  10. Source0: http://pyyaml.org/download/libyaml/yaml-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. %description
  13. YAML is a data serialization format designed for human readability and
  14. interaction with scripting languages. LibYAML is a YAML parser and
  15. emitter written in C.
  16. %package devel
  17. Summary: Development libraries and headers for developing LibYAML applications
  18. Group: programming
  19. Requires: libyaml = %{version}-%{release}
  20. %description devel
  21. Development libraries and headers for developing LibYAML applications.
  22. %debug_package
  23. %prep
  24. %setup -q -n yaml-%{version}
  25. %build
  26. #./bootstrap
  27. %configure
  28. make %{?_smp_mflags}
  29. %install
  30. rm -rf %{buildroot}
  31. make DESTDIR=%{buildroot} INSTALL="install -p" install
  32. rm -f %{buildroot}%{_libdir}/*.{la,a}
  33. soname=$(readelf -d %{buildroot}%{_libdir}/libyaml.so | awk '$2 == "(SONAME)" {print $NF}' | tr -d '[]')
  34. rm -f %{buildroot}%{_libdir}/libyaml.so
  35. echo "INPUT($soname)" > %{buildroot}%{_libdir}/libyaml.so
  36. %check
  37. make check
  38. %clean
  39. rm -rf %{buildroot}
  40. %post -p /sbin/ldconfig
  41. %postun -p /sbin/ldconfig
  42. %files
  43. %defattr(-,root,root,-)
  44. %license LICENSE
  45. %doc README
  46. %{_libdir}/%{name}*.so.*
  47. %files devel
  48. %defattr(-,root,root,-)
  49. %doc doc/html
  50. %{_libdir}/%{name}*.so
  51. %{_libdir}/pkgconfig/yaml-0.1.pc
  52. %{_includedir}/yaml.h
  53. %changelog
  54. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.2.5-1
  55. - new upstream release.
  56. * Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.2.2-1
  57. - new upstream release.
  58. * Sun Oct 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.1.6-2
  59. - moved libyaml to System Environment/Libraries Group
  60. * Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.6-1
  61. - update to 0.1.6
  62. * Mon Mar 12 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.1.4-1
  63. - new upstream release
  64. * Wed Jun 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.2-1
  65. - initial build for Vine Linux
  66. * Tue Mar 3 2009 John Eckersberg <jeckersb@redhat.com> - 0.1.2-3
  67. - Remove static libraries
  68. * Thu Feb 26 2009 John Eckersberg <jeckersb@redhat.com> - 0.1.2-2
  69. - Remove README and LICENSE from docs on -devel package
  70. - Remove -static package and merge contents into the -devel package
  71. * Wed Feb 25 2009 John Eckersberg <jeckersb@redhat.com> - 0.1.2-1
  72. - Initial packaging for Fedora