mailutils-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. %ifarch x86_64
  2. %bcond_without doc
  3. %else
  4. %bcond_with doc
  5. %endif
  6. Name: mailutils
  7. Summary: GNU Mailutils: General-Purpose Mail Package
  8. Summary(ja): GNU Mailutils: 汎用メールユーティリティパッケージ
  9. Version: 3.14
  10. Release: 1%{_dist_release}
  11. Group: internet
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: GPL3+
  15. URL: https://mailutils.org/
  16. Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
  17. BuildRequires: bzip2-devel
  18. BuildRequires: flex
  19. BuildRequires: gdbm-devel
  20. BuildRequires: gnutls-devel
  21. BuildRequires: info
  22. BuildRequires: libgcrypt-devel
  23. BuildRequires: libunistring-devel
  24. BuildRequires: libtool-ltdl-devel
  25. BuildRequires: openldap-devel
  26. BuildRequires: pam-devel
  27. BuildRequires: perl
  28. BuildRequires: readline-devel
  29. BuildRequires: zlib-devel
  30. Requires: mailutils-libs = %{version}-%{release}
  31. %global mailx_version 8.1.2.20180807-2
  32. Conflicts: mailx < %{mailx_version}
  33. Obsoletes: mailx < %{mailx_version}
  34. Provides: mailx = %{mailx_version}
  35. Provides: config(mailx) = %{mailx_version}
  36. Provides: /bin/mail
  37. %description
  38. GNU Mailutils is a rich and powerful protocol-independent mail
  39. framework. It contains a series of useful mail libraries, clients,
  40. and servers. These are the primary mail utilities for the GNU system.
  41. The central library is capable of handling electronic mail in various
  42. mailbox formats and protocols, both local and remote. Specifically,
  43. this project contains a POP3 server, an IMAP4 server, and a Sieve mail
  44. filter. It also provides a POSIX `mailx' client, and a collection of
  45. other handy tools.
  46. %package libs
  47. Summary: GNU Mailutils: mailbox access library.
  48. Group: system
  49. License: LGPL3+
  50. %description libs
  51. The runtime library libmailbox contains various mailbox access
  52. routines and support for a number of mailbox types, such as mbox,
  53. maildir, mh, POP3, and IMAP4. It also supports MIME message
  54. handling, and sending mail via SMTP and /sbin/sendmail.
  55. %package devel
  56. Summary: GNU Mailutils: mailbox access development.
  57. Group: programming
  58. License: LGPL3+
  59. Requires: mailutils-libs = %{version}-%{release}
  60. %description devel
  61. GNU Mailutils: mailbox access development.
  62. %package mh
  63. Summary: GNU Mailutils: The Message Handling System.
  64. Group: internet
  65. License: GPL3+
  66. Requires: mailutils-libs = %{version}-%{release}
  67. %description mh
  68. The GNU MH (Message Handling System).
  69. %if %{with doc}
  70. %package doc
  71. Summary: GNU Mailutils: documentation.
  72. Group: documentation
  73. License: GFDL-1.2
  74. BuildArch: noarch
  75. %description doc
  76. API reference for libmailbox and user documentation for the rest of
  77. the GNU Mailutils.
  78. %endif
  79. %debug_package
  80. %prep
  81. %setup -q
  82. if [ %version = 3.12 ]; then
  83. echo "#endif" >> include/mailutils/sys/streamtrans.h
  84. fi
  85. %build
  86. autoreconf -fiv
  87. %configure \
  88. --disable-static \
  89. --disable-rpath \
  90. --enable-ipv6 \
  91. --with-mail-spool=/var/spool/mail \
  92. --with-mh-bindir=%{_libexecdir}/mu-mh \
  93. --disable-build-pop3d \
  94. --disable-build-imap4d \
  95. --disable-build-comsat \
  96. --disable-build-mda \
  97. --disable-build-lmtpd \
  98. --disable-build-putmail \
  99. --disable-build-sieve \
  100. --without-guile \
  101. --disable-python \
  102. %{nil}
  103. # SMP-incompatible build.
  104. make V=1
  105. %install
  106. %make_install
  107. install -d %{buildroot}/bin
  108. mv -f %{buildroot}%{_bindir}/mail %{buildroot}/bin/
  109. ln -s ./mail %{buildroot}/bin/Mail
  110. ln -s ./mail %{buildroot}/bin/mailx
  111. ln -s ../../bin/mail %{buildroot}%{_bindir}/mail
  112. ln -s ../../bin/mail %{buildroot}%{_bindir}/Mail
  113. ln -s ../../bin/mail %{buildroot}%{_bindir}/mailx
  114. %find_lang %name
  115. # unshipped files
  116. find %{buildroot}%{_libdir} -name "*.la" -delete
  117. rm -f %{buildroot}%{_mandir}/man1/{imap4d,pop3d,popauth}.1*
  118. rm -f %{buildroot}%{_infodir}/dir
  119. # x86_64 only (noarch)
  120. %if !%{with doc}
  121. rm -rf %{buildroot}%{_infodir}
  122. %endif
  123. %check
  124. #make check MH=/dev/null || { cat mh/tests/testsuite.log; exit 1; }
  125. make check
  126. %files -f %name.lang
  127. %license COPYING*
  128. %doc AUTHORS THANKS NEWS README* TODO ChangeLog
  129. /bin/Mail
  130. /bin/mail
  131. /bin/mailx
  132. %{_bindir}/mailutils
  133. %{_bindir}/dotlock
  134. %{_bindir}/frm
  135. %{_bindir}/from
  136. %{_bindir}/Mail
  137. %{_bindir}/mail
  138. %{_bindir}/mailx
  139. %{_bindir}/messages
  140. %{_bindir}/mimeview
  141. %{_bindir}/movemail
  142. %{_bindir}/readmsg
  143. %{_bindir}/decodemail
  144. %{_mandir}/*/mail*
  145. %dir %{_libexecdir}/mailutils
  146. %{_libexecdir}/mailutils/*
  147. %dir %{_datadir}/%{name}
  148. %files libs
  149. %dir %{_libdir}/mailutils
  150. %{_libdir}/mailutils/*.so
  151. %{_libdir}/*.so.*
  152. %files mh
  153. %dir %{_libexecdir}/mu-mh
  154. %{_libexecdir}/mu-mh/*
  155. %dir %{_datadir}/%{name}
  156. %{_datadir}/%{name}/mh
  157. %files devel
  158. %{_bindir}/mailutils-config
  159. %{_includedir}/mailutils
  160. %{_libdir}/*.so
  161. %{_datadir}/aclocal/mailutils.m4
  162. %if %{with doc}
  163. %files doc
  164. %{_infodir}/*
  165. %endif
  166. %changelog
  167. * Fri Jan 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.14-1
  168. - new upstream release.
  169. - dropped install-info scriptlets.
  170. * Fri Aug 06 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.13-1
  171. - new upstream release.
  172. * Thu Mar 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.12-1
  173. - initial build for Vine Linux.