mew-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386
  1. %define _docdir %{_defaultdocdir}
  2. %define _noVersionedDependencies 1
  3. # %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  4. %define _libdir %{_prefix}/lib
  5. %define origver 6.7
  6. %define pkgver %{origver}
  7. %define origname mew
  8. Summary: Mew - Messaging in the Emacs World
  9. Summary(ja): Emacs でメールを読むためのインターフェース
  10. Name: %{origname}
  11. Version: %{origver}
  12. Release: 1%{?_dist_release}
  13. License: distributable
  14. Group: Applications/Editors/Emacs
  15. URL: http://www.mew.org/
  16. Source0: http://www.mew.org/Release/mew-%{pkgver}.tar.gz
  17. Source1: %{origname}-install.sh
  18. Source2: %{origname}-remove.sh
  19. Source3: vine.dot.mew
  20. Source4: %{name}-init.el
  21. Source5: vine-default-%{name}.el
  22. Patch11: mew-6.3-icondir.diff
  23. Requires: emacsen
  24. Requires: perl >= 5.004_jp-4
  25. Provides: %{origname} = %{origver}
  26. #Conflicts: %{origname}-el
  27. Obsoletes: mew-mule, mew-el
  28. Obsoletes: mew-xemacs, mew-xemacs-extra
  29. Requires: mew-common = %{version}
  30. # PreReq: /sbin/install-info
  31. BuildRequires: emacsen
  32. BuildRequires: zlib-devel
  33. BuildRoot: %{_tmppath}/%{name}-%{origver}-root
  34. Vendor: Project Vine
  35. Distribution: Vine Linux
  36. %description
  37. Messaging in the Emacs World. It provides a very easy user interface
  38. to e-mail, MIME and PGP (Pretty Good Privacy) on Emacsen.
  39. Please install Perl5 to use mew.
  40. Don't forget to copy %{_docdir}/mew-%{version}/vine.dot.mew
  41. to your ~/.mew.el file, and modify the site configurations, e.g.
  42. (setq mew-mail-domain-list '("your mail domain"))
  43. %description -l ja
  44. 電子メールを Emacs / XEmacs 上で簡単に読み書きすることができるインター
  45. フェース mew です。MIME や PGP にも対応しています。mewを使うためには、
  46. perlが必要です。
  47. %{_docdir}/mew-common-%{version}/vine.dot.mew を ~/.mew.el としてコピー
  48. し、適切に設定してください。
  49. (setq mew-mail-domain-list '("your mail domain"))
  50. また、%{_docdir}/mew-common-%{version}/contrib/以下にもいくつかのMewを便利に使う
  51. 為のelispを収録しています。
  52. #'
  53. %package -n mew-common
  54. Summary: Common files/programs for Mew Emacs/XEmacs
  55. Summary(ja): Emacs/XEmacs 用 Mew 両方で利用するファイル/プログラム
  56. Group: Applications/Internet
  57. Obsoletes: mew-xemacs-extra
  58. %description -n mew-common
  59. This package contains common files/programs for Mew Emacs/XEmacs.
  60. %description -n mew-common -l ja
  61. Emacs/XEmacs 用 Mew に共通するファイル/プログラムです.
  62. %prep
  63. %setup -q -n mew-%{pkgver}
  64. %patch11 -p1
  65. cp %{SOURCE3} .
  66. %build
  67. %configure
  68. make PREFIX="/usr" CFLAGS="$RPM_OPT_FLAGS" bin
  69. %install
  70. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  71. mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  72. mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/install
  73. mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/remove
  74. mkdir -p %{buildroot}/usr/info
  75. mkdir -p %{buildroot}%{_datadir}/pixmaps/%{origname}
  76. # install el files
  77. # Add here commands to install the package into debian/mew.
  78. cp *.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  79. cp %{SOURCE4} %{SOURCE5} \
  80. %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  81. make install-bin prefix=%{buildroot}%{_prefix} \
  82. mandir=%{buildroot}%{_mandir}/man1 \
  83. bindir=%{buildroot}%{_bindir}
  84. # contrib
  85. #install -m 755 contrib/mewinc contrib/incdir contrib/incmbox \
  86. # $RPM_BUILD_ROOT/%{_docdir}/%{origname}/contrib/
  87. ## install icons
  88. cp etc/*.xpm %{buildroot}/usr/share/pixmaps/%{origname}
  89. cp etc/*.png %{buildroot}/usr/share/pixmaps/%{origname}
  90. cp etc/*.img %{buildroot}/usr/share/pixmaps/%{origname}
  91. ## install contrib
  92. #cp -a contrib $(CURDIR)/debian/mew/usr/share/doc/mew
  93. # install {info,jinfo} for mew-emacs
  94. make infodir="%{buildroot}%{_infodir}" \
  95. INSTALLINFO="/sbin/install-info" install-info install-jinfo
  96. rm -f %{buildroot}%{_infodir}/dir
  97. gzip -9nf %{buildroot}%{_infodir}/*
  98. %_installemacsenscript %{origname} %{SOURCE1}
  99. %_removeemacsenscript %{origname} %{SOURCE2}
  100. %post
  101. if [ "$1" = 2 ]; then
  102. %_emacsenPackageRemove %{origname}
  103. fi
  104. %_addemacsenlist %{origname}
  105. %_emacsenPackageInstall %{origname}
  106. /sbin/install-info %{_infodir}/mew.info.gz %{_infodir}/dir \
  107. --section="Message User Agent"
  108. /sbin/install-info %{_infodir}/mew.ja.info.gz %{_infodir}/dir \
  109. --section="Message User Agent"
  110. %preun
  111. if [ "$1" = 0 ]; then
  112. %_emacsenPackageRemove %{origname}
  113. %_removeemacsenlist %{origname}
  114. /sbin/install-info --delete %{_infodir}/mew.info.gz %{_infodir}/dir \
  115. --section="Message User Agent"
  116. /sbin/install-info --delete %{_infodir}/mew.ja.info.gz %{_infodir}/dir \
  117. --section="Message User Agent"
  118. fi
  119. %clean
  120. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  121. %files
  122. %defattr(-,root,root)
  123. %{_infodir}/mew.info*
  124. %{_infodir}/mew.ja.info*
  125. %{_datadir}/emacs/site-lisp/%{origname}/
  126. %{_libdir}/emacsen-common/packages/install/%{origname}
  127. %{_libdir}/emacsen-common/packages/remove/%{origname}
  128. %{_datadir}/pixmaps/%{origname}
  129. %files -n mew-common
  130. %defattr(-,root,root)
  131. %doc 00changes.* 00copyright 00copyright.ja 00diff 00readme
  132. %doc dot.emacs vine.dot.mew
  133. # %doc contrib/
  134. %{_bindir}/*
  135. %{_mandir}/man1/*
  136. %changelog
  137. * Thu Nov 03 2016 Toshiaki Ara <ara_t@384.jp> 6.7-1
  138. - new upstream release
  139. - add BuildRequires: zlib-devel
  140. - change %%{_infodir}/mew.jis.info* to %%{_infodir}/mew.ja.info*
  141. - change encoding of vine.dot.mew to utf-8
  142. * Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.3-2
  143. - rebuild with rpm-4.8.1
  144. - change pixmap directory
  145. - fix Patch11
  146. * Mon Dec 21 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.3-1
  147. - new upstream release
  148. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-3
  149. - fixed mew-init.el
  150. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-2
  151. - added mew-init.el, vine-default-mew.el
  152. - updated mew-install.sh, mew-remove.sh for vine-default-mew.el
  153. * Fri Jan 16 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.2-1
  154. - new upstream release
  155. * Sun Jun 15 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-1
  156. - applied new versioning policy
  157. * Tue Jun 10 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-0vl1
  158. - new upstream release
  159. * Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 5.2-0vl3
  160. - added %%define _lib lib (for x86_64 support)
  161. * Mon Mar 05 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl2
  162. - added support X-Spam-Flag header in vine.dot.mew
  163. * Tue Jan 23 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl1
  164. - new upstream release
  165. * Mon Nov 26 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.1-0vl1
  166. - new upstream release
  167. - modified vine.dot.mew for Mew-5.1 feature support
  168. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl3
  169. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  170. * Tue Jul 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl2
  171. - changed Group to Applications/Editors/EmacsLisp
  172. - changed common package's Group to Applications/Internet
  173. * Mon Feb 14 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.2-0vl1
  174. - source update
  175. * Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1-0vl1
  176. - source update
  177. * Mon Jul 28 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.3-0vl1
  178. - source update
  179. * Thu Mar 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2-0vl1
  180. - source update
  181. - update vine.dot.mew
  182. Obsoleting the following variables:
  183. mew-noreplyto-to-list
  184. mew-noreplyto-cc-list
  185. mew-replyto-to-list
  186. mew-replyto-cc-list
  187. mew-fromme-to-list
  188. mew-fromme-cc-list
  189. And defining the following variables:
  190. mew-reply-all-alist
  191. mew-reply-sender-alist
  192. mew-reply-fromme-alist
  193. * Sat Jan 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl3
  194. - added vine.dot.mew(Source3)
  195. * Wed Dec 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl2
  196. - source update
  197. * Tue Dec 03 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl1
  198. - update to mew-3.1
  199. * Thu Nov 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.2
  200. - test package: update to mew-3.1rc2
  201. * Fri Nov 01 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.1
  202. - test package: update to mew-3.1rc1
  203. * Mon Mar 18 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-0vl4
  204. - changed License to distributable (not GPL2)
  205. * Mon Mar 18 2002 Hironobu MORIGUCHI <moriguti@luna.email.ne.jp> 2.2-0vl3
  206. - incm and man pages are included in common subpackage
  207. * Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 2.2-0vl2
  208. - corrected Group for common subpackage
  209. * Mon Feb 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2-0vl1
  210. - update to mew-2.2
  211. * Thu Feb 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.99.4-0vl1
  212. - update to mew-2.2rc4
  213. * Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2..99.2-0vl1
  214. - update to mew-2.2rc2
  215. * Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl3
  216. - mew-el -> mew
  217. - added Patch11 to set default icon directory for Vine
  218. * Wed Dec 12 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl2
  219. - added Obsoletes: mew-xemacs, mew-xemacs-extra
  220. - install-info gzipped info files :)
  221. * Thu Nov 01 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-0vl1
  222. - update 2.1
  223. * Sat Oct 6 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0-0vl5
  224. - change package name ( mew -> mew-el)
  225. - apply emacsenc-oomon
  226. * Thu Sep 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
  227. - Oops, forgot to add %%defattr for mew-common. Fixed.
  228. * Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
  229. - split mew-common, obsoletes mew-xemacs-extra
  230. * Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
  231. - 2.0-0vl2: eliminate executable bit in %%doc and bin files install 755
  232. - install info files into %%{_infodir}
  233. * Sun Aug 20 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
  234. - 2.0-0vl1
  235. - update
  236. * Tue Oct 24 2000 Tomoya TAKA <tomoya@olive.plala.or.jp>
  237. - 1.94.2-3
  238. - fixed %files section to handle compressed info pages
  239. * Wed Jun 7 2000 Toru Sagami <czs14350@nifty.ne.jp>
  240. - fix description: mess up with mule/emacs/xemacs...
  241. - added BuildRequires and Conflicts
  242. * Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
  243. - updated 1.94.2
  244. * Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
  245. - added PreReq: /sbin/install-info
  246. - attrib +x for /usr/bin/uumerge
  247. - CFLAGS="$RPM_OPT_FLAGS"
  248. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  249. - 1.94.1-2
  250. - changed destination to /usr/share/emacs/site-lisp/mew
  251. * Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  252. - 1.94.1-1
  253. - updated in sync with 1.94.1 release
  254. - fixed %post and %preun section
  255. - Obsoletes: mew now changed to Obsoletes: mew-mule
  256. * Fri Oct 8 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
  257. - fixed info path & install info
  258. - fixed '%description'
  259. * Sat Oct 2 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
  260. - removed extra packages
  261. - fixed char-set "euc" of the spec file.
  262. - slight modifications for Vine-1.9
  263. * Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  264. - 1.94-3
  265. - package name changed from mew-emacs to mew
  266. - make info, make jinfo now processed even under emacs
  267. * Thu Sep 16 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  268. - Released as version "1.94-2".
  269. Changed from "mew-emacs 1.94-1".
  270. - Deleted "NoSource: 0", the definition part of data.
  271. - Revised some, the definition part of data.
  272. - Revised some, part of "%post, %postun".
  273. - Changerd "%postun" => "%preun".
  274. * Mon Sep 6 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
  275. - First release.