ming-vl.spec 6.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244
  1. Name: ming
  2. Summary: A library for generating Macromedia Flash files
  3. Summary(ja): Macromedia Flash ファイル生成ライブラリ
  4. Version: 0.4.5
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: LGPLv2+
  8. URL: http://www.libming.org/FrontPage
  9. Source0: http://downloads.sourceforge.net/project/ming/Releases/ming-%{version}.tar.bz2
  10. # make ming-config multilib-compatible
  11. Patch0: ming-multilib.patch
  12. # install perl modules to vendorarch dir and link dynamically with libming.so
  13. Patch1: ming-perl.patch
  14. # To build with giflib-4.2.x
  15. Patch100: ming-0.4.5-gif-error.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: bison
  18. BuildRequires: flex
  19. BuildRequires: freetype2-devel
  20. BuildRequires: giflib-devel
  21. BuildRequires: libpng-devel
  22. BuildRequires: perl
  23. BuildRequires: php5-devel
  24. BuildRequires: python-devel
  25. BuildRequires: swig
  26. BuildRequires: tcl
  27. BuildRequires: zlib-devel
  28. %description
  29. Ming is a library for generating Macromedia Flash files (.swf), written in C,
  30. and includes useful utilities for working with .swf files.
  31. %package devel
  32. Summary: A library for generating Macromedia Flash files - development files
  33. Summary(ja): %{name} の開発用ファイル
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. The ming-devel package includes the static libraries,
  38. header files, and developer docs for the ming package.
  39. %package python
  40. Summary: Ming Python wrapper
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. %description python
  44. %{summary}
  45. %package tcl
  46. Summary: Ming Tcl wrapper
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}-%{release}
  49. Requires: tcl
  50. %description tcl
  51. %{summary}
  52. %package perl
  53. Summary: Ming Perl wrapper
  54. Group: Development/Libraries
  55. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  56. Provides: perl-SWF = %{version}-%{release}
  57. %description perl
  58. %{summary}
  59. %package php
  60. Summary: Ming PHP wrapper
  61. Group: Development/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: php5
  64. %description php
  65. %{summary}
  66. %prep
  67. %setup -q
  68. %patch0 -p1 -b .multilib
  69. %patch1 -p1 -b .p
  70. %patch100 -p2 -b .p
  71. pushd src
  72. chmod -x actioncompiler/{compile,listaction}.* blocks/{matrix,outputblock}.* \
  73. displaylist.* position.*
  74. popd
  75. iconv -f iso8859-1 -t utf8 -o ChangeLog.utf8 ChangeLog && \
  76. touch -r ChangeLog ChangeLog.utf8 && \
  77. mv ChangeLog.utf8 ChangeLog
  78. # force rebuild of python bindings
  79. rm py_ext/ming_wrap.c
  80. %build
  81. %configure \
  82. --disable-static \
  83. --enable-python \
  84. --enable-tcl \
  85. --enable-php \
  86. --enable-perl \
  87. --with-pic \
  88. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  89. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  90. make V=1 %{?_smp_mflags}
  91. %install
  92. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  93. make install DESTDIR=$RPM_BUILD_ROOT \
  94. pkgconfigdir=%{_libdir}/pkgconfig \
  95. docdir=$RPM_BUILD_ROOT%{_docdir}/%{name}
  96. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  97. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  98. chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/auto/SWF/*.so
  99. make -C ./docs/man mandir=$RPM_BUILD_ROOT%{_mandir} install-man1
  100. make -C ./docs/man mandir=$RPM_BUILD_ROOT%{_mandir} install-man3
  101. %post -p /sbin/ldconfig
  102. %post python -p /sbin/ldconfig
  103. %post tcl -p /sbin/ldconfig
  104. %post perl -p /sbin/ldconfig
  105. %post php -p /sbin/ldconfig
  106. %postun -p /sbin/ldconfig
  107. %postun python -p /sbin/ldconfig
  108. %postun tcl -p /sbin/ldconfig
  109. %postun perl -p /sbin/ldconfig
  110. %postun php -p /sbin/ldconfig
  111. %clean
  112. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  113. %files
  114. %defattr(-,root,root)
  115. %doc README AUTHORS COPYING ChangeLog
  116. %{_bindir}/*
  117. %{_libdir}/libming*.so.*
  118. %{_mandir}/man1/*
  119. %files devel
  120. %defattr(-, root, root)
  121. %{_includedir}/*
  122. %{_libdir}/libming.so
  123. %{_libdir}/pkgconfig/*.pc
  124. %{_mandir}/man3/*
  125. %exclude %{_mandir}/man3/SWF*.3pm*
  126. %exclude %{_libdir}/*.la
  127. %files python
  128. %defattr(-, root, root)
  129. %{python_sitearch}/*.so
  130. %{python_sitearch}/*.py*
  131. %{python_sitearch}/mingc-%{version}-py%{pyver}.egg-info
  132. %files tcl
  133. %defattr(-, root, root)
  134. %{_libdir}/%{name}/tcl/*.so
  135. %exclude %{_libdir}/%{name}/tcl/*.la
  136. %files perl
  137. %defattr(-, root, root)
  138. %{_libdir}/perl5/*
  139. %{_mandir}/man3/SWF*.3pm*
  140. %files php
  141. %defattr(-, root, root)
  142. %{_libdir}/php5/*
  143. %changelog
  144. * Fri Dec 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.5-1
  145. - updated to 0.4.5
  146. - added Patch0, 1 and 100
  147. - built with libpng 1.6.12, giflib 4.2.3 and perl 5.16.3
  148. - updated URL
  149. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.3-2
  150. - rebuilt with rpm-4.8.1 for pkg-config
  151. * Tue Feb 16 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.3-1
  152. - updated ming to 0.4.3
  153. - added %{name}-python, -tcl, -perl, -php sub packages
  154. - added BR: swig python-devel php-devel
  155. * Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.2-1vl5
  156. - updated ming to 0.4.2
  157. - added tags: BuildRequires Requires
  158. - added sub package: ming-devel
  159. - added script at %%clean
  160. - applied new versioning policy, spec in utf-8
  161. * Wed Sep 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl3
  162. - fixed args type of addString function (Patch1)
  163. - added Japanese Summary
  164. * Sat May 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl2
  165. - removed Vendor: tag
  166. - fixed post and postun section
  167. * Sat May 15 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.2a-4vl1
  168. - rebuild for Vine Linux
  169. - based on TLD 10, but removed Serial:
  170. * Thu Apr 24 2003 Noriyuki Suzuki <noriyuki@turbolinux.co.jp>
  171. - modified spec file for x86_64.
  172. * Thu Feb 28 2002 Kiichiro NAKA <knaka@turbolinux.co.jp>
  173. - I have gotten SRPM from http://rpms.arvin.dk/ming/source/
  174. * Tue Aug 21 2001 Troels Arvin <troels@arvin.dk>
  175. [0.2a-2.arvin]
  176. - Add Hansuck Jo's listmp3.c patch.
  177. - Build and include some of the utils.
  178. * Mon Aug 20 2001 Troels Arvin <troels@arvin.dk>
  179. [0.2a-1.arvin]
  180. - Uses new source version.
  181. * Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
  182. [0.1.1-3.arvin]
  183. - Added distribution to release-tag.
  184. * Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
  185. [0.1.1-2.arvin]
  186. - Fixed a permission problem for the documentation
  187. area.
  188. * Sat Apr 14 2001 Troels Arvin <troels@arvin.dk>
  189. [0.1.1-1.arvin]
  190. - Rebuilt with new source version.
  191. * Mon Mar 19 2001 Troels Arvin <troels@arvin.dk>
  192. [0.1.0-1.arvin]
  193. - Rebuilt with new source version. Patches shouldn't be need
  194. any more.
  195. * Mon Jan 29 2001 Troels Arvin <troels@arvin.dk>
  196. [0.0.9c-1.arvin]
  197. - First Ming RPM package. Currently, the RPM doesn't include
  198. anyting but the shared library and the C-oriented include
  199. file. None of the wrappers for other languages are handled by this
  200. RPM, currently. Also, none of the utilities are included in the
  201. package yet.