neon-vl.spec 9.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: neon
  3. Summary: An HTTP and WebDAV client library.
  4. Summary(ja): HTTP と WebDAV クライアントのライブラリ
  5. Version: 0.32.2
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://notroj.github.io/neon/
  12. Source0: https://notroj.github.io/neon/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. Requires: expat
  15. Requires: zlib >= 1.1.4
  16. Requires: krb5-libs
  17. BuildRequires: expat-devel
  18. BuildRequires: gnutls-devel
  19. BuildRequires: krb5-devel
  20. BuildRequires: libxml2-devel
  21. BuildRequires: sed
  22. BuildRequires: zlib-devel
  23. BuildRequires: keyutils-libs-devel
  24. BuildRequires: xmlto
  25. %description
  26. neon is an HTTP and WebDAV client library, with a C interface;
  27. providing a high-level interface to HTTP and WebDAV methods along
  28. with a low-level interface for HTTP request handling. neon
  29. supports persistent connections, proxy servers, basic, digest and
  30. Kerberos authentication, and has complete SSL support.
  31. %package devel
  32. Summary: Development libraries and C header files for the neon library
  33. Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
  34. Group: programming
  35. Requires: %{name} = %{version}
  36. Requires: zlib-devel
  37. #Requires: openssl-devel
  38. Requires: expat-devel
  39. Requires: gnutls-devel
  40. Requires: krb5-devel
  41. Requires: keyutils-libs-devel
  42. %description devel
  43. The development library for the C language HTTP and WebDAV client library.
  44. %description devel -l ja
  45. C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
  46. ## to build compat32 for x86_64 architecture support
  47. %package -n compat32-%{name}
  48. Summary: C language HTTP and WebDAV client library.
  49. Group: system,legacy
  50. Requires: expat
  51. Requires: zlib >= 1.1.4
  52. %description -n compat32-%{name}
  53. A C language HTTP and WebDAV client library.
  54. %package -n compat32-%{name}-devel
  55. Summary: A C language HTTP and WebDAV client library.
  56. Group: programming,legacy
  57. Requires: compat32-%{name} = %{version}
  58. Requires: compat32-zlib-devel
  59. #Requires: compat32-openssl-devel
  60. Requires: compat32-expat-devel
  61. Requires: compat32-keyutils-libs-devel
  62. Requires: compat32-krb5-devel
  63. %description -n compat32-%{name}-devel
  64. The development library for the C language HTTP and WebDAV client library.
  65. %debug_package
  66. %prep
  67. %setup -q
  68. # for GnuTLS 3.4
  69. #sed -e 's/client_set/set/' \
  70. # -e 's/gnutls_retr/&2/' \
  71. # -e 's/type = t/cert_&/' \
  72. # -i src/ne_gnutls.c
  73. %build
  74. %configure \
  75. --with-expat \
  76. --with-ssl=gnutls \
  77. --enable-threadsafe-ssl=posix \
  78. --enable-shared \
  79. --disable-static \
  80. --with-force-ssl
  81. %__make %{?_smp_mflags}
  82. %install
  83. %__rm -rf %{buildroot}
  84. %makeinstall
  85. sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
  86. $RPM_BUILD_ROOT%{_libdir}/libneon.la
  87. %find_lang %{name}
  88. rm -rf pkgdoc
  89. mv -f %{buildroot}%{_docdir}/neon-%{version} ./pkgdoc
  90. ## remove unuse files
  91. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  92. %clean
  93. rm -rf $RPM_BUILD_ROOT
  94. %files -f %{name}.lang
  95. %defattr(-,root,root)
  96. %doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README.md THANKS TODO
  97. %{_libdir}/*.so.*
  98. %files devel
  99. %defattr(-,root,root)
  100. %doc pkgdoc/*
  101. %{_bindir}/*
  102. %{_includedir}/*
  103. %{_mandir}/man1/*
  104. %{_mandir}/man3/*
  105. #{_libdir}/*.a
  106. #{_libdir}/*.la
  107. %{_libdir}/*.so
  108. %{_libdir}/pkgconfig/*.pc
  109. %if %{build_compat32}
  110. %files -n compat32-%{name}
  111. %defattr(-,root,root)
  112. %{_libdir}/*.so.*
  113. %files -n compat32-%{name}-devel
  114. %defattr(-,root,root)
  115. #{_libdir}/*.a
  116. #{_libdir}/*.la
  117. %{_libdir}/pkgconfig/*.pc
  118. %endif
  119. %changelog
  120. * Mon May 09 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.32.2-1
  121. - new upstream release.
  122. * Wed Nov 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.32.1-1
  123. - new upstream release.
  124. - dropped ldconfig scriptlets.
  125. * Sun Feb 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.31.2-1
  126. - new upstream release.
  127. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.2-1
  128. - new upstream release.
  129. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.1-1
  130. - new upstream release.
  131. - built with gnutls-3.4.x.
  132. * Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 0.30.0-1
  133. - update to 0.30.0
  134. * Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
  135. - rebuild with VineSeed environment
  136. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
  137. - update to 0.29.6
  138. * Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
  139. - add BuildRequires: keyutils-libs-devel
  140. - add Requires: krb5-devel, keyutils-libs-devel (-devel package)
  141. * Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
  142. - new upstream release
  143. * Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
  144. - rebuilt with krb5-libs-1.8.2
  145. - removed BR: openssl-devel
  146. - removed static library from devel package
  147. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
  148. - rebuilt with rpm-4.8.1 for pkg-config
  149. * Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
  150. - new upstream release with security fix (CVE-2009-2473, 2474)
  151. * Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
  152. - rebuild with gnutls-2.6.3
  153. * Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
  154. - add Requires/BuildRequires krb5-libs/krb5-devel tags
  155. - add _smp_mflags into make section
  156. * Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
  157. - new upstream release with security fix (CVE-2008-3746)
  158. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
  159. - removed *.la
  160. - spec in utf-8
  161. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
  162. - added --with-ssl=gnutls --enable-threadsafe-ssl
  163. - added BuildRequires: gnutls-devel
  164. * Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
  165. - new upstream release
  166. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
  167. - removed %%if !%%{build_compat32} case condition
  168. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
  169. - rebuild with expat-2.0.1
  170. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
  171. - new upstream release
  172. * Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
  173. - add Requires: zlib-devel, openssl-devel, expat-devel
  174. * Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
  175. - move %%configure from %%prep to %%build
  176. - remove unneeded locales.patch (for neon-0.26.x or later)
  177. * Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
  178. - new upstream release
  179. - drop doc.patch (patch0)
  180. - use more macros
  181. - drop BuildRequires: autoconf, automake
  182. - add *.pc to -devel (and compat32's) package
  183. - change group
  184. - add Requires: %%{name} = %%{version} to -devel (and compat32's) package
  185. - add doc/html instead of doc/* to %%doc
  186. - move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
  187. - run ldconfig in %%post,postun
  188. - add locales.patch (patch0)
  189. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
  190. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  191. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
  192. - added compat32- packages for x86_64 architecture support
  193. - added --libdir=%{_libdir} option to configure
  194. * Sun Sep 5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
  195. - new upstream release
  196. * Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
  197. - upstream release
  198. - update URL and Source0 tag: valid URL
  199. * Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
  200. - upstream release
  201. - add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
  202. - add Japanese Summary and %%description
  203. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
  204. - build VineLinux
  205. * Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
  206. - Updated to 0.23.5.
  207. * Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
  208. - Upgraded to 0.23.2.
  209. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
  210. - Upgraded to 0.22.0.
  211. - Fixed compilation from CVS.
  212. - Took out man pages until I can figure out xmlto program.
  213. * Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
  214. - Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
  215. to RedHat 7.3 versions and fixing bug in spec file.
  216. - Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
  217. work.
  218. * Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
  219. - Fixed file ownership problems. Made them owned by root.
  220. * Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
  221. - Updated to neon 0.21.3.
  222. * Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
  223. - Updated to neon 0.21.2.
  224. * Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
  225. - Updated to neon 0.21.1.
  226. - Now requires zlib >= 1.1.4.
  227. - Broke into zlib and zlib-devel.
  228. - Now builds shared library.
  229. * Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
  230. - Updated to neon 0.19.4.
  231. * Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
  232. - Updated to neon 0.19.2.
  233. * Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
  234. - Updated to neon 0.18.2.
  235. * Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
  236. - Took out dependency on libxml and w3c-libwww packages.
  237. - Added dependency on expat.
  238. * Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
  239. - Release 0.17.2-1: Updated neon.
  240. * Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
  241. - Release 2: Fixed prefix to be /usr instead of /usr/local.
  242. * Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
  243. - Release 2001-10-20: Initial Version.