ninja-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160
  1. Name: ninja
  2. Version: 1.11.0
  3. Release: 1%{?_dist_release}
  4. Summary: A small build system with a focus on speed
  5. Summary(ja): スピードを重視した小さなビルドシステム
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: ASL 2.0
  10. URL: https://ninja-build.org/
  11. Source0: https://github.com/martine/ninja/archive/v%{version}.tar.gz#/ninja-%{version}.tar.gz
  12. Source1: macros.ninja
  13. Source2: ninja.vim
  14. BuildRequires: asciidoc
  15. BuildRequires: gtest-devel
  16. BuildRequires: python3-rpm-macros
  17. BuildRequires: python3-devel
  18. BuildRequires: re2c >= 0.11.3
  19. %description
  20. Ninja is a small build system with a focus on speed. It differs from other
  21. build systems in two major respects: it is designed to have its input files
  22. generated by a higher-level build system, and it is designed to run builds as
  23. fast as possible.
  24. %package vim
  25. Summary: macros and syntax files of ninja for vim
  26. Summary(ja): VIM用のninjaマクロ・文法ファイル
  27. Group: programming
  28. Requires: vim-common
  29. %description vim
  30. This package contains macros and syntax files of ninja for vim.
  31. %debug_package
  32. %prep
  33. %setup -qn ninja-%{version}
  34. %build
  35. CFLAGS="%{optflags}" LDFLAGS="%{?__global_ldflags}" \
  36. %{__python3} configure.py --bootstrap --verbose
  37. ./ninja -v manual
  38. ./ninja -v ninja_test
  39. %install
  40. # TODO: Install ninja_syntax.py?
  41. mkdir -p %{buildroot}/{%{_bindir},%{_datadir}/bash-completion/completions,%{_datadir}/emacs/site-lisp,%{_datadir}/vim/vimfiles/syntax,%{_datadir}/vim/vimfiles/ftdetect,%{_datadir}/zsh/site-functions}
  42. install -pm755 ninja %{buildroot}%{_bindir}/ninja
  43. ln -sf ninja %{buildroot}%{_bindir}/ninja-build
  44. install -pm644 misc/bash-completion %{buildroot}%{_datadir}/bash-completion/completions/ninja-bash-completion
  45. install -pm644 misc/ninja-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/ninja-mode.el
  46. install -pm644 misc/ninja.vim %{buildroot}%{_datadir}/vim/vimfiles/syntax/ninja.vim
  47. install -pm644 %{SOURCE2} %{buildroot}%{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  48. install -pm644 misc/zsh-completion %{buildroot}%{_datadir}/zsh/site-functions/_ninja
  49. install -Dpm644 %{SOURCE1} %{buildroot}%{_rpmmacrodir}/macros.ninja
  50. %check
  51. # workaround possible too low default limits
  52. ulimit -n 4096 && ulimit -u 4096
  53. ./ninja_test
  54. %files
  55. %license COPYING
  56. %doc README.md doc/manual.html
  57. %{_rpmmacrodir}/macros.ninja
  58. %{_bindir}/ninja
  59. %{_bindir}/ninja-build
  60. %dir %{_datadir}/bash-completion
  61. %dir %{_datadir}/bash-completion/completions
  62. %{_datadir}/bash-completion/completions/ninja-bash-completion
  63. %{_datadir}/emacs/site-lisp/ninja-mode.el
  64. # zsh does not have a -filesystem package
  65. %{_datadir}/zsh/
  66. %files vim
  67. %{_datadir}/vim/vimfiles/syntax/ninja.vim
  68. %{_datadir}/vim/vimfiles/ftdetect/ninja.vim
  69. %changelog
  70. * Mon May 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.11.0-1
  71. - new upstream release.
  72. * Wed Mar 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.2-1
  73. - new upstream release.
  74. * Sun Apr 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.0-1
  75. - new upstream release.
  76. * Mon Sep 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
  77. - updated to 1.7.2.
  78. - added rpmmacros.
  79. - added a subpackage ninja-vim.
  80. * Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
  81. - updated to 1.7.1.
  82. * Mon Jan 18 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-1
  83. - update to 1.6.0
  84. - remove R: vim, emacsen
  85. (TODO: vim or el should be splitted to subpackage)
  86. - add ninja-build symlink to compatible with other rpm distros.
  87. * Thu Jun 12 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.0-1
  88. - initial build for Vine Linux
  89. * Wed Nov 20 2013 Ben Boeckel <mathstuf@gmail.com> - 1.4.0-1
  90. - Update to 1.4.0
  91. * Sun Nov 3 2013 Ville Skyttä <ville.skytta@iki.fi> - 1.3.4-4
  92. - Use special %%doc to install all docs (#994005).
  93. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-3
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  95. * Fri Jun 21 2013 Dan Horák <dan[at]danny.cz> - 1.3.4-2
  96. - workaround possible too low limits for number of processes and open files,
  97. fixes build on ppc/ppc64 and s390(x)
  98. * Sun Jun 09 2013 Ben Boeckel <mathstuf@gmail.com> - 1.3.4-1
  99. - Update to 1.3.4
  100. - Run test suite
  101. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  102. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  103. * Sun Nov 04 2012 Ben Boeckel <mathstuf@gmail.com> - 1.0.0-1
  104. - Update to 1.0.0
  105. * Thu Jul 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.6.20120719git5dc55a3
  106. - Update to new snapshot
  107. * Mon Jul 09 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.5.20120709gitb90d038
  108. - Preserve timestamps on install
  109. - Install as ninja-build to avoid conflicts with the ninja IRC package
  110. - Update snapshot
  111. * Tue Jun 19 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.4.20120605git54553d3
  112. - Add an ftdetect file for ninja
  113. - Fix zsh-stuff directory ownership
  114. * Thu Jun 07 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.3.20120605git54553d3
  115. - Add a Group tag
  116. * Tue Jun 05 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.2.20120605git54553d3
  117. - Update to new snapshot
  118. * Fri Mar 30 2012 Ben Boeckel <mathstuf@gmail.com> - 0-0.1.20120330gitabd33d5
  119. - Initial package