numpy-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367
  1. %bcond_with check
  2. # eval to 2.3 if python isn't yet present, workaround for no python in fc4 minimal buildroot
  3. %{!?python_version: %define python_version %(%{__python} -c 'import sys; print sys.version.split(" ")[0]' || echo "2.3")}
  4. Name: numpy
  5. Summary: A fast multidimensional array facility for Python
  6. Version: 1.22.1
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: BSD and Python and ASL 2.0
  12. URL: https://www.numpy.org/
  13. Source0: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-%{version}.tar.gz
  14. Source1: https://docs.scipy.org/doc/numpy/numpy-html-1.17.0.zip
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gcc-gfortran gcc
  17. BuildRequires: lapack-devel
  18. BuildRequires: openblas-devel
  19. BuildRequires: python-rpm-macros
  20. BuildRequires: python3-devel
  21. BuildRequires: python3-rpm-macros
  22. BuildRequires: python3-setuptools
  23. %if %{with check}
  24. BuildRequires: python3-pytest
  25. %endif
  26. BuildRequires: python3-Cython
  27. %description
  28. NumPy is a general-purpose array-processing package designed to
  29. efficiently manipulate large multi-dimensional arrays of arbitrary
  30. records without sacrificing too much speed for small multi-dimensional
  31. arrays. NumPy is built on the Numeric code base and adds features
  32. introduced by numarray as well as an extended C-API and the ability to
  33. create arrays of arbitrary type.
  34. There are also basic facilities for discrete fourier transform,
  35. basic linear algebra and random number generation. Also included in
  36. this package is a version of f2py that works properly with NumPy.
  37. %package -n python3-numpy
  38. Summary: A fast multidimensional array facility for Python
  39. Group: programming
  40. License: BSD
  41. %{?python_provide:%python_provide python3-numpy}
  42. Provides: libnpymath-static = %{version}-%{release}
  43. Provides: libnpymath-static%{?_isa} = %{version}-%{release}
  44. Obsoletes: numpy-common < 1.19.0
  45. Conflicts: numpy-common < 1.19.0
  46. %description -n python3-numpy
  47. NumPy is a general-purpose array-processing package designed to
  48. efficiently manipulate large multi-dimensional arrays of arbitrary
  49. records without sacrificing too much speed for small multi-dimensional
  50. arrays. NumPy is built on the Numeric code base and adds features
  51. introduced by numarray as well as an extended C-API and the ability to
  52. create arrays of arbitrary type.
  53. There are also basic facilities for discrete fourier transform,
  54. basic linear algebra and random number generation. Also included in
  55. this package is a version of f2py that works properly with NumPy.
  56. %package -n python3-numpy-f2py
  57. Summary: f2py for numpy
  58. Group: programming
  59. Requires: python3-numpy%{?_isa} = %{version}-%{release}
  60. Requires: python3-devel
  61. Provides: python3-f2py = %{version}-%{release}
  62. %{?python_provide:%python_provide python3-numpy-f2py}
  63. %description -n python3-numpy-f2py
  64. This package includes a version of f2py that works properly with NumPy.
  65. %package -n python3-numpy-doc
  66. Summary: Documentation for numpy
  67. Group: documentation
  68. Requires: python3-numpy = %{version}-%{release}
  69. BuildArch: noarch
  70. %description -n python3-numpy-doc
  71. This package provides the complete documentation for NumPy.
  72. %debug_package
  73. %prep
  74. %setup -q -n %{name}-%{version}
  75. # Force re-cythonization (ifed for PKG-INFO presence in setup.py)
  76. rm -f PKG-INFO
  77. # Use openblas pthreads as recommended by upstream (see comment in site.cfg.example)
  78. cat >> site.cfg <<EOF
  79. [openblas]
  80. libraries = openblasp
  81. library_dirs = %{_libdir}
  82. EOF
  83. %build
  84. env OPENBLAS=%{_libdir} \
  85. BLAS=%{_libdir} \
  86. LAPACK=%{_libdir} CFLAGS="%{optflags}" \
  87. %{__python3} setup.py build
  88. %install
  89. rm -rf %{buildroot}
  90. mkdir docs
  91. pushd docs
  92. unzip %{SOURCE1}
  93. popd
  94. env OPENBLAS=%{_libdir} \
  95. FFTW=%{_libdir} BLAS=%{_libdir} \
  96. LAPACK=%{_libdir} CFLAGS="%{optflags}" \
  97. %{__python3} setup.py install --root %{buildroot}
  98. pushd %{buildroot}%{_bindir} &> /dev/null
  99. ln -s f2py3 f2py.numpy
  100. popd &> /dev/null
  101. #symlink for includes, BZ 185079
  102. mkdir -p %{buildroot}%{_includedir}
  103. ln -s %{python3_sitearch}/%{name}/core/include/numpy/ %{buildroot}%{_includedir}/numpy
  104. %if %{with check}
  105. %check
  106. python3 runtests.py
  107. %endif
  108. %clean
  109. rm -rf $RPM_BUILD_ROOT
  110. %pretrans -n python3-numpy -p <lua>
  111. -- Define the path to directory being replaced below.
  112. -- DO NOT add a trailing slash at the end.
  113. path = "%{_includedir}/numpy"
  114. st = posix.stat(path)
  115. if st and st.type == "directory" then
  116. status = os.rename(path, path .. ".rpmmoved")
  117. if not status then
  118. suffix = 0
  119. while not status do
  120. suffix = suffix + 1
  121. status = os.rename(path .. ".rpmmoved", path .. ".rpmmoved." .. suffix)
  122. end
  123. os.rename(path, path .. ".rpmmoved")
  124. end
  125. end
  126. %files -n python3-numpy
  127. %license LICENSE.txt
  128. %doc THANKS.txt site.cfg.example
  129. %dir %{python3_sitearch}/%{name}
  130. %{python3_sitearch}/%{name}/*.py*
  131. %{python3_sitearch}/%{name}/__pycache__
  132. %{python3_sitearch}/%{name}/core
  133. %{python3_sitearch}/%{name}/distutils
  134. %{python3_sitearch}/%{name}/doc
  135. %{python3_sitearch}/%{name}/fft
  136. %{python3_sitearch}/%{name}/lib
  137. %{python3_sitearch}/%{name}/linalg
  138. %{python3_sitearch}/%{name}/ma
  139. %{python3_sitearch}/%{name}/random
  140. %{python3_sitearch}/%{name}/testing
  141. %{python3_sitearch}/%{name}/tests
  142. %{python3_sitearch}/%{name}/compat
  143. %{python3_sitearch}/%{name}/matrixlib
  144. %{python3_sitearch}/%{name}/polynomial
  145. %{python3_sitearch}/%{name}-*.egg-info
  146. %exclude %{python3_sitearch}/%{name}/LICENSE.txt
  147. %{_includedir}/numpy
  148. %{python3_sitearch}/%{name}/__init__.pxd
  149. %{python3_sitearch}/%{name}/__init__.cython-30.pxd
  150. %{python3_sitearch}/%{name}/py.typed
  151. %{python3_sitearch}/%{name}/typing/
  152. %{python3_sitearch}/%{name}/array_api/
  153. %files -n python3-numpy-f2py
  154. %{_bindir}/f2py
  155. %{_bindir}/f2py3
  156. %{_bindir}/f2py.numpy
  157. %{_bindir}/f2py%{python3_version}
  158. %{python3_sitearch}/%{name}/f2py
  159. %files -n python3-numpy-doc
  160. %doc docs/*
  161. %changelog
  162. * Tue Jan 25 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.22.1-1
  163. - new upstream release.
  164. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.19.1-1
  165. - new upstream release.
  166. - built with python3 only.
  167. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.16.5-1
  168. - new upstream release: this version is not newest but final version to suppot python2.
  169. - added python3 support.
  170. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-9
  171. - rebuild with python-2.7.2
  172. * Wed Aug 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.4.1-8
  173. - add Patch3(changeset_r8510.diff) and Patch4(changeset_r8511.diff) from debian
  174. * Fri Aug 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.1-7
  175. - Initial build for Vine Linux
  176. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-6
  177. - actually add the patch this time
  178. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-5
  179. - fix segfault within %check on 2.7 (patch 2)
  180. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 1:1.4.1-4
  181. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  182. * Sun Jul 18 2010 Dan Horák <dan[at]danny.cz> 1.4.1-3
  183. - ignore the "Ticket #1299 second test" failure on s390(x)
  184. * Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-2
  185. - source commit fix
  186. * Thu Jun 24 2010 Jef Spaleta <jspaleta@fedoraprject.org> 1.4.1-1
  187. - New upstream release. Include backported doublefree patch
  188. * Mon Apr 26 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-8
  189. - Moved distutils back to the main package, BZ 572820.
  190. * Thu Apr 08 2010 Jon Ciesla <limb@jcomserv.net> 1.3.0-7
  191. - Reverted to 1.3.0 after upstream pulled 1.4.0, BZ 579065.
  192. * Tue Mar 02 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-5
  193. - Linking /usr/include/numpy to .h files, BZ 185079.
  194. * Tue Feb 16 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-4
  195. - Re-enabling atlas BR, dropping lapack Requires.
  196. * Wed Feb 10 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-3
  197. - Since the previous didn't work, Requiring lapack.
  198. * Tue Feb 09 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-2
  199. - Temporarily dropping atlas BR to work around 562577.
  200. * Fri Jan 22 2010 Jon Ciesla <limb@jcomserv.net> 1.4.0-1
  201. - 1.4.0.
  202. - Dropped ARM patch, ARM support added upstream.
  203. * Tue Nov 17 2009 Jitesh Shah <jiteshs@marvell.com> - 1.3.0-6.fa1
  204. - Add ARM support
  205. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-6
  206. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  207. * Thu Jun 11 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-5
  208. - Fixed atlas BR, BZ 505376.
  209. * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-4
  210. - EVR bump for pygame chainbuild.
  211. * Fri Apr 17 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-3
  212. - Moved linalg, fft back to main package.
  213. * Tue Apr 14 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-2
  214. - Split out f2py into subpackage, thanks Peter Robinson pbrobinson@gmail.com.
  215. * Tue Apr 07 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-1
  216. - Update to latest upstream.
  217. - Fixed Source0 URL.
  218. * Thu Apr 02 2009 Jon Ciesla <limb@jcomserv.net> 1.3.0-0.rc1
  219. - Update to latest upstream.
  220. * Thu Mar 05 2009 Jon Ciesla <limb@jcomserv.net> 1.2.1-3
  221. - Require python-devel, BZ 488464.
  222. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-2
  223. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  224. * Fri Dec 19 2008 Jon Ciesla <limb@jcomserv.net> 1.2.1-1
  225. - Update to 1.2.1.
  226. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.0-2
  227. - Rebuild for Python 2.6
  228. * Tue Oct 07 2008 Jon Ciesla <limb@jcomserv.net> 1.2.0-1
  229. - New upstream release, added python-nose BR. BZ 465999.
  230. - Using atlas blas, not blas-devel. BZ 461472.
  231. * Wed Aug 06 2008 Jon Ciesla <limb@jcomserv.net> 1.1.1-1
  232. - New upstream release
  233. * Thu May 29 2008 Jarod Wilson <jwilson@redhat.com> 1.1.0-1
  234. - New upstream release
  235. * Tue May 06 2008 Jarod Wilson <jwilson@redhat.com> 1.0.4-1
  236. - New upstream release
  237. * Mon Feb 11 2008 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-2
  238. - Add python egg to %%files on f9+
  239. * Wed Aug 22 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3.1-1
  240. - New upstream release
  241. * Wed Jun 06 2007 Jarod Wilson <jwilson@redhat.com> 1.0.3-1
  242. - New upstream release
  243. * Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-2
  244. - Drop BR: atlas-devel, since it just provides binary-compat
  245. blas and lapack libs. Atlas can still be optionally used
  246. at runtime. (Note: this is all per the atlas maintainer).
  247. * Mon May 14 2007 Jarod Wilson <jwilson@redhat.com> 1.0.2-1
  248. - New upstream release
  249. * Tue Apr 17 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-4
  250. - Update gfortran patch to recognize latest gfortran f95 support
  251. - Resolves rhbz#236444
  252. * Fri Feb 23 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-3
  253. - Fix up cpuinfo bug (#229753). Upstream bug/change:
  254. http://projects.scipy.org/scipy/scipy/ticket/349
  255. * Thu Jan 04 2007 Jarod Wilson <jwilson@redhat.com> 1.0.1-2
  256. - Per discussion w/Jose Matos, Obsolete/Provide f2py, as the
  257. stand-alone one is no longer supported/maintained upstream
  258. * Wed Dec 13 2006 Jarod Wilson <jwilson@redhat.com> 1.0.1-1
  259. - New upstream release
  260. * Tue Dec 12 2006 Jarod Wilson <jwilson@redhat.com> 1.0-2
  261. - Rebuild for python 2.5
  262. * Wed Oct 25 2006 Jarod Wilson <jwilson@redhat.com> 1.0-1
  263. - New upstream release
  264. * Wed Sep 06 2006 Jarod Wilson <jwilson@redhat.com> 0.9.8-1
  265. - New upstream release
  266. * Wed Apr 26 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.6-1
  267. - Upstream update
  268. * Thu Feb 16 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.5-1
  269. - Upstream update
  270. * Mon Feb 13 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-2
  271. - Rebuild for Fedora Extras 5
  272. * Thu Feb 2 2006 Ignacio Vazquez-Abrams <ivazquez@ivazquez.net> 0.9.4-1
  273. - Initial RPM release
  274. - Added gfortran patch from Neal Becker