obexftp-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289
  1. %define python_sitearch %(python -c 'from distutils import sysconfig; print sysconfig.get_python_lib(1)')
  2. %define ruby_vendorarch %(ruby -r rbconfig -e 'print RbConfig::CONFIG["vendorarchdir"]')
  3. Name: obexftp
  4. Summary: Tool to access devices via the OBEX protocol
  5. Summary(ja): OBEX プロトコルを使用する機器にアクセスするためのツール
  6. Version: 0.24
  7. Release: 1%{?_dist_release}
  8. License: GPLv2+
  9. Group: Applications/Communications
  10. URL: http://openobex.triq.net/
  11. Source: http://dl.sourceforge.net/project/openobex/obexftp/0.24/obexftp-0.24-Source.tar.gz
  12. Patch0: obexftp-norpath.patch
  13. # From upstream git, fixes fuse apps not being installed
  14. Patch1: %{name}-0.24-fuse.patch
  15. # From OpenSUSE, thanks: fix pkgconfig to require bluez not bluetooth
  16. Patch2: %{name}-pkgconfig_requires.patch
  17. # From OpenSUSE, thanks: fix python install path
  18. Patch3: %{name}-0.24-fix-absurd-install-path.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: asciidoc
  21. BuildRequires: cmake
  22. BuildRequires: bluez-libs-devel
  23. BuildRequires: fuse-devel
  24. BuildRequires: gettext-devel
  25. BuildRequires: openobex-devel
  26. BuildRequires: perl(ExtUtils::MakeMaker)
  27. BuildRequires: python-devel
  28. BuildRequires: ruby-devel
  29. BuildRequires: swig
  30. BuildRequires: tcl
  31. BuildRequires: xmlto
  32. #----------------------------------------------------------------------------
  33. %description
  34. The overall goal of this project is to make mobile devices featuring the OBEX
  35. protocol and adhering to the OBEX FTP standard accessible by an open source
  36. implementation. The common usage for ObexFTP is to access your mobile phones
  37. memory to store and retrieve e.g. your phonebook, logos, ringtones, music,
  38. pictures and alike.
  39. %description -l ja
  40. このプロジェクトは OBEX プロトコルおよび、標準的で便利な OBEX FTP をフィーチャーしたモバイルデバイスを、オープンソースで実装する事を全体的な目標としています。
  41. ObexFTPの共通の使い方
  42. お使いの携帯電話のメモリにアクセスし、電話帳、ロゴ、着メロ、音楽、写真等の保存や取得を行います。
  43. #----------------------------------------------------------------------------
  44. %package -n fuse-%{name}
  45. Summary: FUSE based filesystem using ObexFTP
  46. Group: Applications/Communications
  47. Requires: %{name} = %{version}-%{release}
  48. %description -n fuse-%{name}
  49. This package provides a FUSE based filesystem using Obex protocol as backend.
  50. #----------------------------------------------------------------------------
  51. %package -n python-%{name}
  52. Summary: Python library to access devices via the OBEX protocol
  53. Summary(ja): OBEX プロトコルを使って機器を扱う Python ライブラリ
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. %description -n python-%{name}
  57. The overall goal of this project is to make mobile devices featuring the OBEX
  58. protocol and adhering to the OBEX FTP standard accessible by an open source
  59. implementation. The common usage for ObexFTP is to access your mobile phones
  60. memory to store and retrieve e.g. your phonebook, logos, ringtones, music,
  61. pictures and alike.
  62. %description -n python-%{name} -l ja
  63. このプロジェクトは OBEX プロトコルおよび、標準的で便利な OBEX FTP をフィーチャーしたモバイルデバイスを、オープンソースで実装する事を全体的な目標としています。
  64. ObexFTP の共通の使い方
  65. お使いの携帯電話のメモリにアクセスし、電話帳、ロゴ、着メロ、音楽、写真等の保存や取得を行います。
  66. (このパッケージは Python 向けライブラリです)
  67. #----------------------------------------------------------------------------
  68. %package -n perl-%{name}
  69. Summary: Perl library to access devices via the OBEX protocol
  70. Summary(ja): OBEX プロトコルを使って機器を扱う Perl ライブラリ
  71. Group: Development/Libraries
  72. Requires: %{name} = %{version}-%{release}
  73. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  74. Provides: perl-OBEXFTP = %{version}-%{release}
  75. %description -n perl-%{name}
  76. The overall goal of this project is to make mobile devices featuring the OBEX
  77. protocol and adhering to the OBEX FTP standard accessible by an open source
  78. implementation. The common usage for ObexFTP is to access your mobile phones
  79. memory to store and retrieve e.g. your phonebook, logos, ringtones, music,
  80. pictures and alike.
  81. %description -n perl-%{name} -l ja
  82. このプロジェクトは OBEX プロトコルおよび、標準的で便利な OBEX FTP をフィーチャーしたモバイルデバイスを、オープンソースで実装する事を全体的な目標としています。
  83. ObexFTPの共通の使い方
  84. お使いの携帯電話のメモリにアクセスし、電話帳、ロゴ、着メロ、音楽、写真等の保存や取得を行います。
  85. (このパッケージは perl 向けライブラリです)
  86. #----------------------------------------------------------------------------
  87. %package -n ruby-%{name}
  88. Summary: Ruby library to access devices via the OBEX protocol
  89. Summary(ja): OBEX プロトコルを使って機器を扱う Ruby ライブラリ
  90. Group: Development/Libraries
  91. Requires: %{name} = %{version}-%{release}
  92. %description -n ruby-%{name}
  93. The overall goal of this project is to make mobile devices featuring the OBEX
  94. protocol and adhering to the OBEX FTP standard accessible by an open source
  95. implementation. The common usage for ObexFTP is to access your mobile phones
  96. memory to store and retrieve e.g. your phonebook, logos, ringtones, music,
  97. pictures and alike.
  98. %description -n ruby-%{name} -l ja
  99. このプロジェクトは OBEX プロトコルおよび、標準的で便利な OBEX FTP をフィーチャーしたモバイルデバイスを、オープンソースで実装する事を全体的な目標としています。
  100. ObexFTPの共通の使い方
  101. お使いの携帯電話のメモリにアクセスし、電話帳、ロゴ、着メロ、音楽、写真等の保存や取得を行います。
  102. (このパッケージは ruby 向けライブラリです)
  103. #----------------------------------------------------------------------------
  104. %package devel
  105. Summary: Header files and libraries for %{name}
  106. Summary(ja): OBEX-FTP の開発用ヘッダーファイル
  107. Group: Development/Libraries
  108. Requires: %{name} = %{version}-%{release}
  109. Requires: bluez-libs-devel
  110. Requires: openobex-devel
  111. Requires: pkgconfig
  112. %description devel
  113. This package contains libraries and header files for developing applications
  114. that use %{name}.
  115. %description devel -l ja
  116. このパッケージには、%{name} を使用するアプリケーションを開発するためのライブラリ及びヘッダファイルが含まれています。
  117. #----------------------------------------------------------------------------
  118. %prep
  119. %setup -q -n %{name}-%{version}-Source
  120. %patch0 -p1 -b .norpath
  121. %patch1 -p1 -b .fuse
  122. %patch2 -p1 -b .pkgconfig
  123. %patch3 -p1 -b .pythonpath
  124. %build
  125. mkdir -p %{_target_platform}
  126. pushd %{_target_platform}
  127. %cmake -DCMAKE_SKIP_RPATH=YES ..
  128. # fix xmlto option to build man pages
  129. sed -i 's|\/usr\/bin\/xmlto |\/usr\/bin\/xmlto --skip-validation |g' doc/CMakeFiles/doc.dir/build.make
  130. popd
  131. make %{?_smp_mflags} -C %{_target_platform}
  132. make %{?_smp_mflags} doc -C %{_target_platform}
  133. %install
  134. rm -rf $RPM_BUILD_ROOT
  135. make install -C %{_target_platform} \
  136. DESTDIR=$RPM_BUILD_ROOT \
  137. RUBYARCHDIR=$RPM_BUILD_ROOT%{ruby_vendorarch}
  138. chmod 755 $RPM_BUILD_ROOT%{perl_vendorarch}/*/OBEXFTP/OBEXFTP.so
  139. # rm $RPM_BUILD_ROOT%{_libdir}/*.la
  140. rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
  141. rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/*/OBEXFTP/{.packlist,OBEXFTP.bs}
  142. %clean
  143. rm -rf $RPM_BUILD_ROOT
  144. %post -p /sbin/ldconfig
  145. %postun -p /sbin/ldconfig
  146. %files
  147. %defattr(-, root, root, -)
  148. %doc AUTHORS ChangeLog NEWS README THANKS TODO
  149. %{_bindir}/obexftp
  150. %{_bindir}/obexftpd
  151. %{_libdir}/*.so.*
  152. %{_mandir}/man1/obexftp.1*
  153. %{_mandir}/man1/obexftpd.1*
  154. %files devel
  155. %defattr(-, root, root, -)
  156. %{_includedir}/bfb/
  157. %{_includedir}/multicobex/
  158. %{_includedir}/obexftp/
  159. %{_libdir}/*.so
  160. %{_libdir}/pkgconfig/obexftp.pc
  161. %files -n fuse-%{name}
  162. %{_bindir}/obexautofs
  163. %{_bindir}/obexfs
  164. %files -n python-%{name}
  165. %defattr(-, root, root, -)
  166. %{python_sitearch}/_obexftp.so*
  167. %{python_sitearch}/obexftp.py*
  168. %files -n perl-%{name}
  169. %defattr(-, root, root, -)
  170. %{perl_vendorarch}/OBEXFTP.pm
  171. %dir %{perl_vendorarch}/*/OBEXFTP
  172. %{perl_vendorarch}/*/OBEXFTP/OBEXFTP.so
  173. %files -n ruby-%{name}
  174. %defattr(-, root, root, -)
  175. %{ruby_vendorarch}/obexftp.so
  176. #----------------------------------------------------------------------------
  177. # Maintainers: babasaki@mindgear.org
  178. #
  179. #----------------------------------------------------------------------------
  180. %changelog
  181. * Tue Nov 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.24-1
  182. - updaed to 0.24
  183. - added fuse-obexftp subpackage
  184. - built with openobex 1.7,1 and perl 5.16.3
  185. * Sat Jul 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.23-2
  186. - rebuild with perl-5.12.3
  187. * Sat Dec 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.23-1
  188. - new upstream release
  189. - removed Requires: ruby(abi) (= 1.8) <BTS:799>
  190. * Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.22-4
  191. - rebuild (ruby-obexftp subpackage not uploaded on i386/x86_64 yet)
  192. * Fri Oct 24 2008 Seiichirou Babasaki 0.22-3
  193. - change %{perl_sitearch} -> %{perl_vendorarch}
  194. - added "# Maintainers: " comments.
  195. - changed UTF-8 encode at obexftp.vs.spec
  196. - Updated specfile
  197. * Wed Oct 2 2008 Seiichirou Babasaki 0.22-2
  198. - change %{perl_vendorarch} -> %{perl_sitearch}
  199. - Updated specfile
  200. * Wed Jan 16 2008 Seiichirou Babasaki 0.20-0.5_2-1
  201. - Import obexftp - Packager: Babasaki
  202. - Updated specfile
  203. #----------------------------------------------------------------------------
  204. * Thu Sep 06 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.5.rc7
  205. - updated to 0.22-rc7
  206. - added pkgconfig file
  207. - make perl BR more specific
  208. * Mon Aug 27 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.4.rc6
  209. - rebuilt for BuildID
  210. - updated license tag
  211. * Mon Aug 06 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.3.rc6
  212. - updated to 0.22-rc6
  213. - added ruby bindings (patch by Andy Shevchenko)
  214. - dropped upstreamed patch
  215. - added missing BRs for F7+
  216. * Mon Mar 26 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.2.pre4
  217. - fix segfault in obexftpd (patch by Jan Kratochvil), closes (#230991)
  218. * Fri Mar 23 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.22-0.1.pre4
  219. - updated to 0.22-pre4
  220. - updated patches
  221. * Fri Jan 26 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-3
  222. - add missing disttag
  223. * Thu Jan 25 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-2
  224. - added missing defattr
  225. - require openobex-devel > 1.2
  226. - added missing MODULE_COMPAT Requires: to perl subpackage
  227. - renamed subpackages to perl/python-obexftp
  228. - fixed rpaths
  229. * Mon Jan 01 2007 Dominik Mierzejewski <rpm@greysector.net> - 0.20-1
  230. - updated to 0.20
  231. * Sun Jan 29 2006 Dag Wieers <dag@wieers.com> - 0.18-1
  232. - Initial package. (using DAR)