qt5-qtquickcontrols2-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186
  1. %global qt_module qtquickcontrols2
  2. #define prerelease
  3. %global qt5_minorver 5.15
  4. %global qt5_version 5.15.2
  5. #global qt5_patchlevel 1
  6. Name: qt5-%{qt_module}
  7. Summary: Qt5 - module with set of QtQuick controls for embedded
  8. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  9. Release: 1%{?_dist_release}
  10. Group: system
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: GPLv2+ or LGPLv3 and GFDL
  14. Url: https://www.qt.io/
  15. Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
  16. # filter qml provides
  17. %global __provides_exclude_from ^%{_qt5_archdatadir}/qml/.*\\.so$
  18. BuildRequires: qt5-rpm-macros
  19. BuildRequires: qt5-qtbase-devel >= %{version}
  20. BuildRequires: qt5-qtbase-private-devel
  21. #libQt53DRender.so.5(Qt_5_PRIVATE_API)(64bit)
  22. #libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit)
  23. #libQt5Gui.so.5(Qt_5_PRIVATE_API)(64bit)
  24. #libQt5Qml.so.5(Qt_5_PRIVATE_API)(64bit)
  25. #libQt5Quick.so.5(Qt_5_PRIVATE_API)(64bit)
  26. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  27. BuildRequires: qt5-qtdeclarative-devel
  28. Requires: qt5-qtdeclarative%{?_isa} >= %{version}
  29. Requires: qt5-qtgraphicaleffects%{_isa} >= %{version}
  30. %description
  31. The Qt Labs Controls module provides a set of controls that can be used to
  32. build complete interfaces in Qt Quick.
  33. Unlike Qt Quick Controls, these controls are optimized for embedded systems
  34. and so are preferred for hardware with limited resources.
  35. %package devel
  36. Summary: Development files for %{name}
  37. Group: programming
  38. Requires: %{name}%{?_isa} = %{version}-%{release}
  39. Requires: qt5-qtbase-devel%{?_isa}
  40. Requires: qt5-qtdeclarative-devel%{?_isa}
  41. %description devel
  42. %{summary}.
  43. %package examples
  44. Summary: Examples for %{name}
  45. Group: programming
  46. Requires: %{name}%{?_isa} = %{version}-%{release}
  47. %description examples
  48. %{summary}.
  49. %debug_package
  50. %prep
  51. %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
  52. %if 0%{?prerelease}
  53. syncqt.pl -version %{version}
  54. %endif
  55. %build
  56. mkdir %{_target_platform}
  57. pushd %{_target_platform}
  58. %{qmake_qt5} ..
  59. make %{?_smp_mflags}
  60. %install
  61. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  62. ## .prl/.la file love
  63. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  64. pushd %{buildroot}%{_qt5_libdir}
  65. for prl_file in libQt5*.prl ; do
  66. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  67. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  68. rm -fv "$(basename ${prl_file} .prl).la"
  69. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  70. fi
  71. done
  72. popd
  73. # Remove .la leftovers
  74. rm -f %{buildroot}%{_qt5_libdir}/libQt5*.la
  75. %files
  76. %license LICENSE.LGPLv3 LICENSE.GPLv3
  77. %{_qt5_libdir}/libQt5QuickTemplates2.so.5*
  78. %{_qt5_libdir}/libQt5QuickControls2.so.5*
  79. %{_qt5_qmldir}/Qt/labs/calendar
  80. %{_qt5_qmldir}/Qt/labs/platform
  81. %{_qt5_archdatadir}/qml/QtQuick/Controls.2/
  82. %{_qt5_archdatadir}/qml/QtQuick/Templates.2/
  83. %if 0%{?docs}
  84. %files doc
  85. %license LICENSE.FDL LICENSE.LGPLv3 LICENSE.GPLv3
  86. %dir %{_qt5_docdir}/qtlabscontrols/
  87. %{_qt5_docdir}/qtlabscontrols/*
  88. %{_qt5_docdir}/qtlabscontrols.qch
  89. %endif
  90. %files devel
  91. %{_qt5_headerdir}/
  92. %{_qt5_libdir}/pkgconfig/*.pc
  93. %{_qt5_libdir}/libQt5QuickTemplates2.so
  94. %{_qt5_libdir}/libQt5QuickControls2.so
  95. %{_qt5_libdir}/libQt5QuickTemplates2.prl
  96. %{_qt5_libdir}/libQt5QuickControls2.prl
  97. %{_qt5_libdir}/qt5/mkspecs/modules/*
  98. %{_libdir}/cmake/Qt5QuickControls2/
  99. %{_libdir}/cmake/Qt5QuickTemplates2/
  100. %files examples
  101. %{_qt5_examplesdir}/quickcontrols2/
  102. %changelog
  103. * Tue Apr 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.15.2-1
  104. - new upstream release.
  105. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
  106. - new upstream release.
  107. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
  108. - new upstream release.
  109. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  110. - new upstream release.
  111. * Fri Jan 12 2018 Toshiaki Ara <ara_t@384.jp> - 5.6.3-1
  112. - update to 5.6.3
  113. * Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  114. - new upstream release.
  115. - initial build for Vine Linux.
  116. * Sat Jun 11 2016 Pier Luigi Fiorini <pierluigi.fiorini@gmail.com> - 5.6.1-2
  117. - Add qt5-qtgraphicaleffects dependency
  118. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
  119. - Update to 5.6.1
  120. * Sun Apr 17 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-4
  121. - BR: qt5-qtbase-private-devel qt5-qtdeclarative-private-devel
  122. * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
  123. - rebuild
  124. * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
  125. - rebuild
  126. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org>
  127. - 5.6.0 final release
  128. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
  129. - 5.6.0 final release
  130. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.4.rc
  131. - Update to final RC
  132. * Thu Feb 18 2016 Pier Luigi Fiorini <pierluigi.fiorini@gmail.com> - 5.6.0-0.3.rc
  133. - Update to rc
  134. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.2.beta
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  136. * Fri Jan 15 2016 Pier Luigi Fiorini <pierluigi.fiorini@gmail.com> - 5.6.0-0.1.beta
  137. - Initial packaging