star-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457
  1. Summary: An archiving tool with ACL support
  2. Summary(ja): An archiving tool with ACL support
  3. Name: star
  4. Version: 1.5.3
  5. Release: 1%{?_dist_release}
  6. License: CDDL
  7. Group: Applications/Archiving
  8. URL: http://cdrecord.berlios.de/old/private/star.html
  9. Source: ftp://ftp.berlios.de/pub/star/%{name}-%{version}.tar.bz2
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. # do not segfault with data-change-warn option (#255261)
  13. Patch2: star-1.5-changewarnSegv.patch
  14. # Prevent buffer overflow for filenames with length of 100 characters (#556664)
  15. Patch3: star-1.5.2-bufferoverflow.patch
  16. # Fix some invalid manpage references (#624612)
  17. Patch4: star-1.5.1-manpagereferences.patch
  18. # note that the H=crc format uses Sum32 algorithm, not CRC
  19. Patch6: star-1.5.1-crc.patch
  20. # Allow rmt to access all files.
  21. # ~> downstream
  22. # ~> #968980
  23. Patch8: star-1.5.2-rmt-rh-access.patch
  24. # Use ssh rather than rsh by default
  25. # ~> downstream
  26. # ~> related to #968980
  27. Patch9: star-1.5.2-use-ssh-by-default.patch
  28. # Fix broken star.mk in 1.5.3 (included from all.mk)
  29. Patch10: star-1.5.3-star-mk.patch
  30. # Fix segfault for 'pax -X' (rhbz#1175009)
  31. # ~> downstream
  32. Patch11: star-1.5.3-pax-X-option.patch
  33. BuildRequires: libattr-devel libacl-devel libtool
  34. BuildRequires: e2fsprogs-devel
  35. # Historically, star installed /usr/bin/spax binary also so we don't want to
  36. # break the compatibility. We don't care about scpio because scpio binary was
  37. # not installed.
  38. Requires: spax
  39. %description
  40. Star saves many files together into a single tape or disk archive,
  41. and can restore individual files from the archive. Star supports ACL.
  42. %package -n spax
  43. Summary: Portable archive exchange
  44. Group: Applications/Archiving
  45. Obsoletes: pax < 3.4-2
  46. Provides: pax
  47. %description -n spax
  48. The pax utility shall read and write archives, write lists of the members of
  49. archive files and copy directory hierarchies as is defined in IEEE Std 1003.1.
  50. %package -n scpio
  51. Summary: Copy file archives in and out (LEGACY)
  52. Group: Applications/Archiving
  53. %description -n scpio
  54. The scpio utility, depending on the options used: copies files to an archive
  55. file, extracts files from an archive file, lists files from an archive file or
  56. copies files from one directory tree to another.
  57. %package -n rmt
  58. Summary: Provides certain programs with access to remote tape devices
  59. Group: Applications/Archiving
  60. %description -n rmt
  61. The rmt utility provides remote access to tape devices for programs
  62. like dump (a filesystem backup program), restore (a program for
  63. restoring files from a backup), and tar (an archiving program).
  64. %prep
  65. %setup -q
  66. %patch2 -p1 -b .changewarnSegv
  67. %patch3 -p1 -b .namesoverflow
  68. %patch4 -p1 -b .references
  69. %patch6 -p1 -b .crc
  70. %patch8 -p1 -b .rmt-access-rules
  71. %patch9 -p1 -b .ssh-by-default
  72. %patch10 -p1 -b .bug-config-1.5.3
  73. %patch11 -p1 -b .pax-X
  74. cp -a star/all.mk star/Makefile
  75. star_recode()
  76. {
  77. for i in $@; do
  78. iconv -f iso_8859-1 -t utf-8 $i > .tmp_file
  79. mv .tmp_file $i
  80. done
  81. }
  82. star_recode AN-1.5 AN-1.5.2 star/star.4
  83. cp -a READMEs/README.linux .
  84. for PLAT in %{arm} %{power64} aarch64 x86_64 s390 s390x sh3 sh4 sh4a sparcv9; do
  85. for AFILE in gcc cc; do
  86. [ ! -e RULES/${PLAT}-linux-${AFILE}.rul ] \
  87. && ln -s i586-linux-${AFILE}.rul RULES/${PLAT}-linux-${AFILE}.rul
  88. done
  89. done
  90. %build
  91. # This is config/work-around for atypical build system. Variables used are
  92. # docummented makefiles.5. GMAKE_NOWARN silences irritating warnings in
  93. # GNU/Linux ecosystem.
  94. %global make_flags GMAKE_NOWARN=true \\\
  95. RUNPATH= \\\
  96. LDPATH= \\\
  97. PARCH=%{_target_cpu} \\\
  98. K_ARCH=%{_target_cpu} \\\
  99. INS_BASE=$RPM_BUILD_ROOT%{_prefix} \\\
  100. INS_RBASE=$RPM_BUILD_ROOT \\\
  101. INSTALL='sh $(SRCROOT)/conf/install-sh -c -m $(INSMODEINS)' \\\
  102. COPTX="$RPM_OPT_FLAGS -DTRY_EXT2_FS" \\\
  103. DEFCCOM=gcc
  104. # Note: disable optimalisation by COPTX='-g3 -O0' LDOPTX='-g3 -O0'
  105. make %{?_smp_mflags} %make_flags
  106. %install
  107. make install -s %make_flags
  108. ln -s spax ${RPM_BUILD_ROOT}%{_bindir}/pax
  109. ln -s spax.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/pax.1
  110. ln -s star.1.gz ${RPM_BUILD_ROOT}%{_mandir}/man1/ustar.1
  111. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}
  112. mkdir -p ${RPM_BUILD_ROOT}%{_pkgdocdir}
  113. ln -s %{_sbindir}/rmt ${RPM_BUILD_ROOT}%{_sysconfdir}/rmt
  114. install -p -m 644 COPYING star/README CDDL.Schily.txt AN-* \
  115. ${RPM_BUILD_ROOT}%{_pkgdocdir}
  116. # XXX Nuke unpackaged files.
  117. ( cd ${RPM_BUILD_ROOT}
  118. rm -f .%{_bindir}/mt
  119. rm -f .%{_bindir}/smt
  120. rm -f .%{_bindir}/tartest
  121. rm -f .%{_bindir}/tar
  122. rm -f .%{_bindir}/gnutar
  123. rm -f .%{_bindir}/star_fat
  124. rm -f .%{_bindir}/star_sym
  125. rm -f .%{_bindir}/suntar
  126. rm -f .%{_sysconfdir}/default/star
  127. rm -rf .%{_prefix}%{_sysconfdir}
  128. rm -rf .%{_prefix}/include
  129. rm -rf .%{_prefix}/lib # hard-wired intently
  130. rm -rf .%{_mandir}/man3
  131. rm -rf .%{_mandir}/man5/{makefiles,makerules}.5*
  132. rm -rf .%{_mandir}/man1/{tartest,gnutar,smt,mt,suntar,match}.1*
  133. rm -rf .%{_docdir}/star/testscripts
  134. rm -rf .%{_docdir}/star/TODO
  135. rm -rf .%{_docdir}/rmt
  136. )
  137. %clean
  138. %global general_docs README AN* COPYING CDDL.Schily.txt TODO README.linux
  139. %files
  140. %doc %{general_docs}
  141. %{_bindir}/star
  142. %{_bindir}/ustar
  143. %{_mandir}/man1/star.1*
  144. %{_mandir}/man1/ustar.1*
  145. %{_mandir}/man5/star.5*
  146. %files -n scpio
  147. %doc %{general_docs}
  148. %doc %{_mandir}/man1/scpio.1*
  149. %{_bindir}/scpio
  150. %files -n spax
  151. %doc %{general_docs}
  152. %doc %{_mandir}/man1/spax.1*
  153. %doc %{_mandir}/man1/pax.1*
  154. %{_bindir}/spax
  155. %{_bindir}/pax
  156. %files -n rmt
  157. %doc %{general_docs}
  158. %{_sbindir}/rmt
  159. %{_mandir}/man1/rmt.1*
  160. %config %{_sysconfdir}/default/rmt
  161. # This symlink is used by cpio, star, spax, scpio, .. thus it is needed. Even
  162. # if the cpio may be configured to use /sbin/rmt rather than /etc/rmt, star (and
  163. # thus spax, ..) has the lookup path hardcoded to '/etc/rmt' (it means that even
  164. # non rpm based systems will try to look for /etc/rmt). And - the conclusion is
  165. # - it does not make sense to fight against /etc/rmt symlink ATM (year 2013).
  166. %{_sysconfdir}/rmt
  167. %changelog
  168. * Thu May 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.3-1
  169. - new upstream release.
  170. - updated patches.
  171. * Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.5.2-1
  172. - initial build for Vine Linux
  173. - add Obsoletes/Provides pax to spax
  174. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-11
  175. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  176. * Fri Jan 17 2014 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-10
  177. - enable build for ppc64le (#1054401)
  178. * Mon Jan 13 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.5.2-9
  179. - Temporarily disable profiling on aarch64
  180. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-8
  181. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  182. * Thu Jun 20 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-7
  183. - we should provide /etc/rmt symlink for a while (related to #968980)
  184. - use the ssh as the default remote access method
  185. * Thu May 30 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-6
  186. - subpackage also 'rmt' (#968980)
  187. * Fri May 24 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-5
  188. - add missing ghost files (#960007)
  189. - fix the upgrade path, sorry for the noise (#959917, #960007)
  190. * Mon May 06 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-2
  191. - package spax and scpio separately (#959917)
  192. - fedora-review fixes, unapplied patch
  193. - make the spax to be pax alternative (#960007)
  194. * Wed Apr 10 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.2-1
  195. - rebase to most up2date upstream tarball, remove patches already upstream, fix
  196. code movements in patches (#928758)
  197. - fix man-page-day objections (private #948866)
  198. - fix the build for aarch64 (#926571)
  199. * Thu Mar 21 2013 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-12
  200. - package also the 'scpio' utility (#771926)
  201. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-11
  202. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  203. * Thu Oct 18 2012 Pavel Raiskup <praiskup@redhat.com> - 1.5.1-10
  204. - do not crash during extracting if extended attributes are not set on all
  205. archived files (#861848)
  206. - note in man page that H=crc format uses Sum32 algorithm (FIPS refuses CRC)
  207. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-9
  208. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  209. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-8
  210. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  211. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-7
  212. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  213. * Tue Jan 04 2011 Ondrej Vasik <ovasik@redhat.com> 1.5.1-6
  214. - fix segfault with multivol option due to signedness(#666015)
  215. * Wed Sep 29 2010 jkeating - 1.5.1-5
  216. - Rebuilt for gcc bug 634757
  217. * Tue Sep 14 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-4
  218. - fix another instance of buffer overflow for files with
  219. long names(#632384)
  220. * Tue Aug 17 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-3
  221. - Fix some invalid manpage references (#624612)
  222. - ship star.4 manpage with star format description
  223. * Wed Feb 03 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-2
  224. - fix buffer overflow for files with names of length
  225. 100 chars(#556664)
  226. * Wed Jan 13 2010 Ondrej Vasik <ovasik@redhat.com> 1.5.1-1
  227. - new upstream release 1.5.1
  228. * Thu Aug 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-8
  229. - provide symlinked manpage for ustar
  230. * Thu Aug 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-7
  231. - Merge review (#226434) changes: convert AN-1.5 to utf-8,
  232. spec file cosmetic/policy changes, ship README.linux in doc
  233. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-6
  234. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  235. * Sun May 10 2009 Ville Skyttä <ville.skytta at iki.fi> - 1.5-5
  236. - Build with $RPM_OPT_FLAGS.
  237. - Convert specfile to UTF-8.
  238. * Wed Apr 08 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-4
  239. - fix build failure due to symbols conflicting
  240. with stdio(#494213)
  241. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5-3
  242. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  243. * Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-2
  244. - remove names.c requirements from non-fat Makefiles,
  245. do not ship names.c (#255261 for details)
  246. * Tue Jan 27 2009 Ondrej Vasik <ovasik@redhat.com> 1.5-1
  247. - use final instead of beta
  248. - ship missing names.c separately
  249. - enable optimalization again
  250. * Wed Dec 03 2008 Ondrej Vasik <ovasik@redhat.com> 1.5a89-1
  251. - update to latest upstream release
  252. * Fri Jun 06 2008 Dennis Gilmore <dennis@ausil.us> 1.5a84-6
  253. - add sparcv9 support
  254. * Mon May 12 2008 Peter Vrabec <pvrabec@redhat.com> 1.5a84-5
  255. - add super-H(sh3,4) architecture support (#442883)
  256. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.5a84-4
  257. - Autorebuild for GCC 4.3
  258. * Fri Aug 31 2007 Dan Kopecek <dkopecek@redhat.com> 1.5a84-3
  259. - added -O0 to COPTX (CFLAGS) (see #255261)
  260. * Mon Aug 27 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a84-2
  261. - fix segfault of data-change-warn option (#255261),
  262. patch from dkopecek@redhat.com
  263. * Fri Aug 24 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a84-1
  264. - new upstream release with CVE-2007-4134 fix
  265. * Sun Jun 24 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a76-3
  266. - build star on ARM platforms (#245465)
  267. * Mon Jan 29 2007 Peter Vrabec <pvrabec@redhat.com> 1.5a76-2
  268. - fix buildreq. and rebuild
  269. * Thu Jan 18 2007 Jan Cholasta <grubber.x@gmail.com> 1.5a76-1
  270. - upgrade
  271. * Tue Aug 08 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a75-1
  272. - upgrade
  273. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.5a74-3.1
  274. - rebuild
  275. * Tue Jun 13 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-3
  276. - use autoconf provided by star
  277. * Fri Jun 02 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-2
  278. - update tarball
  279. * Mon Apr 24 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a74-1
  280. - upgrade
  281. * Wed Mar 22 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a73-1
  282. - upgrade
  283. * Wed Mar 01 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a72-1
  284. - upgrade
  285. * Wed Feb 22 2006 Peter Vrabec <pvrabec@redhat.com> 1.5a71-1
  286. - upgrade
  287. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  288. - rebuilt
  289. * Tue Nov 08 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a69-1
  290. - upgrade
  291. * Mon Oct 10 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a68-1
  292. - upgrade
  293. * Thu Sep 22 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a67-1
  294. - upgrade
  295. * Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com> 1.5a65-1
  296. - upgrade 1.5a65-1 made by Horst H. von Brand <vonbrand@inf.utfsm.cl>
  297. - Source URL changed, no homepage now
  298. - License changed from GPL to CDDL 1.0
  299. - Define MAKEPROG=gmake like the Gmake.linux script does
  300. - Disable fat binary as per star/Makefile, update star-1.5-selinux.patch for
  301. the various *.mk files used in that case
  302. - Axe /usr/share/man/man1/match.1*, /usr/etc/default/rmt too
  303. - Explicit listing in %%files, allow for compressed or plain manpages
  304. * Fri Aug 26 2005 Peter Vrabec <pvrabec@redhat.com>
  305. - do not remove star_fat
  306. * Fri Aug 12 2005 Peter Vrabec <pvrabec@redhat.com>
  307. - upgrade 1.5a64-1
  308. * Thu Aug 04 2005 Karsten Hopp <karsten@redhat.de> 1.5a54-3
  309. - remove /usr/bin/tar symlink
  310. * Fri Mar 18 2005 Peter Vrabec <pvrabec@redhat.com>
  311. - rebuilt
  312. * Mon Nov 22 2004 Peter Vrabec <pvrabec@redhat.com>
  313. - upgrade 1.5a54-1 & rebuild
  314. * Mon Oct 25 2004 Peter Vrabec <pvrabec@redhat.com>
  315. - fix dependencie (#123770)
  316. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  317. - rebuilt
  318. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  319. - rebuilt
  320. * Mon Jan 26 2004 Dan Walsh <dwalsh@redhat.com> 1.5a25-4
  321. - Fix call to is_selinux_enabled
  322. * Mon Jan 19 2004 Jeff Johnson <jbj@jbj.org> 1.5.a25-3
  323. - fix: (!(x & 1)) rather than (!x & 1) patch.
  324. * Wed Sep 24 2003 Dan Walsh <dwalsh@redhat.com> 1.5a25-2
  325. - turn selinux off
  326. * Tue Sep 16 2003 Dan Walsh <dwalsh@redhat.com> 1.5a25-1.sel
  327. - turn selinux on
  328. * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-5
  329. - turn selinux off
  330. * Mon Aug 25 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-3
  331. - Add SELinux modification to handle setting security context before creation.
  332. * Thu Aug 21 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-2
  333. - Fix free_xattr bug
  334. * Wed Jul 16 2003 Dan Walsh <dwalsh@redhat.com> 1.5a18-1
  335. - Add SELinux support
  336. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  337. - rebuilt
  338. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  339. - rebuilt
  340. * Tue Nov 12 2002 Elliot Lee <sopwith@redhat.com> 1.5a08-3
  341. - Build when uname -m != _target_platform
  342. - Use _smp_mflags
  343. - Build on x86_64
  344. * Mon Nov 11 2002 Jeff Johnson <jbj@redhat.com> 1.5a08-2
  345. - update to 1.5a08.
  346. - build from cvs.
  347. * Wed Jun 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.5a04
  348. - Initial build. Alpha version - it's needed for ACLs.