stunnel-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591
  1. %bcond_with systemd
  2. %bcond_with crypto_policies
  3. Summary: An SSL-encrypting socket wrapper
  4. Name: stunnel
  5. Version: 5.60
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: internet
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: iwaim
  11. License: GPLv2
  12. URL: https://www.stunnel.org/
  13. Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
  14. Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
  15. Source2: Certificate-Creation
  16. Source3: sfinger.xinetd
  17. Source4: stunnel-sfinger.conf
  18. Source5: pop3-redirect.xinetd
  19. Source6: stunnel-pop3s-client.conf
  20. Source7: stunnel@.service
  21. Source100: stunnel.init
  22. Patch0: stunnel-5.50-authpriv.patch
  23. Patch1: stunnel-5.50-systemd-service.patch
  24. Patch3: stunnel-5.56-system-ciphers.patch
  25. Patch4: stunnel-5.56-coverity.patch
  26. Patch5: stunnel-5.56-default-tls-version.patch
  27. Patch6: stunnel-5.56-curves-doc-update.patch
  28. Patch100: stunnel-5.60-compile.patch
  29. BuildRoot: %{_tmppath}/stunnel-root
  30. # util-linux is needed for rename
  31. BuildRequires: openssl-devel
  32. BuildRequires: pkgconfig
  33. BuildRequires: util-linux
  34. %if %{with systemd}
  35. %{?systemd_requires}
  36. %else
  37. Requires(post): chkconfig
  38. Requires(preun): chkconfig /sbin/service
  39. Requires(postun): /sbin/service
  40. %endif
  41. %if %{with systemd}
  42. %global pidfile %{_rundir}/stunnel.pid
  43. %else
  44. %global pidfile %{_localstatedir}/run/stunnel.pid
  45. %endif
  46. # Do not generate provides for private libraries
  47. %global __provides_exclude_from ^%{_libdir}/stunnel/.*$
  48. %description
  49. Stunnel is a socket wrapper which can provide SSL (Secure Sockets
  50. Layer) support to ordinary applications. For example, it can be used
  51. in conjunction with imapd to create an SSL secure IMAP server.
  52. %debug_package
  53. %prep
  54. %setup -q
  55. %patch0 -p1
  56. %patch1 -p1
  57. %if %{with crypto_policies}
  58. %patch3 -p1
  59. %endif
  60. %patch4 -p1
  61. %patch5 -p1
  62. %patch6 -p1
  63. %patch100 -p1
  64. # Fix a testcase with system-ciphers support
  65. sed -i '/client = yes/a \\ ciphers = PSK' tests/recipes/014_PSK_secrets
  66. # modify systemd service unit
  67. sed -i '/Type=forking/a \\PrivateTmp=true' tools/stunnel.service.in
  68. %build
  69. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  70. if pkg-config openssl ; then
  71. CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
  72. LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
  73. fi
  74. %configure --disable-fips --enable-ipv6 --with-ssl=%{_prefix} \
  75. CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{pidfile}\"'"
  76. make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
  77. %install
  78. rm -rf $RPM_BUILD_ROOT
  79. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
  80. touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
  81. make install DESTDIR=$RPM_BUILD_ROOT
  82. # Move the translated man pages to the right subdirectories, and strip off the
  83. # language suffixes.
  84. for lang in pl ; do
  85. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
  86. mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
  87. rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
  88. done
  89. mkdir -p srpm-docs
  90. cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
  91. %if %{with systemd}
  92. mkdir -p %{buildroot}%{_unitdir}
  93. cp %{buildroot}%{_datadir}/doc/stunnel/examples/%{name}.service %{buildroot}%{_unitdir}/%{name}.service
  94. cp %{SOURCE7} %{buildroot}%{_unitdir}/%{name}@.service
  95. %else
  96. install -d -m755 %{buildroot}%{_initdir}
  97. install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
  98. install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
  99. cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
  100. ENABLED=0
  101. EOF
  102. %endif
  103. %clean
  104. rm -rf $RPM_BUILD_ROOT
  105. %post
  106. %if %{with systemd}
  107. %systemd_post %{name}.service
  108. %else
  109. /sbin/chkconfig --add stunnel
  110. %endif
  111. %preun
  112. %if %{with systemd}
  113. %systemd_preun %{name}.service
  114. %else
  115. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  116. /sbin/service stunnel stop /dev/null 2>/dev/null ||:
  117. /sbin/chkconfig --del stunnel
  118. fi
  119. %endif
  120. %postun
  121. %if %{with systemd}
  122. %systemd_postun_with_restart %{name}.service
  123. %else
  124. if [ $1 -gt 0 ]; then
  125. if /sbin/service stunnel status >/dev/null; then
  126. /sbin/service stunnel restart
  127. fi
  128. fi
  129. %endif
  130. %files
  131. %defattr(-,root,root)
  132. %doc AUTHORS.md BUGS.md CREDITS.md PORTS.md README.md TODO.md
  133. %doc tools/stunnel.conf-sample
  134. %doc srpm-docs/*
  135. %license COPY*
  136. %lang(en) %doc doc/en/*
  137. %lang(po) %doc doc/pl/*
  138. %{_bindir}/stunnel
  139. %exclude %{_bindir}/stunnel3
  140. %exclude %{_datadir}/doc/stunnel
  141. %{_libdir}/stunnel
  142. %exclude %{_libdir}/stunnel/libstunnel.la
  143. %{_mandir}/man8/stunnel.8*
  144. %lang(pl) %{_mandir}/pl/man8/stunnel.8*
  145. %dir %{_sysconfdir}/%{name}
  146. %dir %{_sysconfdir}/%{name}/conf.d
  147. %exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
  148. %exclude %{_sysconfdir}/stunnel/stunnel.pem
  149. %if %{with systemd}
  150. %{_unitdir}/%{name}*.service
  151. %else
  152. %{_initdir}/stunnel
  153. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  154. %endif
  155. %changelog
  156. * Mon Oct 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.60-1
  157. - new upstream release.
  158. - built with openssl-3.0.0.
  159. - imported Patch100 from openmandriva.
  160. * Thu May 06 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.59-1
  161. - new upstream release.
  162. - diabled crypto-policies (not implemented for Vine Linux).
  163. * Sun Feb 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.58-1
  164. - new upstream release.
  165. - uodated patches.
  166. * Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.56-1
  167. - new upstream release.
  168. - replaced all patches.
  169. - added systemd support (disabled as default).
  170. * Sat Dec 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.49-1
  171. - new upstream release.
  172. - updated Patch0,1.
  173. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 5.32-2
  174. - rebuid with OpenSSL 1.0.2k
  175. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.32-1
  176. - new upstream release.
  177. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.31-1
  178. - new upstream release.
  179. * Fri Nov 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
  180. - new upstream release.
  181. - fixed dates in %%changelog.
  182. - updated all patches.
  183. * Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
  184. - initial build for Vine Linux
  185. *Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
  186. - 884183: support for full relro.
  187. *Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
  188. - New upstream realease 4.54
  189. - Updated local patches
  190. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
  191. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  192. * Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
  193. - New upstream realease 4.53
  194. - Updated local patches
  195. * Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
  196. - New upstream realease 4.52
  197. - Updated local patches
  198. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
  199. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  200. * Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
  201. - New upstream realease 4.50
  202. - Updated local patches
  203. * Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
  204. - New upstream realease 4.44
  205. - Updated local patches
  206. * Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
  207. - New upstream realease 4.42
  208. - Updated local patches
  209. - Fixes #732069
  210. * Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
  211. - New upstream realease 4.41
  212. - Updated local patches to match the new release
  213. * Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
  214. - New upstream realease 4.37
  215. - Updated local patches to match the new release
  216. * Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
  217. - New upstream realease 4.35
  218. - Updated authpriv and sample patches to match the new release
  219. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
  220. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  221. * Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
  222. - New upstream realease 4.34
  223. - Updated authpriv and sample patches to match the new release
  224. * Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
  225. - New upstream realease 4.33
  226. - Updated authpriv and sample patches to match the new release
  227. - Addresses bz 580117 (inted mode support issue)
  228. * Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
  229. - New upstream realease 4.32
  230. - Updated authpriv and sample patches to match the new release
  231. * Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
  232. - New upstream realease 4.31
  233. - Updated authpriv and sample patches to match the new release
  234. * Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
  235. - New upstream realease 4.30
  236. - Updated authpriv and sample patches for the new release
  237. * Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
  238. - New upstream realease 4.29
  239. - Updated authpriv and sample patches for the new release
  240. - Modified spec file to include dist tag
  241. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
  242. - rebuilt with new openssl
  243. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
  244. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  245. * Sun May 3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
  246. - Fix the previous patch.
  247. * Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
  248. - Avoid aliasing undefined by ISO C
  249. * Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
  250. - Update to stunnel-4.27.
  251. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
  252. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  253. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
  254. - disable openssl upstream fips mode
  255. * Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
  256. - Update to stunnel-4.26.
  257. * Sun Jun 8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
  258. - Use a clearer error message if the service name is unknown in "accept"
  259. Resolves: #450344
  260. * Mon Jun 2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
  261. - Update to stunnel-4.25
  262. * Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
  263. - Drop stunnel3
  264. Resolves: #442842
  265. * Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
  266. - Update to stunnel-4.24
  267. * Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
  268. - Update to stunnel-4.22
  269. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
  270. - Autorebuild for GCC 4.3
  271. * Tue Dec 4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
  272. - Rebuild with openssl-0.9.8g
  273. * Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
  274. - Revert the port to NSS, wait for NSS-based stunnel 5.x instead
  275. Resolves: #301971
  276. - Mark localized man pages with %%lang (patch by Ville Skyttä)
  277. Resolves: #322281
  278. * Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
  279. - Port to NSS
  280. * Mon Dec 4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
  281. - Update BuildRequires for the separate tcp_wrappers-devel package
  282. * Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
  283. - Update to stunnel-4.20
  284. * Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
  285. - Update to stunnel-4.19
  286. * Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
  287. - Update to stunnel-4.18
  288. - Remove unused stunnel.cnf from the src.rpm
  289. - Fix some rpmlint warnings
  290. * Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
  291. - rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
  292. (#203001)
  293. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
  294. - rebuild
  295. * Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
  296. - Update to stunnel-4.15
  297. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
  298. - bump again for double-long bug on ppc(64)
  299. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
  300. - rebuilt for new gcc4.1 snapshot and glibc changes
  301. * Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
  302. - Use pthread threading to fix crash on x86_64 (#179236)
  303. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  304. - rebuilt
  305. * Wed Nov 9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
  306. - Rebuild with newer openssl
  307. * Thu Nov 3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
  308. - Update to stunnel-4.14
  309. - Override changed default pid file location, keep it in %%{_localstatedir}/run
  310. * Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
  311. - Update to stunnel-4.13
  312. * Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
  313. - Update to stunnel-4.12
  314. * Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
  315. - Enable IPv6 (#169050, patch by Peter Bieringer)
  316. - Don't ship another copy of man pages in HTML
  317. * Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
  318. - Update to stunnel-4.11
  319. - Fix int/size_t mismatches in stack_info ()
  320. - Update Certificate-Creation for /etc/pki
  321. * Wed Jun 1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
  322. - Fix inetd mode
  323. - Remove unnecessary Requires: and BuildRequires:
  324. - Clean up the spec file
  325. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
  326. - update to 4.10
  327. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
  328. - add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
  329. coreutils (#133961)
  330. * Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
  331. - update to 4.08
  332. - build stunnel as a PIE binary
  333. * Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
  334. - Convert man pages to UTF-8
  335. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  336. - rebuilt
  337. * Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
  338. - move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
  339. * Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
  340. - update to 4.05
  341. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  342. - rebuilt
  343. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  344. - rebuilt
  345. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
  346. - Fix libtool
  347. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  348. - rebuilt
  349. * Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
  350. - fix xinetd configuration samples
  351. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
  352. - rebuild
  353. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  354. - rebuilt
  355. * Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
  356. - update to 4.04
  357. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
  358. - use pkgconfig for information about openssl, if available
  359. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  360. - update to 4.03
  361. * Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
  362. - update to 4.02
  363. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
  364. - don't create a dummy cert
  365. * Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
  366. - update to 4.00
  367. - remove textutils and fileutils as buildreqs, add automake/autoconf
  368. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  369. - automated rebuild
  370. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  371. - automated rebuild
  372. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
  373. - rebuild in new environment
  374. * Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
  375. - update to 3.22, correcting a format-string vulnerability
  376. * Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
  377. - update to 3.21a
  378. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
  379. - log using LOG_AUTHPRIV facility by default (#47289)
  380. - make permissions on stunnel binary 0755
  381. - implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
  382. * Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
  383. - update to 3.19 to avoid problems with stunnel being multithreaded, but
  384. tcp wrappers not being thrad-safe
  385. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  386. - update to 3.17
  387. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  388. - update to 3.16
  389. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  390. - update to 3.15
  391. - enable tcp-wrappers support
  392. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  393. - remove explicit requirement on openssl (specific version isn't enough,
  394. we have to depend on shared library version anyway)
  395. * Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  396. - update to 3.14
  397. * Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
  398. - depend on make (#33148)
  399. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  400. - rebuild in new environment
  401. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  402. - update to 3.13 to get pthread, OOB, 64-bit fixes
  403. - don't need sdf any more
  404. * Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  405. - pull in sdf to build the man page (#22892)
  406. * Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  407. - update to 3.11
  408. - chuck the SIGHUP patch (went upstream)
  409. - chuck parts of the 64-bit clean patch (went upstream)
  410. * Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  411. - update to 3.10
  412. - more 64-bit clean changes, hopefully the last bunch
  413. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  414. - change piddir from the default /var/stunnel to /var/run
  415. - clean out pid file on SIGHUP
  416. * Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
  417. - update to 3.9 to get a security fix
  418. * Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
  419. - change all unsigned longs to u_int32_t when dealing with network
  420. addresses
  421. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  422. - make stunnel.pem also be (missingok)
  423. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  424. - move to Applications/Internet group
  425. - clean up %%post script
  426. - make stunnel.pem %%ghost %%config(noreplace)
  427. - provide a sample file for use with xinetd
  428. * Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  429. - FHS compliance fixes
  430. - modify defaults
  431. * Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  432. - update to 3.8
  433. - do not create certificate if one already exists
  434. * Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  435. - update to 3.7
  436. - add patch to find /usr/share/ssl
  437. - change some perms
  438. * Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  439. - Modify spec file to match Red Hat standards
  440. * Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
  441. - Updated to 3.4a
  442. - Patched for OpenSSL 0.9.4
  443. - Cleaned up files section
  444. * Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
  445. - Updated to 3.3
  446. * Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
  447. - Initial RPMification