syasokoban-vl.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899
  1. %define name syasokoban
  2. %define version 2.0.1
  3. %define release 1%{?_dist_release}
  4. Summary: Sokoban puzzle game
  5. Summary(ja): 倉庫番パズルゲーム
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. #Source0: http://scorpioncity.com/sokoban/%{name}Src.zip # ver.2.0
  10. Source0: %{name}-%{version}.tar.gz
  11. License: BSD License
  12. Group: Applications/Games
  13. URL: http://scorpioncity.com/sokoban.html
  14. Requires: SDL
  15. BuildRequires: SDL-devel
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. %description
  18. An implementation of the popular Sokoban puzzle game.
  19. The goal is to push the crates onto the designated squares
  20. without getting stuck.
  21. #%desctiption -l ja
  22. %prep
  23. rm -rf ${RPM_BUILD_ROOT}
  24. %setup -q
  25. %build
  26. make
  27. %install
  28. #make DESTDIR=${RPM_BUILD_ROOT} install
  29. mkdir -p ${RPM_BUILD_ROOT}/usr/share/SYASokoban
  30. cp README.txt syasokoban ${RPM_BUILD_ROOT}/usr/share/SYASokoban/
  31. cp -r data ${RPM_BUILD_ROOT}/usr/share/SYASokoban/
  32. mkdir -p ${RPM_BUILD_ROOT}/usr/share/applications
  33. cat > ${RPM_BUILD_ROOT}/usr/share/applications/%{name}.desktop <<EOF
  34. [Desktop Entry]
  35. Name=Still Yet Another Sokoban
  36. Comment=An implementation of the popular Sokoban puzzle game.
  37. TryExec=syasokoban
  38. Exec=/usr/bin/syasokoban
  39. Icon=
  40. Terminal=0
  41. Type=Application
  42. Categories=GNOME;Application;Game
  43. EOF
  44. # syasokobanの実行スクリプトを作成:ソースを書き換える???
  45. mkdir -p ${RPM_BUILD_ROOT}/usr/bin
  46. cat > ${RPM_BUILD_ROOT}/usr/bin/syasokoban <<EOF
  47. #! /bin/bash
  48. cd /usr/share/SYASokoban/; ./syasokoban
  49. EOF
  50. # syasokobanが実行したときのログファイルが同じディレクトリにできるので、
  51. # それが書き込めるようにした対処策:ソースを書き換える???
  52. cat > ${RPM_BUILD_ROOT}/usr/share/SYASokoban/syasokobanlog.txt <<EOF
  53. Sokoban:OnMouseEnter (0 0)
  54. Desktop:OnMouseEnter (0 0)
  55. CSokoban::Destroy()
  56. EOF
  57. %clean
  58. rm -rf ${RPM_BUILD_ROOT}
  59. %files
  60. %defattr(-,root,root)
  61. /usr/share/SYASokoban
  62. %attr(755,root,root) /usr/bin/syasokoban
  63. %attr(770,root,root) /usr/share/SYASokoban/syasokobanlog.txt
  64. /usr/share/applications/%{name}.desktop
  65. %changelog
  66. * Sat Oct 11 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1vl5
  67. - new upstream release
  68. - applied new versioning policy, spec in utf-8
  69. * Sun Jun 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.0-0vl2
  70. - rebuild for VineSeed
  71. * Tue Mar 9 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 2.0-0vl1
  72. - initial build for Vine Linux
  73. # * Sun Jul 2 2006 2.0-0vl1
  74. # - Update
  75. # * Mon Jul 4 2005 1.02-0vl1
  76. # - initial build for Vine Linux
  77. # end of file