vulkan-validation-layers-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144
  1. %bcond_without clang
  2. Name: vulkan-validation-layers
  3. Summary: Vulkan validation layers
  4. Version: 1.2.170.0
  5. Release: 1%{?_dist_release}
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: ASL 2.0
  10. URL: https://github.com/KhronosGroup/Vulkan-ValidationLayers
  11. Source0: %url/archive/sdk-%{version}.tar.gz#/Vulkan-ValidationLayers-sdk-%{version}.tar.gz
  12. Patch0: fix_shared.patch
  13. %if %{with clang}
  14. BuildRequires: clang
  15. BuildRequires: lld
  16. %else
  17. BuildRequires: gcc
  18. BuildRequires: gcc-c++
  19. %endif
  20. BuildRequires: cmake
  21. BuildRequires: glslang-devel
  22. BuildRequires: ninja
  23. BuildRequires: python3-devel
  24. BuildRequires: spirv-tools-devel
  25. BuildRequires: spirv-headers-devel
  26. BuildRequires: vulkan-loader-devel
  27. BuildRequires: pkgconfig(wayland-client)
  28. BuildRequires: pkgconfig(wayland-cursor)
  29. BuildRequires: pkgconfig(wayland-server)
  30. BuildRequires: pkgconfig(wayland-egl)
  31. BuildRequires: pkgconfig(x11)
  32. BuildRequires: pkgconfig(xrandr)
  33. BuildRequires: pkgconfig(xcb)
  34. %description
  35. Vulkan validation layers
  36. %package devel
  37. Summary: Development files for %{name}
  38. Group: programming
  39. Requires: %{name}%{?_isa} = %{version}-%{release}
  40. Requires: vulkan-headers
  41. %description devel
  42. The %{name}-devel package contains libraries and header files for
  43. developing applications that use %{name}.
  44. %debug_package
  45. %prep
  46. %autosetup -p1 -n Vulkan-ValidationLayers-sdk-%{version}
  47. %build
  48. %if %{with clang}
  49. export CC=clang
  50. export CXX=clang++
  51. export LD=clang++
  52. %global build_ldflags %(echo "%{build_ldflags} -fuse-ld=lld")
  53. %endif
  54. # Decrease debuginfo verbosity to reduce memory consumption even more
  55. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  56. %cmake -GNinja \
  57. -DCMAKE_BUILD_TYPE=Release \
  58. -DGLSLANG_INSTALL_DIR=%{_prefix} \
  59. -DBUILD_LAYER_SUPPORT_FILES:BOOL=ON \
  60. -DSPIRV_HEADERS_INSTALL_DIR=%{_includedir}/spirv \
  61. -DCMAKE_INSTALL_INCLUDEDIR=%{_includedir}/vulkan/
  62. %cmake_build
  63. %install
  64. %cmake_install
  65. %files
  66. %license LICENSE.txt
  67. %doc README.md CONTRIBUTING.md
  68. %{_datadir}/vulkan/explicit_layer.d/*.json
  69. %{_libdir}/libVkLayer_*.so
  70. %files devel
  71. %{_includedir}/vulkan/*
  72. %changelog
  73. * Sun Mar 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.170.0-1
  74. - new upstream release.
  75. - add wayland support.
  76. - dropped ldconfig scriptlets.
  77. * Thu Jul 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.135.0-2
  78. - initial build for Vine Linux.
  79. * Wed Apr 22 2020 Dave Airlie <airlied@redhat.com> - 1.2.135.0-1
  80. - Update validation layers to 1.2.135.0
  81. * Wed Jan 29 2020 Dave Airlie <airlied@redhat.com> - 1.2.131.1-1
  82. - Update validation layers to 1.2.131.1
  83. * Wed Nov 13 2019 Dave Airlie <airlied@redhat.com> - 1.1.126.0-1
  84. - Update validation layers to 1.1.126.0
  85. * Wed Jul 31 2019 Dave Airlie <airlied@redhat.com> - 1.1.114.0-1
  86. - Update validation layers to 1.1.114.0
  87. * Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.108.0-2
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  89. * Tue Jun 25 2019 Dave Airlie <airlied@redhat.com> - 1.1.108.0-1
  90. - Update valdiation layers to 1.1.108.0
  91. * Wed Mar 06 2019 Dave Airlie <airlied@redhat.com> - 1.1.101.0-1
  92. - Update valdiation layers to 1.1.101.0
  93. * Wed Feb 13 2019 Dave Airlie <airlied@redhat.com> - 1.1.97.0-1
  94. - Update validation layers to 1.1.97.0
  95. * Wed Feb 13 2019 Dave Airlie <airlied@redhat.com> - 1.1.92.0-1
  96. - Update validation layers to 1.1.92.0
  97. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.82.0-2
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  99. * Tue Aug 07 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.82.0-1
  100. - Update to 1.1.82.0
  101. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.77.0-4
  102. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  103. * Tue Jun 26 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-3
  104. - Workaround i686 build issue
  105. * Tue Jun 26 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-2
  106. - Exclude i686 due to 'virtual memory exhausted' FTBFS
  107. * Sat Jun 23 2018 Leigh Scott <leigh123linux@googlemail.com> - 1.1.77.0-1
  108. - Initial package