gnome-settings-daemon-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297
  1. Summary: The daemon sharing settings from GNOME to GTK+/KDE applications
  2. Summary(ja): GNOME から GTK+/KDE のアプリケーションで設定を共有するためのデーモン
  3. Name: gnome-settings-daemon
  4. Version: 2.28.2
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Daemons
  7. License: GPLv2+
  8. URL: http://ftp.gnome.org/pub/gnome/sources/%{name}
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/%{name}/2.26/%{name}-%{version}.tar.bz2
  10. # from fedora
  11. # https://bugzilla.gnome.org/show_bug.cgi?id=596136
  12. Patch0: 0002-Use-a-rounded-instead-of-curved-rectangle.patch
  13. Patch1: 0003-Improve-the-media-keys-overlay-design.patch
  14. # https://bugzilla.gnome.org/show_bug.cgi?id=567249
  15. Patch4: 0001-Fix-bluriness-in-level-bar-and-popup.patch
  16. # https://bugzilla.redhat.com/show_bug.cgi?id=498249
  17. Patch2: left-handed-touchpad.patch
  18. # change font rendering
  19. Patch3: slight-hinting.patch
  20. # vine
  21. Patch100: gnome-settings-daemon-2.28.1-default-font-setting.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. Requires(pre): GConf2 >= 2.14
  24. Requires(preun): GConf2 >= 2.14
  25. Requires(post): GConf2 >= 2.14
  26. BuildRequires: dbus-glib-devel
  27. BuildRequires: GConf2-devel
  28. BuildRequires: gtk2-devel
  29. BuildRequires: gnome-desktop-devel >= 2.26.3
  30. BuildRequires: libgnome-devel
  31. BuildRequires: xorg-x11-proto-devel
  32. BuildRequires: libXrandr-devel
  33. BuildRequires: fontconfig-devel
  34. BuildRequires: gstreamer-devel
  35. BuildRequires: gstreamer-plugins-base-devel
  36. BuildRequires: pulseaudio-libs-devel
  37. BuildRequires: libgnomekbd-devel >= 2.28.0
  38. BuildRequires: libxklavier-devel >= 4.0
  39. BuildRequires: libnotify-devel >= 0.4.3
  40. BuildRequires: gettext
  41. BuildRequires: perl-XML-Parser
  42. %description
  43. A daemon to share settings from GNOME to other applications. It also
  44. handles global keybindings, as well as a number of desktop-wide settings.
  45. %package devel
  46. Summary: Development files for %{name}
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}-%{release}
  49. Requires: pkgconfig
  50. Requires: dbus-glib-devel
  51. %description devel
  52. The %{name}-devel package contains libraries and header files for
  53. developing applications that use %{name}.
  54. %prep
  55. %setup -q
  56. ## %patch4 -p1 -b .blurry
  57. %patch0 -p1 -b .osd-rounded-rectangle
  58. %patch1 -p1 -b .osd-visual-refresh
  59. ## %patch2 -p1 -b .left-handed-touchpad
  60. %patch3 -p1 -b .slight-hinting
  61. %patch100 -p1 -b .defaults
  62. %build
  63. %configure --enable-static=no --enable-profiling --disable-esd
  64. make %{?_smp_mflags}
  65. # strip unneeded translations from .mo files
  66. # ideally intltool (ha!) would do that for us
  67. # http://bugzilla.gnome.org/show_bug.cgi?id=474987
  68. cd po
  69. grep -v ".*[.]desktop[.]in[.]in$\|.*[.]server[.]in[.]in$" POTFILES.in > POTFILES.keep
  70. mv POTFILES.keep POTFILES.in
  71. intltool-update --pot
  72. for p in *.po; do
  73. msgmerge $p %{name}.pot > $p.out
  74. msgfmt -o `basename $p .po`.gmo $p.out
  75. done
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. make install DESTDIR=$RPM_BUILD_ROOT
  79. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  80. %find_lang %{name} --with-gnome
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %post
  84. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  85. gconftool-2 --makefile-install-rule \
  86. %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas \
  87. %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas \
  88. %{_sysconfdir}/gconf/schemas/desktop_gnome_font_rendering.schemas \
  89. %{_sysconfdir}/gconf/schemas/gnome-settings-daemon.schemas \
  90. %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas \
  91. >& /dev/null || :
  92. touch %{_datadir}/icons/hicolor
  93. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  94. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  95. fi
  96. %pre
  97. if [ "$1" -gt 1 ]; then
  98. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  99. if [ -f %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas ] ; then
  100. gconftool-2 --makefile-uninstall-rule \
  101. %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas \
  102. >& /dev/null || :
  103. fi
  104. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  105. if [ -f %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas ] ; then
  106. gconftool-2 --makefile-uninstall-rule \
  107. %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas \
  108. >& /dev/null || :
  109. fi
  110. gconftool-2 --makefile-uninstall-rule \
  111. %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas \
  112. %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas \
  113. %{_sysconfdir}/gconf/schemas/desktop_gnome_font_rendering.schemas \
  114. %{_sysconfdir}/gconf/schemas/gnome-settings-daemon.schemas \
  115. >& /dev/null || :
  116. fi
  117. %preun
  118. if [ "$1" -eq 0 ]; then
  119. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  120. if [ -f %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas ] ; then
  121. gconftool-2 --makefile-uninstall-rule \
  122. %{_sysconfdir}/gconf/schemas/desktop_gnome_peripherals_touchpad.schemas \
  123. >& /dev/null || :
  124. fi
  125. if [ -f %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas ] ; then
  126. gconftool-2 --makefile-uninstall-rule \
  127. %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_default_editor.schemas \
  128. >& /dev/null || :
  129. fi
  130. gconftool-2 --makefile-uninstall-rule \
  131. %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_keybindings.schemas \
  132. %{_sysconfdir}/gconf/schemas/apps_gnome_settings_daemon_screensaver.schemas \
  133. %{_sysconfdir}/gconf/schemas/desktop_gnome_font_rendering.schemas \
  134. %{_sysconfdir}/gconf/schemas/gnome-settings-daemon.schemas \
  135. >& /dev/null || :
  136. fi
  137. %postun
  138. touch %{_datadir}/icons/hicolor
  139. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  140. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  141. fi
  142. %files -f %{name}.lang
  143. %defattr(-,root,root,-)
  144. %doc AUTHORS COPYING NEWS
  145. %{_sysconfdir}/gconf/schemas/*
  146. %{_sysconfdir}/xdg/autostart/gnome-settings-daemon.desktop
  147. %{_libdir}/gnome-settings-daemon-2.0
  148. %{_libexecdir}/gnome-settings-daemon
  149. %{_libexecdir}/gsd-locate-pointer
  150. %{_datadir}/gnome-settings-daemon/
  151. %{_datadir}/dbus-1/services/org.gnome.SettingsDaemon.service
  152. %{_datadir}/icons/hicolor/*/apps/gsd-xrandr.*
  153. %{_datadir}/gnome-control-center/keybindings/*.xml
  154. %files devel
  155. %defattr(-,root,root,-)
  156. %{_includedir}/gnome-settings-daemon-2.0
  157. %{_libdir}/pkgconfig/gnome-settings-daemon.pc
  158. %changelog
  159. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  160. - new upstream release
  161. - drop Patch2, Patch4
  162. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  163. - new upstream release
  164. - updated Patch100
  165. * Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-2
  166. - import patches from fedora
  167. - Patch10: listen for DeviceAdded
  168. - Patch11,12: add support touchpads
  169. - Patch13: Make custom keybindings work better
  170. - Patch14: Don't rely on _BACKUP property for xkb initialization
  171. * Wed Apr 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.1-1
  172. - new upstream release
  173. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
  174. - update Patch10
  175. - change hinting type to "none" instead of "medium"
  176. * Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
  177. - add Patch10 to set default dpi
  178. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  179. - new upstream release
  180. * Mon Jan 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
  181. - new upstream release
  182. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  183. - new upstream release
  184. * Mon Sep 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2.1-2
  185. - build with pulseaudio
  186. - add patch6 to ignore the legacy ESD GConf preference if compiled
  187. to use Pulseaudio
  188. * Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.2.1-1
  189. - new upstream release
  190. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.1-1vl5
  191. - new upstream release
  192. * Mon Mar 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
  193. - Initial build for Vine Linux
  194. * Wed Mar 26 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.1-0.2008.03.26.3
  195. - Add patch for the mouse plugin not to eat multimedia key events (#438942)
  196. * Wed Mar 26 2008 Jon McCann <jmccann@redhat.com> - 2.22.1-0.2008.03.26.2
  197. - Rebuild
  198. * Wed Mar 26 2008 Jon McCann <jmccann@redhat.com> - 2.22.1-0.2008.03.26.1
  199. - Update to snapshot
  200. - Enable profiling
  201. * Wed Mar 26 2008 - Bastien Nocera <bnocera@redhat.com> - 2.22.0-3
  202. - apps_gnome_settings_daemon_default_editor.schemas is obsolete (#438937)
  203. * Thu Mar 20 2008 Matthias Clasen <mclasen@redhat.com> 2.22.0-2
  204. - Fix interaction between "Locate Pointer" and volume keys
  205. * Mon Mar 10 2008 Matthias Clasen <mclasen@redhat.com> 2.22.0-1
  206. - Update to 2.22.0
  207. * Sun Mar 9 2008 Ray Strode <rstrode@redhat.com> - 2.21.92-3
  208. - Don't set keyboard model on startup from gconf if evdev is being used.
  209. Evdev needs to use its own keyboard model to work right.
  210. * Sun Mar 2 2008 Soren Sandmann <sandmann@redhat.com> - 2.21.92-2
  211. - Update randr patch to handle video key
  212. * Fri Feb 29 2008 Jon McCann <jmccann@redhat.com> - 2.21.92-1
  213. - Update to 2.21.92
  214. * Tue Feb 12 2008 Soren Sandmann <sandmann@redhat.com> - 2.21.91-3
  215. - Add patch to make the xrandr plugin listen for client messages from
  216. the control panel and reread the configuration file.
  217. * Mon Feb 11 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.91-2
  218. - Remove obsolete control-center translations
  219. * Mon Feb 11 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.91-1
  220. - Update to 2.21.91
  221. - Remove obsolete patches
  222. * Thu Feb 7 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.90.1-3
  223. - Load xkb settings initially
  224. * Thu Jan 31 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90.1-2
  225. - Fix the path for g-s-d, from upstream patch
  226. * Tue Jan 29 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90.1-1
  227. - Update to 2.21.90.1
  228. * Tue Jan 29 2008 - Bastien Nocera <bnocera@redhat.com> - 2.21.90-1
  229. - Update to 2.21.90
  230. * Tue Jan 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.5.2-2
  231. - Incorporate review feedback (#428833)
  232. * Tue Jan 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.5.2-1
  233. - Update to 2.21.5.2
  234. * Tue Jan 15 2008 Matthias Clasen <mclasen@redhat.com> - 2.21.5.1-1
  235. - Update to 2.21.5.1
  236. - Fix up BuildRequires
  237. * Thu Dec 06 2007 - Bastien Nocera <bnocera@redhat.com> - 2.21.5-1
  238. - First package