stunnel-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570
  1. %bcond_with systemd
  2. Summary: An SSL-encrypting socket wrapper
  3. Name: stunnel
  4. Version: 5.58
  5. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  6. Group: internet
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Packager: iwaim
  10. License: GPLv2
  11. URL: https://www.stunnel.org/
  12. Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
  13. Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
  14. Source2: Certificate-Creation
  15. Source3: sfinger.xinetd
  16. Source4: stunnel-sfinger.conf
  17. Source5: pop3-redirect.xinetd
  18. Source6: stunnel-pop3s-client.conf
  19. Source7: stunnel@.service
  20. Source100: stunnel.init
  21. Patch0: stunnel-5.50-authpriv.patch
  22. Patch1: stunnel-5.50-systemd-service.patch
  23. Patch3: stunnel-5.56-system-ciphers.patch
  24. Patch4: stunnel-5.56-coverity.patch
  25. Patch5: stunnel-5.56-default-tls-version.patch
  26. Patch6: stunnel-5.56-curves-doc-update.patch
  27. Buildroot: %{_tmppath}/stunnel-root
  28. # util-linux is needed for rename
  29. BuildRequires: openssl-devel
  30. BuildRequires: pkgconfig
  31. BuildRequires: util-linux
  32. %if %{with systemd}
  33. %{?systemd_requires}
  34. %else
  35. Requires(post): chkconfig
  36. Requires(preun): chkconfig /sbin/service
  37. Requires(postun): /sbin/service
  38. %endif
  39. %if %{with systemd}
  40. %global pidfile %{_rundir}/stunnel.pid
  41. %else
  42. %global pidfile %{_localstatedir}/run/stunnel.pid
  43. %endif
  44. # Do not generate provides for private libraries
  45. %global __provides_exclude_from ^%{_libdir}/stunnel/.*$
  46. %description
  47. Stunnel is a socket wrapper which can provide SSL (Secure Sockets
  48. Layer) support to ordinary applications. For example, it can be used
  49. in conjunction with imapd to create an SSL secure IMAP server.
  50. %debug_package
  51. %prep
  52. %setup -q
  53. %autopatch -p1
  54. # Fix a testcase with system-ciphers support
  55. sed -i '/client = yes/a \\ ciphers = PSK' tests/recipes/014_PSK_secrets
  56. # modify systemd service unit
  57. sed -i '/Type=forking/a \\PrivateTmp=true' tools/stunnel.service.in
  58. %build
  59. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  60. if pkg-config openssl ; then
  61. CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
  62. LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
  63. fi
  64. %configure --disable-fips --enable-ipv6 --with-ssl=%{_prefix} \
  65. CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{pidfile}\"'"
  66. make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
  70. touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
  71. make install DESTDIR=$RPM_BUILD_ROOT
  72. # Move the translated man pages to the right subdirectories, and strip off the
  73. # language suffixes.
  74. for lang in pl ; do
  75. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
  76. mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
  77. rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
  78. done
  79. mkdir -p srpm-docs
  80. cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
  81. %if %{with systemd}
  82. mkdir -p %{buildroot}%{_unitdir}
  83. cp %{buildroot}%{_datadir}/doc/stunnel/examples/%{name}.service %{buildroot}%{_unitdir}/%{name}.service
  84. cp %{SOURCE7} %{buildroot}%{_unitdir}/%{name}@.service
  85. %else
  86. install -d -m755 %{buildroot}%{_initdir}
  87. install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
  88. install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
  89. cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
  90. ENABLED=0
  91. EOF
  92. %endif
  93. %clean
  94. rm -rf $RPM_BUILD_ROOT
  95. %post
  96. %if %{with systemd}
  97. %systemd_post %{name}.service
  98. %else
  99. /sbin/chkconfig --add stunnel
  100. %endif
  101. %preun
  102. %if %{with systemd}
  103. %systemd_preun %{name}.service
  104. %else
  105. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  106. /sbin/service stunnel stop /dev/null 2>/dev/null ||:
  107. /sbin/chkconfig --del stunnel
  108. fi
  109. %endif
  110. %postun
  111. %if %{with systemd}
  112. %systemd_postun_with_restart %{name}.service
  113. %else
  114. if [ $1 -gt 0 ]; then
  115. if /sbin/service stunnel status >/dev/null; then
  116. /sbin/service stunnel restart
  117. fi
  118. fi
  119. %endif
  120. %files
  121. %defattr(-,root,root)
  122. %doc AUTHORS.md BUGS.md CREDITS.md PORTS.md README.md TODO.md
  123. %doc tools/stunnel.conf-sample
  124. %doc srpm-docs/*
  125. %license COPY*
  126. %lang(en) %doc doc/en/*
  127. %lang(po) %doc doc/pl/*
  128. %{_bindir}/stunnel
  129. %exclude %{_bindir}/stunnel3
  130. %exclude %{_datadir}/doc/stunnel
  131. %{_libdir}/stunnel
  132. %exclude %{_libdir}/stunnel/libstunnel.la
  133. %{_mandir}/man8/stunnel.8*
  134. %lang(pl) %{_mandir}/pl/man8/stunnel.8*
  135. %dir %{_sysconfdir}/%{name}
  136. %dir %{_sysconfdir}/%{name}/conf.d
  137. %exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
  138. %exclude %{_sysconfdir}/stunnel/stunnel.pem
  139. %if %{with systemd}
  140. %{_unitdir}/%{name}*.service
  141. %else
  142. %{_initdir}/stunnel
  143. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  144. %endif
  145. %changelog
  146. * Sun Feb 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.58-1
  147. - new upstream release.
  148. - uodated patches.
  149. * Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.56-1
  150. - new upstream release.
  151. - replaced all patches.
  152. - added systemd support (disabled as default).
  153. * Sat Dec 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.49-1
  154. - new upstream release.
  155. - updated Patch0,1.
  156. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 5.32-2
  157. - rebuid with OpenSSL 1.0.2k
  158. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.32-1
  159. - new upstream release.
  160. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.31-1
  161. - new upstream release.
  162. * Fri Nov 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
  163. - new upstream release.
  164. - fixed dates in %%changelog.
  165. - updated all patches.
  166. * Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
  167. - initial build for Vine Linux
  168. *Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
  169. - 884183: support for full relro.
  170. *Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
  171. - New upstream realease 4.54
  172. - Updated local patches
  173. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
  174. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  175. * Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
  176. - New upstream realease 4.53
  177. - Updated local patches
  178. * Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
  179. - New upstream realease 4.52
  180. - Updated local patches
  181. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
  182. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  183. * Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
  184. - New upstream realease 4.50
  185. - Updated local patches
  186. * Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
  187. - New upstream realease 4.44
  188. - Updated local patches
  189. * Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
  190. - New upstream realease 4.42
  191. - Updated local patches
  192. - Fixes #732069
  193. * Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
  194. - New upstream realease 4.41
  195. - Updated local patches to match the new release
  196. * Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
  197. - New upstream realease 4.37
  198. - Updated local patches to match the new release
  199. * Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
  200. - New upstream realease 4.35
  201. - Updated authpriv and sample patches to match the new release
  202. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
  203. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  204. * Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
  205. - New upstream realease 4.34
  206. - Updated authpriv and sample patches to match the new release
  207. * Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
  208. - New upstream realease 4.33
  209. - Updated authpriv and sample patches to match the new release
  210. - Addresses bz 580117 (inted mode support issue)
  211. * Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
  212. - New upstream realease 4.32
  213. - Updated authpriv and sample patches to match the new release
  214. * Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
  215. - New upstream realease 4.31
  216. - Updated authpriv and sample patches to match the new release
  217. * Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
  218. - New upstream realease 4.30
  219. - Updated authpriv and sample patches for the new release
  220. * Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
  221. - New upstream realease 4.29
  222. - Updated authpriv and sample patches for the new release
  223. - Modified spec file to include dist tag
  224. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
  225. - rebuilt with new openssl
  226. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
  227. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  228. * Sun May 3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
  229. - Fix the previous patch.
  230. * Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
  231. - Avoid aliasing undefined by ISO C
  232. * Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
  233. - Update to stunnel-4.27.
  234. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
  235. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  236. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
  237. - disable openssl upstream fips mode
  238. * Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
  239. - Update to stunnel-4.26.
  240. * Sun Jun 8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
  241. - Use a clearer error message if the service name is unknown in "accept"
  242. Resolves: #450344
  243. * Mon Jun 2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
  244. - Update to stunnel-4.25
  245. * Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
  246. - Drop stunnel3
  247. Resolves: #442842
  248. * Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
  249. - Update to stunnel-4.24
  250. * Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
  251. - Update to stunnel-4.22
  252. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
  253. - Autorebuild for GCC 4.3
  254. * Tue Dec 4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
  255. - Rebuild with openssl-0.9.8g
  256. * Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
  257. - Revert the port to NSS, wait for NSS-based stunnel 5.x instead
  258. Resolves: #301971
  259. - Mark localized man pages with %%lang (patch by Ville Skyttä)
  260. Resolves: #322281
  261. * Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
  262. - Port to NSS
  263. * Mon Dec 4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
  264. - Update BuildRequires for the separate tcp_wrappers-devel package
  265. * Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
  266. - Update to stunnel-4.20
  267. * Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
  268. - Update to stunnel-4.19
  269. * Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
  270. - Update to stunnel-4.18
  271. - Remove unused stunnel.cnf from the src.rpm
  272. - Fix some rpmlint warnings
  273. * Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
  274. - rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
  275. (#203001)
  276. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
  277. - rebuild
  278. * Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
  279. - Update to stunnel-4.15
  280. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
  281. - bump again for double-long bug on ppc(64)
  282. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
  283. - rebuilt for new gcc4.1 snapshot and glibc changes
  284. * Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
  285. - Use pthread threading to fix crash on x86_64 (#179236)
  286. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  287. - rebuilt
  288. * Wed Nov 9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
  289. - Rebuild with newer openssl
  290. * Thu Nov 3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
  291. - Update to stunnel-4.14
  292. - Override changed default pid file location, keep it in %%{_localstatedir}/run
  293. * Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
  294. - Update to stunnel-4.13
  295. * Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
  296. - Update to stunnel-4.12
  297. * Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
  298. - Enable IPv6 (#169050, patch by Peter Bieringer)
  299. - Don't ship another copy of man pages in HTML
  300. * Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
  301. - Update to stunnel-4.11
  302. - Fix int/size_t mismatches in stack_info ()
  303. - Update Certificate-Creation for /etc/pki
  304. * Wed Jun 1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
  305. - Fix inetd mode
  306. - Remove unnecessary Requires: and BuildRequires:
  307. - Clean up the spec file
  308. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
  309. - update to 4.10
  310. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
  311. - add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
  312. coreutils (#133961)
  313. * Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
  314. - update to 4.08
  315. - build stunnel as a PIE binary
  316. * Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
  317. - Convert man pages to UTF-8
  318. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  319. - rebuilt
  320. * Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
  321. - move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
  322. * Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
  323. - update to 4.05
  324. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  325. - rebuilt
  326. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  327. - rebuilt
  328. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
  329. - Fix libtool
  330. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  331. - rebuilt
  332. * Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
  333. - fix xinetd configuration samples
  334. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
  335. - rebuild
  336. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  337. - rebuilt
  338. * Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
  339. - update to 4.04
  340. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
  341. - use pkgconfig for information about openssl, if available
  342. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  343. - update to 4.03
  344. * Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
  345. - update to 4.02
  346. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
  347. - don't create a dummy cert
  348. * Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
  349. - update to 4.00
  350. - remove textutils and fileutils as buildreqs, add automake/autoconf
  351. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  352. - automated rebuild
  353. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  354. - automated rebuild
  355. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
  356. - rebuild in new environment
  357. * Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
  358. - update to 3.22, correcting a format-string vulnerability
  359. * Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
  360. - update to 3.21a
  361. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
  362. - log using LOG_AUTHPRIV facility by default (#47289)
  363. - make permissions on stunnel binary 0755
  364. - implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
  365. * Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
  366. - update to 3.19 to avoid problems with stunnel being multithreaded, but
  367. tcp wrappers not being thrad-safe
  368. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  369. - update to 3.17
  370. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  371. - update to 3.16
  372. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  373. - update to 3.15
  374. - enable tcp-wrappers support
  375. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  376. - remove explicit requirement on openssl (specific version isn't enough,
  377. we have to depend on shared library version anyway)
  378. * Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  379. - update to 3.14
  380. * Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
  381. - depend on make (#33148)
  382. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  383. - rebuild in new environment
  384. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  385. - update to 3.13 to get pthread, OOB, 64-bit fixes
  386. - don't need sdf any more
  387. * Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  388. - pull in sdf to build the man page (#22892)
  389. * Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  390. - update to 3.11
  391. - chuck the SIGHUP patch (went upstream)
  392. - chuck parts of the 64-bit clean patch (went upstream)
  393. * Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  394. - update to 3.10
  395. - more 64-bit clean changes, hopefully the last bunch
  396. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  397. - change piddir from the default /var/stunnel to /var/run
  398. - clean out pid file on SIGHUP
  399. * Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
  400. - update to 3.9 to get a security fix
  401. * Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
  402. - change all unsigned longs to u_int32_t when dealing with network
  403. addresses
  404. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  405. - make stunnel.pem also be (missingok)
  406. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  407. - move to Applications/Internet group
  408. - clean up %%post script
  409. - make stunnel.pem %%ghost %%config(noreplace)
  410. - provide a sample file for use with xinetd
  411. * Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  412. - FHS compliance fixes
  413. - modify defaults
  414. * Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  415. - update to 3.8
  416. - do not create certificate if one already exists
  417. * Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  418. - update to 3.7
  419. - add patch to find /usr/share/ssl
  420. - change some perms
  421. * Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  422. - Modify spec file to match Red Hat standards
  423. * Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
  424. - Updated to 3.4a
  425. - Patched for OpenSSL 0.9.4
  426. - Cleaned up files section
  427. * Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
  428. - Updated to 3.3
  429. * Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
  430. - Initial RPMification