libdb-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583
  1. %define __soversion_major 5
  2. %define __soversion %{__soversion_major}.3
  3. %bcond_with java
  4. Summary: The Berkeley DB database library for C
  5. Name: libdb
  6. Version: 5.3.28
  7. Release: 5%{?_dist_release}
  8. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  9. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  10. # For mt19937db.c
  11. Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
  12. Patch0: libdb-multiarch.patch
  13. # db-1.85 upstream patches
  14. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  15. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  16. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  17. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  18. # other patches
  19. Patch20: db-1.85-errno.patch
  20. Patch22: db-4.6.21-1.85-compat.patch
  21. Patch24: db-4.5.20-jni-include-dir.patch
  22. # License clarification patch
  23. # http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
  24. Patch25: 007-mt19937db.c_license.patch
  25. URL: http://www.oracle.com/database/berkeley-db/
  26. License: BSD and LGPLv2 and Sleepycat
  27. Group: System Environment/Libraries
  28. BuildRequires: perl libtool
  29. BuildRequires: tcl >= 8.5.2-3
  30. %if %{with java}
  31. BuildRequires: java-devel >= 1:1.6.0
  32. %endif
  33. #BuildRequires: chrpath
  34. #Conflicts: filesystem < 3
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: tomop
  38. %description
  39. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  40. provides embedded database support for both traditional and
  41. client/server applications. The Berkeley DB includes B+tree, Extended
  42. Linear Hashing, Fixed and Variable-length record access methods,
  43. transactions, locking, logging, shared memory caching, and database
  44. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  45. used by many applications, including Python and Perl, so this should
  46. be installed on all systems.
  47. %package utils
  48. Summary: Command line tools for managing Berkeley DB databases
  49. Group: Applications/Databases
  50. Requires: %{name}%{?_isa} = %{version}-%{release}
  51. Obsoletes: db4-utils
  52. %description utils
  53. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  54. provides embedded database support for both traditional and
  55. client/server applications. Berkeley DB includes B+tree, Extended
  56. Linear Hashing, Fixed and Variable-length record access methods,
  57. transactions, locking, logging, shared memory caching, and database
  58. recovery. DB supports C, C++, Java and Perl APIs.
  59. %package devel
  60. Summary: C development files for the Berkeley DB library
  61. Group: Development/Libraries
  62. Requires: %{name}%{?_isa} = %{version}-%{release}
  63. Obsoletes: db4-devel
  64. %description devel
  65. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  66. provides embedded database support for both traditional and
  67. client/server applications. This package contains the header files,
  68. libraries, and documentation for building programs which use the
  69. Berkeley DB.
  70. %package devel-doc
  71. Summary: C development documentation files for the Berkeley DB library
  72. Group: Documentation
  73. Requires: %{name} = %{version}-%{release}
  74. Requires: %{name}-devel = %{version}-%{release}
  75. BuildArch: noarch
  76. %description devel-doc
  77. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  78. provides embedded database support for both traditional and
  79. client/server applications. This package contains the header files,
  80. libraries, and documentation for building programs which use the
  81. Berkeley DB.
  82. %package devel-static
  83. Summary: Berkeley DB static libraries
  84. Group: Development/Libraries
  85. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  86. %description devel-static
  87. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  88. provides embedded database support for both traditional and
  89. client/server applications. This package contains static libraries
  90. needed for applications that require static linking of
  91. Berkeley DB.
  92. %package cxx
  93. Summary: The Berkeley DB database library for C++
  94. Group: System Environment/Libraries
  95. Requires: %{name}%{?_isa} = %{version}-%{release}
  96. %description cxx
  97. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  98. provides embedded database support for both traditional and
  99. client/server applications. The Berkeley DB includes B+tree, Extended
  100. Linear Hashing, Fixed and Variable-length record access methods,
  101. transactions, locking, logging, shared memory caching, and database
  102. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  103. used by many applications, including Python and Perl, so this should
  104. be installed on all systems.
  105. %package cxx-devel
  106. Summary: The Berkeley DB database library for C++
  107. Group: System Environment/Libraries
  108. Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
  109. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  110. %description cxx-devel
  111. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  112. provides embedded database support for both traditional and
  113. client/server applications. The Berkeley DB includes B+tree, Extended
  114. Linear Hashing, Fixed and Variable-length record access methods,
  115. transactions, locking, logging, shared memory caching, and database
  116. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  117. used by many applications, including Python and Perl, so this should
  118. be installed on all systems.
  119. %package tcl
  120. Summary: Development files for using the Berkeley DB with tcl
  121. Group: Development/Libraries
  122. Requires: %{name}%{?_isa} = %{version}-%{release}
  123. %description tcl
  124. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  125. provides embedded database support for both traditional and
  126. client/server applications. This package contains the libraries
  127. for building programs which use the Berkeley DB in Tcl.
  128. %package tcl-devel
  129. Summary: Development files for using the Berkeley DB with tcl
  130. Group: Development/Libraries
  131. Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
  132. %description tcl-devel
  133. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  134. provides embedded database support for both traditional and
  135. client/server applications. This package contains the libraries
  136. for building programs which use the Berkeley DB in Tcl.
  137. %package sql
  138. Summary: Development files for using the Berkeley DB with sql
  139. Group: Development/Libraries
  140. Requires: %{name}%{?_isa} = %{version}-%{release}
  141. %description sql
  142. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  143. provides embedded database support for both traditional and
  144. client/server applications. This package contains the libraries
  145. for building programs which use the Berkeley DB in SQL.
  146. %package sql-devel
  147. Summary: Development files for using the Berkeley DB with sql
  148. Group: Development/Libraries
  149. Requires: %{name}-sql%{?_isa} = %{version}-%{release}
  150. %description sql-devel
  151. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  152. provides embedded database support for both traditional and
  153. client/server applications. This package contains the libraries
  154. for building programs which use the Berkeley DB in SQL.
  155. %if %{with java}
  156. %package java
  157. Summary: Development files for using the Berkeley DB with Java
  158. Group: Development/Libraries
  159. Requires: %{name}%{?_isa} = %{version}-%{release}
  160. %description java
  161. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  162. provides embedded database support for both traditional and
  163. client/server applications. This package contains the libraries
  164. for building programs which use the Berkeley DB in Java.
  165. %package java-devel
  166. Summary: Development files for using the Berkeley DB with Java
  167. Group: Development/Libraries
  168. Requires: %{name}-java%{?_isa} = %{version}-%{release}
  169. %description java-devel
  170. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  171. provides embedded database support for both traditional and
  172. client/server applications. This package contains the libraries
  173. for building programs which use the Berkeley DB in Java.
  174. %endif
  175. %prep
  176. %setup -q -n db-%{version} -a 1
  177. cp %{SOURCE2} .
  178. %patch0 -p1 -b .multiarch
  179. pushd db.1.85/PORT/linux
  180. %patch10 -p0 -b .1.1
  181. popd
  182. pushd db.1.85
  183. %patch11 -p0 -b .1.2
  184. %patch12 -p0 -b .1.3
  185. %patch13 -p0 -b .1.4
  186. %patch20 -p1 -b .errno
  187. popd
  188. %patch22 -p1 -b .185compat
  189. %patch24 -p1 -b .4.5.20.jni
  190. %patch25 -p1 -b .licensefix
  191. cd dist
  192. ./s_config
  193. cd ..
  194. %build
  195. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  196. CFLAGS="$CFLAGS -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
  197. export CFLAGS
  198. # Build the old db-185 libraries.
  199. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  200. test -d dist/dist-tls || mkdir dist/dist-tls
  201. # Static link db_dump185 with old db-185 libraries.
  202. /bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
  203. /bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  204. # Update config files to understand aarch64
  205. #for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
  206. # cp /usr/lib/rpm/config.{guess,sub} "$dir"
  207. #done
  208. pushd dist/dist-tls
  209. %define _configure ../configure
  210. %configure -C \
  211. --enable-compat185 \
  212. --enable-dump185 \
  213. --enable-shared \
  214. --enable-static \
  215. --enable-tcl \
  216. --with-tcl=%{_libdir} \
  217. --enable-cxx \
  218. --enable-sql \
  219. --enable-test \
  220. --disable-rpath \
  221. --with-tcl=%{_libdir}/tcl8.5 \
  222. %if %{with java}
  223. --enable-java
  224. %endif
  225. # Remove libtool predep_objects and postdep_objects wonkiness so that
  226. # building without -nostdlib doesn't include them twice. Because we
  227. # already link with g++, weird stuff happens if you don't let the
  228. # compiler handle this.
  229. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  230. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  231. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  232. make %{?_smp_mflags}
  233. %if %{with java}
  234. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  235. LDBJ=./.libs/libdb_java-%{__soversion}.la
  236. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  237. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  238. fi
  239. %endif
  240. popd
  241. %install
  242. rm -rf ${RPM_BUILD_ROOT}
  243. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  244. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  245. %makeinstall STRIP=/bin/true -C dist/dist-tls
  246. # XXX Nuke non-versioned archives and symlinks
  247. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
  248. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  249. # Move the header files to a subdirectory, in case we're deploying on a
  250. # system with multiple versions of DB installed.
  251. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
  252. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
  253. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  254. for i in db.h db_cxx.h db_185.h; do
  255. ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
  256. done
  257. %if %{with java}
  258. # Move java jar file to the correct place
  259. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  260. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  261. %endif
  262. # Eliminate installed doco
  263. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  264. # XXX Avoid Permission denied. strip when building as non-root.
  265. chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
  266. # remove unneeded .la files (#225675)
  267. rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
  268. # remove RPATHs
  269. #chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
  270. # unify documentation and examples, remove stuff we don't need
  271. rm -rf docs/csharp
  272. rm -rf examples/csharp
  273. rm -rf docs/installation
  274. mv examples docs
  275. %clean
  276. rm -rf ${RPM_BUILD_ROOT}
  277. %post
  278. /sbin/ldconfig
  279. %postun
  280. /sbin/ldconfig
  281. %post cxx
  282. /sbin/ldconfig
  283. %postun cxx
  284. /sbin/ldconfig
  285. %post sql
  286. /sbin/ldconfig
  287. %postun sql
  288. /sbin/ldconfig
  289. %post tcl
  290. /sbin/ldconfig
  291. %postun tcl
  292. /sbin/ldconfig
  293. %if %{with java}
  294. %post java
  295. /sbin/ldconfig
  296. %postun java
  297. /sbin/ldconfig
  298. %endif
  299. %files
  300. %defattr(-,root,root,-)
  301. %doc LICENSE README lgpl-2.1.txt
  302. %{_libdir}/libdb-%{__soversion}.so
  303. %{_libdir}/libdb-%{__soversion_major}.so
  304. %files devel
  305. %defattr(-,root,root,-)
  306. %{_libdir}/libdb.so
  307. %dir %{_includedir}/%{name}
  308. %{_includedir}/%{name}/db.h
  309. %{_includedir}/%{name}/db_185.h
  310. %{_includedir}/db.h
  311. %{_includedir}/db_185.h
  312. %files devel-doc
  313. %defattr(-,root,root,-)
  314. %doc docs/*
  315. %files devel-static
  316. %defattr(-,root,root,-)
  317. %{_libdir}/libdb-%{__soversion}.a
  318. %{_libdir}/libdb_cxx-%{__soversion}.a
  319. %{_libdir}/libdb_tcl-%{__soversion}.a
  320. %{_libdir}/libdb_sql-%{__soversion}.a
  321. %if %{with java}
  322. %{_libdir}/libdb_java-%{__soversion}.a
  323. %endif
  324. %files utils
  325. %defattr(-,root,root,-)
  326. %{_bindir}/db*_archive
  327. %{_bindir}/db*_checkpoint
  328. %{_bindir}/db*_deadlock
  329. %{_bindir}/db*_dump*
  330. %{_bindir}/db*_hotbackup
  331. %{_bindir}/db*_load
  332. %{_bindir}/db*_printlog
  333. %{_bindir}/db*_recover
  334. %{_bindir}/db*_replicate
  335. %{_bindir}/db*_stat
  336. %{_bindir}/db*_upgrade
  337. %{_bindir}/db*_verify
  338. %{_bindir}/db*_tuner
  339. %files cxx
  340. %defattr(-,root,root,-)
  341. %{_libdir}/libdb_cxx-%{__soversion}.so
  342. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  343. %files cxx-devel
  344. %defattr(-,root,root,-)
  345. %{_includedir}/%{name}/db_cxx.h
  346. %{_includedir}/db_cxx.h
  347. %{_libdir}/libdb_cxx.so
  348. %files tcl
  349. %defattr(-,root,root,-)
  350. %{_libdir}/libdb_tcl-%{__soversion}.so
  351. %{_libdir}/libdb_tcl-%{__soversion_major}.so
  352. %files tcl-devel
  353. %defattr(-,root,root,-)
  354. %{_libdir}/libdb_tcl.so
  355. %files sql
  356. %defattr(-,root,root,-)
  357. %{_libdir}/libdb_sql-%{__soversion}.so
  358. %{_libdir}/libdb_sql-%{__soversion_major}.so
  359. %files sql-devel
  360. %defattr(-,root,root,-)
  361. %{_bindir}/dbsql
  362. %{_libdir}/libdb_sql.so
  363. %{_includedir}/%{name}/dbsql.h
  364. %if %{with java}
  365. %files java
  366. %defattr(-,root,root,-)
  367. %{_libdir}/libdb_java-%{__soversion_major}*.so
  368. %{_datadir}/java/*.jar
  369. %files java-devel
  370. %defattr(-,root,root,-)
  371. %{_libdir}/libdb_java.so
  372. %endif
  373. %changelog
  374. * Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
  375. - initial build for Vine Linux.
  376. * Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
  377. - Add some of the previous aarch64 bits back as the sub configure don't use the macro
  378. * Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
  379. - Fix configure macro usage for better aarch64 build fix
  380. * Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
  381. - Updated config files to allow build on aarch64 (#1022970)
  382. * Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
  383. - Added Sleepycat to the license list (#1013841)
  384. - Updated to 5.3.28 (#1013233)
  385. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
  386. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  387. * Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
  388. - add copy of lgpl-2.1.txt
  389. * Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
  390. - Fix missing debuginfo issue for utils subpackage
  391. * Thu May 9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
  392. - add license clarification fix
  393. * Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
  394. - Added sqlite compability CFLAGS (#788496)
  395. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
  396. - Cleaning the specfile - removed gcc-java dependecy other way
  397. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
  398. - Removed dependency on obsolete gcc-java package (#927742)
  399. * Thu Mar 7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
  400. - add LGPLv2+ and remove Sleepycat in license tag (#886838)
  401. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
  402. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  403. * Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
  404. - fix license tag
  405. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
  406. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  407. * Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
  408. - Specify tag for libtool (fixes FTBFS # 838334 )
  409. * Thu Jul 5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
  410. - update to 5.3.21
  411. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  412. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
  413. - move C++ header files to cxx-devel
  414. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
  415. - fix -devel packages dependencies yet more (#832225)
  416. * Sun May 6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
  417. - package -devel packages correctly
  418. * Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
  419. - fix multiarch conflict in libdb-devel (#812901)
  420. - remove unneeded dos2unix BR
  421. * Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
  422. - update to 5.3.15
  423. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  424. * Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
  425. - Resolves rhbz#794472
  426. - Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
  427. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
  428. - add filesystem guard
  429. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
  430. - install everything in /usr
  431. https://fedoraproject.org/wiki/Features/UsrMove
  432. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
  433. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  434. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
  435. - update to 5.2.36,
  436. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
  437. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
  438. - move development documentation to devel-doc subpackage (#705386)
  439. * Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
  440. - update to 5.2.28
  441. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
  442. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  443. * Thu Feb 3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
  444. - update to 5.1.25
  445. * Wed Sep 29 2010 jkeating - 5.1.19-2
  446. - Rebuilt for gcc bug 634757
  447. * Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
  448. - update to 5.1.19
  449. - rename -devel-static to -static subpackage (#617800)
  450. - build java on all arches
  451. * Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
  452. - update to 5.0.26
  453. - drop BR: ed
  454. * Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
  455. - add Requires: libdb-cxx to libdb-devel
  456. * Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
  457. - initial build
  458. * Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
  459. - remove C# documentation
  460. - disable/remove rpath
  461. - fix description
  462. - tighten dependencies
  463. - run ldconfig for cxx and sql subpackages
  464. * Fri Apr 9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
  465. - enable sql
  466. - package 5.0.21