zabbix-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730
  1. %bcond_with systemd
  2. %define only_agent 0
  3. %if %{only_agent}
  4. %bcond_with server
  5. %bcond_with proxy
  6. %bcond_with frontend
  7. %else
  8. %bcond_without server
  9. %bcond_without proxy
  10. %bcond_without frontend
  11. %endif
  12. %bcond_without agent
  13. %global php_pkgname php74
  14. Summary: The Enterprise-class Monitoring Solution for Everyone
  15. Name: zabbix
  16. Version: 6.0.6
  17. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  18. Group: system
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: iwaim
  22. License: GPLv2
  23. URL: https://www.zabbix.com/
  24. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  25. Source0: https://cdn.zabbix.com/zabbix/sources/stable/%{shortver}/%{name}-%{version}.tar.gz
  26. Source1: zabbix_server.init
  27. Source2: zabbix_proxy.init
  28. Source3: zabbix_agentd.init
  29. Source4: zabbix_server.logrotate
  30. Source5: zabbix_proxy.logrotate
  31. Source6: zabbix_agentd.logrotate
  32. Source9: %{name}-tmpfiles-zabbix.conf
  33. # systemd units -- Alternatives switches between them (they state their dependencies)
  34. # https://support.zabbix.com/browse/ZBXNEXT-1593
  35. Source10: %{name}-agent.service
  36. Source11: %{name}-proxy-mysql.service
  37. Source12: %{name}-proxy-pgsql.service
  38. Source14: %{name}-server-mysql.service
  39. Source15: %{name}-server-pgsql.service
  40. Source17: %{name}-tmpfiles-zabbixsrv.conf
  41. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
  42. %if %{with server}%{with proxy}
  43. BuildRequires: libpq-devel
  44. BuildRequires: libmariadb-devel
  45. %endif
  46. BuildRequires: libevent-devel
  47. BuildRequires: pcre-devel
  48. BuildRequires: curl-devel
  49. BuildRequires: net-snmp-devel
  50. BuildRequires: OpenIPMI-devel
  51. BuildRequires: unixODBC-devel
  52. BuildRequires: libssh2-devel
  53. BuildRequires: openssl-devel
  54. Requires(pre): glibc-common
  55. Requires(pre): shadow-utils
  56. %if %{with systemd}
  57. BuildRequires: systemd
  58. %endif
  59. %description
  60. The Enterprise-class Monitoring Solution for Everyone.
  61. %if %{with server}
  62. %package server-common
  63. Summary: common files for Zabbix Server
  64. Group: servers
  65. Requires: %{name} == %{version}-%{release}
  66. %if %{with systemd}
  67. %{?systemd_requires}
  68. %else
  69. Requires(post,preun): chkconfig
  70. Requires(preun,postun): initscripts
  71. %endif
  72. %description server-common
  73. This package include common files for Zabbix Server.
  74. %package server-mysql
  75. Summary: Zabbix Server for MySQL/MariaDB
  76. Group: servers
  77. Provides: %{name}-server
  78. Requires: %{name}-server-common == %{version}-%{release}
  79. %description server-mysql
  80. Zabbix Server for MySQL/MariaDB
  81. %package server-postgresql
  82. Summary: Zabbix Server for PostgreSQL
  83. Group: servers
  84. Provides: %{name}-server
  85. Requires: %{name}-server-common == %{version}-%{release}
  86. %description server-postgresql
  87. Zabbix Server for PostgreSQL
  88. %endif
  89. %if %{with agent}
  90. %package agent
  91. Summary: Zabbix Agent
  92. Group: system
  93. Requires: %{name} == %{version}-%{release}
  94. %if %{with systemd}
  95. %{?systemd_requires}
  96. %else
  97. Requires(post,preun): chkconfig
  98. Requires(preun,postun): initscripts
  99. %endif
  100. %description agent
  101. Zabbix Agent
  102. %endif
  103. %if %{with proxy}
  104. %package proxy-common
  105. Summary: common files for Zabbix Proxy
  106. Group: servers
  107. Requires: %{name} == %{version}-%{release}
  108. %if %{with systemd}
  109. %{?systemd_requires}
  110. %else
  111. Requires(post,preun): chkconfig
  112. Requires(preun,postun): initscripts
  113. %endif
  114. %description proxy-common
  115. This package include common files for Zabbix Proxy
  116. %package proxy-mysql
  117. Summary: Zabbix Proxy for MySQL/MariaDB
  118. Group: servers
  119. Provides: %{name}-proxy
  120. Requires: %{name}-proxy-common == %{version}-%{release}
  121. %description proxy-mysql
  122. Zabbix Proxy for MySQL/MariaDB
  123. %package proxy-postgresql
  124. Summary: Zabbix Proxy for PostgreSQL
  125. Group: servers
  126. Provides: %{name}-proxy
  127. Requires: %{name}-proxy-common == %{version}-%{release}
  128. %description proxy-postgresql
  129. Zabbix Proxy for PostgreSQL
  130. %endif
  131. %if %{with frontend}
  132. %package frontend-php
  133. Summary: Zabbix web frontend with PHP
  134. Group: servers
  135. Requires: %{php_pkgname}
  136. Requires: TrueType-vlgothic
  137. %description frontend-php
  138. Zabbix web frontend with PHP.
  139. %package frontend-php-mysql
  140. Summary: Zabbix web frontend with PHP and MySQL/MariaDB
  141. Group: servers
  142. Provides: %{name}-frontend-php == %{version}-%{release}
  143. Requires: %{php_pkgname}-mysql
  144. %description frontend-php-mysql
  145. Zabbix web frontend with PHP and MySQL/MariaDB.
  146. %package frontend-php-postgresql
  147. Summary: Zabbix web frontend with PHP and PostgreSQL
  148. Group: servers
  149. Provides: %{name}-frontend-php == %{version}-%{release}
  150. Requires: %{php_pkgname}-pgsql
  151. %description frontend-php-postgresql
  152. Zabbix web frontend with PHP and PostgreSQL.
  153. %endif
  154. %debug_package
  155. %prep
  156. %setup -q -T -a 0 -c -n zabbix-%{version}
  157. mv zabbix-%{version} zabbix_mysql
  158. %if %{with server}%{with proxy}
  159. %setup -q -D -T -a 0 -n zabbix-%{version}
  160. mv zabbix-%{version} zabbix_pgsql
  161. %endif
  162. for v in mysql pgsql; do
  163. pushd zabbix_$v
  164. sed -i -e 's/DejaVuSans/VL-Gothic-Regular/g' ./ui/include/defines.inc.php
  165. sed -i \
  166. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_agentd.pid' \
  167. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_agentd.log|' \
  168. conf/zabbix_agentd.conf
  169. sed -i \
  170. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_proxy.pid' \
  171. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_proxy.log|' \
  172. conf/zabbix_proxy.conf
  173. sed -i \
  174. -e '\|^# PidFile=.*|a PidFile=/run/zabbix/zabbix_server.pid' \
  175. -e 's|^LogFile=.*|LogFile=%{_localstatedir}/log/zabbix/zabbix_server.log|' \
  176. conf/zabbix_server.conf
  177. popd
  178. done
  179. %build
  180. Build()
  181. {
  182. perl -pi -e 's|/usr/bin/traceroute|/bin/traceroute|' \
  183. ./database/{ibm_db2,mysql,oracle,postgresql,sqlite3}/data.sql
  184. %configure \
  185. %{?with_server:--enable-server} \
  186. %{?with_proxy:--enable-proxy} \
  187. %{?with_agent:--enable-agent} \
  188. --enable-ipv6 \
  189. --sysconfdir=%{_sysconfdir}/zabbix \
  190. --with-libcurl \
  191. --with-openipmi \
  192. --with-net-snmp \
  193. --with-unixodbc \
  194. --with-ssh2 \
  195. --with-openssl \
  196. $@
  197. %__make
  198. }
  199. %if %{with server}%{with proxy}
  200. pushd zabbix_mysql
  201. Build --with-mysql
  202. popd
  203. pushd zabbix_pgsql
  204. Build --with-postgresql
  205. popd
  206. %else
  207. pushd zabbix_mysql
  208. Build
  209. popd
  210. %endif
  211. %install
  212. %__rm -rf %{buildroot}
  213. pushd zabbix_mysql
  214. make DESTDIR=%{buildroot} install
  215. %if %{with server}
  216. mv -f %{buildroot}%{_sbindir}/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.mysql
  217. %endif
  218. %if %{with proxy}
  219. mv -f %{buildroot}%{_sbindir}/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.mysql
  220. %endif
  221. # make directories
  222. %__mkdir_p %{buildroot}%{_localstatedir}/{log,run}/%{name}
  223. # DB
  224. %__mkdir_p %{buildroot}%{_datadir}/zabbix
  225. %if %{with server}%{with proxy}
  226. %__cp -a database/postgresql %{buildroot}%{_datadir}/zabbix/
  227. %__cp -a database/mysql %{buildroot}%{_datadir}/zabbix/
  228. %endif
  229. %if %{with systemd}
  230. # unit files
  231. %__mkdir_p %{buildroot}%{_unitdir}
  232. # Install different systemd units because of the requirements for DBMS daemons
  233. install -m 0644 -p %{SOURCE10} %{buildroot}%{_unitdir}/zabbix-agent.service
  234. install -m 0644 -p %{SOURCE11} %{buildroot}%{_unitdir}/zabbix-proxy-mysql.service
  235. install -m 0644 -p %{SOURCE12} %{buildroot}%{_unitdir}/zabbix-proxy-pgsql.service
  236. install -m 0644 -p %{SOURCE14} %{buildroot}%{_unitdir}/zabbix-server-mysql.service
  237. install -m 0644 -p %{SOURCE15} %{buildroot}%{_unitdir}/zabbix-server-pgsql.service
  238. # systemd tmpfiles
  239. mkdir -p %{buildroot}%{_prefix}/lib/tmpfiles.d
  240. install -m 0644 -p %{SOURCE9} %{buildroot}%{_prefix}/lib/tmpfiles.d/zabbix.conf
  241. %else
  242. # init.d
  243. %__mkdir_p %{buildroot}%{_initddir}
  244. %if %{with server}
  245. %__cp %{SOURCE1} %{buildroot}%{_initddir}/zabbix_server
  246. %endif
  247. %if %{with proxy}
  248. %__cp %{SOURCE2} %{buildroot}%{_initddir}/zabbix_proxy
  249. %endif
  250. %if %{with agent}
  251. %__cp %{SOURCE3} %{buildroot}%{_initddir}/zabbix_agentd
  252. %endif
  253. %endif
  254. # logrotate
  255. %__mkdir_p %{buildroot}%{_sysconfdir}/logrotate.d
  256. %if %{with server}
  257. %__cp %{SOURCE4} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_server
  258. %endif
  259. %if %{with proxy}
  260. %__cp %{SOURCE5} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_proxy
  261. %endif
  262. %if %{with agent}
  263. %__cp %{SOURCE6} %{buildroot}%{_sysconfdir}/logrotate.d/zabbix_agentd
  264. %endif
  265. %if %{with frontend}
  266. # frontend-php
  267. %__mkdir_p %{buildroot}%{_datadir}/zabbix-frontend
  268. %__cp -a ui %{buildroot}%{_datadir}/zabbix-frontend/php
  269. %__rm -f %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/DejaVuSans.ttf
  270. ln -s /usr/share/fonts/TrueType-vlgothic/VL-Gothic-Regular.ttf \
  271. %{buildroot}%{_datadir}/zabbix-frontend/php/assets/fonts/
  272. %endif
  273. %if %{with proxy}
  274. # proxy
  275. mkdir -p %{buildroot}%{_datadir}/zabbix-proxy
  276. ln -sf ../zabbix/mysql %{buildroot}%{_datadir}/zabbix-proxy/
  277. ln -sf ../zabbix/postgresql %{buildroot}%{_datadir}/zabbix-proxy/
  278. %endif
  279. popd
  280. %if %{with server}%{with proxy}
  281. pushd zabbix_pgsql
  282. install -m755 src/zabbix_server/zabbix_server %{buildroot}%{_sbindir}/zabbix_server.pgsql
  283. install -m755 src/zabbix_proxy/zabbix_proxy %{buildroot}%{_sbindir}/zabbix_proxy.pgsql
  284. popd
  285. %endif
  286. %clean
  287. %__rm -rf %{buildroot}
  288. %pre
  289. getent group zabbix >/dev/null || groupadd -r zabbix
  290. getent passwd zabbix >/dev/null || \
  291. useradd -r -g zabbix -d %{_sysconfdir}/zabbix -s /sbin/nologin \
  292. -c "Zabbix Monitoring Solution" zabbix
  293. exit 0
  294. %if %{with server}
  295. %post server-mysql
  296. %if %{with systemd}
  297. %systemd_post zabbix-server-mysql.service
  298. %else
  299. /sbin/update-alternatives --install /usr/sbin/zabbix_server \
  300. zabbix_server /usr/sbin/zabbix_server.mysql 10
  301. %endif
  302. %post server-postgresql
  303. %if %{with systemd}
  304. %systemd_post zabbix-server-pgsql.service
  305. %else
  306. /sbin/update-alternatives --install /usr/sbin/zabbix_server \
  307. zabbix_server /usr/sbin/zabbix_server.pgsql 10
  308. /sbin/chkconfig --add zabbix_server
  309. %endif
  310. %endif
  311. %if %{with proxy}
  312. %post proxy-mysql
  313. %if %{with systemd}
  314. %systemd_post zabbix-proxy-mysql.service
  315. %else
  316. /sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
  317. zabbix_proxy /usr/sbin/zabbix_proxy.mysql 10
  318. /sbin/chkconfig --add zabbix_proxy
  319. %endif
  320. %post proxy-postgresql
  321. %if %{with systemd}
  322. %systemd_post zabbix-proxy-pgsql.service
  323. %else
  324. /sbin/update-alternatives --install /usr/sbin/zabbix_proxy \
  325. zabbix_proxy /usr/sbin/zabbix_proxy.pgsql 10
  326. /sbin/chkconfig --add zabbix_proxy
  327. %endif
  328. %endif
  329. %if %{with agent}
  330. %post agent
  331. %if %{with systemd}
  332. %systemd_post zabbix-agent.service
  333. %else
  334. /sbin/chkconfig --add zabbix_agentd
  335. %endif
  336. %endif
  337. %if %{with server}
  338. %preun server-mysql
  339. %if %{with systemd}
  340. %systemd_preun zabbix-server-mysql.service
  341. %else
  342. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  343. /sbin/service zabbix_server stop >/dev/null 2>&1
  344. /sbin/chkconfig --del zabbix_server
  345. /sbin/update-alternatives --remove zabbix_server \
  346. /usr/sbin/zabbix_server.mysql
  347. fi
  348. %endif
  349. %preun server-postgresql
  350. %if %{with systemd}
  351. %systemd_preun zabbix-server-pgysql.service
  352. %else
  353. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  354. /sbin/service zabbix_server stop >/dev/null 2>&1
  355. /sbin/chkconfig --del zabbix_server
  356. /sbin/update-alternatives --remove zabbix_server \
  357. /usr/sbin/zabbix_server.pgsql
  358. fi
  359. %endif
  360. %endif
  361. %if %{with proxy}
  362. %preun proxy-mysql
  363. %if %{with systemd}
  364. %systemd_preun zabbix-proxy-mysql.service
  365. %else
  366. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  367. /sbin/service zabbix_proxy stop >/dev/null 2>&1
  368. /sbin/chkconfig --del zabbix_proxy
  369. /sbin/update-alternatives --remove zabbix_proxy \
  370. /usr/sbin/zabbix_proxy.mysql
  371. fi
  372. %endif
  373. %preun proxy-postgresql
  374. %if %{with systemd}
  375. %systemd_preun zabbix-proxy-pgsql.service
  376. %else
  377. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  378. /sbin/service zabbix_proxy stop >/dev/null 2>&1
  379. /sbin/chkconfig --del zabbix_proxy
  380. /sbin/update-alternatives --remove zabbix_proxy \
  381. /usr/sbin/zabbix_proxy.pgsql
  382. fi
  383. %endif
  384. %endif
  385. %if %{with agent}
  386. %preun agent
  387. %if %{with systemd}
  388. %systemd_preun zabbix-agent.service
  389. %else
  390. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  391. /sbin/service zabbix_agentd stop >/dev/null 2>&1
  392. /sbin/chkconfig --del zabbix_agentd
  393. fi
  394. %endif
  395. %endif
  396. %if %{with server}
  397. %postun server-mysql
  398. %if %{with systemd}
  399. %systemd_postun_with_restart zabbix-server-mysql.service
  400. %else
  401. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  402. /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
  403. fi
  404. %endif
  405. %postun server-postgresql
  406. %if %{with systemd}
  407. %systemd_postun_with_restart zabbix-server-pgsql.service
  408. %else
  409. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  410. /sbin/service zabbix_server condrestart >/dev/null 2>&1 || :
  411. fi
  412. %endif
  413. %endif
  414. %if %{with proxy}
  415. %postun proxy-mysql
  416. %if %{with systemd}
  417. %systemd_postun_with_restart zabbix-proxy-mysql.service
  418. %else
  419. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  420. /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
  421. fi
  422. %endif
  423. %postun proxy-postgresql
  424. %if %{with systemd}
  425. %systemd_postun_with_restart zabbix-proxy-pgsql.service
  426. %else
  427. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  428. /sbin/service zabbix_proxy condrestart >/dev/null 2>&1 || :
  429. fi
  430. %endif
  431. %postun agent
  432. %if %{with systemd}
  433. %systemd_postun_with_restart zabbix-agent.service
  434. %else
  435. if [ "$1" -ge "1" -a ! -x /bin/systemctl ]; then
  436. /sbin/service zabbix_agentd condrestart >/dev/null 2>&1 || :
  437. fi
  438. %endif
  439. %endif
  440. %files
  441. %defattr(-,root,root,-)
  442. %license zabbix_mysql/COPYING
  443. %doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
  444. %attr(0755,zabbix,zabbix) %dir %{_localstatedir}/log/%{name}
  445. %dir %{_datadir}/zabbix
  446. %if %{with server}%{with proxy}
  447. %{_datadir}/zabbix/mysql
  448. %{_datadir}/zabbix/postgresql
  449. %endif
  450. %if %{with systemd}
  451. %{_prefix}/lib/tmpfiles.d/zabbix.conf
  452. %endif
  453. %{_bindir}/zabbix_js
  454. %if %{with server}
  455. %files server-common
  456. %defattr(-,root,root,-)
  457. %dir %{_sysconfdir}/zabbix
  458. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_server.conf
  459. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_server
  460. %if !%{with systemd}
  461. %{_initddir}/zabbix_server*
  462. %endif
  463. %{_mandir}/man8/zabbix_server.8*
  464. %files server-mysql
  465. %defattr(-,root,root,-)
  466. %{_sbindir}/zabbix_server.mysql
  467. %if %{with systemd}
  468. %{_unitdir}/zabbix-server-mysql.service
  469. %endif
  470. %files server-postgresql
  471. %defattr(-,root,root,-)
  472. %{_sbindir}/zabbix_server.pgsql
  473. %if %{with systemd}
  474. %{_unitdir}/zabbix-server-pgsql.service
  475. %endif
  476. %endif
  477. %if %{with agent}
  478. %files agent
  479. %defattr(-,root,root,-)
  480. %dir %{_sysconfdir}/zabbix
  481. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_agentd.conf
  482. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_agentd
  483. %{_bindir}/zabbix_get
  484. %{_bindir}/zabbix_sender
  485. %{_sbindir}/zabbix_agentd
  486. %if %{with systemd}
  487. %{_unitdir}/zabbix-agent.service
  488. %else
  489. %{_initddir}/zabbix_agentd
  490. %endif
  491. %{_mandir}/man1/zabbix_get.1*
  492. %{_mandir}/man1/zabbix_sender.1*
  493. %{_mandir}/man8/zabbix_agentd.8*
  494. %endif
  495. %if %{with proxy}
  496. %files proxy-common
  497. %defattr(-,root,root,-)
  498. %dir %{_sysconfdir}/zabbix
  499. %config(noreplace) %{_sysconfdir}/zabbix/zabbix_proxy.conf
  500. %config(noreplace) %{_sysconfdir}/logrotate.d/zabbix_proxy
  501. %if !%{with systemd}
  502. %{_initddir}/zabbix_proxy
  503. %endif
  504. %{_mandir}/man8/zabbix_proxy.8*
  505. %{_datadir}/zabbix-proxy
  506. %files proxy-mysql
  507. %defattr(-,root,root,-)
  508. %{_sbindir}/zabbix_proxy.mysql
  509. %if %{with systemd}
  510. %{_unitdir}/zabbix-proxy-mysql.service
  511. %endif
  512. %files proxy-postgresql
  513. %defattr(-,root,root,-)
  514. %{_sbindir}/zabbix_proxy.pgsql
  515. %if %{with systemd}
  516. %{_unitdir}/zabbix-proxy-pgsql.service
  517. %endif
  518. %endif
  519. %if %{with frontend}
  520. %files frontend-php
  521. %defattr(-,root,root,-)
  522. %license zabbix_mysql/COPYING
  523. %doc zabbix_mysql/AUTHORS zabbix_mysql/ChangeLog zabbix_mysql/NEWS zabbix_mysql/README
  524. %dir %{_datadir}/zabbix-frontend
  525. %{_datadir}/zabbix-frontend/php
  526. %files frontend-php-mysql
  527. %files frontend-php-postgresql
  528. %endif
  529. %changelog
  530. * Fri Jul 15 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.6-1
  531. - new upstream release.
  532. * Sat Jan 22 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.19-1
  533. - new upstream release.
  534. * Tue Oct 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
  535. - new upstream release.
  536. * Tue Aug 31 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.15-1
  537. - new upstream release.
  538. * Fri Mar 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  539. - new upstream release.
  540. * Sun Dec 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.6-1
  541. - new upstream release.
  542. * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
  543. - new upstream release.
  544. * Thu Jul 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
  545. - new upstream release.
  546. - dropped all patches: made to get the same effect by another method.
  547. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-2
  548. - rebuilt with libevent-2.1.11.
  549. * Mon Apr 06 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.19-1
  550. - new upstream release.
  551. - dropped Patch3: fixed in upstream.
  552. - changed R:php5 to R:php74.
  553. - added systemd support (disabled as default).
  554. * Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.15-1
  555. - new upstream release.
  556. - imported Patch13 from upstream to support php74.
  557. * Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-1
  558. - new upstream release.
  559. - updated patches.
  560. * Wed May 08 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  561. - new upstream release.
  562. - switched to 4.0 LTS.
  563. - dropped Patch0: made to get same effect by another method.
  564. - updated Patch1 and 2.
  565. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.23-1
  566. - new upstream release.
  567. * Tue Jun 12 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 3.0.13-2
  568. - accept building only agent
  569. * Thu Dec 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.13-1
  570. - new upstream release.
  571. * Fri Apr 21 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
  572. - new upstream release.
  573. * Fri Mar 18 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
  574. - new upstream release.
  575. - disabled jabber support.
  576. * Wed Sep 9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-1
  577. - new upstream release.
  578. * Sat Apr 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.9-1
  579. - new upstream release.
  580. * Sun Jul 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.4-1
  581. - new upstream release.
  582. - built with both of mysql and postgresql.
  583. * Mon Oct 07 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
  584. - update to 2.0.8
  585. * Wed Feb 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.5-2
  586. - use %%bcond_with mysql to build with mysql
  587. * Tue Feb 19 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.5-1
  588. - update to 2.0.5
  589. - add using MySQL client library switch: default no
  590. - define use_postfix and use_mysql
  591. - add BuildRequires: MySQL-devel
  592. - add configure option: --with-mysql
  593. * Thu Feb 7 2013 IWAI, Masaharu <iwai@alib.jp> 2.0.4-1
  594. - initial build for Vine Linux