openbabel-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273
  1. %define perl_vendorarch %(eval "`perl -V:installvendorarch`"; echo $installvendorarch)
  2. %define perl_archlib %(eval "`perl -V:archlib`"; echo $archlib)
  3. Name: openbabel
  4. Version: 2.3.2
  5. Release: 4%{?_dist_release}
  6. Summary: Chemistry software file format converter
  7. Summary(ja): 化学ソフトデータファイル変換プログラム
  8. License: GPLv2
  9. Group: Applications/Edutainment
  10. URL: http://openbabel.sourceforge.net/
  11. Source: http://dl.sourceforge.net/sourceforge/openbabel/%{name}-%{version}.tar.gz
  12. # fron fedora
  13. Patch0: openbabel-2.3.1-gcc47-darwin.patch
  14. Patch1: openbabel-rpm.patch
  15. Patch2: openbabel-2.3.2-cmake.patch
  16. Patch3: openbabel-2.3.1-ruby19-vendorarch.patch
  17. Patch4: openbabel-2.3.1-ruby22-remove-deprecated-usage.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: inchi-devel
  20. BuildRequires: libtool
  21. BuildRequires: libxml2-devel
  22. BuildRequires: perl
  23. BuildRequires: python
  24. BuildRequires: python-devel
  25. BuildRequires: ruby
  26. BuildRequires: ruby-devel
  27. BuildRequires: swig
  28. BuildRequires: wxGTK-devel
  29. BuildRequires: zlib-devel
  30. BuildRequires: cmake
  31. BuildRequires: eigen2-devel
  32. Distribution: Vine Linux
  33. Vendor: Project Vine
  34. Packager: inagaki
  35. %description
  36. Open Babel is a free, open-source version of the Babel chemistry file
  37. translation program. Open Babel is a project designed to pick up where
  38. Babel left off, as a cross-platform program and library designed to
  39. interconvert between many file formats used in molecular modeling,
  40. computational chemistry, and many related areas.
  41. Open Babel includes two components, a command-line utility and a C++
  42. library. The command-line utility is intended to be used as a replacement
  43. for the original babel program, to translate between various chemical file
  44. formats. The C++ library includes all of the file-translation code as well
  45. as a wide variety of utilities to foster development of other open source
  46. scientific software.
  47. %package devel
  48. Summary: Development tools for programs which will use the Open Babel library
  49. Summary(ja): %{name} の開発用ヘッダファイル
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. Requires: pkgconfig
  53. %description devel
  54. The %{name}-devel package includes the header files and libraries
  55. necessary for developing programs using the Open Babel library.
  56. If you are going to develop programs which will use this library
  57. you should install %{name}-devel. You'll also need to have the
  58. %{name} package installed.
  59. %description devel -l ja
  60. %{name}の開発用ヘッダファイル
  61. %package -n perl-%{name}
  62. Summary: Perl wrapper for the Open Babel library
  63. Summary(ja): Open Babel ライブラリの Perl ラッパー
  64. Group: Development/Libraries
  65. Requires: perl > %(eval "`%{__perl} -V:version`"; echo $version)
  66. Obsoletes: %{name}-perl < 2.2.0
  67. Provides: %{name}-perl = %{version}-%{release}
  68. %description -n perl-%{name}
  69. Perl wrapper for the Open Babel library.
  70. %description -n perl-%{name} -l ja
  71. Open Babel ライブラリの Perl ラッパーです.
  72. %package -n python-%{name}
  73. Group: Development/Libraries
  74. Summary: Python wrapper for the Open Babel library
  75. Summary(ja): Open Babel ライブラリの Python ラッパー
  76. Obsoletes: %{name}-python < 2.2.0
  77. Provides: %{name}-python = %{version}-%{release}
  78. %description -n python-%{name}
  79. Python wrapper for the Open Babel library.
  80. %description -n python-%{name} -l ja
  81. Open Babel ライブラリの Python ラッパー
  82. %package -n ruby-%{name}
  83. Summary: Ruby wrapper for the Open Babel library
  84. Summary(ja): Open Babel ライブラリの Ruby ラッパー
  85. Group: Development/Libraries
  86. Requires: ruby >= 1.8
  87. Requires: %{name} = %{version}-%{release}
  88. %description -n ruby-%{name}
  89. Open Babel ライブラリの Ruby ラッパー
  90. %prep
  91. %setup -q
  92. %patch0 -p1 -b .gcc47
  93. %patch1 -p1 -b .rpm
  94. %patch2 -p1 -b .cmake
  95. %patch3 -p1 -b .ruby_vendor
  96. %patch4 -p1 -b .rbconfig
  97. chmod 644 src/formats/{mmcif,fchk}format.cpp
  98. %build
  99. %cmake \
  100. -DOPENBABEL_USE_SYSTEM_INCHI=true \
  101. -DPYTHON_BINDINGS:BOOL=ON \
  102. -DRUBY_BINDINGS:BOOL=ON \
  103. -DPERL_BINDINGS:BOOL=ON \
  104. .
  105. make %{?_smp_mflags}
  106. %install
  107. rm -rf $RPM_BUILD_ROOT
  108. make install DESTDIR=$RPM_BUILD_ROOT
  109. rm -f $RPM_BUILD_ROOT%{_libdir}{,/%{name}}/*.la
  110. mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
  111. mv $RPM_BUILD_ROOT%{_libdir}/_openbabel.so \
  112. $RPM_BUILD_ROOT%{_libdir}/openbabel.py \
  113. $RPM_BUILD_ROOT%{_libdir}/pybel.py \
  114. $RPM_BUILD_ROOT%{python_sitearch}
  115. rm -rf $RPM_BUILD_ROOT%{_libdir}/cmake/openbabel2
  116. rm -f $RPM_BUILD_ROOT%{_libdir}/perl5/*/*/perllocal.pod
  117. rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/.packlist
  118. rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Chemistry/OpenBabel/OpenBabel.bs
  119. %clean
  120. rm -rf $RPM_BUILD_ROOT
  121. %post -p /sbin/ldconfig
  122. %postun -p /sbin/ldconfig
  123. %files
  124. %defattr(-,root,root,-)
  125. %doc AUTHORS COPYING ChangeLog README THANKS
  126. %doc doc/*.html
  127. #doc doc/README* doc/babel*.inc doc/dioxin.*
  128. %doc doc/README* doc/dioxin.*
  129. %{_bindir}/*
  130. %{_mandir}/man1/*
  131. %{_datadir}/%{name}
  132. %{_libdir}/libopenbabel.so.*
  133. %{_libdir}/%{name}
  134. %files devel
  135. %defattr(-,root,root,-)
  136. %{_includedir}/%{name}-2.0
  137. %{_libdir}/libopenbabel.so
  138. %{_libdir}/pkgconfig/*.pc
  139. %files -n perl-%{name}
  140. %defattr(-,root,root,-)
  141. %{perl_vendorarch}/Chemistry/OpenBabel.pm
  142. %dir %{perl_vendorarch}/*/Chemistry/OpenBabel
  143. %{perl_vendorarch}/*/Chemistry/OpenBabel/OpenBabel.so
  144. %files -n python-%{name}
  145. %defattr(-,root,root,-)
  146. %{python_sitearch}/_openbabel.so
  147. %{python_sitearch}/openbabel.py*
  148. %{python_sitearch}/pybel.py*
  149. %files -n ruby-%{name}
  150. %defattr(-,root,root,-)
  151. %{ruby_vendorarchdir}/openbabel.so
  152. %changelog
  153. * Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-4
  154. - rebuild with ruby-2.2.3
  155. - add Patch4 (openbabel-2.3.1-ruby22-remove-deprecated-usage.patch) from fedora
  156. * Fri Jan 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-3
  157. - add BuildRequires: wxGTK-devel, eigen2-devel
  158. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
  159. - rebuilt with ruby 2.1.5 and perl 5.16.3
  160. * Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.2-1
  161. - new upstream release
  162. - add BuildRequires: cmake
  163. - add Patch0,1,2,3 from fedora
  164. * Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-4
  165. - rebuilt with rpm-4.8.1 for pkg-config
  166. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.2.3-3
  167. - rebuild with python-2.6
  168. * Fri Nov 13 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.3-2
  169. - <BTS:0789> ruby binding install path changed to Config::CONFIG["archdir"]
  170. * Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
  171. - applied new versioning policy, spec in UTF-8
  172. - using system inchi package
  173. - added ruby-%{name} package
  174. * Mon May 14 2007 Susumu Tanimura <arumiant@gmail.com> 2.1.0-0vl1
  175. - Updated to 2.1.0
  176. * Tue May 1 2007 Susumu Tanimura <arumiant@gmail.com> 2.0.2-5vl1
  177. - built for VineLinux
  178. * Tue Oct 03 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-5
  179. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  180. * Wed Sep 20 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-4
  181. - .pyo files no longer ghosted
  182. - fix chicken-and-egg problem when building perl and python bindings
  183. * Tue Aug 29 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-3
  184. - simplified autotools invocation
  185. - mass rebuild
  186. * Mon Aug 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-2
  187. - simplified file lists and permissions
  188. - removed weird character from inchi summary and description
  189. - added missing pkgconfig Req: for -devel
  190. * Sat Aug 05 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.2-1
  191. - updated to 2.0.2
  192. - dropped GCC4 fix (upstream'd)
  193. - split off inchi package
  194. - added python and perl bindings packages
  195. * Sat Jan 07 2006 Dominik Mierzejewski <rpm@greysector.net> 2.0.0-1
  196. - updated to 2.0.0
  197. - fix compilation with GCC4
  198. - FE compliance
  199. * Thu Feb 10 2005 Dominik Mierzejewski <rpm@greysector.net> 1.100.2-1
  200. - rebuilt for Fedora 3
  201. * Tue Jan 18 2005 ALT QA Team Robot <qa-robot@altlinux.org> 1.100.2-alt1.1
  202. - Rebuilt with libstdc++.so.6.
  203. * Wed Mar 03 2004 Michael Shigorin <mike@altlinux.ru> 1.100.2-alt1
  204. - 1.100.2
  205. * Wed Dec 17 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt2
  206. - removed *.la
  207. - don't package static library by default
  208. * Mon Sep 22 2003 Michael Shigorin <mike@altlinux.ru> 1.100.1-alt1
  209. - 1.100.1
  210. - #2994 fixed; thanks to Alex Ott (ott@) for a pointer
  211. - spec cleanup (underlibification fixup)
  212. * Mon Jun 30 2003 Michael Shigorin <mike@altlinux.ru> 1.100.0-alt1
  213. - built for ALT Linux
  214. - based on Mandrake Cooker spec by:
  215. * Lenny Cartier <lenny@mandrakesoft.com>
  216. * Austin Acton <aacton@yorku.ca>
  217. - spec cleanup