ModemManager-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423
  1. %bcond_with systemd
  2. #%define git_snapshot .git20130607
  3. %define git_snapshot %{nil}
  4. #define ppp_version 2.4.7
  5. %define glib2_version 2.40
  6. Name: ModemManager
  7. Summary: Mobile broadband modem management service
  8. Summary(ja): モバイルブロードバンドモデム運用サービス
  9. Version: 1.14.0
  10. Release: 1%{git_snapshot}%{?_dist_release}%{?with_systemd:.systemd}
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: GPLv2+
  14. URL: https://www.freedesktop.org/wiki/Software/ModemManager/
  15. Source: https://www.freedesktop.org/software/%{name}/%{name}-%{version}.tar.xz
  16. Patch0: buildsys-hates-openpty.patch
  17. Patch1: ModemManager-1.8.2-elogind-1.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. BuildRequires: glib2-devel >= %{glib2_version}
  20. BuildRequires: automake autoconf intltool libtool
  21. BuildRequires: gobject-introspection-devel
  22. BuildRequires: vala-devel
  23. BuildRequires: vala-tools
  24. BuildRequires: polkit-devel
  25. BuildRequires: gtk-doc
  26. # for xsltproc
  27. BuildRequires: libxslt
  28. %if %{with systemd}
  29. BuildRequires: systemd-devel
  30. %{?systemd_requires}
  31. %else
  32. BuildRequires: libgudev-devel
  33. BuildRequires: elogind-devel
  34. %endif
  35. Requires: dbus-glib
  36. %description
  37. The ModemManager service manages WWAN modems and provides a consistent API for
  38. interacting with these devices to client applications.
  39. %package devel
  40. Summary: Development tools for %{name}
  41. Summary(ja): %{name} の開発環境
  42. Group: Development/Libraries
  43. Requires: %{name} = %{version}-%{release}
  44. Requires: pkgconfig
  45. %description devel
  46. Header files and libraries for building a extension library for the %{name}.
  47. %package glib
  48. Summary: Libraries for adding ModemManager support to applications that use glib.
  49. Summary(ja): Glib を使用するアプリケーションに ModemManager サポートを追加するためのライブラリ
  50. Group: System Environment/Libraries
  51. Requires: glib2 >= %{glib2_version}
  52. %description glib
  53. This package contains the libraries that make it easier to use some ModemManager
  54. functionality from applications that use glib.
  55. %package glib-devel
  56. Summary: Development tools for %{name}-glib
  57. Summary(ja): %{name}-glib の開発環境
  58. Group: Development/Libraries
  59. Requires: %{name}-glib = %{version}-%{release}
  60. Requires: %{name}-devel = %{version}-%{release}
  61. Requires: glib2-devel
  62. Requires: pkgconfig
  63. %description glib-devel
  64. Header files and libraries for building a extension library for the %{name}-glib.
  65. %prep
  66. %setup -q
  67. %patch0 -p1 -b .pty
  68. %if !%{with systemd}
  69. %patch1 -p1 -b .elogind
  70. %endif
  71. %build
  72. autoreconf -vif
  73. #pppddir=`ls -1d %{_libdir}/pppd/2*`
  74. %configure \
  75. --disable-static \
  76. --enable-gtk-doc=yes \
  77. --enable-vala=yes \
  78. --enable-more-warnings=yes \
  79. --with-udev-base-dir=/lib/udev \
  80. --without-mbim \
  81. --without-qmi \
  82. --with-dist-version=%{version}-%{release} \
  83. %if %{with systemd}
  84. --with-systemdsystemunitdir=%{_unitdir}
  85. %else
  86. --with-elogind-suspend-resume=yes
  87. %endif
  88. make %{?_smp_mflags}
  89. %check
  90. make check
  91. %install
  92. make install DESTDIR=$RPM_BUILD_ROOT
  93. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  94. #rm -f $RPM_BUILD_ROOT%{_libdir}/pppd/2.*/*.so
  95. %find_lang %{name}
  96. %post
  97. /sbin/ldconfig
  98. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  99. %if %{with systemd}
  100. %systemd_post ModemManager.service
  101. %endif
  102. %if %{with systemd}
  103. %preun
  104. %systemd_preun ModemManager.service
  105. %endif
  106. %postun
  107. /sbin/ldconfig
  108. if [ $1 -eq 0 ]; then
  109. touch --no-create %{_datadir}/icons/hicolor >&/dev/null || :
  110. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  111. fi
  112. %if %{with systemd}
  113. %systemd_postun ModemManager.service
  114. %endif
  115. %posttrans
  116. gtk-update-icon-cache %{_datadir}/icons/hicolor >&/dev/null || :
  117. %post glib -p /sbin/ldconfig
  118. %postun glib -p /sbin/ldconfig
  119. %files -f %{name}.lang
  120. %defattr(-,root, root,-)
  121. %license COPYING
  122. %doc README
  123. %{_sysconfdir}/dbus-1/system.d/org.freedesktop.ModemManager1.conf
  124. %{_libdir}/girepository-1.0/ModemManager-1.0.typelib
  125. %{_datadir}/dbus-1/system-services/org.freedesktop.ModemManager1.service
  126. %attr(0755,root,root) %{_sbindir}/ModemManager
  127. %attr(0755,root,root) %{_bindir}/mmcli
  128. %dir %{_libdir}/%{name}
  129. %attr(0755,root,root) %{_libdir}/%{name}/*.so*
  130. %dir %{_datadir}/%{name}
  131. %{_datadir}/%{name}/*
  132. /lib/udev/rules.d/*
  133. %{_datadir}/dbus-1/interfaces/*.xml
  134. %{_datadir}/icons/hicolor/22x22/apps/*.png
  135. %{_datadir}/polkit-1/actions/org.freedesktop.ModemManager1.policy
  136. %{_mandir}/man1/*
  137. %{_mandir}/man8/*
  138. %dir %{_datadir}/bash-completion
  139. %dir %{_datadir}/bash-completion/completions
  140. %{_datadir}/bash-completion/completions/*
  141. %if %{with systemd}
  142. %{_unitdir}/*.service
  143. %endif
  144. %files devel
  145. %defattr(-,root,root,-)
  146. %{_includedir}/ModemManager/*.h
  147. %dir %{_datadir}/gtk-doc/html/%{name}
  148. %{_datadir}/gir-1.0/ModemManager-1.0.gir
  149. %{_datadir}/gtk-doc/html/%{name}/*
  150. %{_libdir}/pkgconfig/%{name}.pc
  151. %files glib
  152. %defattr(-,root,root,-)
  153. %{_libdir}/libmm-glib.so.*
  154. %files glib-devel
  155. %defattr(-,root,root,-)
  156. %{_libdir}/libmm-glib.so
  157. %dir %{_includedir}/libmm-glib
  158. %{_includedir}/libmm-glib/*.h
  159. %{_libdir}/pkgconfig/mm-glib.pc
  160. %dir %{_datadir}/vala
  161. %dir %{_datadir}/vala/vapi
  162. %{_datadir}/vala/vapi/libmm-glib.*
  163. %dir %{_datadir}/gtk-doc/html/libmm-glib
  164. %{_datadir}/gtk-doc/html/libmm-glib/*
  165. %changelog
  166. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.4-1
  167. - new upstream release.
  168. * Mon Dec 17 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
  169. - new upstream release.
  170. - added elogind support.
  171. * Sat Mar 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.12-1
  172. - new upstream release.
  173. * Sun Apr 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
  174. - new upstream release
  175. - change BuildRequires: libgudev-devel instead of eudev-libgudev1-devel
  176. * Sun Feb 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-3
  177. - fix spec file
  178. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-2
  179. - fix spec file
  180. * Fri Oct 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.12-1
  181. - new upstream release
  182. - add BuildRequires: gobject-introspection-devel, polkit-devel
  183. * Sun Jul 26 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.10-1
  184. - new upstream release
  185. * Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
  186. - new upstream release
  187. * Mon Apr 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6-1
  188. - new upstream release
  189. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.2-1
  190. - new upstream release
  191. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  192. - new upstream release
  193. * Tue Oct 7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.2.0-2
  194. - moved ModemManager-glib to System Environment/Libraries Group
  195. - removed BR: ppp, ppp-devel and dbus-glib-devel
  196. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
  197. - new upstream release
  198. - remove Patch1 (ModemManager-1.0.0-git20130911.patch)
  199. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  200. - add Patch1 (ModemManager-1.0.0-git20130911.patch)
  201. * Tue Aug 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  202. - new upstream release
  203. - update Patch0
  204. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.991-1.git20130607
  205. - update to 0.7.991 snapshot
  206. - fix spec file based on FC package
  207. * Fri Jun 7 2013 Dan Williams <dcbw@redhat.com> - 0.7.991-1.git20130607
  208. - Update to 0.7.991 snapshot
  209. - Fix SMS validity parsing
  210. - Allow registration changes to 'searching' without disconnecting
  211. - Fix reading SMS messages from some QMI-based devices
  212. - Increase connection timeout for Novatel E362
  213. - Fix PIN retries checking when unlocking Ericsson devices
  214. - Better handling of supported and preferred modes (eg 2G, 3G, 4G preference)
  215. - add configure option (--enable-gtk-doc=yes, --without-qmi)
  216. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.2.0-1
  217. - new upstream release
  218. * Tue Aug 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  219. - new upstream release
  220. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.998-1
  221. - delete Patch20
  222. * Wed May 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-2
  223. - update Patch20 (ModemManager-0.4-git20110428.patch)
  224. - delete Patch21,22
  225. * Sat Jan 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4-1
  226. - update to 0.4
  227. - add Patch20 (ModemManager-0.4-git20100720.patch)
  228. - add Patch21 (ModemManager-0.4-glib2-2.25.12.patch)
  229. - add Patch22 (ModemManager-0.4-dbus-glib-property-access-bug.patch)
  230. * Fri May 07 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3-1.git20100502
  231. - initial build for Vine Linux
  232. * Sun May 2 2010 Dan Williams <dcbw@redhat.com> - 0.3-11.git20100502
  233. - core: ignore some failures on disconnect (rh #578280)
  234. - core: add support for platform serial devices
  235. - gsm: better Blackberry DUN support
  236. - gsm: periodically poll access technology
  237. - cdma: prevent crash on modem removal (rh #571921)
  238. - mbm: add support for Sony Ericsson MD400, Dell 5541, and Dell 5542 modems
  239. - novatel: better signal strength reporting on CDMA cards
  240. - novatel: add access technology and mode preference support on GSM cards
  241. - zte: fix mode preference retrieval
  242. - longcheer: add support for Zoom modems (4595, 4596, etc)
  243. - longcheer: add access technology and mode preference support
  244. * Fri Apr 30 2010 Matthias Clasen <mclasen@redhat.com> - 0.3-10.git20100409
  245. - Silence %%post
  246. - Update scripts
  247. * Fri Apr 9 2010 Dan Williams <dcbw@redhat.com> - 0.3-9.git20100409
  248. - gsm: fix parsing Blackberry supported character sets response
  249. * Thu Apr 8 2010 Dan Williams <dcbw@redhat.com> - 0.3-8.git20100408
  250. - mbm: fix retrieval of current allowed mode
  251. - gsm: fix initialization issues with some devices (like Blackberries)
  252. * Mon Apr 5 2010 Dan Williams <dcbw@redhat.com> - 0.3-7.git20100405
  253. - core: fix detection of some generic devices (rh #579247)
  254. - core: fix detection regression of some Huawei devices in 0.3-5
  255. - cdma: periodically poll registration state and signal quality
  256. - cdma: really fix registration detection on various devices (rh #569067)
  257. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-6.git20100331
  258. - core: fix PPC/SPARC/etc builds
  259. * Wed Mar 31 2010 Dan Williams <dcbw@redhat.com> - 0.3-5.git20100331
  260. - core: only export a modem when all its ports are handled (rh #540438, rh #569067, rh #552121)
  261. - cdma: handle signal quality requests while connected for more devices
  262. - cdma: handle serving system requests while connected for more devices
  263. - gsm: determine current access technology earlier
  264. - huawei: work around automatic registration issues on some devices
  265. * Tue Mar 23 2010 Dan Williams <dcbw@redhat.com> - 0.3-4.git20100323
  266. - core: ensure enabled modems are disabled when MM stops
  267. - core: better capability detection for Blackberry devices (rh #573510)
  268. - cdma: better checking of registration states (rh #540438, rh #569067, rh #552121)
  269. - gsm: don't block modem when it requires PIN2
  270. - option: fix access technology updates
  271. * Wed Mar 17 2010 Dan Williams <dcbw@redhat.com> - 0.3-3.git20100317
  272. - mbm: add device IDs for C3607w
  273. - mbm: fail earlier during connection failures
  274. - mbm: fix username/password authentication when checked by the network
  275. - hso: implement asynchronous signal quality updates
  276. - option: implement asynchronous signal quality updates
  277. - novatel: correctly handle CDMA signal quality
  278. - core: basic PolicyKit support
  279. - core: fix direct GSM registration information requests
  280. - core: general GSM PIN/PUK unlock fixes
  281. - core: poll GSM registration state internally for quicker status updates
  282. - core: implement GSM 2G/3G preference
  283. - core: implement GSM roaming allowed/disallowed preference
  284. - core: emit signals on access technology changes
  285. - core: better handling of disconnections
  286. - core: fix simple CDMA status requests
  287. * Thu Feb 11 2010 Dan Williams <dcbw@redhat.com> - 0.3-2.git20100211
  288. - core: startup speed improvements
  289. - core: GSM PIN checking improvements
  290. - huawei: fix EVDO-only connections on various devices (rh #553199)
  291. - longcheer: add support for more devices
  292. * Tue Jan 19 2010 Dan Williams <dcbw@redhat.com> - 0.3-1.git20100119
  293. - anydata: new plugin for AnyData CDMA modems (rh #547294)
  294. - core: fix crashes when devices are unplugged during operation (rh #553953)
  295. - cdma: prefer primary port for status/registration queries
  296. - core: fix probing/detection of some PIN-locked devices (rh #551376)
  297. - longcheer: add plugin for Alcatel (X020, X030, etc) and other devices
  298. - gsm: fix Nokia N80 network scan parsing
  299. * Fri Jan 1 2010 Dan Williams <dcbw@redhat.com> - 0.2.997-5.git20100101
  300. - core: fix apparent hangs by limiting retried serial writes
  301. - gsm: ensure modem state is reset when disabled
  302. * Fri Dec 18 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-4.git20091218
  303. - sierra: fix CDMA registration detection in some cases (rh #547513)
  304. * Wed Dec 16 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-3.git20091216
  305. - sierra: ensure CDMA device is powered up when trying to use it
  306. - cdma: better signal quality parsing (fixes ex Huawei EC168C)
  307. - zte: handle unsolicited messages better during probing
  308. * Mon Dec 14 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-2.git20091214
  309. - cdma: fix signal strength reporting on some devices
  310. - cdma: better registration state detection when dialing (ex Sierra 5275)
  311. - option: always use the correct tty for dialing commands
  312. * Mon Dec 7 2009 Dan Williams <dcbw@redhat.com> - 0.2.997-1
  313. - core: fix reconnect after manual disconnect (rh #541314)
  314. - core: fix various segfaults during registration
  315. - core: fix probing of various modems on big-endian architectures (ie PPC)
  316. - core: implement modem states to avoid duplicate operations
  317. - hso: fix authentication for Icera-based devices like iCON 505
  318. - zte: use correct port for new devices
  319. - nozomi: fix detection
  320. * Thu Nov 5 2009 Dan Williams <dcbw@redhat.com> - 0.2-4.20091105
  321. - Update to latest git
  322. - core: fix pppd 2.4.5 errors about 'baudrate 0'
  323. - cdma: wait for network registration before trying to connect
  324. - gsm: add cell access technology reporting
  325. - gsm: allow longer-running network scans
  326. - mbm: various fixes for Ericsson F3507g/F3607gw/Dell 5530
  327. - nokia: don't power down phones on disconnect
  328. - hso: fix disconnection/disable
  329. * Wed Aug 26 2009 Dan Williams <dcbw@redhat.com> - 0.2-3.20090826
  330. - Fixes for Motorola and Ericsson devices
  331. - Fixes for CDMA "serving-system" command parsing
  332. * Fri Jul 31 2009 Matthias Clasen <mclasen@redhat.com>
  333. - Fix a typo in one of the udev rules files
  334. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2.20090707
  335. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  336. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-1.20090707
  337. - Fix source repo location
  338. - Fix directory ownership
  339. * Tue Jul 7 2009 Dan Williams <dcbw@redhat.com> - 0.2-0.20090707
  340. - Initial version