colord-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351
  1. %bcond_with systemd
  2. %bcond_with firstbuild
  3. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  4. Summary: Color daemon
  5. Name: colord
  6. Version: 1.4.4
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2+ and LGPLv2+
  11. URL: http://gitorious.org/colord
  12. Source0: https://www.freedesktop.org/software/%{name}/releases/%{name}-%{version}.tar.xz
  13. Patch0: colord-1.4.3-elogind.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: meson
  16. BuildRequires: dbus-devel
  17. BuildRequires: docbook-utils
  18. BuildRequires: docbook5-style-xsl
  19. BuildRequires: gettext
  20. BuildRequires: glib2-devel
  21. BuildRequires: intltool
  22. BuildRequires: lcms2-devel
  23. BuildRequires: libgudev1-devel
  24. BuildRequires: libgusb-devel
  25. BuildRequires: polkit-devel
  26. BuildRequires: sqlite3-devel
  27. BuildRequires: vala-tools
  28. BuildRequires: bash-completion
  29. %{!?with_firstbuild:BuildRequires: colord-devel, gobject-introspection-devel}
  30. %if %{with systemd}
  31. BuildRequires: systemd-devel
  32. %{?systemd_requires}
  33. %else
  34. BuildRequires: libudev-devel
  35. BuildRequires: elogind-devel
  36. %endif
  37. Requires: shared-color-profiles
  38. %description
  39. colord is a low level system activated daemon that maps color devices
  40. to color profiles in the system context.
  41. %package devel
  42. Summary: Development package for %{name}
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. Requires: glib2-devel
  46. Requires: dbus-devel
  47. Requires: lcms2-devel
  48. %description devel
  49. Files for development with %{name}.
  50. # compat32
  51. %package -n compat32-%{name}
  52. Summary: Color daemon
  53. Group: System Environment/Daemons
  54. Requires: %{name} = %{version}-%{release}
  55. %description -n compat32-%{name}
  56. colord is a low level system activated daemon that maps color devices
  57. to color profiles in the system context.
  58. %package -n compat32-%{name}-devel
  59. Summary: Development package for %{name}
  60. Group: Development/Libraries
  61. Requires: compat32-%{name} = %{version}-%{release}
  62. %description -n compat32-%{name}-devel
  63. Files for development with %{name}.
  64. %prep
  65. %setup
  66. %if !%{with systemd}
  67. %patch0 -p1
  68. %endif
  69. %build
  70. %meson \
  71. -Ddaemon_user=colord \
  72. %if %{with systemd}
  73. -Dsystemd=true \
  74. %else
  75. -Dsystemd=false \
  76. -Delogind=true \
  77. %endif
  78. -Dargyllcms_sensor=false \
  79. -Dvapi=true \
  80. -Ddocs=false
  81. %meson_build
  82. %install
  83. rm -rf %{buildroot}
  84. %meson_install
  85. # databases
  86. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/mapping.db
  87. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/colord/storage.db
  88. %find_lang %{name}
  89. %triggerin -- colord < 1.4.4
  90. if [ -d %{_localstatedir}/lib/colord ]; then
  91. chown -R colord:colord %{_localstatedir}/lib/colord
  92. fi
  93. %pre
  94. getent group colord >/dev/null || groupadd -r colord
  95. getent passwd colord >/dev/null || \
  96. useradd -r -g colord -d /var/lib/colord -s /sbin/nologin \
  97. -c "User for colord" colord
  98. exit 0
  99. %post
  100. /sbin/ldconfig
  101. %if %{with systemd}
  102. %systemd_post colord.service
  103. %endif
  104. %if %{with systemd}
  105. %preun
  106. %systemd_preun colord.service
  107. %endif
  108. %postun
  109. /sbin/ldconfig
  110. if [ $1 -eq 0 ]; then
  111. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  112. fi
  113. %if %{with systemd}
  114. %systemd_postun colord.service
  115. %endif
  116. %posttrans
  117. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  118. %post -n compat32-%{name} -p /sbin/ldconfig
  119. %postun -n compat32-%{name} -p /sbin/ldconfig
  120. %files -f %{name}.lang
  121. %defattr(-,root,root,-)
  122. %license COPYING
  123. %doc AUTHORS NEWS README.md
  124. %{_libexecdir}/colord
  125. %{_libexecdir}/colord-session
  126. %attr(755,colord,colord) %dir %{_localstatedir}/lib/colord
  127. %attr(755,colord,colord) %dir %{_localstatedir}/lib/colord/icc
  128. %{_bindir}/*
  129. %{_datadir}/dbus-1/system.d/org.freedesktop.ColorManager.conf
  130. %dir %{_datadir}/bash-completion
  131. %dir %{_datadir}/bash-completion/completions
  132. %{_datadir}/bash-completion/completions/colormgr
  133. %{_datadir}/color
  134. %{_datadir}/colord
  135. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorHelper.xml
  136. %{_datadir}/dbus-1/interfaces/org.freedesktop.ColorManager*.xml
  137. %{_datadir}/dbus-1/services/org.freedesktop.ColorHelper.service
  138. %{_datadir}/dbus-1/system-services/org.freedesktop.ColorManager.service
  139. %{_datadir}/glib-2.0/schemas/org.freedesktop.ColorHelper.gschema.xml
  140. %{_datadir}/polkit-1/actions/org.freedesktop.color.policy
  141. %{_datadir}/man/man1/*.1.gz
  142. %{_libdir}/libcolord.so.*
  143. %{_libdir}/libcolordprivate.so.*
  144. %{_libdir}/libcolorhug.so.*
  145. %{_libdir}/colord-plugins/libcolord_sensor_camera.so
  146. %{_libdir}/colord-plugins/libcolord_sensor_scanner.so
  147. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Colord-1.0.typelib}
  148. %{!?with_firstbuild:%{_libdir}/girepository-1.0/Colorhug-1.0.typelib}
  149. /lib/udev/rules.d/*.rules
  150. %{_libdir}/colord-sensors
  151. %ghost %{_localstatedir}/lib/colord/*.db
  152. %if %{with systemd}
  153. %{_unitdir}/*.service
  154. %{_userunitdir}/*.service
  155. %{_tmpfilesdir}/colord.conf
  156. %endif
  157. %files devel
  158. %defattr(-,root,root,-)
  159. %{_includedir}/colord-1
  160. %{_libdir}/libcolord.so
  161. %{_libdir}/libcolordprivate.so
  162. %{_libdir}/libcolorhug.so
  163. %{_libdir}/pkgconfig/colord.pc
  164. %{_libdir}/pkgconfig/colorhug.pc
  165. %{!?with_firstbuild:%{_datadir}/gir-1.0/Colord-1.0.gir}
  166. %{!?with_firstbuild:%{_datadir}/gir-1.0/Colorhug-1.0.gir}
  167. %dir %{_datadir}/vala
  168. %dir %{_datadir}/vala/vapi
  169. %{_datadir}/vala/vapi/*
  170. # compat32
  171. %if %{build_compat32}
  172. %files -n compat32-%{name}
  173. %defattr(-,root,root,-)
  174. %{_libdir}/libcolord.so.*
  175. %{_libdir}/libcolordprivate.so.*
  176. %{_libdir}/libcolorhug.so.*
  177. %files -n compat32-%{name}-devel
  178. %defattr(-,root,root,-)
  179. %{_libdir}/libcolord.so
  180. %{_libdir}/libcolordprivate.so
  181. %{_libdir}/libcolorhug.so
  182. %endif
  183. %changelog
  184. * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.4-1
  185. - new upstream release.
  186. - added systemd support (disabled as default).
  187. - changed daemon-user to "colord".
  188. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
  189. - new upstream release.
  190. * Fri Dec 12 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.8-2
  191. - added libcolordprivate and libcolorhug to compat32-* subpackages
  192. * Mon Nov 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.8-1
  193. - new upstream release
  194. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.7-1
  195. - update to 1.1.7
  196. * Sat Jun 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-1
  197. - new upstream release
  198. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-1
  199. - new upstream release
  200. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.5-1
  201. - new upstream release
  202. * Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  203. - new upstream release
  204. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  205. - new upstream release
  206. - add BuildRequires: bash-completion
  207. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.33-1
  208. - new upstream release
  209. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.26-1
  210. - new upstream release
  211. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.24-1
  212. - new upstream release
  213. - remove BuildRequires: sane-devel
  214. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.23-1
  215. - new upstream release
  216. - change BuildRequires: libgusb-devel instead of libusb1-devel
  217. - add BuildRequires: gobject-introspection-devel
  218. * Tue Jun 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.21-1
  219. - new upstream release
  220. * Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.19-1
  221. - new upstream release
  222. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.18-1
  223. - new upstream release
  224. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.15-1
  225. - new upstream release
  226. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.14-1
  227. - new upstream release
  228. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.13-1
  229. - new upstream release
  230. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.12-1
  231. - new upstream release
  232. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.11-1
  233. - new upstream release
  234. - create compat32 sub packages
  235. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.1.10-1
  236. - initial build for Vine Linux
  237. * Wed Jul 06 2011 Richard Hughes <richard@hughsie.com> 0.1.10-1
  238. - New upstream version
  239. * Mon Jun 13 2011 Richard Hughes <richard@hughsie.com> 0.1.9-1
  240. - New upstream version
  241. * Thu Jun 02 2011 Richard Hughes <richard@hughsie.com> 0.1.8-1
  242. - New upstream version
  243. - Add a webcam device kind
  244. - Add a timestamp when making profiles default
  245. - Add support for reading and writing ICC profile metadata
  246. - Allow the client to pass file descriptors out of band to CreateProfile
  247. - Prettify the device vendor and model names
  248. - Split out the sensors into runtime-loadable shared objects
  249. - Provide some GIO async variants for the methods in CdClient
  250. - Ensure GPhoto2 devices get added to the device list
  251. * Fri May 06 2011 Richard Hughes <richard@hughsie.com> 0.1.7-1
  252. - New upstream version.
  253. - Create /var/lib/colord at buildtime not runtime for SELinux
  254. - Ensure profiles with embedded profile checksums are parsed correctly
  255. - Move the colorimeter rules to be run before 70-acl.rules
  256. - Stop watching the client when the sensor is finalized
  257. - Ensure the source is destroyed when we unref CdUsb to prevent a crash
  258. - Only enable the volume mount tracking when searching volumes
  259. * Tue Apr 26 2011 Richard Hughes <rhughes@redhat.com> 0.1.6-2
  260. - Own /var/lib/colord and /var/lib/colord/*.db
  261. * Sun Apr 24 2011 Richard Hughes <richard@hughsie.com> 0.1.6-1
  262. - New upstream version.
  263. * Thu Mar 31 2011 Richard Hughes <richard@hughsie.com> 0.1.5-1
  264. - New upstream version.
  265. * Wed Mar 09 2011 Richard Hughes <richard@hughsie.com> 0.1.4-1
  266. - New upstream version.
  267. * Mon Feb 28 2011 Richard Hughes <richard@hughsie.com> 0.1.3-1
  268. - New upstream version.
  269. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-3
  270. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  271. * Fri Jan 28 2011 Richard Hughes <richard@hughsie.com> 0.1.1-2
  272. - Rebuild in the vain hope koji isn't broken today.
  273. * Wed Jan 26 2011 Richard Hughes <richard@hughsie.com> 0.1.1-1
  274. - New upstream version.
  275. * Thu Jan 13 2011 Richard Hughes <richard@hughsie.com> 0.1.0-1
  276. - Initial version for Fedora package review.