gjs-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193
  1. %define mozjs mozjs68
  2. Summary: Javascript binding for GNOME
  3. Summary(ja): GNOME 向け JavaScript バインディング
  4. Name: gjs
  5. Version: 1.64.4
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. License: MPL1.1/LGPLv2+/GPLv2+
  12. URL: https://wiki.gnome.org/Projects/GnomeShell
  13. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  14. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  15. BuildRequires: meson
  16. BuildRequires: pkgconfig >= 0.14.0
  17. BuildRequires: glib2-devel
  18. BuildRequires: dbus-glib-devel
  19. BuildRequires: gobject-introspection-devel >= 1.29.16
  20. BuildRequires: cairo-devel
  21. BuildRequires: %{mozjs}-devel
  22. BuildRequires: readline-devel
  23. BuildRequires: yelp-tools
  24. BuildRequires: desktop-file-utils
  25. BuildRequires: gnome-common
  26. %description
  27. GNOME Shell is the defining technology of the GNOME 3 desktop user experience. It provides core interface functions like switching to windows and launching applications. GNOME Shell takes advantage of the capabilities of modern graphics hardware and introduces innovative user interface concepts to provide a delightful and easy to use experience.
  28. %package devel
  29. Summary: Development files of the gjs library.
  30. Summary(ja): gjs ライブラリの開発用ファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Requires: pkgconfig
  34. Requires: gtk-doc
  35. Requires: %{mozjs}-devel
  36. %description devel
  37. Development files of the gjs library.
  38. %prep
  39. %setup -q
  40. %build
  41. %meson \
  42. -Dprofiler=disabled \
  43. -Dinstalled_tests=false \
  44. -Dskip_dbus_tests=true \
  45. -Dskip_gtk_tests=true
  46. %meson_build
  47. %install
  48. %{__rm} -rf %{buildroot}
  49. %meson_install
  50. #check
  51. #{__make} %{?_smp_mflags} check
  52. %clean
  53. %{__rm} -rf %{buildroot}
  54. %post -p /sbin/ldconfig
  55. %postun -p /sbin/ldconfig
  56. %files
  57. %defattr(-,root,root)
  58. %license COPYING
  59. %doc ChangeLog NEWS README
  60. %{_bindir}/gjs*
  61. %{_libdir}/lib*.so.*
  62. %{_libdir}/gjs/*
  63. %files devel
  64. %defattr(-,root,root,-)
  65. %{_includedir}/gjs-1.0
  66. %{_libdir}/lib*.so
  67. %{_libdir}/pkgconfig/*.pc
  68. %dir %{_datadir}/gjs-1.0
  69. %dir %{_datadir}/gjs-1.0/lsan
  70. %{_datadir}/gjs-1.0/lsan/lsan.supp
  71. %dir %{_datadir}/gjs-1.0/valgrind
  72. %{_datadir}/gjs-1.0/valgrind/gjs.supp
  73. %changelog
  74. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.64.4-1
  75. - new upstream release.
  76. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.54.3-2
  77. - rebuilt with libffi-3.3.
  78. * Tue Mar 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.54.3-1
  79. - new upstream release.
  80. - dropped Patch0: fixed in upstream.
  81. * Sun Dec 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.53.4-2
  82. - added Patch0.
  83. - added "R:mozjs52-devel" to gjs-devel.
  84. * Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.53.4-1
  85. - new upstream release.
  86. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.44.0-2
  87. - rebuild with gcc-5.4.0
  88. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.44.0-1
  89. - new upstream release
  90. * Mon Mar 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.43.3-1
  91. - new upstream release
  92. * Thu Jan 1 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.42.0-2
  93. - moved to System Environment/Libraries Group
  94. - added Japanese summary
  95. - changed BR: automake instead of automake112
  96. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.42.0-1
  97. - new upstream release
  98. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.40.1-2
  99. - rebuild with libffi-3.0.13
  100. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.40.1-1
  101. - new upstream release
  102. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.40.0-1
  103. - new upstream release
  104. - change BuildRequires: mozjs24-devel instead of mozjs17-devel
  105. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.38.1-2
  106. - rebuild with VineSeed environment
  107. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.38.1-1
  108. - new upstream release
  109. - change BuildRequires: mozjs17-devel instead of js-devel
  110. - add BuildRequires: autoconf, automake112
  111. * Wed Apr 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.1-1
  112. - new upstream release
  113. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.0-1
  114. - new upstream release
  115. - change BuildRequires: yelp-tools instead of gnome-doc-utils
  116. * Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.0-1
  117. - new upstream release
  118. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
  119. - new upstream release
  120. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.18-1
  121. - new upstream release
  122. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.17-1
  123. - new upstream release
  124. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.15-1
  125. - new upstream release
  126. - change BuildRequires: js-devel instead of xulrunner-devel
  127. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.13-1
  128. - new upstream release
  129. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.7-1
  130. - new upstream release
  131. * Thu Oct 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.4-1
  132. - new upstream release
  133. - remove BuildRequires: mutter-devel
  134. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6-2
  135. - rebuild with rpm-4.8.1 for pkg-config file
  136. * Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6-1
  137. - new upstream release
  138. - fix typo
  139. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5-1
  140. - initial build for Vine Linux