gnome-software-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779
  1. %global glib2_version 2.56.0
  2. %global gtk3_version 3.22.4
  3. %global json_glib_version 1.2.0
  4. %global packagekit_version 1.1.1
  5. %global appstream_glib_version 0.7.14-3
  6. %global libsoup_version 2.52.0
  7. %global gsettings_desktop_schemas_version 3.12.0
  8. %global gnome_desktop_version 3.18.0
  9. %global fwupd_version 1.0.7
  10. %global flatpak_version 0.9.4
  11. Summary: A software center for GNOME
  12. Name: gnome-software
  13. Version: 3.36.1
  14. Release: 1%{?_dist_release}
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. License: GPLv2+
  18. URL: https://wiki.gnome.org/Apps/Software
  19. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  20. Source0: https://download.gnome.org/sources/gnome-software/%{shortver}/%{name}-%{version}.tar.xz
  21. # /usr/share/pixmaps/backgrounds/Vine/vinelinux7-7-1920x1200.jpg from vine-backgrounds
  22. Source1: vine.jpg
  23. BuildRequires: gcc
  24. BuildRequires: gettext
  25. BuildRequires: libxslt
  26. BuildRequires: docbook-style-xsl
  27. BuildRequires: desktop-file-utils
  28. #BuildRequires: fwupd-devel >= %{fwupd_version}
  29. BuildRequires: glib2-devel >= %{glib2_version}
  30. BuildRequires: gnome-desktop3-devel
  31. BuildRequires: gnome-online-accounts-devel
  32. BuildRequires: gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_version}
  33. BuildRequires: gspell-devel
  34. BuildRequires: gtk3-devel >= %{gtk3_version}
  35. BuildRequires: gtk-doc
  36. BuildRequires: json-glib-devel >= %{json_glib_version}
  37. BuildRequires: libappstream-glib-devel >= %{appstream_glib_version}
  38. BuildRequires: libsoup-devel
  39. BuildRequires: libxmlb-devel
  40. BuildRequires: meson
  41. BuildRequires: PackageKit-devel >= %{packagekit_version}
  42. BuildRequires: polkit-devel
  43. BuildRequires: libsecret-devel
  44. BuildRequires: flatpak-devel >= %{flatpak_version}
  45. BuildRequires: ostree-devel
  46. #BuildRequires: rpm-ostree-devel
  47. BuildRequires: libgudev-devel
  48. #BuildRequires: valgrind-devel
  49. #Requires: appstream-data
  50. Requires: flatpak%{?_isa} >= %{flatpak_version}
  51. Requires: flatpak-libs%{?_isa} >= %{flatpak_version}
  52. #Requires: fwupd%{?_isa} >= %{fwupd_version}
  53. Requires: glib2%{?_isa} >= %{glib2_version}
  54. Requires: gnome-desktop3%{?_isa} >= %{gnome_desktop_version}
  55. # gnome-menus is needed for app folder .directory entries
  56. Requires: gnome-menus%{?_isa}
  57. Requires: gsettings-desktop-schemas%{?_isa} >= %{gsettings_desktop_schemas_version}
  58. Requires: gtk3%{?_isa} >= %{gtk3_version}
  59. Requires: json-glib%{?_isa} >= %{json_glib_version}
  60. Requires: iso-codes
  61. Requires: libappstream-glib%{?_isa} >= %{appstream_glib_version}
  62. # librsvg2 is needed for gdk-pixbuf svg loader
  63. Requires: librsvg2%{?_isa}
  64. Requires: libsoup%{?_isa} >= %{libsoup_version}
  65. Requires: PackageKit%{?_isa} >= %{packagekit_version}
  66. # this is not a library version
  67. %define gs_plugin_version 13
  68. %description
  69. gnome-software is an application that makes it easy to add, remove
  70. and update software in the GNOME desktop.
  71. %package devel
  72. Summary: Headers for building external gnome-software plugins
  73. Requires: %{name}%{?_isa} = %{version}-%{release}
  74. %description devel
  75. These development files are for building gnome-software plugins outside
  76. the source tree. Most users do not need this subpackage installed.
  77. %prep
  78. %autosetup -p1
  79. %build
  80. %meson \
  81. -Dsnap=false \
  82. -Dgudev=true \
  83. -Dpackagekit=true \
  84. -Dexternal_appstream=true \
  85. %if 0
  86. -Drpm_ostree=true \
  87. %else
  88. -Drpm_ostree=false \
  89. %endif
  90. -Dmalcontent=false \
  91. -Dtests=false \
  92. -Dubuntuone=false \
  93. -Dubuntu_reviews=false \
  94. -Dfwupd=false \
  95. -Dvalgrind=false
  96. %meson_build
  97. %install
  98. %meson_install
  99. # make the software center load faster
  100. desktop-file-edit %{buildroot}%{_datadir}/applications/org.gnome.Software.desktop \
  101. --set-key=X-AppInstall-Package --set-value=%{name}
  102. %if 0
  103. # set up for Fedora
  104. cat >> %{buildroot}%{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override << FOE
  105. [org.gnome.software]
  106. official-repos = [ 'fedora', 'fedora-debuginfo', 'fedora-source', 'koji-override-0', 'koji-override-1', 'rawhide', 'rawhide-debuginfo', 'rawhide-source', 'updates', 'updates-debuginfo', 'updates-source', 'updates-testing', 'updates-testing-debuginfo', 'updates-testing-source', 'fedora-modular', 'fedora-modular-debuginfo', 'fedora-modular-source', 'rawhide-modular', 'rawhide-modular-debuginfo', 'rawhide-modular-source' ]
  107. FOE
  108. %endif
  109. # Install upgrade background image
  110. mkdir -p %{buildroot}%{_datadir}/gnome-software/backgrounds
  111. cp -a %{SOURCE1} %{buildroot}%{_datadir}/gnome-software/backgrounds/
  112. rm -rf %{buildroot}%{_docdir}/gnome-software
  113. %find_lang %name --with-gnome
  114. %check
  115. desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
  116. %post
  117. if [ $1 -eq 1 ]; then
  118. glib-compile-schemas /usr/share/glib-2.0/schemas ||:
  119. update-desktop-database -q > /dev/null || :
  120. fi
  121. %postun
  122. if [ $1 -eq 0 ]; then
  123. glib-compile-schemas /usr/share/glib-2.0/schemas ||:
  124. update-desktop-database -q > /dev/null || :
  125. fi
  126. %files -f %{name}.lang
  127. %doc AUTHORS README.md
  128. %license COPYING
  129. %{_bindir}/gnome-software
  130. %{_datadir}/applications/gnome-software-local-file.desktop
  131. %{_datadir}/applications/org.gnome.Software.desktop
  132. %{_mandir}/man1/gnome-software.1.gz
  133. %{_datadir}/icons/hicolor/*/apps/*
  134. %{_datadir}/icons/hicolor/scalable/status/software-installed-symbolic.svg
  135. %dir %{_datadir}/gnome-software
  136. %{_datadir}/gnome-software/*.png
  137. %{_datadir}/gnome-software/backgrounds/
  138. %{_datadir}/gnome-software/featured-*.svg
  139. %{_datadir}/gnome-software/featured-*.jpg
  140. %{_datadir}/metainfo/org.gnome.Software.appdata.xml
  141. %{_datadir}/metainfo/org.gnome.Software.Plugin.Flatpak.metainfo.xml
  142. %if 0
  143. %{_datadir}/metainfo/org.gnome.Software.Plugin.Fwupd.metainfo.xml
  144. %endif
  145. %{_datadir}/metainfo/org.gnome.Software.Plugin.Odrs.metainfo.xml
  146. %{_datadir}/polkit-1/actions/org.gnome.software.external-appstream.policy
  147. %dir %{_libdir}/gs-plugins-%{gs_plugin_version}
  148. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_appstream.so
  149. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_desktop-categories.so
  150. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_desktop-menu-path.so
  151. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_dpkg.so
  152. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_dummy.so
  153. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fedora-pkgdb-collections.so
  154. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_flatpak.so
  155. %if 0
  156. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fwupd.so
  157. %endif
  158. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_external-appstream.so
  159. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fedora-langpacks.so
  160. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_generic-updates.so
  161. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_hardcoded-blacklist.so
  162. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_hardcoded-popular.so
  163. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_icons.so
  164. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_key-colors-metadata.so
  165. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_key-colors.so
  166. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_modalias.so
  167. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_odrs.so
  168. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_os-release.so
  169. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-history.so
  170. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-local.so
  171. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-offline.so
  172. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-proxy.so
  173. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refine-repos.so
  174. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refine.so
  175. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refresh.so
  176. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-upgrade.so
  177. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-url-to-app.so
  178. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit.so
  179. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_provenance-license.so
  180. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_provenance.so
  181. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_repos.so
  182. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_rewrite-resource.so
  183. %if 0
  184. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_rpm-ostree.so
  185. %endif
  186. %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_systemd-updates.so
  187. %{_sysconfdir}/xdg/autostart/gnome-software-service.desktop
  188. %{_datadir}/app-info/xmls/org.gnome.Software.Featured.xml
  189. %{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service
  190. %{_datadir}/dbus-1/services/org.gnome.Software.service
  191. %{_datadir}/gnome-shell/search-providers/org.gnome.Software-search-provider.ini
  192. %{_datadir}/glib-2.0/schemas/org.gnome.software.gschema.xml
  193. %if 0
  194. %{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override
  195. %endif
  196. %{_libexecdir}/gnome-software-cmd
  197. %{_libexecdir}/gnome-software-install-appstream
  198. %{_libexecdir}/gnome-software-restarter
  199. %files devel
  200. %{_libdir}/pkgconfig/gnome-software.pc
  201. %dir %{_includedir}/gnome-software
  202. %{_includedir}/gnome-software/*.h
  203. %{_datadir}/gtk-doc/html/gnome-software
  204. %changelog
  205. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.36.1-1
  206. - new upstream release.
  207. * Mon Sep 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.30.6-5
  208. - initial build for Vine Linux.
  209. * Tue May 07 2019 Kalev Lember <klember@redhat.com> - 3.30.6-4
  210. - Fix distro upgrade progress bar to actually work
  211. * Sun Apr 28 2019 Kalev Lember <klember@redhat.com> - 3.30.6-3
  212. - Add artwork for F30 upgrades
  213. * Mon Feb 25 2019 Kalev Lember <klember@redhat.com> - 3.30.6-2
  214. - Backport various fixes to error messages to avoid the dreaded
  215. "Unable to update '(null)'" error
  216. * Tue Dec 18 2018 Kalev Lember <klember@redhat.com> - 3.30.6-1
  217. - Update to 3.30.6
  218. * Wed Oct 24 2018 Kalev Lember <klember@redhat.com> - 3.30.5-1
  219. - Update to 3.30.5
  220. * Thu Oct 18 2018 Kalev Lember <klember@redhat.com> - 3.30.3-1
  221. - Update to 3.30.3
  222. * Fri Oct 05 2018 Kalev Lember <klember@redhat.com> - 3.30.2-1
  223. - Update to 3.30.2
  224. * Wed Sep 26 2018 Kalev Lember <klember@redhat.com> - 3.30.1-2
  225. - Add modular repos to official repos list
  226. * Tue Sep 25 2018 Kalev Lember <klember@redhat.com> - 3.30.1-1
  227. - Update to 3.30.1
  228. * Thu Sep 06 2018 Kalev Lember <klember@redhat.com> - 3.30.0-1
  229. - Update to 3.30.0
  230. * Tue Aug 28 2018 Richard Hughes <rhughes@redhat.com> - 3.29.92-1
  231. - Update to 3.29.92
  232. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.29.1-2
  233. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  234. * Wed May 09 2018 Kalev Lember <klember@redhat.com> - 3.29.1-1
  235. - Update to 3.29.1
  236. * Mon Apr 09 2018 Kalev Lember <klember@redhat.com> - 3.28.1-1
  237. - Update to 3.28.1
  238. * Thu Mar 29 2018 Kalev Lember <klember@redhat.com> - 3.28.0-5
  239. - Fix empty OS Updates showing up
  240. - Make rpm-ostree update triggering work
  241. * Thu Mar 15 2018 Kalev Lember <klember@redhat.com> - 3.28.0-4
  242. - Fix opening results from gnome-shell search provider
  243. * Wed Mar 14 2018 Kalev Lember <klember@redhat.com> - 3.28.0-3
  244. - Fix crash on initial run with no network (#1554986)
  245. * Tue Mar 13 2018 Kalev Lember <klember@redhat.com> - 3.28.0-2
  246. - Backport an upstream patch to fix shell extensions app ID
  247. * Mon Mar 12 2018 Kalev Lember <klember@redhat.com> - 3.28.0-1
  248. - Update to 3.28.0
  249. * Sun Mar 11 2018 Kalev Lember <klember@redhat.com> - 3.27.92-3
  250. - Rebuilt for gspell 1.8
  251. * Wed Mar 07 2018 Kalev Lember <klember@redhat.com> - 3.27.92-2
  252. - Move org.gnome.Software.Featured.xml from -editor to main package
  253. * Mon Mar 05 2018 Kalev Lember <klember@redhat.com> - 3.27.92-1
  254. - Update to 3.27.92
  255. * Sun Mar 04 2018 Neal Gompa <ngompa13@gmail.com> - 3.27.90-4
  256. - Drop obsolete snapd-login-service requirement for snap plugin subpackage
  257. * Mon Feb 19 2018 Adam Williamson <awilliam@redhat.com> - 3.27.90-3
  258. - Backport fix for RHBZ #1546893 from upstream git
  259. * Mon Feb 19 2018 Kalev Lember <klember@redhat.com> - 3.27.90-2
  260. - Re-enable rpm-ostree plugin
  261. * Thu Feb 15 2018 Kalev Lember <klember@redhat.com> - 3.27.90-1
  262. - Update to 3.27.90
  263. - Temporarily disable the rpm-ostree plugin
  264. * Tue Feb 13 2018 Björn Esser <besser82@fedoraproject.org> - 3.27.4-4
  265. - Rebuild against newer gnome-desktop3 package
  266. * Thu Feb 08 2018 Kalev Lember <klember@redhat.com> - 3.27.4-3
  267. - Add fedora-workstation-repositories to nonfree-sources schema defaults
  268. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.27.4-2
  269. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  270. * Mon Jan 08 2018 Kalev Lember <klember@redhat.com> - 3.27.4-1
  271. - Update to 3.27.4
  272. - Drop unused --without packagekit option
  273. * Fri Jan 05 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.27.3-2
  274. - Remove obsolete scriptlets
  275. * Sat Dec 16 2017 Kalev Lember <klember@redhat.com> - 3.27.3-1
  276. - Update to 3.27.3
  277. * Mon Nov 13 2017 Kalev Lember <klember@redhat.com> - 3.27.2-1
  278. - Update to 3.27.2
  279. * Thu Nov 09 2017 Kalev Lember <klember@redhat.com> - 3.26.2-1
  280. - Update to 3.26.2
  281. - Re-enable fwupd support
  282. * Tue Oct 31 2017 Kalev Lember <klember@redhat.com> - 3.26.1-5
  283. - Enable the rpm-ostree plugin
  284. * Wed Oct 25 2017 Kalev Lember <klember@redhat.com> - 3.26.1-4
  285. - Fix "too many results returned" error after distro upgrades (#1496489)
  286. * Tue Oct 10 2017 Kalev Lember <klember@redhat.com> - 3.26.1-3
  287. - Backport a flatpakref installation fix
  288. * Mon Oct 09 2017 Richard Hughes <rhughes@redhat.com> - 3.26.1-2
  289. - Disable fwupd support until we get a 3.27.1 tarball
  290. * Sun Oct 08 2017 Kalev Lember <klember@redhat.com> - 3.26.1-1
  291. - Update to 3.26.1
  292. * Mon Sep 11 2017 Kalev Lember <klember@redhat.com> - 3.26.0-1
  293. - Update to 3.26.0
  294. * Sun Aug 27 2017 Kalev Lember <klember@redhat.com> - 3.25.91-1
  295. - Update to 3.25.91
  296. * Tue Aug 15 2017 Kalev Lember <klember@redhat.com> - 3.25.90-1
  297. - Update to 3.25.90
  298. * Fri Aug 11 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-6
  299. - Rebuilt after RPM update (№ 3)
  300. * Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-5
  301. - Rebuilt for RPM soname bump
  302. * Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-4
  303. - Rebuilt for RPM soname bump
  304. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.4-3
  305. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  306. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.4-2
  307. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  308. * Fri Jul 21 2017 Kalev Lember <klember@redhat.com> - 3.25.4-1
  309. - Update to 3.25.4
  310. * Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 3.25.3-6
  311. - Drop a meson workaround now that meson is fixed
  312. * Wed Jun 28 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-5
  313. - Actually properly enable snap subpackage after removing conditional
  314. * Wed Jun 28 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-4
  315. - Remove unnecessary arch-specific conditional for snap subpackage
  316. * Tue Jun 27 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-3
  317. - Ensure snap subpackage is installed if snapd is installed
  318. * Fri Jun 23 2017 Richard Hughes <rhughes@redhat.com> - 3.24.3-2
  319. - Enable the snap subpackage
  320. * Fri Jun 23 2017 Kalev Lember <klember@redhat.com> - 3.25.3-1
  321. - Update to 3.25.3
  322. - Switch to the meson build system
  323. - Add an -editor subpackage with new banner editor
  324. * Mon May 15 2017 Richard Hughes <rhughes@redhat.com> - 3.24.3-1
  325. - Update to 3.23.3
  326. - Fix a common crash when installing flatpakrepo files
  327. - Ensure we show the banner when upgrades are available
  328. * Tue May 09 2017 Kalev Lember <klember@redhat.com> - 3.24.2-1
  329. - Update to 3.24.2
  330. * Tue Apr 25 2017 Adam Williamson <awilliam@redhat.com> - 3.24.1-2
  331. - Backport crasher fix from upstream (RHBZ #1444669 / BGO #781217)
  332. * Tue Apr 11 2017 Kalev Lember <klember@redhat.com> - 3.24.1-1
  333. - Update to 3.24.1
  334. * Tue Mar 21 2017 Kalev Lember <klember@redhat.com> - 3.24.0-1
  335. - Update to 3.24.0
  336. * Thu Mar 16 2017 Kalev Lember <klember@redhat.com> - 3.23.92-1
  337. - Update to 3.23.92
  338. * Mon Feb 27 2017 Richard Hughes <rhughes@redhat.com> - 3.23.91-1
  339. - Update to 3.23.91
  340. * Mon Feb 13 2017 Richard Hughes <rhughes@redhat.com> - 3.23.90-1
  341. - Update to 3.23.90
  342. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.23.3-2
  343. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  344. * Thu Dec 15 2016 Richard Hughes <rhughes@redhat.com> - 3.23.3-1
  345. - Update to 3.23.3
  346. * Wed Nov 23 2016 Kalev Lember <klember@redhat.com> - 3.23.2-1
  347. - Update to 3.23.2
  348. * Tue Nov 08 2016 Kalev Lember <klember@redhat.com> - 3.22.2-1
  349. - Update to 3.22.2
  350. * Wed Oct 12 2016 Kalev Lember <klember@redhat.com> - 3.22.1-1
  351. - Update to 3.22.1
  352. * Mon Sep 19 2016 Kalev Lember <klember@redhat.com> - 3.22.0-1
  353. - Update to 3.22.0
  354. * Wed Sep 14 2016 Kalev Lember <klember@redhat.com> - 3.21.92-1
  355. - Update to 3.21.92
  356. - Don't set group tags
  357. * Thu Sep 01 2016 Kalev Lember <klember@redhat.com> - 3.21.91-1
  358. - Update to 3.21.91
  359. * Wed Aug 17 2016 Kalev Lember <klember@redhat.com> - 3.21.90-2
  360. - Rebuilt for fixed libappstream-glib headers
  361. * Wed Aug 17 2016 Kalev Lember <klember@redhat.com> - 3.21.90-1
  362. - Update to 3.21.90
  363. - Tighten -devel subpackage dependencies
  364. * Thu Jul 28 2016 Richard Hughes <rhughes@redhat.com> - 3.21.4-2
  365. - Allow building without PackageKit for the atomic workstation.
  366. * Mon Jul 18 2016 Richard Hughes <rhughes@redhat.com> - 3.21.4-1
  367. - Update to 3.21.4
  368. * Thu May 26 2016 Kalev Lember <klember@redhat.com> - 3.21.2-2
  369. - Build with flatpak support
  370. * Mon May 23 2016 Richard Hughes <rhughes@redhat.com> - 3.21.2-1
  371. - Update to 3.21.2
  372. * Tue May 10 2016 Kalev Lember <klember@redhat.com> - 3.21.1-2
  373. - Require PackageKit 1.1.1 for system upgrade support
  374. * Mon Apr 25 2016 Richard Hughes <rhughes@redhat.com> - 3.21.1-1
  375. - Update to 3.21.1
  376. * Mon Apr 25 2016 Richard Hughes <rhughes@redhat.com> - 3.20.2-1
  377. - Update to 3.20.1
  378. - Allow popular and featured apps to match any plugin
  379. - Do not make the ODRS plugin depend on xdg-app
  380. - Fix many of the os-upgrade issues and implement the latest mockups
  381. - Make all the plugins more threadsafe
  382. - Return all update descriptions newer than the installed version
  383. - Show some non-fatal error messages if installing fails
  384. - Use a background PackageKit transaction when downloading upgrades
  385. * Wed Apr 13 2016 Kalev Lember <klember@redhat.com> - 3.20.1-1
  386. - Update to 3.20.1
  387. * Fri Apr 01 2016 Richard Hughes <rhughes@redhat.com> - 3.20.1-2
  388. - Set the list of official sources
  389. - Compile with xdg-app support
  390. * Tue Mar 22 2016 Kalev Lember <klember@redhat.com> - 3.20.0-1
  391. - Update to 3.20.0
  392. * Mon Mar 14 2016 Richard Hughes <rhughes@redhat.com> - 3.19.92-1
  393. - Update to 3.19.92
  394. * Thu Mar 03 2016 Kalev Lember <klember@redhat.com> - 3.19.91-2
  395. - Set minimum required json-glib version
  396. * Mon Feb 29 2016 Richard Hughes <rhughes@redhat.com> - 3.19.91-1
  397. - Update to 3.19.91
  398. * Mon Feb 15 2016 Richard Hughes <rhughes@redhat.com> - 3.19.90-1
  399. - Update to 3.19.90
  400. * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.19.4-2
  401. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  402. * Fri Jan 15 2016 Richard Hughes <rhughes@redhat.com> - 3.19.4-1
  403. - Update to 3.19.4
  404. * Thu Dec 03 2015 Kalev Lember <klember@redhat.com> - 3.18.3-2
  405. - Require librsvg2 for the gdk-pixbuf svg loader
  406. * Thu Nov 05 2015 Richard Hughes <rhughes@redhat.com> - 3.18.3-1
  407. - Update to 3.18.3
  408. - Use the correct user agent string when downloading firmware
  409. - Fix a crash in the limba plugin
  410. - Fix installing web applications
  411. * Mon Oct 26 2015 Kalev Lember <klember@redhat.com> - 3.18.2-2
  412. - Fix apps reappearing as installed a few seconds after removal (#1275163)
  413. * Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 3.18.2-1
  414. - Update to 3.18.2
  415. * Tue Oct 13 2015 Kalev Lember <klember@redhat.com> - 3.18.1-1
  416. - Update to 3.18.1
  417. * Wed Oct 07 2015 Kalev Lember <klember@redhat.com> - 3.18.0-2
  418. - Backport two crasher fixes from upstream
  419. * Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 3.18.0-1
  420. - Update to 3.18.0
  421. * Tue Sep 15 2015 Kalev Lember <klember@redhat.com> - 3.17.92-2
  422. - Update dependency versions
  423. * Tue Sep 15 2015 Richard Hughes <rhughes@redhat.com> - 3.17.92-1
  424. - Update to 3.17.92
  425. * Thu Sep 10 2015 Richard Hughes <rhughes@redhat.com> - 3.17.91-2
  426. - Fix firmware updates
  427. * Thu Sep 03 2015 Kalev Lember <klember@redhat.com> - 3.17.91-1
  428. - Update to 3.17.91
  429. * Wed Aug 19 2015 Kalev Lember <klember@redhat.com> - 3.17.90-1
  430. - Update to 3.17.90
  431. * Wed Aug 12 2015 Richard Hughes <rhughes@redhat.com> - 3.17.3-1
  432. - Update to 3.17.3
  433. * Wed Jul 22 2015 David King <amigadave@amigadave.com> - 3.17.2-3
  434. - Bump for new gnome-desktop3
  435. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.17.2-2
  436. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  437. * Fri Jun 05 2015 Kalev Lember <kalevlember@gmail.com> - 3.17.2-1
  438. - Update to 3.17.2
  439. * Mon May 25 2015 Kalev Lember <kalevlember@gmail.com> - 3.17.1-1
  440. - Update to 3.17.1
  441. * Fri May 15 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-2
  442. - Fix a crash under Wayland (#1221968)
  443. * Mon May 11 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-1
  444. - Update to 3.16.2
  445. * Tue Apr 14 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.1-1
  446. - Update to 3.16.1
  447. * Mon Mar 23 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.0-1
  448. - Update to 3.16.0
  449. * Mon Mar 16 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.92-1
  450. - Update to 3.15.92
  451. - Use license macro for the COPYING file
  452. - Add a patch to adapt to gnome-terminal desktop file rename
  453. * Mon Mar 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.91-1
  454. - Update to 3.15.91
  455. * Sat Feb 21 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.90-3
  456. - Export DisplayName property on the packagekit session service
  457. * Thu Feb 19 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.90-2
  458. - Backport a crash fix
  459. * Tue Feb 17 2015 Richard Hughes <rhughes@redhat.com> - 3.15.90-1
  460. - Update to 3.15.90
  461. * Mon Jan 19 2015 Richard Hughes <rhughes@redhat.com> - 3.15.4-1
  462. - Update to 3.15.4
  463. * Tue Nov 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.15.2-1
  464. - Update to 3.15.2
  465. * Thu Nov 13 2014 Richard Hughes <rhughes@redhat.com> - 3.14.2-3
  466. - Fix non-Fedora build
  467. * Tue Nov 11 2014 Richard Hughes <rhughes@redhat.com> - 3.14.2-2
  468. - Backport a patch to fix compilation
  469. * Mon Nov 10 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.2-1
  470. - Update to 3.14.2
  471. * Sat Nov 08 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-3
  472. - Update the list of system apps
  473. * Sat Nov 01 2014 David King <amigadave@amigadave.com> - 3.14.1-2
  474. - Rebuild for new libappstream-glib (#1156494)
  475. * Mon Oct 13 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-1
  476. - Update to 3.14.1
  477. * Thu Oct 09 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-2
  478. - Depend on gnome-menus for app folder directory entries
  479. * Mon Sep 22 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-1
  480. - Update to 3.14.0
  481. * Wed Sep 17 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.92-2
  482. - Set minimum required dependency versions (#1136343)
  483. * Tue Sep 16 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.92-1
  484. - Update to 3.13.92
  485. - Replace gnome-system-log with gnome-logs in the system apps list
  486. * Tue Sep 02 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.91-1
  487. - Update to 3.13.91
  488. * Tue Aug 19 2014 Richard Hughes <rhughes@redhat.com> - 3.13.90-1
  489. - Update to 3.13.90
  490. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.13.5-0.2.git5c89189
  491. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  492. * Mon Aug 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.5-0.1.git5c89189
  493. - Update to 3.13.5 git snapshot
  494. - Ship HighContrast icons
  495. * Sun Aug 03 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-2
  496. - Replace Epiphany with Firefox in the system apps list
  497. * Wed Jul 23 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-1
  498. - Update to 3.13.4
  499. * Wed Jun 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.3-1
  500. - Update to 3.13.3
  501. * Thu Jun 12 2014 Richard Hughes <rhughes@redhat.com> - 3.13.3-0.2.git7491627
  502. - Depend on the newly-created appstream-data package and stop shipping
  503. the metadata here.
  504. * Sat Jun 07 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.3-0.1.git7491627
  505. - Update to 3.13.3 git snapshot
  506. * Wed May 28 2014 Richard Hughes <rhughes@redhat.com> - 3.13.2-2
  507. - Rebuild with new metadata.
  508. * Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.2-1
  509. - Update to 3.13.2
  510. * Thu May 15 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.1-4
  511. - Depend on gsettings-desktop-schemas
  512. * Mon May 12 2014 Richard Hughes <rhughes@redhat.com> - 3.13.1-3
  513. - Update the metadata and use appstream-util to install the metadata.
  514. * Wed May 07 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.1-2
  515. - Drop gnome-icon-theme dependency
  516. * Mon Apr 28 2014 Richard Hughes <rhughes@redhat.com> - 3.13.1-1
  517. - Update to 3.13.1
  518. * Fri Apr 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.12.1-2
  519. - Rebuild with new metadata.
  520. * Fri Apr 11 2014 Richard Hughes <rhughes@redhat.com> - 3.12.1-1
  521. - Update to 3.12.1
  522. * Mon Mar 24 2014 Richard Hughes <rhughes@redhat.com> - 3.12.0-1
  523. - Update to 3.12.0
  524. * Thu Mar 20 2014 Richard Hughes <rhughes@redhat.com> - 3.11.92-1
  525. - Update to 3.11.92
  526. * Tue Mar 18 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-2
  527. - Rebuild with new metadata.
  528. * Sat Mar 08 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-1
  529. - Update to 3.11.91
  530. * Tue Feb 18 2014 Richard Hughes <rhughes@redhat.com> - 3.11.90-1
  531. - Update to 3.11.90
  532. * Mon Feb 03 2014 Richard Hughes <rhughes@redhat.com> - 3.11.5-2
  533. - Require epiphany-runtime rather than the full application
  534. * Mon Feb 03 2014 Richard Hughes <rhughes@redhat.com> - 3.11.5-1
  535. - Update to 3.11.5
  536. * Thu Jan 30 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-3
  537. - Rebuild for libpackagekit-glib soname bump
  538. * Wed Jan 22 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-2
  539. - Rebuild with metadata that has the correct screenshot url.
  540. * Thu Jan 16 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-1
  541. - Update to 3.11.4
  542. * Tue Dec 17 2013 Richard Hughes <rhughes@redhat.com> - 3.11.3-1
  543. - Update to 3.11.3
  544. * Tue Nov 19 2013 Richard Hughes <rhughes@redhat.com> - 3.11.2-1
  545. - Update to 3.11.2
  546. * Tue Oct 29 2013 Richard Hughes <rhughes@redhat.com> - 3.11.1-1
  547. - Update to 3.11.1
  548. - Add a gnome shell search provider
  549. - Add a module to submit the user rating to the fedora-tagger web service
  550. - Add support for 'missing' codecs that we know exist but we can't install
  551. - Add support for epiphany web applications
  552. - Handle offline installation sensibly
  553. - Save the user rating if the user clicks the rating stars
  554. - Show a modal error message if install or remove actions failed
  555. - Show a star rating on the application details page
  556. - Show font screenshots
  557. - Show more detailed version numbers when required
  558. - Show screenshots to each application
  559. * Wed Sep 25 2013 Richard Hughes <richard@hughsie.com> 3.10.0-1
  560. - New upstream release.
  561. - New metadata for fedora, updates and updates-testing
  562. - Add a plugin to query the PackageKit prepared-update file directly
  563. - Do not clear the offline-update trigger if rebooting succeeded
  564. - Do not load incompatible projects when parsing AppStream data
  565. - Lots of updated translations
  566. - Show the window right away when starting
  567. * Fri Sep 13 2013 Richard Hughes <richard@hughsie.com> 3.9.3-1
  568. - New upstream release.
  569. - Lots of new and fixed UI and updated metadata for Fedora 20
  570. * Tue Sep 03 2013 Richard Hughes <richard@hughsie.com> 3.9.2-1
  571. - New upstream release.
  572. - Allow stock items in the AppStream XML
  573. - Extract the AppStream URL and description from the XML
  574. - Only present the window when the overview is complete
  575. - Return the subcategories sorted by name
  576. * Mon Sep 02 2013 Richard Hughes <richard@hughsie.com> 3.9.1-1
  577. - New upstream release which is a technical preview for the alpha.
  578. * Sun Sep 01 2013 Richard Hughes <richard@hughsie.com> 0.1-3
  579. - Use buildroot not RPM_BUILD_ROOT
  580. - Own all gnome-software directories
  581. - Drop gtk-update-icon-cache requires and the mime database functionality
  582. * Thu Aug 29 2013 Richard Hughes <richard@hughsie.com> 0.1-2
  583. - Add call to desktop-file-validate and fix other review comments.
  584. * Wed Aug 28 2013 Richard Hughes <richard@hughsie.com> 0.1-1
  585. - First release for Fedora package review