libical-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249
  1. %define _unpackaged_files_terminate_build 1
  2. Name: libical
  3. Summary: An Open Source implementation of the iCalendar protocols and protocol data units
  4. Version: 3.0.8
  5. Release: 2%{?_dist_release}
  6. Group: System Environment/Libraries
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Packager: babasaki, daisuke, inagaki
  10. License: LGPLv2 or MPLv1.1
  11. URL: https://libical.github.io/libical/
  12. Source0: https://github.com/libical/libical/releases/download/v%{version}/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: cmake
  15. BuildRequires: libxml2-devel
  16. BuildRequires: glib2-devel
  17. BuildRequires: gobject-introspection-devel
  18. BuildRequires: vala-tools
  19. Requires: tzdata
  20. #----------------------------------------------------------------------------
  21. %description
  22. Reference implementation of the iCalendar data type and serialization format
  23. used in dozens of calendaring and scheduling products.
  24. %description -l pl
  25. Implementacja formatu iCalendar, używana w wielu kalendarzach i
  26. planerach/planistach.
  27. #----------------------------------------------------------------------------
  28. %package devel
  29. Summary: Development files for libical
  30. Summary(ja): libical の開発用ファイル
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. The libical-devel package contains libraries and header files for developing
  35. applications that use libical.
  36. %description devel -l pl
  37. libical-devel zawiera biblioteki i pliki niezbędne do tworzenia aplikacji
  38. korzystających z libical.
  39. #----------------------------------------------------------------------------
  40. %package glib
  41. Summary: libical with glib
  42. Group: System Environment/Libraries
  43. %description glib
  44. this package contains a library to use libical with glib.
  45. #----------------------------------------------------------------------------
  46. %package glib-devel
  47. Summary: Development files for libical-glib
  48. Summary(ja): libical-glib の開発用ファイル
  49. Group: Development/Libraries
  50. Requires: %{name}-devel = %{version}-%{release}
  51. Requires: %{name}-glib = %{version}-%{release}
  52. %description glib-devel
  53. The libical-glib-devel package contains libraries and header files for
  54. developing applications that use libical-glib.
  55. #----------------------------------------------------------------------------
  56. %prep
  57. %setup -q
  58. %build
  59. mkdir -p %{_target_platform}
  60. pushd %{_target_platform}
  61. %cmake \
  62. -DCMAKE_BUILD_TYPE=release \
  63. -DGOBJECT_INTROSPECTION=true \
  64. -DICAL_GLIB=true \
  65. -DICAL_GLIB_VAPI=true \
  66. -DENABLE_GTK_DOC=OFF \
  67. ..
  68. popd
  69. make %{?_smp_mflags} -C %{_target_platform}
  70. %check
  71. # make check
  72. # Fails on x86_64 and ppc64.
  73. #----------------------------------------------------------------------------
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  77. #make install INSTALL="%{__install} -p" DESTDIR=$RPM_BUILD_ROOT
  78. #find $RPM_BUILD_ROOT -type f -name "*.la" -delete
  79. rm -f %{buildroot}%{_libdir}/*.a
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. #----------------------------------------------------------------------------
  83. %post -p /sbin/ldconfig
  84. %postun -p /sbin/ldconfig
  85. %files
  86. %defattr(-,root,root,-)
  87. %license COPYING LICENSE*
  88. %doc AUTHORS ReadMe.* ReleaseNotes.txt THANKS TODO
  89. %{_libdir}/%{name}.so.*
  90. %{_libdir}/%{name}_cxx.so.*
  91. %{_libdir}/libicalss.so.*
  92. %{_libdir}/libicalss_cxx.so.*
  93. %{_libdir}/libicalvcal.so.*
  94. %{_libdir}/girepository-1.0/ICal-*.typelib
  95. %files devel
  96. %defattr(-,root,root,-)
  97. %doc doc/UsingLibical.txt
  98. %dir %{_includedir}/%{name}
  99. %{_includedir}/%{name}/*.h
  100. %{_libdir}/%{name}.so
  101. %{_libdir}/libical_cxx.so
  102. %{_libdir}/libicalss.so
  103. %{_libdir}/libicalss_cxx.so
  104. %{_libdir}/libicalvcal.so
  105. %dir %{_libdir}/cmake/LibIcal
  106. %{_libdir}/cmake/LibIcal/*.cmake
  107. %{_libdir}/pkgconfig/libical.pc
  108. %{_datadir}/gir-1.0/ICal-*.gir
  109. %files glib
  110. %defattr(-,root,root,-)
  111. %{_libdir}/%{name}-glib.so.*
  112. %{_libdir}/girepository-1.0/ICalGLib-*.typelib
  113. %files glib-devel
  114. %defattr(-,root,root,-)
  115. %doc doc/UsingLibical.txt
  116. %dir %{_includedir}/%{name}-glib
  117. %{_includedir}/%{name}-glib/*.h
  118. %{_libdir}/%{name}-glib.so
  119. %{_libdir}/pkgconfig/libical-glib.pc
  120. %{_datadir}/gir-1.0/ICalGLib-*.gir
  121. %dir %{_datadir}/vala
  122. %dir %{_datadir}/vala/vapi
  123. %{_datadir}/vala/vapi/*
  124. %changelog
  125. * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-2
  126. - added vala support.
  127. * Fri May 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
  128. - new upstream release.
  129. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.5-1
  130. - updated to 3.0.5.
  131. * Fri Jan 26 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
  132. - updated to 3.0.1.
  133. - added subpackages for glib.
  134. * Mon Feb 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.1-1
  135. - updated to 1.0.1
  136. - updated URL
  137. - added BR: cmake
  138. * Sun Sep 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48-1
  139. - update to 0.48
  140. - remove old patches
  141. * Sat Apr 2 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1
  142. - new upstream release
  143. - added Patch0-2 from Fedora
  144. * Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.44-2
  145. - rebuild with rpm-4.8.1 for pkg-config file
  146. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.44-1
  147. - new upstream release
  148. - drop Patch0
  149. * Fri May 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.43-2
  150. - remove comment line after %%postun
  151. - add Vendor/Distribution/Packager tags
  152. * Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.43-1
  153. - new upstream release
  154. - add pkgconfig file to -devel subpackage.
  155. - move libicalvcal headers to /usr/include/libical (patch1,2)
  156. - add patch0 to fix implicit pointer conversion from Debian. Fixes Debian BTS
  157. bug #511598.
  158. * Mon Oct 27 2008 Seiichirou Babasaki - 0.32-2
  159. - Import libical - Packager: Babasaki
  160. - Updated specfile
  161. * Wed Sep 03 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.32-1
  162. - Version bump to 0.32.
  163. - Parallel build problems fixed.
  164. * Sun Jul 27 2008 Jeff Perry <jeffperry_fedora@sourcesink.com> - 0.31-3
  165. - Added 'BuildRequires: bison byacc flex'.
  166. * Sun Jul 27 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.31-2
  167. - Fixed linkage problems and disabled parallel build till upstream accepts fix.
  168. * Thu Jul 17 2008 Jeff Perry <jeffperry_fedora@sourcesink.com> - 0.31-1
  169. - Version bump to 0.31.
  170. * Thu Jul 17 2008 Debarshi Ray <rishi@fedoraproject.org> - 0.30-4
  171. - Changed value of License according to Fedora licensing guidelines.
  172. - Enabled reentrant system calls and C++ bindings.
  173. - Omitted unused direct shared library dependencies.
  174. - Added ChangeLog, COPYING, LICENSE, NEWS and README to doc and dropped
  175. examples.
  176. * Wed Apr 02 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.30-3
  177. - Source URL... Fixed
  178. * Wed Apr 02 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.30-2
  179. - Removed untrue note about libical's homepage (to get rid of eventuall mess)
  180. * Sat Feb 23 2008 David Nielsen <gnomeuser@gmail.com> - 0.30-1
  181. - Switch to freeassociation libical
  182. - bump to 0.30
  183. * Sat Feb 09 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-5
  184. - Mass rebuild for new GCC... Done
  185. * Sat Jan 19 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-4
  186. - Licence... Fixed
  187. * Fri Jan 18 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-3
  188. - Files section... Fixed
  189. * Thu Jan 17 2008 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-2
  190. - Source... Changed
  191. - Debug information in libical main package... Excluded
  192. - Non-numbered .so files in libical main package... Moved
  193. - libical-devel documentation... Added
  194. * Mon Dec 24 2007 Jakub 'Livio' Rusinek <jakub.rusinek@gmail.com> - 0.27-1
  195. - Initial release