vala-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444
  1. %global api_ver 0.48
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A modern programming language for GNOME
  4. Summary(ja): GNOME 用のモダンなプログラミング言語
  5. Name: vala
  6. Version: 0.48.8
  7. Release: 1%{?_dist_release}
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
  11. License: LGPLv2+ and BSD
  12. URL: https://wiki.gnome.org/Projects/Vala
  13. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  14. Source0: https://download.gnome.org/sources/vala/%{shortver}/vala-%{version}.tar.xz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: glib2-devel
  17. BuildRequires: gobject-introspection-devel
  18. BuildRequires: flex
  19. BuildRequires: bison
  20. BuildRequires: libxslt
  21. BuildRequires: graphviz-devel
  22. %description
  23. Vala is a new programming language that aims to bring modern programming
  24. language features to GNOME developers without imposing any additional
  25. runtime requirements and without using a different ABI compared to
  26. applications and libraries written in C.
  27. valac, the Vala compiler, is a self-hosting compiler that translates
  28. Vala source code into C source and header files. It uses the GObject
  29. type system to create classes and interfaces declared in the Vala source
  30. code. It's also planned to generate GIDL files when gobject-
  31. introspection is ready.
  32. The syntax of Vala is similar to C#, modified to better fit the GObject
  33. type system.
  34. %package devel
  35. Summary: Development files for %{name}
  36. Summary(ja): %{name} の開発用ファイル
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. Requires: pkgconfig
  40. %description devel
  41. Vala is a new programming language that aims to bring modern programming
  42. language features to GNOME developers without imposing any additional
  43. runtime requirements and without using a different ABI compared to
  44. applications and libraries written in C.
  45. This package contains development files for %{name}. This is not necessary for
  46. using the %{name} compiler.
  47. %package tools
  48. Summary: Tools for creating projects and bindings for %{name}
  49. Summary(ja): %{name} のプロジェクト作成やバインディングのためのツール集
  50. Group: Development/Tools
  51. License: LGPLv2+
  52. Requires: %{name} = %{version}-%{release}
  53. Requires: gnome-common intltool libtool
  54. Provides: %{name}-vapigen = %{version}-%{release}
  55. Obsoletes: %{name}-vapigen < %{version}-%{release}
  56. %description tools
  57. Vala is a new programming language that aims to bring modern programming
  58. language features to GNOME developers without imposing any additional
  59. runtime requirements and without using a different ABI compared to
  60. applications and libraries written in C.
  61. This package contains tools to generate Vala projects, as well as API bindings
  62. from existing C libraries, allowing access from Vala programs.
  63. %package doc
  64. Summary: Documentation for %{name}
  65. Summary(ja): %{name} のドキュメント
  66. Group: Documentation
  67. License: LGPLv2+
  68. BuildArch: noarch
  69. Requires: %{name} = %{version}-%{release}
  70. Requires: devhelp
  71. Provides: %{name}-docs = %{version}-%{release}
  72. Obsoletes: %{name}-docs < %{version}-%{release}
  73. %description doc
  74. Vala is a new programming language that aims to bring modern programming
  75. language features to GNOME developers without imposing any additional
  76. runtime requirements and without using a different ABI compared to
  77. applications and libraries written in C.
  78. This package contains documentation in a devhelp HTML book.
  79. %package -n valadoc
  80. Summary: Vala documentation generator
  81. Summary(ja): Valaのドキュメントジェネレータ
  82. Group: Development/Tools
  83. License: LGPLv2+
  84. Requires: vala = %{version}-%{release}
  85. %description -n valadoc
  86. Valadoc is a documentation generator for generating API documentation from Vala
  87. source code.
  88. %package -n valadoc-devel
  89. Summary: Development files for valadoc
  90. Summary(ja): valadocを利用した開発のためのファイル群
  91. Group: Development/Libraries
  92. License: LGPLv2+
  93. Requires: valadoc = %{version}-%{release}
  94. %description -n valadoc-devel
  95. Valadoc is a documentation generator for generating API documentation from Vala
  96. source code.
  97. The valadoc-devel package contains libraries and header files for
  98. developing applications that use valadoc.
  99. %prep
  100. %setup -q
  101. %build
  102. %configure --enable-vapigen
  103. # Don't use rpath!
  104. sed -i 's|/lib /usr/lib|/lib /usr/lib /lib64 /usr/lib64|' libtool
  105. make %{?_smp_mflags}
  106. %install
  107. rm -rf $RPM_BUILD_ROOT
  108. make install DESTDIR=$RPM_BUILD_ROOT
  109. find %{buildroot}%{_libdir} -type f -name 'lib*.la' | xargs rm -f
  110. %check
  111. make check
  112. %clean
  113. rm -rf $RPM_BUILD_ROOT
  114. %post -p /sbin/ldconfig
  115. %postun -p /sbin/ldconfig
  116. %files
  117. %defattr(-,root,root,-)
  118. %license COPYING
  119. %doc AUTHORS ChangeLog NEWS README THANKS
  120. %{_bindir}/vala
  121. %{_bindir}/valac
  122. %{_bindir}/vala-%{api_ver}
  123. %{_bindir}/valac-%{api_ver}
  124. %{_datadir}/vala-%{api_ver}
  125. %{_datadir}/vala
  126. %{_libdir}/libvala-%{api_ver}.so.*
  127. %{_mandir}/*/valac*
  128. %files devel
  129. %defattr(-,root,root,-)
  130. %{_includedir}/vala-%{api_ver}
  131. %{_libdir}/libvala-%{api_ver}.so
  132. %{_libdir}/pkgconfig/libvala-%{api_ver}.pc
  133. %{_datadir}/aclocal/vala.m4
  134. %{_datadir}/aclocal/vapigen.m4
  135. %{_libdir}/pkgconfig/vapigen.pc
  136. %{_libdir}/pkgconfig/vapigen-%{api_ver}.pc
  137. %{_datadir}/vala/Makefile.vapigen
  138. %files tools
  139. %defattr(-,root,root,-)
  140. %{_bindir}/vala-gen-introspect
  141. %{_bindir}/vapigen
  142. %{_bindir}/vala-gen-introspect-%{api_ver}
  143. %{_bindir}/vapigen-%{api_ver}
  144. %{_libdir}/vala-%{api_ver}
  145. %{_mandir}/*/*gen*
  146. %files doc
  147. %defattr(-,root,root,-)
  148. %{_datadir}/devhelp/books/vala-%{api_ver}
  149. %files -n valadoc
  150. %defattr(-,root,root,-)
  151. %{_bindir}/valadoc*
  152. %{_libdir}/libvaladoc-%{api_ver}.so.*
  153. %{_libdir}/valadoc-%{api_ver}
  154. %{_datadir}/valadoc-%{api_ver}
  155. %{_mandir}/*/valadoc*
  156. %files -n valadoc-devel
  157. %{_libdir}/libvaladoc-%{api_ver}.so
  158. %{_libdir}/pkgconfig/valadoc-%{api_ver}.pc
  159. %{_includedir}/valadoc-%{api_ver}
  160. %changelog
  161. * Mon Aug 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.48.8-1
  162. - new upstream release.
  163. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.44.7-1
  164. - new upstream release.
  165. * Mon Dec 10 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.40.11-1
  166. - new upstream release (LTS 0.40).
  167. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.38.4-1
  168. - new upstream release.
  169. - added subpackages "valadoc" and "valadoc-devel".
  170. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.32.1-1
  171. - new upstream release
  172. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.30.0-1
  173. - new upstream release
  174. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.1-1
  175. - new upstream release
  176. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.28.0-1
  177. - new upstream release
  178. * Wed Jan 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.26.2-1
  179. - new upstream release
  180. * Sat Nov 8 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.26.1-1
  181. - new upstream release
  182. - moved tools subpackage to Development/Tools Group
  183. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.0-1
  184. - new upstream release
  185. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.1-1
  186. - new upstream release
  187. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.0-1
  188. - new upstream release
  189. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.20.1-1
  190. - new upstream release
  191. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.1-1
  192. - new upstream release
  193. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.18.0-1
  194. - new upstream release
  195. * Mon Jun 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
  196. - new upstream release
  197. * Sun Apr 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
  198. - new upstream release
  199. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
  200. - new upstream release
  201. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  202. - new upstream release
  203. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  204. - new upstream release
  205. - remove BuildRequires: gtk2-devel, xulrunner-devel
  206. - add BuildRequires: glib2-devel, libxslt
  207. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
  208. - new upstream release
  209. - remove BuildRequires: devhelp
  210. * Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
  211. - new upstream release
  212. * Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
  213. - new upstream release
  214. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
  215. - new upstream release
  216. * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  217. - rebuilt with rpm-4.8.1 for pkg-config
  218. * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
  219. - new upstream release
  220. - made -doc subpackage noarch
  221. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
  222. - new upstream release
  223. * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
  224. - new upstream release
  225. * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
  226. - new upstream release
  227. * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
  228. - new upstream release
  229. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  230. - new upstream release
  231. - change BuildRequires: gecko-libs -> xulrunner-devel
  232. * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
  233. - new upstream release
  234. * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
  235. - new upstream release
  236. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
  237. - new upstream release
  238. * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
  239. - initial build for Vine Linux
  240. * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
  241. - Update to 0.7.5
  242. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
  243. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  244. * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
  245. - Patch broken ModuleInit attribute (upstream bug 587444)
  246. * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
  247. - Update to 0.7.4
  248. * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
  249. - Update to 0.7.3
  250. * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
  251. - Update to 0.6.1
  252. * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
  253. - Update to 0.5.7
  254. * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
  255. - Update to 0.5.6
  256. * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
  257. - Update to 0.5.3
  258. * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
  259. - Fix bug in Emacs version detection
  260. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
  261. - Use buildsystem variables to determine available Emacs version
  262. - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
  263. * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
  264. - Update to 0.5.2
  265. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
  266. - Update to 0.5.1
  267. * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
  268. - Update to 0.3.5
  269. * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
  270. - Add vala-mode for editing Vala code in Emacs
  271. * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
  272. - Update to 0.3.4
  273. * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
  274. - Update to 0.3.3
  275. * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
  276. - Update to 0.3.2
  277. * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
  278. - Update to 0.2.0
  279. * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
  280. - Update to 0.1.7
  281. - -tool subpackage now requires gnome-common, intltool and libtoolize
  282. for out-of-the-box vala-gen-project support
  283. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
  284. - Autorebuild for GCC 4.3
  285. * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
  286. - Update to 0.1.6
  287. - Revert vapi addition, needed declarations have been inlined (r846)
  288. - Rename -docs subpackage to -doc, to comply with guidelines
  289. * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
  290. - Manually add Gee vapi file to package (bz #428692)
  291. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
  292. - Backport patch to autodetect location of automake shared files
  293. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
  294. - Add build dependency on gtk2-devel
  295. * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
  296. - Enable project generator tool
  297. * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
  298. - Update to 0.1.5
  299. * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
  300. - Add build dependency on devhelp
  301. * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
  302. - Update to 0.1.4
  303. - Put newly-added documentation in its own subpackage (depends on devhelp)
  304. * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
  305. - vapigen subpackage: add missing Require: on perl-XML-Twig
  306. * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
  307. - Split -vapigen subpackage. It is functionally self-contained and the license
  308. is more restricted
  309. - Updated license declarations
  310. * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
  311. - Licensing and URL updates
  312. * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
  313. - Enable binding generation tools
  314. * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
  315. - Update to 0.1.3
  316. * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
  317. - Update to 0.0.8
  318. * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
  319. - Update to 0.0.7
  320. * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
  321. - Update to 0.0.6
  322. * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
  323. - Initial package