avidemux-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412
  1. %define _pkgbuilddir %{_builddir}/%{name}_%{version}
  2. Name: avidemux
  3. Version: 2.5.5
  4. Release: 1%{?_dist_release}
  5. Summary: Graphical video editing and transcoding tool
  6. Group: Applications/Multimedia
  7. License: GPLv2+
  8. URL: http://www.avidemux.org/
  9. Source0: http://download.berlios.de/avidemux/avidemux_%{version}.tar.gz
  10. Source1: %{name}-gtk.desktop
  11. Source2: %{name}-qt.desktop
  12. # Patch0 obtained from avidemux-2.5.0-patches-1.tar.bz2:
  13. # http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/distfiles/avidemux-2.5.0-patches-1.tar.bz2
  14. Patch0: 2.5.0-coreImage-parallel-build.patch
  15. Patch1: avidemux-2.5-pulseaudio-default.patch
  16. Patch2: avidemux-2.4-qt4.patch
  17. # Prevents avidemux from creating the symlinks for .so files, which we do below
  18. Patch3: avidemux-2.5.3-tmplinktarget.patch
  19. # libADM_xvidRateCtl.so and libADM_vidEnc_pluginOptions.so are supposed to be
  20. # build statically according to upstream... Let's get them installed instead
  21. Patch4: avidemux-2.5.3-mpeg2enc.patch
  22. Patch5: avidemux-2.5.3-pluginlibs.patch
  23. # Patch8 obtained from http://lists.rpmfusion.org/pipermail/rpmfusion-developers/2010-October/008645.html
  24. #Patch6: avidemux_2.5.4-ffmpeg-aac.patch
  25. Patch6: avidemux_2.5.5-ffmpeg_aac.patch
  26. Patch7: avidemux-2.5.5-gcc46_tmp_fix.patch
  27. # Patch needed for version of x264 in F15/rawhide.
  28. # Use system libraries
  29. Patch8: avidemux-2.5.4-libass.patch
  30. Patch9: avidemux-2.5.4-liba52.patch
  31. Patch10: avidemux-2.5.4-libmad.patch
  32. Patch11: avidemux-2.5.4-libtwolame.patch
  33. Patch12: avidemux-2.5.5_fix_lav_audio_encoder.patch
  34. # Patch for ABI change in x264 115.
  35. Patch13: avidemux-2.5.5-x264_i_to_b_open_gop.patch
  36. # Uses a header file not found in the standard package
  37. #Patch16: avidemux-2.5.4-mpeg2enc.patch
  38. ## Vine customization patches
  39. Patch50: avidemux-2.5.2-no-qt4-ui.patch
  40. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  41. Obsoletes: %{name}-cli %{name}-gui %{name}-qt
  42. Obsoletes: %{name}-devel <= 2.5.5
  43. # *-devel pacages provided by other self-build-* should only be listed
  44. # in self-build-%{name}.spec as PreReq.
  45. # Compiling
  46. BuildRequires: cmake
  47. #BuildRequires: gettext-devel
  48. BuildRequires: gettext
  49. # Libraries
  50. BuildRequires: nasm >= 0.98.38
  51. BuildRequires: libxml2-devel >= 2.6.8
  52. BuildRequires: fontconfig-devel
  53. #BuildRequires: freetype-devel
  54. BuildRequires: freetype2-devel
  55. BuildRequires: js-devel
  56. BuildRequires: libXv-devel
  57. BuildRequires: libXmu-devel
  58. # Required by gtk: libXi-devel, libXext-devel, libX11-devel
  59. # Required by qt: libXt-devel, libXext-devel, libX11-devel
  60. BuildRequires: libsamplerate-devel
  61. BuildRequires: jack-audio-connection-kit-devel
  62. # Sound out
  63. BuildRequires: alsa-lib-devel >= 1.0.3
  64. BuildRequires: pulseaudio-libs-devel
  65. # Video out
  66. BuildRequires: SDL-devel >= 1.2.7
  67. # Audio Codecs
  68. #BuildRequires: a52dec-devel >= 0.7.4
  69. #BuildRequires: faac-devel >= 1.24
  70. #BuildRequires: faad2-devel >= 2.0
  71. #BuildRequires: lame-devel >= 3.96.1
  72. #BuildRequires: libmad-devel >= 0.15.1
  73. BuildRequires: libogg-devel >= 1.1
  74. BuildRequires: libvorbis-devel >= 1.0.1
  75. # BuildRequires: self-build-a52dec >= 0.7.4
  76. # BuildRequires: self-build-faac >= 1.24
  77. # BuildRequires: self-build-faad2 >= 2.0
  78. # BuildRequires: self-build-lame >= 3.96.1
  79. # BuildRequires: self-build-libmad >= 0.15.1
  80. #BuildRequires: libdca-devel
  81. # BuildRequires: self-build-libdca
  82. # Video Codecs
  83. #BuildRequires: xvidcore-devel >= 1.0.2
  84. #BuildRequires: x264-devel
  85. #BuildRequires: ffmpeg-devel
  86. # BuildRequires: self-build-xvidcore >= 1.0.2
  87. # BuildRequires: self-build-x264
  88. # BuildRequires: self-build-ffmpeg
  89. # FIXME: aften not packaged, add BR when it is
  90. # Finally...
  91. BuildRequires: desktop-file-utils
  92. #gtk
  93. BuildRequires: gtk2-devel >= 2.8.0
  94. BuildRequires: cairo-devel
  95. %if %{?with_qt_ui:1} %{!?with_qt_ui:0}
  96. BuildRequires: qt4-devel >= 4.5.0-9
  97. BuildRequires: qt4-designer
  98. %endif
  99. %description
  100. Avidemux is a free video editor designed for simple cutting, filtering and
  101. encoding tasks. It supports many file types, including AVI, DVD compatible
  102. MPEG files, MP4 and ASF, using a variety of codecs. Tasks can be automated
  103. using projects, job queue and powerful scripting capabilities.
  104. For compatability reasons, avidemux is a meta-package which installs the
  105. graphical, command line and plugin packages. If you want a smaller setup,
  106. you may selectively install one or more of the avidemux-* subpackages.
  107. %prep
  108. %__rm -rf $RPM_BUILD_ROOT
  109. %setup -q -n avidemux_%{version}
  110. # Remove unneeded external libraries
  111. rm -rf plugins/ADM_videoFilters/Ass/ADM_libAss
  112. rm -rf plugins/ADM_audioEncoders/twolame/ADM_libtwolame
  113. rm -rf plugins/ADM_audioDecoders/ADM_ad_mad/ADM_libMad
  114. rm -rf plugins/ADM_audioDecoders/ADM_ad_ac3/ADM_liba52
  115. #rm -rf plugins/ADM_videoEncoder/ADM_vidEnc_mpeg2enc/mpeg2enc
  116. # change hardcoded libdir paths
  117. %ifarch x86_64 ppc64
  118. %__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/ADM_core/src/ADM_fileio.cpp
  119. %__sed -i.bak 's/startDir="lib";/startDir="lib64";/' avidemux/main.cpp
  120. %endif
  121. %patch0 -p1 -b .parallel
  122. %patch1 -p1 -b .pulse
  123. #%patch2 -p1 -b .qt4
  124. %patch3 -p1 -b .tmplinktarget
  125. %patch4 -p1 -b .mpeg2enc
  126. %patch5 -p1 -b .pluginlibs
  127. #%patch6 -p1 -b .ffmpegaac
  128. %patch7 -p1 -b .gcc46tmpfix
  129. %patch8 -p1 -b .libass
  130. %patch9 -p1 -b .liba52
  131. %patch10 -p1 -b .libmad
  132. %patch11 -p1 -b .libtwolame
  133. %patch12 -p1 -b .lavencode
  134. %patch13 -p1 -b .x264
  135. %{!?with_qt_ui:%patch50 -p1 -b .qt4}
  136. %build
  137. # Out of source build
  138. %__mkdir_p build && cd build
  139. %cmake -DAVIDEMUX_INSTALL_PREFIX=%{_prefix} \
  140. -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
  141. -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
  142. -DUSE_SYSTEM_SPIDERMONKEY:BOOL=OFF \
  143. ..
  144. %__make %{?_smp_mflags}
  145. # Create the temp link directory manuall since otherwise it happens too early
  146. %__mkdir_p %{_pkgbuilddir}/build/%{_lib}
  147. find %{_pkgbuilddir}/build/avidemux -name '*.so*' | \
  148. xargs ln -sft %{_pkgbuilddir}/build/%{_lib}
  149. %__mkdir_p ../build_plugins && cd ../build_plugins
  150. %cmake -DAVIDEMUX_INSTALL_PREFIX="%{_pkgbuilddir}/build/" \
  151. -DAVIDEMUX_SOURCE_DIR="%{_pkgbuilddir}" \
  152. -DAVIDEMUX_CORECONFIG_DIR="%{_pkgbuilddir}/build/config" \
  153. ../plugins
  154. %__make %{?_smp_mflags}
  155. %install
  156. %__rm -rf $RPM_BUILD_ROOT
  157. %__make -C build install DESTDIR=$RPM_BUILD_ROOT
  158. %__make -C build_plugins install DESTDIR=$RPM_BUILD_ROOT
  159. # Find and remove all la files
  160. find $RPM_BUILD_ROOT -type f -name "*.la" -exec %__rm -f {} ';'
  161. # Remove Windows-only executables
  162. # Must check this for new Linux-relevant files upon new avidemux releases
  163. %__rm -rf %{buildroot}%{_datadir}/ADM_addons/avsfilter
  164. %__rm -rf %{buildroot}%{_datadir}/ADM_addons/
  165. # Install .desktop shortcuts
  166. desktop-file-install --vendor vine \
  167. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  168. %{SOURCE1}
  169. %if %{?with_qt_ui:1} %{!?with_qt_ui:0}
  170. desktop-file-install --vendor vine \
  171. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  172. %{SOURCE2}
  173. # Remove duplicated Qt translations
  174. rm -f %{buildroot}%{_datadir}/%{name}/i18n/qt_*.qm
  175. # find_lang.sh doesn't recognize this one, and there already is avidemux_sr.qm
  176. rm -f %{buildroot}%{_datadir}/%{name}/i18n/avidemux_sr@latin.qm
  177. # Qt-style translations
  178. %find_lang %{name} --with-qt --without-mo
  179. mv -f %{name}.lang %{name}-qt.lang
  180. %endif
  181. %find_lang %{name}
  182. %clean
  183. %__rm -rf $RPM_BUILD_ROOT
  184. %post -p /sbin/ldconfig
  185. %postun -p /sbin/ldconfig
  186. %files -f %{name}.lang
  187. %defattr(-,root,root,-)
  188. %doc AUTHORS COPYING README TODO
  189. %{_datadir}/%{name}/
  190. %{_datadir}/ADM_scripts/
  191. %{_libdir}/libADM*
  192. %{_libdir}/ADM_plugins/
  193. %{_bindir}/avidemux2_cli
  194. %{_bindir}/avidemux2_gtk
  195. %{_datadir}/applications/*gtk*.desktop
  196. %if %{?with_qt_ui:1} %{!?with_qt_ui:0}
  197. %{_bindir}/avidemux2_qt4
  198. %{_datadir}/applications/*qt*.desktop
  199. %endif
  200. %changelog
  201. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.5-1
  202. - new upstream release
  203. - Obsoletes: avidemux-cli avidemux-gui avidemux-qt avidemux-devel <= 2.5.5
  204. * Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-5
  205. - dropped BuildRequires: esound-devel
  206. * Sun May 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.2-4
  207. - add Patch7 (avidemux-2.5.4-x264-X264_WEIGHTP_BLIND-fix.patch)
  208. * Sat Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-3
  209. - unapply avidemux-2.4-qt4.patch
  210. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-2
  211. - change release to sync with self-build-avidemux
  212. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.5.2-1
  213. - new upstream release
  214. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.4-1
  215. - new upstream release
  216. - update patches accordingly
  217. - build with x264 >= 0.0.0-9.20090522
  218. - dropped avidemux-2.4.3-ppc.patch, avidemux-x264.patch
  219. * Sat Feb 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> - 2.4.3-7
  220. - corrected release number
  221. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-5
  222. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  223. - changed to PreReq: self-build-libmad >= 0.15.1 from libmad-devel
  224. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-4
  225. - change release to sync with self-build-avidemux
  226. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-3
  227. - added avidemux-x264.patch from Gentoo
  228. * Mon Dec 08 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-2
  229. - applied avidemux-2.4.3-alsa-device-default.patch
  230. * Mon Nov 24 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.4.3-1
  231. - initial build based on RPM Fusion of Fedora package
  232. - changed to BuildRequires: gettext from gettext-devel
  233. - added BuildRequires: qt4-designer for gtk subpackage
  234. - dropped avidemux-2.4.3-qt4.patch
  235. * Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-5
  236. - Add CMake patch for PPC64
  237. - Update patches for 2.4.3
  238. - Remove outdated libmad patch (Nov. 2007)
  239. * Thu Sep 18 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-4
  240. - Add another patch to fix ppc64 build (pointer type), first
  241. patch was for libmad
  242. * Fri Aug 22 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-3
  243. - Add patch to fix ppc64 build
  244. * Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-2
  245. - retag
  246. * Sat Aug 16 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.3-1
  247. - Update to 2.4.3
  248. * Tue Aug 12 2008 Stewart Adam <s.adam at diffingo.com> - 2.4.2-3
  249. - ppc64 uint_32 fun
  250. * Sun Aug 03 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 2.4.2-2
  251. - rebuild
  252. * Sat Jul 19 2008 Thorsten Leemhuis <s.adam at diffingo.com> - 2.4.2-1
  253. - Update to 2.4.2
  254. * Wed May 21 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-3.20080521svn
  255. - Disable --new-faad
  256. - 20080521 subversion snapshot
  257. * Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-2
  258. - Disable %%{?_smp_mflags}
  259. * Sat Mar 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4.1-1
  260. - Update to 2.4.1
  261. - Don't list the bin files twice, revisited
  262. - Default to GTK frontend
  263. * Wed Feb 20 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-6.20080126svn
  264. - Make pulseaudio default for sound out
  265. - Don't list the bin files twice
  266. - Don't build with arts support
  267. * Fri Feb 15 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-5.20080126svn
  268. - Don't list the .desktop files twice (bz#1870)
  269. - Oops, we should have %%{svndate}svn in release tag!
  270. * Sat Feb 2 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-4
  271. - F-8/F-7 x86_64 does seem to need --with-newfaad
  272. * Fri Feb 1 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-3
  273. - Update to version 2.4 (20080126svn) and include fixes from devel branch
  274. * Mon Jan 14 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-2
  275. - Fix many copy/paste errors and desktop file's Exec field
  276. * Sun Jan 13 2008 Stewart Adam <s.adam AT diffingo DOT com> - 2.4-1
  277. - Update to 2.4 final
  278. - Split up desktop files and make them pass desktop-file-validate
  279. - Add structure to split into gtk and qt pacakges
  280. - Disable qt4 for now, doesn't compile
  281. * Sun Oct 7 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info>3- 2.3.0-4.3
  282. - move js-include to a place where it is honored
  283. * Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.2
  284. - Fix macro problem
  285. - Fix changelog date
  286. - Rebuild with faad, but don't pass --newfaad
  287. * Sun Oct 7 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4.1
  288. - Rebuild with no faad
  289. * Sat Oct 6 2007 Stewart Adam <s.adam AT diffingo DOT com> - 2.3.0-4
  290. - Rebuild for ffmpeg dependency problems
  291. - Update License: tag per Fedora guidelines
  292. * Sat Jan 13 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-3
  293. - more features with new BR's: x264-devel libXv-devel
  294. - make a note regarding the libdca-devel problem
  295. - remove the "0:" from the versioned BR's
  296. * Thu Jan 04 2007 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.3.0-2
  297. - don't use smp_mflags during make for now
  298. * Sat Dec 23 2006 kwizart < kwizart at gmail.com > - 2.3.0-1
  299. - Update to 2.3.0 Final
  300. - Use find_lang
  301. * Mon Apr 03 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.1.2-1
  302. - Update to 2.1.2
  303. * Thu Mar 09 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  304. - switch to new release field
  305. * Tue Feb 28 2006 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  306. - add dist
  307. * Wed Jan 04 2006 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.1.0-0.lvn.1
  308. - Update to 2.1.0
  309. - Drop epoch
  310. - gtk 2.6 now, so drop FC3 support
  311. * Sat Aug 27 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.3
  312. - Remove bogus BR ffmpeg-devel (#555)
  313. * Thu Jul 09 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.2
  314. - Add missing BR desktop-file-utils (thanks to ixs)
  315. * Thu Jul 07 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.42-0.lvn.1
  316. - Update to 2.0.42
  317. * Sat Jan 22 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.36-0.lvn.1
  318. - Update to 2.0.34
  319. - Rename package to avidemux -- no need for avidemux2 afaics
  320. * Sun Nov 21 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.34-0.lvn.1.test1
  321. - Update to 2.0.34-test1
  322. - BR gettext, libtool
  323. * Tue Oct 18 2004 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 0:2.0.30-0.lvn.1
  324. - Initial RPM release.