ffmpeg-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348
  1. #TODO: Build with openjpeg, opencore-amr, vo-amrwbenc
  2. #TODO: add make test to %%check section
  3. #% define svndate 20100625
  4. %define with_faac 1
  5. %define with_vaapi 1
  6. %define with_libvpx 1
  7. %define use_prebuilt_man 1
  8. Summary: Digital VCR and streaming server
  9. Name: ffmpeg
  10. Version: 0.9
  11. Release: 1%{?svndate:.%svndate}%{?_dist_release}
  12. Source: http://ffmpeg.org/releases/%{name}-%{?svndate:%svndate}%{!?svndate:%version}.tar.bz2
  13. Source1: %{name}-snapshot.sh
  14. # pre-built man files
  15. %if %{use_prebuilt_man}
  16. #$ tar Jcvf ~/rpm/SOURCES/ffmpeg/ffmpeg-0.9-doc.tar.xz ffmpeg-0.9/doc/*.html ffmpeg-0.9/doc/*.pod ffmpeg-0.9/doc/*.1
  17. Source90: ffmpeg-%{version}-doc.tar.xz
  18. %endif
  19. %if 0%{?_with_amr:1}
  20. License: GPLv3+
  21. %else
  22. License: GPLv2+
  23. %endif
  24. Group: Applications/Multimedia
  25. URL: http://ffmpeg.org/
  26. BuildRequires: bzip2-devel
  27. BuildRequires: celt-devel
  28. ##BuildRequires: dirac-devel
  29. BuildRequires: freetype2-devel
  30. BuildRequires: gsm-devel
  31. BuildRequires: imlib2-devel
  32. BuildRequires: libdc1394-devel
  33. BuildRequires: libogg-devel
  34. BuildRequires: libraw1394-devel
  35. BuildRequires: librtmp-devel >= 2.3
  36. BuildRequires: libtheora-devel
  37. %{?with_vaapi:BuildRequires:libva-devel >= 0.31.0}
  38. BuildRequires: libvdpau-devel
  39. BuildRequires: libvorbis-devel
  40. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.6}
  41. %{?_with_opencore_amr:BuildRequires: opencore-amr-devel vo-amrwbenc-devel}
  42. ##BuildRequires: openjpeg-devel
  43. ##BuildRequires: schroedinger-devel
  44. BuildRequires: SDL-devel
  45. BuildRequires: speex-devel
  46. %{!?use_prebuilt_man:BuildRequires: texi2html}
  47. BuildRequires: zlib-devel
  48. BuildRequires: yasm
  49. # *-devel packages provided by other self-build-* should only be listed
  50. # in self-build-%{name}.spec as PreReq.
  51. #BuildRequires: a52dec-devel
  52. #BuildRequires: faac-devel
  53. #BuildRequires: lame-devel
  54. #BuildRequires: libdca-devel
  55. #BuildRequires: x264-devel >= 0.0.0-15.20110322
  56. #BuildRequires: xvidcore-devel
  57. Requires: %{name}-libs = %{version}-%{release}
  58. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  59. %description
  60. FFMpeg is a complete and free Internet live audio and video
  61. broadcasting solution for Linux/Unix. It also includes a digital
  62. VCR. It can encode in real time in many formats including MPEG1 audio
  63. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  64. %package libs
  65. Summary: Libraries for %{name}
  66. Group: System Environment/Libraries
  67. %description libs
  68. FFMpeg is a complete and free Internet live audio and video
  69. broadcasting solution for Linux/Unix. It also includes a digital
  70. VCR. It can encode in real time in many formats including MPEG1 audio
  71. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  72. This package contains the libraries for %{name}.
  73. %package devel
  74. Summary: Development package for %{name}
  75. Group: Development/Libraries
  76. Requires: %{name}-libs = %{version}-%{release}
  77. Requires: pkgconfig
  78. %description devel
  79. FFMpeg is a complete and free Internet live audio and video
  80. broadcasting solution for Linux/Unix. It also includes a digital
  81. VCR. It can encode in real time in many formats including MPEG1 audio
  82. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  83. This package contains development files for %{name}.
  84. %prep
  85. %setup -q -n %{name}-%{?svndate:%svndate}%{!?svndate:%version}
  86. %if %{use_prebuilt_man}
  87. tar -C .. -xf %{SOURCE90}
  88. %endif
  89. %build
  90. %ifarch ppc
  91. # compile with -mlongcall on ppc/ppc64 (rf804)
  92. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  93. %endif
  94. ./configure \
  95. --prefix=%{_prefix} \
  96. --incdir=%{_includedir}/%{name} \
  97. --shlibdir=%{_libdir} \
  98. --libdir=%{_libdir} \
  99. --mandir=%{_mandir} \
  100. --arch=%{_target_cpu} \
  101. %ifarch %{ix86}
  102. --cpu=%{_target_cpu} \
  103. %endif
  104. %ifarch ppc
  105. --cpu=g3 \
  106. --enable-pic \
  107. %endif
  108. --enable-runtime-cpudetect \
  109. --extra-cflags="$RPM_OPT_FLAGS" \
  110. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-version3} \
  111. --enable-bzlib \
  112. --enable-zlib \
  113. --enable-libcelt \
  114. --enable-libdc1394 \
  115. %{?_with_libdirac:--enable-libdirac} \
  116. %{?with_faac:--enable-libfaac --enable-nonfree} \
  117. --enable-libfreetype \
  118. --enable-libgsm \
  119. --enable-libmp3lame \
  120. %{?_with_openjpeg:--enable-libopenjpeg} \
  121. --enable-librtmp \
  122. --enable-libspeex \
  123. --enable-libtheora \
  124. --enable-libvorbis \
  125. %{?with_libvpx:--enable-libvpx} \
  126. --enable-libx264 \
  127. --enable-libxvid \
  128. \
  129. --enable-x11grab \
  130. --enable-avfilter \
  131. --enable-postproc \
  132. --enable-pthreads \
  133. --disable-static \
  134. --enable-shared \
  135. --enable-gpl \
  136. %{?use_prebuilt_man:--disable-doc} \
  137. --disable-debug \
  138. --disable-stripping \
  139. ;
  140. %__make %{?_smp_mflags}
  141. %if %{!use_prebuilt_man}
  142. %__make documentation
  143. %endif
  144. %__make alltools
  145. %install
  146. %__make install DESTDIR=$RPM_BUILD_ROOT
  147. ## install tool/qt-faststart
  148. %__install -pm755 tools/qt-faststart $RPM_BUILD_ROOT%{_bindir}
  149. # ## install man
  150. %if %{!use_prebuilt_man}
  151. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  152. %__install -m0644 doc/*.1 $RPM_BUILD_ROOT%{_mandir}/man1/
  153. %endif
  154. %clean
  155. %{__rm} -rf $RPM_BUILD_ROOT
  156. %post libs -p /sbin/ldconfig
  157. %postun libs -p /sbin/ldconfig
  158. %files
  159. %defattr(-,root,root,-)
  160. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  161. %{_bindir}/avconv
  162. %{_bindir}/ffmpeg
  163. %{_bindir}/ffplay
  164. %{_bindir}/ffprobe
  165. %{_bindir}/ffserver
  166. %{_bindir}/qt-faststart
  167. %{_mandir}/man1/avconv.1*
  168. %{_mandir}/man1/ffmpeg.1*
  169. %{_mandir}/man1/ffplay.1*
  170. %{_mandir}/man1/ffprobe.1*
  171. %{_mandir}/man1/ffserver.1*
  172. %{_datadir}/ffmpeg
  173. %files libs
  174. %defattr(-,root,root,-)
  175. %{_libdir}/lib*.so.*
  176. %files devel
  177. %defattr(-,root,root,-)
  178. %doc MAINTAINERS doc/APIchanges doc/*.txt doc/*.html
  179. %{_includedir}/ffmpeg
  180. %{_libdir}/pkgconfig/lib*.pc
  181. %{_libdir}/lib*.so
  182. %changelog
  183. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.9-1
  184. - new upstream release
  185. - enable CELT decoding via libcelt
  186. - enable FreeType support
  187. - drop faad2 support (dropped upstream)
  188. * Mon Sep 12 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-2
  189. - change release to sync with self-build-ffmpeg-vl.spec
  190. * Sun May 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.3-1
  191. - new upstream release
  192. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.2-1
  193. - new upstream release
  194. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-2
  195. - required latest x264 build
  196. - added BuildRequires: librtmp-devel >= 2.3
  197. - build PIC objects on PPC
  198. #- add qt-faststart tool
  199. * Sat Oct 30 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6.1-1
  200. - new upstream release
  201. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-4
  202. - change release to sync with self-build-ffmpeg-vl.spec
  203. * Sun Jul 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-3
  204. - added BuildRequires: libvpx-devel >= 0.9.1
  205. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-2
  206. - new upstream release
  207. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  208. - bumped version to pre-0.6
  209. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  210. - updated source snapshot 20100410
  211. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  212. - change release to sync with self-build-ffmpeg-vl.spec
  213. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  214. - change release to sync with self-build-ffmpeg-vl.spec
  215. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  216. - updated source snapshot 20100401
  217. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  218. - updated source snapshot 20100326
  219. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  220. - change release to sync with self-build-ffmpeg
  221. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  222. - updated source snapshot 20100216
  223. - rebuild with recent x264-devel
  224. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  225. - added BuildRequires: libvdpau-devel
  226. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  227. - change release to sync with self-build-ffmpeg
  228. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  229. - change release to sync with self-build-ffmpeg
  230. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  231. - applied ffmpeg-0.5-disable-texi2html.patch
  232. - dropped BuildRequires: texi2html
  233. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  234. - change release to sync with self-build-ffmpeg
  235. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  236. - corrected release number
  237. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  238. - new upstream release
  239. - added BuildRequires:
  240. - speex-devel
  241. - bzip2-devel
  242. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  243. - 20090227 snapshot
  244. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  245. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  246. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  247. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  248. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  249. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  250. - 20090202 snapshot
  251. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  252. - 20090110 snapshot
  253. - dropped some patches
  254. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  255. - source updated (r15488)
  256. - fixed License: GPLv2+
  257. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  258. - added BuildRequires: yasm (only %%ix86)
  259. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  260. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  261. - spec in utf8
  262. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  263. - change release to sync with self-build-ffmpeg
  264. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  265. - drop "Patch100: ffmpeg-vine.patch".
  266. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  267. - build with new versioning policy
  268. - change to use svn export from svn checkout on post install
  269. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  270. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  271. - [self-build-ffmpeg.spec]
  272. For all pre-required package that is provied by self-build,
  273. changed to its self-build package
  274. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  275. - initial build for Vine Linux 4.2
  276. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  277. ### end of file