mplayer-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545
  1. %global with_faac 1
  2. %global with_vaapi 1
  3. %global with_libvpx 1
  4. # define with_ffmpeg 1
  5. %global name mplayer
  6. %global version 1.0
  7. # define extver rc4
  8. %global svndate 20111210
  9. %global release 45%{?extver:.%extver}%{?svndate:.%svndate}%{?_dist_release}
  10. # define dvbappver 0.95
  11. %global ttfontdir /usr/share/fonts
  12. %global ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  13. TrueType-sazanami-gothic/sazanami-gothic
  14. Summary: The Movie Player
  15. Summary(ja): 動画プレイヤー
  16. Name: %{name}
  17. Version: %{version}
  18. Release: %{release}
  19. #Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  20. Source0: mplayer-export-%{svndate}.tar.xz
  21. Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.8.tar.bz2
  22. Source10: mplayer-snapshot-vine.sh
  23. ## DVB app.
  24. ## 0.9.5
  25. # Source100: http://2sen.dip.jp/cgi-bin/dtvup/source/up0624.zip
  26. ## 0.9.5 -> 0.9.6
  27. # Source101: http://2sen.dip.jp/cgi-bin/dtvup/source/up0658.zip
  28. #Patch2: %{name}-config.patch
  29. Patch2: %{name}-config-20111217-vine.patch
  30. Patch8: %{name}-manlinks.patch
  31. Patch14: %{name}-nodvdcss.patch
  32. Patch18: %{name}-ffmpeg.patch
  33. ## Vine
  34. # Patch50: mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  35. # Patch101: mplayer-1.0rc4-0001-makes-ffdec_aac-more-robust-against-erroneous-irregu.patch
  36. # Patch102: mplayer-1.0rc4-0002-add-support-for-audio-channel-reconfiguration.patch
  37. # Patch103: mplayer-1.0rc4-0003-add-support-for-dual-mono-auto-selection-and-switchi.patch
  38. # Patch106: mplayer-1.0rc4-0006-add-support-for-S2API-tuning-with-a-new-channels.con.patch
  39. # Patch107: mplayer-1.0rc4-0007-add-BCAS-descrambling-feature.patch
  40. # Patch111: mplayer-1.0rc4-ffmpeg-0001-makes-ffdec_aac-more-robust-against-erroneous-irregu.patch
  41. # Patch113: mplayer-1.0rc4-ffmpeg-0003-add-dual-mono-support-to-ffdec_aac.patch
  42. License: GPLv2+
  43. Group: Applications/Multimedia
  44. URL: http://www.mplayerhq.hu/
  45. BuildRequires: SDL-devel
  46. BuildRequires: aalib-devel
  47. BuildRequires: alsa-lib-devel
  48. BuildRequires: cdparanoia-devel
  49. BuildRequires: desktop-file-utils
  50. BuildRequires: libdvdnav-devel
  51. BuildRequires: enca-devel
  52. BuildRequires: freetype2-devel >= 2.0.9
  53. BuildRequires: fribidi-devel
  54. BuildRequires: fontconfig-devel
  55. BuildRequires: giflib-devel
  56. BuildRequires: gtk2-devel
  57. BuildRequires: mesa-libGL-devel
  58. BuildRequires: libXinerama-devel
  59. BuildRequires: libXScrnSaver-devel
  60. BuildRequires: libXv-devel
  61. BuildRequires: libXvMC-devel
  62. BuildRequires: libXxf86dga-devel
  63. BuildRequires: libXxf86vm-devel
  64. BuildRequires: libass-devel
  65. BuildRequires: libpng-devel
  66. BuildRequires: libjpeg-devel
  67. BuildRequires: libdvdread
  68. BuildRequires: libmpcdec-devel >= 1.2.1
  69. BuildRequires: librtmp-devel >= 2.3
  70. BuildRequires: speex-devel >= 1.1
  71. %if %{?_dist_release} != "vl5"
  72. %{?with_vaapi:BuildRequires:libva-devel}
  73. %endif
  74. BuildRequires: libvdpau-devel
  75. BuildRequires: libvorbis-devel
  76. %if %{?_dist_release} != "vl5"
  77. %{?with_libvpx:BuildRequires: libvpx-devel >= 0.9.6}
  78. %endif
  79. BuildRequires: lzo-devel >= 2
  80. BuildRequires: pulseaudio-lib-devel
  81. BuildRequires: speex-devel >= 1.1
  82. BuildRequires: twolame-devel
  83. BuildRequires: xorg-x11-devel
  84. BuildRequires: yasm
  85. BuildRequires: zlib-devel
  86. # *-devel packages provided by other self-build-* should only be listed
  87. # in self-build-%{name}.spec as PreReq.
  88. ##Requires: self-build-mplayer-codecs
  89. ##BuildRequires: self-build-libdvdcss
  90. ##BuildRequires: self-build-lame
  91. ##BuildRequires: self-build-libdca
  92. ##BuildRequires: self-build-x264 >= 0.0.0-15.20110322
  93. ##BuildRequires: self-build-xvidcore >= 0.9.2
  94. ##BuildRequires: self-build-faad2 >= 2.6.1
  95. ##BuildRequires: self-build-libmpeg2
  96. Requires: TrueType-vlgothic
  97. Requires: mesa-libGL
  98. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  99. %description
  100. MPlayer can play most standard video formats out of the box and almost
  101. all others with the help of external codecs.
  102. MPlayer currently works best from the command line, but visual feedback
  103. for many functions is available from its onscreen status display (OSD),
  104. which is also used for displaying subtitles.
  105. MPlayer also has a GUI with skin support and several unofficial alternative
  106. graphical frontends are available.
  107. MEncoder is a command line video encoder for advanced users that can
  108. be built from the MPlayer source tree. Unofficial graphical frontends
  109. exist but arenot included.
  110. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  111. support for some newer codecs are not yet inpmlemented.
  112. You should install mplayer-codecs package if you want to play videos
  113. using those new codecs.
  114. %description -l ja
  115. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  116. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  117. で再生できます。
  118. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、
  119. 多くの操作は字幕と同様に、
  120. オンスクリーン・ディスプレイ (OSD) によりその結果が画面上で確認できます。
  121. MPlayer には スキンを変更できる GUI も用意されていますし、
  122. また複数の非公式なフロントエンドも利用できます。
  123. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  124. 非公式な GUI フロントエンドもありますが、このパッケージには含まれていません。
  125. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  126. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  127. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  128. をインストールする必要があります。
  129. %prep
  130. #%setup -q -n MPlayer-%{version}%{extver}
  131. %setup -q -n mplayer-export-%{svndate}
  132. %patch2 -p1 -b .vine
  133. %patch8 -p1 -b .manlinks
  134. %patch14 -p1 -b .nodvdcss
  135. %{?with_ffmpeg:%patch18 -p1 -b .ffmpeg}
  136. # ## apply the DVB app. patches
  137. # unzip %{SOURCE100}
  138. # cat>ffmpeg<<EOF
  139. # Subproject commit 4f84e728dad84a366a2d183da03b7d92cb20fb23
  140. # EOF
  141. # %patch101 -p1 -b .vine
  142. # %patch102 -p1 -b .vine
  143. # %patch103 -p1 -b .vine
  144. # patch -p1 < mplayer-patches-%{dvbappver}/0004-improved-stream-selection-by-limiting-the-switch-wit.patch || exit 1
  145. # patch -p1 < mplayer-patches-%{dvbappver}/0005-extended-DVB-options-to-support-more-cards-and-speci.patch || exit 1
  146. # %patch106 -p1 -b .vine
  147. # %patch107 -p1 -b .vine
  148. # patch -p1 < mplayer-patches-%{dvbappver}/0008-supports-PMT-contents-change.patch || exit 1
  149. # patch -p1 < mplayer-patches-%{dvbappver}/0009-supports-video-frame-size-change.patch || exit 1
  150. # %patch111 -p1 -b .vine
  151. # patch -p1 < mplayer-patches-%{dvbappver}/ffmpeg/0002-add-support-for-audio-channel-reconfiguration.patch || exit 1
  152. # %patch113 -p1 -b .vine
  153. # patch -p1 < mplayer-patches-%{dvbappver}/ffmpeg/0004-fixed-sample-rate-calculation-in-SBR-AAC-HE_AAC.patch || exit 1
  154. %build
  155. ./configure \
  156. --prefix=%{_prefix} \
  157. --bindir=%{_bindir} \
  158. --datadir=%{_datadir}/mplayer \
  159. --mandir=%{_mandir} \
  160. --confdir=%{_sysconfdir}/mplayer \
  161. --libdir=%{_libdir} \
  162. \
  163. --extra-cflags="$RPM_OPT_FLAGS" \
  164. --language=ja,en \
  165. --enable-joystick \
  166. --enable-gui --enable-menu \
  167. --enable-radio --enable-radio-capture \
  168. --enable-runtime-cpudetection \
  169. \
  170. --disable-dvdread-internal \
  171. --disable-libdvdcss-internal \
  172. --disable-nemesi \
  173. \
  174. %{?with_ffmpeg:--disable-ffmpeg_a} %{!?with_ffmpeg:--disable-ffmpeg_so} \
  175. %{?_without_amr:--disable-libopencore_amrnb --disable-libopencore_amrwb} \
  176. %{!?with_faac:--disable-faac} \
  177. --disable-libmpeg2-internal \
  178. --disable-libopenjpeg \
  179. \
  180. --disable-bitmap-font \
  181. --disable-dga1 --disable-dga2 \
  182. --disable-directfb \
  183. --disable-svga \
  184. --disable-termcap \
  185. --enable-xvmc \
  186. --with-xvmclib=XvMCW \
  187. \
  188. --disable-arts --disable-esd --disable-jack --disable-openal \
  189. ;
  190. %{__make} V=1 %{?_smp_mflags}
  191. %install
  192. %{__rm} -rf ${RPM_BUILD_ROOT}
  193. %{__make} install INSTALLSTRIP= \
  194. prefix=${RPM_BUILD_ROOT}%{_prefix} \
  195. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  196. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  197. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  198. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  199. MANDIR=${RPM_BUILD_ROOT}%{_mandir} \
  200. ;
  201. ## install some default config files
  202. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  203. %{__install} -pm 644 etc/example.conf \
  204. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  205. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  206. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  207. # Icons
  208. install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  209. %__mv $RPM_BUILD_ROOT%{_datadir}/pixmaps/mplayer.png \
  210. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  211. # install default skin
  212. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  213. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  214. %{__tar} xjf %{SOURCE1}
  215. %{__ln_s} Blue default
  216. popd
  217. # make sybolic link to ttf font for subtitle
  218. for i in %{ttfontlist}; do
  219. if [ -e %{ttfontdir}/$i.ttf ];then
  220. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  221. break;
  222. fi;
  223. done
  224. ## install TOOLS
  225. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  226. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  227. done
  228. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  229. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  230. done
  231. for file in vobshift.py ; do
  232. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  233. done
  234. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  235. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  236. %clean
  237. %{__rm} -rf ${RPM_BUILD_ROOT}
  238. %post
  239. touch --no-create %{_datadir}/icons/hicolor
  240. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  241. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  242. fi
  243. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  244. %postun
  245. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  246. touch --no-create %{_datadir}/icons/hicolor
  247. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  248. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  249. fi || :
  250. %files
  251. %defattr(-,root,root)
  252. #%doc AUTHORS Changelog Copyright LICENSE README
  253. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  254. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  255. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  256. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  257. %{_bindir}/mplayer
  258. %{_bindir}/gmplayer
  259. %{_bindir}/mencoder
  260. %{_datadir}/mplayer/skins/Blue
  261. %{_datadir}/mplayer/skins/default
  262. %{_datadir}/mplayer/subfont.ttf
  263. %{_datadir}/applications/mplayer.desktop
  264. %{_datadir}/icons/hicolor/48x48/apps/mplayer.png
  265. %{_mandir}/man1/mplayer.1*
  266. %{_mandir}/man1/mencoder.1*
  267. ## TOOLS
  268. %{_bindir}/aconvert
  269. %{_bindir}/calcbpp
  270. %{_bindir}/countquant
  271. %{_bindir}/divx2svcd
  272. %{_bindir}/dvd2divxscript
  273. %{_bindir}/mencvcd
  274. %{_bindir}/midentify
  275. %{_bindir}/mpconsole
  276. %{_bindir}/qepdvcd
  277. %{_bindir}/subsearch
  278. %{_bindir}/vobshift
  279. %{_datadir}/mplayer/*.fp
  280. %changelog
  281. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
  282. - updated snapshot 20111217 (with ffmpeg 0.9)
  283. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
  284. - s/self-build-libdvdnav/libdvdnav/
  285. * Fri Oct 7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
  286. - updated %%SOURCE1
  287. - update to 1.8
  288. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
  289. - dropped BuildRequires: esound-devel
  290. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  291. - new upstream release
  292. - ready for Vine Linux 6
  293. - revived support for Vine Linux 5
  294. - added BuildRequires:
  295. - libass-devel
  296. - librtmp-devel >= 2.3
  297. - speex-devel >= 1.1
  298. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  299. - added BuildRequires:
  300. - aalib-devel
  301. - enca-devel
  302. - lzo-devel
  303. - speex-devel
  304. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  305. - updated fixed %{name}-config.patch
  306. - applied %{name}-config-20100709-vine.patch
  307. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  308. - change release to sync with self-build-mplayer
  309. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  310. - updated source snapshot 20100709
  311. - renamed %%Source10 to mplayer-snapshot-vine.sh
  312. - applied mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  313. - added BuildRequires: libvpx-devel >= 0.9.1
  314. * Sun Jun 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  315. - updated source snapshot 20100621
  316. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-35.20100615
  317. - updated source snapshot 20100615
  318. - added BuildRequires: libXinerama-devel
  319. - dropped vl4 support
  320. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-34.20100410
  321. - updated source snapshot 20100410
  322. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  323. - updated source snapshot 20100401
  324. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  325. - updated source snapshot 20100326
  326. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  327. - updated source snapshot 20100317
  328. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  329. - updated source snapshot 20100216
  330. - moved scripts from TOOLS
  331. - added --disable-libopenjpeg in configure options
  332. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  333. - updated source snapshot 20100201
  334. - dropped obsolete patches
  335. - added BuildRequires:
  336. - libvdpau-devel
  337. - libXScrnSaver-devel
  338. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  339. - update mplayer-config-20091215-vine.patch
  340. - update mplayer-20091215-x86_32-compile.patch
  341. - added --enable-runtime-cpudetection in configure options
  342. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  343. - source snapshot 20091031
  344. - updated mplayer-20091031-x86_32-compile.patch
  345. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  346. - source snapshot 20091003
  347. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  348. - change release to sync with self-build-mplayer
  349. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  350. - source snapshot 20090905
  351. - added settings for vl6
  352. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  353. - source snapshot 20090821
  354. - replaced BR: libungif-devel with BR: giflib-devel
  355. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  356. - source snapshot 20090722
  357. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  358. - source snapshot 20090702
  359. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  360. - source snapshot 20090611
  361. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  362. - added Requires: TrueType-vlgothic
  363. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  364. - source snapshot 20090522
  365. - build with x264 >= 0.0.0-9.20090522
  366. - updated mplayer-20090522-nodvdcss.patch
  367. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  368. - change release to sync with self-build-mplayer
  369. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  370. - source snapshot 20090502
  371. - updated mplayer-20090503-x86_32-compile.patch
  372. - updated mplayer-20090502-nodvdcss.patch
  373. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  374. - applied mplayer-config-vine.patch
  375. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  376. - source snapshot 20090327
  377. - updated mplayer-20090327-x86_32-compile.patch
  378. - updated mplayer-20090325-nodvdcss.patch
  379. - dropped gmplayer-about-vine.patch
  380. - install some default config files
  381. - added configure options:
  382. - --disable-termcap
  383. - --enable-xvmc
  384. - --with-xvmclib=XvMCW
  385. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  386. - fixed %%files for *.conf
  387. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  388. - source snapshot 20090305
  389. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  390. - source snapshot 20090227
  391. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  392. - source snapshot 20090216
  393. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  394. - source snapshot 20090206
  395. - dropped mplayer-man-zh_CN.patch
  396. - updated mplayer-20090206-nodvdcss.patch
  397. - changed to PreReq: self-build-faad2 from faad2-devel
  398. - added PreReq: self-build-libmad
  399. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  400. - source snapshot 20090131
  401. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  402. - change release to sync with self-build-mplayer
  403. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  404. - source snapshot
  405. - update mplayer-20090122-nodvdcss.patch
  406. - added BuildRequires:
  407. - faad2-devel
  408. - libmpcdec-devel
  409. - twolame-devel
  410. - yasm
  411. - faac-devel (as PreReq in self-build-%{name})
  412. - lame-devel (as PreReq in self-build-%{name})
  413. - libdca-devel (as PreReq in self-build-%{name})
  414. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  415. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  416. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  417. - source snapshot
  418. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  419. --disable-faad-internal in configure options
  420. - dropped gmplayer-add-flv-extension.patch
  421. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  422. - source snapshot
  423. - fixed License
  424. - added some patches from RPM Fusion
  425. - updated gmplayer-about-vine.patch for 20081001 snapshot
  426. - added BuildRequires: libdvdread
  427. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  428. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  429. in configure options
  430. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  431. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  432. - fixed License
  433. - added some devel packages to support OpenGL
  434. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  435. - spec in utf8
  436. - fix sybolic link of subfont for vl5
  437. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  438. - add "Patch105: CVE-2008-1558.patch".
  439. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  440. - build with new versioning policy.
  441. - fix Source[01] URLs.
  442. - add "Patch200: gmplayer-about-vine.patch".
  443. - add "Patch201: gmplayer-add-flv-extension.patch".
  444. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  445. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  446. CVE-2008-0629, CVE-2008-0630)
  447. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  448. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  449. - change source download URL. <BTS:VineLinux:603>
  450. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  451. - fix CONFDIR for make install. <BTS:wishes:33>
  452. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  453. - initial build for Vine Linux