self-build-mplayer-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458
  1. %global with_faac 1
  2. %global with_vaapi 1
  3. %global with_libvpx 1
  4. # define with_ffmpeg 1
  5. %global pkgname mplayer
  6. %global name self-build-%{pkgname}
  7. %global version 1.0
  8. #% global extver rc4
  9. %global svndate 20111210
  10. %global release 45%{?extver:.%extver}%{?svndate:.%svndate}%{?_dist_release}
  11. %global source0path MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  12. %global source1path MPlayer/skins/Blue-1.8.tar.bz2
  13. Summary: Package to automatically build %{pkgname} rpm package
  14. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  15. Name: %{name}
  16. Version: %{version}
  17. Release: %{release}
  18. Source0: %{pkgname}-vl.spec
  19. Source10: %{pkgname}-snapshot-vine.sh
  20. #Source102: %{pkgname}-config.patch
  21. Source102: %{pkgname}-config-20111217-vine.patch
  22. Source108: %{pkgname}-manlinks.patch
  23. Source114: %{pkgname}-nodvdcss.patch
  24. Source118: %{pkgname}-ffmpeg.patch
  25. Source150: mplayer-20100709-fixed-vo_x11_create_vo_window.patch
  26. License: GPLv2+
  27. Group: Restricted Software
  28. Requires(post): self-build-setup >= 0.9.9
  29. Requires(post): subversion
  30. # (build)requies of target package.
  31. Requires(post): SDL-devel
  32. Requires(post): aalib-devel
  33. Requires(post): alsa-lib-devel
  34. Requires(post): cdparanoia-devel
  35. Requires(post): desktop-file-utils
  36. Requires(post): libdvdnav-devel
  37. Requires(post): enca-devel
  38. Requires(post): freetype2-devel >= 2.0.9
  39. Requires(post): fribidi-devel
  40. Requires(post): fontconfig-devel
  41. Requires(post): giflib-devel
  42. Requires(post): gtk2-devel
  43. Requires(post): mesa-libGL-devel
  44. Requires(post): libXinerama-devel
  45. Requires(post): libXScrnSaver-devel
  46. Requires(post): libXv-devel
  47. Requires(post): libXvMC-devel
  48. Requires(post): libXxf86dga-devel
  49. Requires(post): libXxf86vm-devel
  50. Requires(post): libass-devel
  51. Requires(post): libpng-devel
  52. Requires(post): libjpeg-devel
  53. Requires(post): libdvdread
  54. Requires(post): libmpcdec-devel >= 1.2.1
  55. Requires(post): librtmp-devel >= 2.3
  56. Requires(post): speex-devel >= 1.1
  57. %if %{?_dist_release} != "vl5"
  58. %{?with_vaapi:Requires(post):libva-devel}
  59. %endif
  60. Requires(post): libvdpau-devel
  61. Requires(post): libvorbis-devel
  62. %if %{?_dist_release} != "vl5"
  63. %{?with_libvpx:Requires(post): libvpx-devel >= 0.9.6}
  64. %endif
  65. Requires(post): lzo-devel >= 2
  66. Requires(post): pulseaudio-lib-devel
  67. Requires(post): speex-devel >= 1.1
  68. Requires(post): twolame-devel
  69. Requires(post): xorg-x11-devel
  70. Requires(post): yasm
  71. Requires(post): zlib-devel
  72. Requires(post): self-build-mplayer-codecs
  73. Requires(post): self-build-libdvdcss
  74. Requires(post): self-build-faac
  75. Requires(post): self-build-faad2 >= 2.6.1
  76. Requires(post): self-build-lame
  77. Requires(post): self-build-libdca
  78. Requires(post): self-build-libmad
  79. %if %{?_dist_release} != "vl5"
  80. Requires(post): self-build-x264 >= 0.0.0-18.20111216
  81. %elseif %{?_dist_release} == "vl5"
  82. Requires(post): self-build-x264 >= 0.0.0-9.20090522
  83. %endif
  84. Requires(post): self-build-xvidcore >= 0.9.2
  85. Requires(post): self-build-libmpeg2
  86. Requires: TrueType-vlgothic
  87. Requires: mesa-libGL
  88. BuildArch: noarch
  89. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  90. Packager: munepi
  91. %description
  92. MPlayer can play most standard video formats out of the box and almost
  93. all others with the help of external codecs.
  94. MPlayer currently works best from the command line, but visual feedback
  95. for many functions is available from its onscreen status display (OSD),
  96. which is also used for displaying subtitles.
  97. MPlayer also has a GUI with skin support and several unofficial alternative
  98. graphical frontends are available.
  99. MEncoder is a command line video encoder for advanced users that can
  100. be built from the MPlayer source tree. Unofficial graphical frontends
  101. exist but arenot included.
  102. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  103. support for some newer codecs are not yet inpmlemented.
  104. You should install mplayer-codecs package if you want to play videos
  105. using those new codecs.
  106. Additional function is automatically included if following
  107. packages are installed in advance.
  108. samba-libsmbclient-devel: SMB file system support
  109. [Note]
  110. This package requires many other packages to compile
  111. targetsoftware. So it consume more disk space than usual.
  112. Also installation takes logner time because of compilation.
  113. (This will take a few minutes to quarter or half of an hour,
  114. depends on building environment)
  115. [About self-build package]
  116. For some kind of software, distributing of binary package
  117. may viorate the patent or law. Therefore we chose self-build
  118. packge, create binary package on your machine, for such kind
  119. of softwares instead of distributing binary package.
  120. Please obey the national law when you use the created binary
  121. packages. And if you want to use the softwares using patented
  122. thechnology, it may be required to get a permission, make an
  123. agreement or purchas a license. Please consider it with your
  124. purpose or way of use and take appropriate action.
  125. %description -l ja
  126. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  127. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  128. で再生できます。
  129. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
  130. は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
  131. 面上で確認できます。
  132. MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
  133. 非公式なフロントエンドも利用できます。
  134. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  135. 非公式な GUI フロントエンドもありますが、このパッケージには含まれて
  136. いません。
  137. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  138. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  139. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  140. をインストールする必要があります。
  141. このパッケージより前に以下の関連パッケージをインストールして
  142. おくと、%{pkgname} が対応できる機能が自動的に追加されます。
  143. samba-libsmbclient-devel: SMB ファイルシステムのサポート
  144. [注意]
  145. コンパイルに必要な多くの関連パッケージを要求するので通常より
  146. ディスクの領域を多く消費します。
  147. またインストール時にコンパイルを行うため、通常より時間がかか
  148. る場合があります。(環境にもよりますが数分から数十分程度)
  149. [self-build パッケージについて]
  150. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  151. 違反する可能性があるものがあります。その為、このような問題が
  152. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  153. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  154. ジという方法を採っています。
  155. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  156. アのライセンス、および利用する国の各種法令に従ってください。
  157. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  158. センスの購入などが必要となる場合がありますので、利用する目的
  159. や形態に応じて各自で判断し適切な対応を取ってください。
  160. %prep
  161. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  162. %install
  163. %{__rm} -rf ${RPM_BUILD_ROOT}
  164. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  165. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  166. %{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  167. %{__install} -m 644 \
  168. %{SOURCE102} %{SOURCE108} %{SOURCE114} %{SOURCE118} \
  169. ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  170. %clean
  171. %{__rm} -rf ${RPM_BUILD_ROOT}
  172. %posttrans
  173. # ## official tarball
  174. # /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  175. # http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source0path} \
  176. # http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
  177. # 635000
  178. # exit 0
  179. ## svn checkout
  180. # set locale
  181. case $LANG in
  182. ja*)LOCALE=ja ;;
  183. *) LOCALE=C ;;
  184. esac
  185. GetSrc_C(){
  186. echo -n " "
  187. echo "Download source file with Subversion..."
  188. }
  189. GetSrc_ja(){
  190. echo -n " "
  191. echo "Subversion を用いてソースファイルをダウンロードしています..."
  192. }
  193. GetSrc_$LOCALE
  194. # svn checkout
  195. . /etc/self-build.conf
  196. (cd $TEMP_DIR
  197. su $BUILD_USER -c "/bin/bash %{_datadir}/%{name}/%{pkgname}-snapshot-vine.sh >/dev/null 2>&1 || exit 1"
  198. %__mv %{pkgname}-export-%{svndate}.tar.xz %{_datadir}/%{name}/ || exit 1
  199. )
  200. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  201. http://www{,1,2,3,4,5,7,8,9}.mplayerhq.hu/%{source1path} \
  202. 635000
  203. %files
  204. %defattr(-,root,root)
  205. %{_datadir}/%{name}
  206. %changelog
  207. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-45.20111217
  208. - updated snapshot 20111217 (with ffmpeg 0.9)
  209. * Wed Nov 2 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-44.rc4
  210. - s/self-build-libdvdnav/libdvdnav/
  211. * Fri Oct 7 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-43.rc4
  212. - updated %%source1path
  213. - update to 1.8
  214. * Sun Jun 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-42.rc4
  215. - dropped Requires(post): esound-devel
  216. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-41.rc4
  217. - new upstream release
  218. - ready for Vine Linux 6
  219. - revived support for Vine Linux 5
  220. - added Requires(post):
  221. - libass-devel
  222. - librtmp-devel >= 2.3
  223. - speex-devel >= 1.1
  224. * Tue Feb 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-40.20100709
  225. - added BuildRequires:
  226. - aalib-devel
  227. - enca-devel
  228. - lzo-devel
  229. - speex-devel
  230. * Sun Jul 25 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-39.20100709
  231. - updated fixed %{name}-config.patch
  232. - applied %{name}-config-20100709-vine.patch
  233. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-38.20100709
  234. - unpacked source archives
  235. * Sat Jul 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-37.20100709
  236. - updated source snapshot 20100709
  237. - renamed %%Source10 to mplayer-snapshot-vine.sh
  238. - added Requires(post): libva-devel, libvpx-devel >= 0.9.1
  239. - dropped vl4 support
  240. - updated %%description
  241. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-36.20100621
  242. - updated source snapshot 20100621
  243. - added Requires(post): libXinerama-devel
  244. - dropped vl4 support
  245. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  246. - updated source snapshot 20100401
  247. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  248. - updated source snapshot 20100317
  249. - renamed %%{Source0} to mplayer-vl.spec
  250. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  251. - updated source snapshot 20100216
  252. - dropped obsolete patches
  253. - added Requires(post): libvdpau-devel libXScrnSaver-devel
  254. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  255. - update mplayer-config-20091215-vine.patch
  256. - update mplayer-20091215-x86_32-compile.patch
  257. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  258. - source snapshot 20091031
  259. - updated mplayer-20091031-x86_32-compile.patch
  260. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  261. - source snapshot 20091003
  262. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  263. - added some if conditions for "vl6"
  264. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  265. - source snapshot 20090905
  266. - added settings for vl6
  267. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  268. - source snapshot 20090821
  269. - replaced BR: libungif-devel with BR: giflib-devel
  270. - mentioned VDPAU support in %%description
  271. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  272. - source snapshot 20090722
  273. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  274. - source snapshot 20090702
  275. - check version between original spec and self-build spec in %%prep
  276. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  277. - source snapshot 20090611
  278. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  279. - added Requires: TrueType-vlgothic
  280. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  281. - source snapshot 20090522
  282. - build with x264 >= 0.0.0-9.20090522
  283. - updated mplayer-20090502-nodvdcss.patch
  284. - avoided to execute self-build-rpm.sh on RPM transaction
  285. - moved %%post actions to %%posttrans
  286. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  287. - added PreReq: self-build-mplayer-codecs
  288. * Tue May 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  289. - added BuildArch: noarch
  290. - source snapshot 20090502
  291. - updated mplayer-20090503-x86_32-compile.patch
  292. - updated mplayer-20090502-nodvdcss.patch
  293. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  294. - included source archives:
  295. - mplayer-export-20090327.tar.bz2
  296. - Blue-1.7.tar.bz2
  297. - applied mplayer-config-vine.patch
  298. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  299. - source snapshot 20090327
  300. - updated mplayer-20090327-x86_32-compile.patch
  301. - updated mplayer-20090325-nodvdcss.patch
  302. - dropped gmplayer-about-vine.patch
  303. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  304. - source snapshot 20090206
  305. - dropped mplayer-man-zh_CN.patch
  306. - updated mplayer-20090206-nodvdcss.patch
  307. - changed to PreReq: self-build-faad2 from faad2-devel
  308. - added PreReq: self-build-libmad
  309. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  310. - source snapshot 20090131
  311. - fixed %%files section
  312. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  313. - fixed %%post: added rm -f "$pwd"/%{pkgname}-export-%{svndate}.tar.bz2
  314. * Sun Jan 25 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  315. - source snapshot
  316. - update mplayer-nodvdcss.patch: mplayer-20090122-nodvdcss.patch
  317. - added PreReq:
  318. - faad2-devel
  319. - libmpcdec-devel
  320. - twolame-devel
  321. - yasm
  322. - self-build-libdvdcss
  323. - self-build-libdvdnav
  324. - self-build-faac
  325. - self-build-lame
  326. - self-build-libdca
  327. - self-build-x264 >= 0.0.0-4.20090110
  328. - self-build-xvidcore >= 0.9.2
  329. - move %%define source0Exists() from %%post section to header
  330. - fixed %%post section: clean up source archive
  331. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  332. - source snapshot
  333. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  334. --disable-faad-internal in configure options
  335. - dropped gmplayer-add-flv-extension.patch
  336. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  337. - source snapshot
  338. - fixed License
  339. - added some patches from RPM Fusion
  340. - updated gmplayer-about-vine.patch for 20081001 snapshot
  341. - added BuildRequires: libdvdread
  342. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  343. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  344. in configure options
  345. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  346. - added PreReq: subversion
  347. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  348. - fixed License
  349. - added some devel packages to support OpenGL
  350. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  351. - spec in utf8
  352. - fix sybolic link of subfont for vl5
  353. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  354. - add "Source105: CVE-2008-1558.patch".
  355. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  356. - build with new versioning policy.
  357. - add "Source200: gmplayer-about-vine.patch".
  358. - add "Source201: gmplayer-add-flv-extension.patch".
  359. - fix <BTS:VineLinux:603>.
  360. - add ">= 0.7-1vl4" to "PreReq: self-build-setup".
  361. - add mirror URLs to self-build-rpm.sh.
  362. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  363. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  364. CVE-2008-0629, CVE-2008-0630)
  365. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  366. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  367. - change source download URL. <BTS:VineLinux:603>
  368. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  369. - fix CONFDIR for make install in mplayer.spec. <BTS:wishes:33>
  370. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  371. - initial build for Vine Linux.