gedit-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620
  1. %{!?python3_sitearch: %define python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
  2. %define glib2_version 2.48.0
  3. %define gtk3_version 3.20.0
  4. %define desktop_file_utils_version 0.17
  5. %define gtksourceview3_version 3.20.0
  6. Summary: gedit is a small but powerful text editor for GNOME.
  7. Summary(ja): GNOME 用の小さくかつ強力なテキストエディタ
  8. Name: gedit
  9. Version: 3.20.2
  10. Release: 1%{?_dist_release}
  11. License: GPLv2
  12. Group: Applications/Editors
  13. Source0: http://ftp.gnome.org/pub/GNOME/sources/gedit/3.20/%{name}-%{version}.tar.xz
  14. URL: http://gedit.sourceforge.net/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. Requires: pygobject3
  17. BuildRequires: glib2-devel >= %{glib2_version}
  18. BuildRequires: gtk3-devel >= %{gtk3_version}
  19. BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
  20. BuildRequires: gtksourceview3-devel >= %{gtksourceview3_version}
  21. BuildRequires: pygobject3-devel
  22. BuildRequires: python3-pygobject
  23. BuildRequires: perl-XML-Parser
  24. BuildRequires: libattr-devel
  25. BuildRequires: libffi-devel
  26. BuildRequires: libSM-devel
  27. BuildRequires: libpeas-devel >= 0.7.3
  28. BuildRequires: gsettings-desktop-schemas-devel
  29. BuildRequires: yelp-tools
  30. BuildRequires: intltool > 0.40
  31. BuildRequires: autoconf
  32. BuildRequires: gnome-common
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: daisuke, inagaki, Takemikaduchi
  36. %description
  37. gedit is a small but powerful text editor designed specifically for
  38. the GNOME GUI desktop. gedit includes a plug-in API (which supports
  39. extensibility while keeping the core binary small), support for
  40. editing multiple documents using notebook tabs, and standard text
  41. editor functions.
  42. You will need to have GNOME and GTK+ installed to use gedit.
  43. %description -l ja
  44. gedit は GNOME 用の小さく、それでいて、強力なテキストエディタです。
  45. これは、コア部分は小さいままに、geditに対し多くの機能を拡張
  46. できるようにするための(画面分割モード等の)プラグインの機能や、
  47. 『タブ』ノートブックを利用した複数のドキュメント編集、そして、
  48. その他多くの機能を備えています。
  49. gedit には GNOME と GTK+2 が必要です
  50. %package python3-plugins
  51. Summary: The python3 plugins for gedit
  52. Summary(ja): gedit エディタ用 python3 プラグイン集
  53. Group: Applications/Editors
  54. Requires: %{name} = %{version}-%{release}
  55. Requires: python3-pygobject
  56. %description python3-plugins
  57. %{summary}
  58. %package devel
  59. Summary: The files needed for developing plug-ins for the gedit editor.
  60. Summary(ja): gedit エディタ用のプラグイン開発
  61. Group: Development/Libraries
  62. Requires: %{name} = %{version}-%{release}
  63. Requires: gtksourceview3-devel >= %{gtksourceview3_version}
  64. %description devel
  65. gedit is a small but powerful text editor for the GNOME GUI desktop.
  66. This package allows you to develop plug-ins that work within gedit.
  67. Install gedit-devel if you want to write plug-ins for gedit.
  68. %description -l ja devel
  69. gedit は GNOME 用の小さく、それでいて、強力なテキストエディタです。
  70. このパッケージを用いてgedit内で動くプラグインを開発することができます。
  71. gedit のプラグインを開発する場合には gedit-devel をインストールしてください。
  72. %prep
  73. %setup -n gedit-%{version} -q
  74. %build
  75. %configure \
  76. --disable-schemas-install \
  77. --disable-spell \
  78. --disable-updater \
  79. --enable-attr
  80. make %{?_smp_mflags}
  81. %install
  82. rm -rf $RPM_BUILD_ROOT
  83. make DESTDIR=$RPM_BUILD_ROOT install
  84. desktop-file-install --delete-original \
  85. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  86. --add-only-show-in GNOME \
  87. $RPM_BUILD_ROOT%{_datadir}/applications/*
  88. ## clean up all the static libs for plugins (workaround for no -module)
  89. /bin/rm -f `find $RPM_BUILD_ROOT%{_libdir}/%{name}/plugin-loaders -name "*.la"`
  90. /bin/rm -f `find $RPM_BUILD_ROOT%{_libdir}/%{name}/plugins -name "*.la"`
  91. /bin/rm -f `find $RPM_BUILD_ROOT%{_libdir} -name "*.la"`
  92. ## clean up unpackage files
  93. #/bin/rm -rf $RPM_BUILD_ROOT%{_includedir}/gedit-2.20
  94. /bin/rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/gedit
  95. /bin/rm -rf $RPM_BUILD_ROOT%{_libexecdir}/gedit
  96. %find_lang %{name}
  97. %clean
  98. rm -rf $RPM_BUILD_ROOT
  99. %post
  100. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  101. %postun
  102. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  103. glib-compile-schemas %{_datadir}/glib-2.0/schemas >& /dev/null ||:
  104. gtk-update-icon-cache %{_datadir}/icons/hicolor >& /dev/null || :
  105. %posttrans
  106. glib-compile-schemas %{_datadir}/glib-2.0/schemas >& /dev/null ||:
  107. gtk-update-icon-cache %{_datadir}/icons/hicolor >& /dev/null || :
  108. %postun python3-plugins
  109. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  110. %posttrans python3-plugins
  111. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  112. %files -f %{name}.lang
  113. %defattr(-, root, root)
  114. %doc AUTHORS COPYING ChangeLog NEWS README
  115. %{_bindir}/gedit
  116. %{_bindir}/gnome-text-editor
  117. %{_libdir}/%{name}/libgedit.so
  118. %{_libdir}/%{name}/girepository-1.0/*.typelib
  119. %dir %{_libdir}/%{name}/plugins
  120. %{_libdir}/gedit/plugins/docinfo.plugin
  121. %{_libdir}/gedit/plugins/filebrowser.plugin
  122. %{_libdir}/gedit/plugins/libdocinfo.so
  123. %{_libdir}/gedit/plugins/libfilebrowser.so
  124. %{_libdir}/gedit/plugins/libmodelines.so
  125. %{_libdir}/gedit/plugins/libsort.so
  126. %{_libdir}/gedit/plugins/libtime.so
  127. %{_libdir}/gedit/plugins/modelines.plugin
  128. %{_libdir}/gedit/plugins/sort.plugin
  129. %{_libdir}/gedit/plugins/time.plugin
  130. %{_datadir}/GConf/gsettings/gedit.convert
  131. %{_datadir}/appdata/org.gnome.gedit.appdata.xml
  132. %{_datadir}/applications/org.gnome.gedit.desktop
  133. %{_datadir}/dbus-1/services/org.gnome.gedit.service
  134. %dir %{_datadir}/%{name}/plugins
  135. %{_datadir}/gedit/plugins/modelines
  136. %{_datadir}/glib-2.0/schemas/org.gnome.gedit.enums.xml
  137. %{_datadir}/glib-2.0/schemas/org.gnome.gedit.gschema.xml
  138. %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.filebrowser.enums.xml
  139. %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.filebrowser.gschema.xml
  140. %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.time.enums.xml
  141. %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.time.gschema.xml
  142. %{_datadir}/help/*/%{name}
  143. %{_datadir}/icons/*/*/*/*
  144. %{_mandir}/man1/*
  145. %files python3-plugins
  146. %defattr(-, root, root)
  147. %{python3_sitearch}/gi/overrides/Gedit.*
  148. %{python3_sitearch}/gi/overrides/__pycache__/Gedit.cpython-*
  149. %{_libdir}/gedit/plugins/externaltools
  150. %{_libdir}/gedit/plugins/externaltools.plugin
  151. %{_libdir}/gedit/plugins/pythonconsole
  152. %{_libdir}/gedit/plugins/pythonconsole.plugin
  153. %{_libdir}/gedit/plugins/quickopen
  154. %{_libdir}/gedit/plugins/quickopen.plugin
  155. %{_libdir}/gedit/plugins/snippets
  156. %{_libdir}/gedit/plugins/snippets.plugin
  157. %{_datadir}/gedit/plugins/externaltools
  158. %{_datadir}/gedit/plugins/pythonconsole
  159. %{_datadir}/gedit/plugins/snippets
  160. %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.externaltools.gschema.xml
  161. %{_datadir}/glib-2.0/schemas/org.gnome.gedit.plugins.pythonconsole.gschema.xml
  162. %files devel
  163. %defattr(-, root, root)
  164. %{_includedir}/%{name}-3.14
  165. %{_libdir}/pkgconfig/*.pc
  166. %{_datadir}/%{name}/gir-1.0/*.gir
  167. %changelog
  168. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.2-1
  169. - new upstream release
  170. * Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.3-1
  171. - new upstream release
  172. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  173. - new upstream release
  174. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  175. - new upstream release
  176. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
  177. - new upstream release
  178. * Sat May 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
  179. - new upstream release
  180. * Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  181. - new upstream release
  182. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  183. - new upstream release
  184. * Sun Feb 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.3-1
  185. - new upstream release
  186. * Mon Jan 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-2
  187. - rebuild with python-3.4.2
  188. * Wed Nov 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
  189. - new upstream release
  190. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  191. - new upstream release
  192. * Sat Jun 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
  193. - new upstream release
  194. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  195. - new upstream release
  196. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  197. - new upstream release
  198. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.4-1
  199. - new upstream release
  200. * Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.3-1
  201. - new upstream release
  202. * Sat Nov 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
  203. - new upstream release
  204. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.1-1
  205. - new upstream release
  206. - add BuildRequires: python3-pygobject-devel
  207. - create python3-plugins subpackage
  208. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.3-1
  209. - new upstream release
  210. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
  211. - new upstream release
  212. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  213. - new upstream release
  214. - add BuildRequires: autoconf, gnome-common
  215. * Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-1
  216. - new upstream release
  217. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  218. - new upstream release
  219. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  220. - new upstream release
  221. - change BuildRequires: yelp-tools instead of gnome-doc-utils
  222. * Tue Jun 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  223. - new upstream release
  224. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  225. - new upstream release
  226. - add BuildRequires: itstool, pygobject3-devel
  227. - remove BuildRequires: GConf2-devel
  228. * Sat Jan 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.6-1
  229. - new upstream release
  230. * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.5-1
  231. - new upstream release
  232. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.3-1
  233. - new upstream release
  234. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  235. - new upstream release
  236. * Thu Sep 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  237. - new upstream release
  238. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.6-1
  239. - new upstream release
  240. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
  241. - new upstream release
  242. - change BuildRequires: gtk3-devel instead of gtk2-devel
  243. - change BuildRequires: gtksourceview3-devel instead of gtksourceview2-devel
  244. - add BuildRequires: libpeas-devel, gsettings-desktop-schemas
  245. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
  246. - new upstream release
  247. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-2
  248. - rebuild with rpm-4.8.1 for pkg-config file
  249. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
  250. - new upstream release
  251. * Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  252. - new upstream release
  253. * Fri Apr 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  254. - new upstream release
  255. - add BuildRequires: libSM-devel
  256. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.2-3
  257. - rebuilt with python-2.6.4-3
  258. * Tue Dec 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-2
  259. - split devel package
  260. - added Requires: gtksourceview2 to devel package (<BTS:831>)
  261. * Sat Nov 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.2-1
  262. - new upstream release
  263. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  264. - new upstream release
  265. - dropped Patch1 (merged into upstream)
  266. - added --disable-updater
  267. * Sun Aug 2 2009 Kazutaka HARADA <toshi.kd2@gmail.com> 2.26.3-1
  268. - new upstream release
  269. - added BuildRequires: libffi-devel
  270. * Fri Jun 19 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.26.2-2
  271. - add Patch1 to fix errors on external tools (<BTS:VineLinux:710>)
  272. - add BuildRequires: libattr-devel
  273. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  274. - new upstream release
  275. * Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-2
  276. - s/gEdit/gedit in Summary/Description
  277. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  278. - new upstream release
  279. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  280. - new upstream release
  281. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.1-1
  282. - new upstream release
  283. * Sat Oct 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-3
  284. - add Requires: pygobject >= 2.15.4
  285. * Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.0-2
  286. - drop --vendor=gnome option when executing desktop-file-install
  287. * Thu Sep 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  288. - new upstream release
  289. * Sat Jul 19 2008 Shu KONNO <owa@bg.wakwak.com> 2.22.1-2vl5
  290. - added lBuildRequires: perl-XML-Parser
  291. - rebuilt with python-2.5.2
  292. * Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  293. - new upstream release
  294. - added BuildRequires: pygtksourceview-devel
  295. * Sat Aug 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.18.2-0vl2
  296. - add BuildRequires: pygobject-devel, gnome-python-desktop
  297. because of adding --enable-python
  298. (TODO: moving to pygobjects and gnome-python-desktop to main or not?)
  299. * Wed Aug 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  300. - new upstream release
  301. - added --enable-python option
  302. * Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.1-0vl1
  303. - new upstream release
  304. * Sat Jun 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
  305. - new upstream release
  306. * Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
  307. - temporarily disabled patch10 which has encoding detection bugs.
  308. * Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
  309. - new upstream release
  310. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  311. - new upstream release
  312. * Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.93-0vl1
  313. - new upstream release
  314. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  315. - new upstream release
  316. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  317. - new upstream release
  318. - forwardport Patch10 from Vine Linux 3.2.
  319. * Mon Apr 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  320. - new upstream release
  321. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  322. - new upstream release
  323. * Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  324. - new upstream version
  325. * Tue Mar 08 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl2
  326. - fixed to include message catalogs
  327. * Sat Mar 05 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-0vl1
  328. - new upstream release
  329. * Tue Nov 09 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  330. - new upstream release
  331. * Sat Feb 14 2004 Tomoya TAKA <taka@vinelinux.org> 2.4.1-0vl2
  332. - add Patch0, fix type mismatch in gedit_document_load()
  333. * Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  334. - new upstream release
  335. * Tue Oct 07 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
  336. - add missing files to %%files
  337. * Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  338. - new upstream release
  339. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl2
  340. - remove obsolete ja.po
  341. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.5-0vl1
  342. - new upstream release
  343. * Mon Jun 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  344. - new upstream release
  345. - update ja.po
  346. * Thu Apr 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  347. - new upstream release
  348. - update ja.po
  349. * Tue Jan 28 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  350. - new upstream release
  351. * Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.91-0vl1
  352. - new upstream release
  353. * Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl2
  354. - add updated ja.po
  355. * Thu Jan 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
  356. - new upstream release
  357. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  358. - new upstream release
  359. - build for Vine Linux
  360. * Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
  361. - Add missing bonobo server files (#71261, Taco Witte)
  362. - Remove empty NEWS, FAQ files from %%doc (#66079)
  363. * Thu Aug 1 2002 Havoc Pennington <hp@redhat.com>
  364. - fix desktop file really
  365. * Thu Aug 1 2002 Havoc Pennington <hp@redhat.com>
  366. - fix desktop file
  367. * Mon Jul 29 2002 Havoc Pennington <hp@redhat.com>
  368. - 2.0.2
  369. - build with new gail
  370. * Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
  371. - 2.0.1
  372. * Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
  373. - 2.0.0, fix missing locale files
  374. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  375. - 1.199.0
  376. - use desktop-file-install
  377. - remove static libs from plugins dir
  378. * Sat Jun 08 2002 Havoc Pennington <hp@redhat.com>
  379. - rebuild in different environment
  380. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  381. - 1.121.1
  382. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  383. - automated rebuild
  384. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  385. - rebuild in different environment
  386. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  387. - 1.120.0
  388. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  389. - 1.118.0
  390. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  391. - move to gnome 2 version
  392. * Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
  393. - fix ko.po
  394. * Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
  395. - get correct po files from elvis
  396. * Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
  397. - gedit-pofiles.tar.gz, not gedit-po.tar.gz
  398. * Mon Apr 15 2002 Havoc Pennington <hp@redhat.com>
  399. - merge translations
  400. * Fri Mar 29 2002 Havoc Pennington <hp@redhat.com>
  401. - gettextize default font
  402. * Thu Mar 28 2002 Havoc Pennington <hp@redhat.com>
  403. - more multibyte fixes #61948
  404. * Wed Mar 27 2002 Havoc Pennington <hp@redhat.com>
  405. - 0.9.7 for multibyte support
  406. * Tue Mar 26 2002 Akira TAGOH <tagoh@redhat.com> 0.9.4-11
  407. - gedit-0.9.4-printprefs.patch: I forgot to add to POTFILES.in...
  408. - gedit-po.tar.gz: added. it's on CVS now.
  409. * Sun Mar 24 2002 Akira TAGOH <tagoh@redhat.com> 0.9.4-10
  410. - gedit-0.9.4-printprefs.patch: fix typo and sanity check.
  411. * Mon Mar 04 2002 Akira TAGOH <tagoh@redhat.com> 0.9.4-9
  412. - Applied a font selector patch for the printing
  413. - fix BuildRequires for automake-1.4
  414. * Mon Jan 28 2002 Havoc Pennington <hp@redhat.com>
  415. - rebuild in rawhide
  416. - fix up cflags for moved gnome headers
  417. * Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
  418. - add some more build requires
  419. * Tue Jul 17 2001 Havoc Pennington <hp@redhat.com>
  420. - require libglade-devel to build
  421. * Fri Jun 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  422. - rebuild in new environment
  423. * Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
  424. - Fixed preview for !ja locale.
  425. * Wed Feb 07 2001 Akira TAGOH <tagoh@redhat.com>
  426. - Fixed handling fontset. (Bug#24998)
  427. - Added print out for multibyte patch.
  428. * Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
  429. - 0.9.4
  430. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  431. - Up Epoch and release
  432. * Wed Aug 09 2000 Jonathan Blandford <jrb@redhat.com>
  433. - include glade files so that it will actually work.
  434. * Tue Aug 01 2000 Jonathan Blandford <jrb@redhat.com>
  435. - upgrade package to newer version at request of author.
  436. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  437. - automatic rebuild
  438. * Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
  439. - FHS paths
  440. * Sun Jun 11 2000 Jonathan Blandford <jrb@redhat.com>
  441. - update to 0.7.9. Somewhat untested.
  442. * Fri Feb 11 2000 Jonathan Blandford <jrb@redhat.com>
  443. - removed "reverse search function as it doesn't work.
  444. * Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
  445. - rebuild to gzip man pages
  446. * Mon Jan 17 2000 Elliot Lee <sopwith@redhat.com>
  447. - If I don't put in a log entry here, people will be very upset about not
  448. being able to find out that I am to blame for the 0.6.1 upgrade
  449. * Mon Aug 16 1999 Michael Fulbright <drmike@redhat.com>
  450. - version 0.5.4
  451. * Sat Feb 06 1999 Michael Johnson <johnsonm@redhat.com>
  452. - Cleaned up a bit for Red Hat use
  453. * Thu Oct 22 1998 Alex Roberts <bse@dial.pipex.com>
  454. - First try at an RPM