mikmod-vl.spec 7.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267
  1. # libmikmod rpm specification file
  2. %define lversion 3.1.11
  3. Summary: A MOD music file player.
  4. Summary(ja): MOD ファイル再生プログラム
  5. Name: mikmod
  6. Version: 3.1.6
  7. Release: 34%{?_dist_release}
  8. License: GPL/LGPL
  9. Group: Applications/Multimedia
  10. Prereq: /sbin/ldconfig
  11. Prefix: /usr
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. Requires: gpm ncurses
  14. BuildRequires: gpm ncurses
  15. BuildPrereq: ncurses-devel texinfo
  16. URL: http://mikmod.raphnet.net/
  17. Source0: http://mikmod.raphnet.net/files/mikmod-%{version}.tar.gz
  18. Source1: http://mikmod.raphnet.net/files/libmikmod-%{lversion}.tar.gz
  19. Patch0: http://mikmod.raphnet.net/files/libmikmod-3.1.11-a.diff
  20. Patch1: mikmod-strip.patch
  21. Patch2: libmikmod-esd.patch
  22. Patch3: libmikmod-64bit.patch
  23. Patch4: patch-mikmod-3.1.6-a
  24. Patch5: mikmod-3.1.6-varargs.patch
  25. Patch6: libmikmod-strip-lib.patch
  26. Provides: libmikmod = %{lversion}-%{release}
  27. #Obsoletes: tracker
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: OOI Keita <ooi.keita@gmail.com>
  31. %description
  32. MikMod is one of the best and most well known MOD music file players
  33. for UNIX-like systems. This particular distribution is intended to
  34. compile fairly painlessly in a Linux environment. MikMod uses the OSS
  35. /dev/dsp driver including all recent kernels for output, and will also
  36. write .wav files. Supported file formats include MOD, STM, S3M, MTM,
  37. XM, ULT, and IT. The player uses ncurses for console output and
  38. supports transparent loading from gzip/pkzip/zoo archives and the
  39. loading/saving of playlists.
  40. Install the mikmod package if you need a MOD music file player.
  41. %description -l ja
  42. mikmod はとても手軽な音楽トラック再生プログラムです。
  43. 幅広い種類のモジュール形式に対応しており、
  44. その中には Impulse Tracker の圧縮サンプルも含まれます。
  45. その他にも、多くのアーカイブ形式にも対応しています。
  46. %package devel
  47. Group: Development/Libraries
  48. Summary: Header files and documentation for compiling mikmod applications.
  49. Requires: %{name} = %{version}-%{release}
  50. PreReq: /sbin/install-info
  51. Provides: libmikmod-devel = %{lversion}-%{release}
  52. %description devel
  53. This package includes the header files you will need to compile
  54. applications for mikmod.
  55. %prep
  56. %setup -q -a 1
  57. %patch0 -p0
  58. %patch1 -p1 -b .strip
  59. %patch2 -p1 -b .esd
  60. %patch3 -p1
  61. %patch4 -p1 -b .orig
  62. %patch5 -p1
  63. %patch6 -p1 -b .lib-strip
  64. %build
  65. rm -rf $RPM_BUILD_ROOT
  66. cd libmikmod-%{lversion}
  67. cp /usr/share/libtool/config.{sub,guess} .
  68. %configure
  69. make
  70. %makeinstall
  71. cd ..
  72. # Trick it into compiling while libmikmod is not installed...
  73. export LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{prefix}/lib:$LD_LIBRARY_PATH
  74. perl -pi -e "s,-lmikmod,-I$RPM_BUILD_ROOT%{prefix}/include -L$RPM_BUILD_ROOT%{_libdir} -lmikmod,g" libmikmod-%{lversion}/libmikmod-config
  75. export LIBMIKMOD_CONFIG=`pwd`/libmikmod-%{lversion}/libmikmod-config
  76. cp /usr/share/libtool/config.{sub,guess} .
  77. %configure \
  78. --with-libmikmod-prefix=$RPM_BUILD_ROOT%{prefix} \
  79. --with-libmikmod-exec-prefix=$RPM_BUILD_ROOT%{prefix}/bin \
  80. --disable-libmikmodtest
  81. make CFLAGS="$RPM_OPT_FLAGS `libmikmod-%{lversion}/libmikmod-config --cflags` -I."
  82. %install
  83. %makeinstall
  84. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  85. ## remove unuse files
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  87. %clean
  88. rm -fr $RPM_BUILD_ROOT
  89. %post -p /sbin/ldconfig
  90. %post devel
  91. /sbin/install-info %{_infodir}/mikmod.info.gz %{_infodir}/dir
  92. %postun -p /sbin/ldconfig
  93. %postun devel
  94. if [ $1 = 0 ] ; then
  95. /sbin/install-info --delete %{_infodir}/mikmod.info.gz %{_infodir}/dir
  96. fi
  97. %files
  98. %defattr(-, root, root)
  99. %doc AUTHORS COPYING NEWS README
  100. %doc libmikmod-%{lversion}/TODO
  101. %{_bindir}/mikmod
  102. %{_mandir}/man1/mikmod*
  103. %{_libdir}/*.so*
  104. %files devel
  105. %defattr(-, root, root)
  106. %{_bindir}/*-config
  107. %{_libdir}/*.a
  108. #%{_libdir}/*.la
  109. %{_datadir}/aclocal/*
  110. %{_includedir}/*
  111. %{_infodir}/mikmod*
  112. %{_mandir}/man1/libmikmod-config*
  113. %changelog
  114. * Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.6-34vl5
  115. - applied new versioning policy, spec in utf-8
  116. - removed *.la
  117. * Thu Mar 10 2005 OOI Keita <ooi.keita@gmail.com> 3.1.6-33vl2
  118. - build for vine
  119. - add ja summary and description from deb
  120. * Tue Dec 21 2004 Martin Stransky <stransky@redhat.com> 3.1.6-33
  121. - strip library (#143258)
  122. * Mon Dec 13 2004 Bill Nottingham <notting@redhat.com> 3.1.6-31
  123. - move mikmod binary back to main package (#142668)
  124. * Fri Oct 8 2004 Bill Nottingham <notting@redhat.com> 3.1.6-30
  125. - add texinfo buildreqs (#135088)
  126. * Wed Oct 6 2004 Bill Nottingham <notting@redhat.com> 3.1.6-29
  127. - install-info scripts go with -devel (#134882)
  128. * Wed Sep 22 2004 Than Ngo <than@redhat.com> 3.1.6-28
  129. - increase release number
  130. * Wed Sep 22 2004 Than Ngo <than@redhat.com> 3.1.6-27
  131. - new devel sub package, multiarch problem
  132. - add /sbin/ldconfig in Prereq
  133. - cleanup specfile
  134. * Wed Aug 4 2004 Miloslav Trmac <mitr@redhat.com> - 3.1.6-26
  135. - Update to libmikmod-3.1.11-a, fixes #116182
  136. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  137. - rebuilt
  138. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  139. - rebuilt
  140. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  141. - rebuilt
  142. * Wed Jul 23 2003 Bill Nottingham <notting@redhat.com> 3.1.6-23
  143. - remove URL (#77375)
  144. * Mon Jul 14 2003 Bill Nottingham <notting@redhat.com> 3.1.6-22
  145. - fix build with gcc-3.3 some more
  146. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  147. - rebuilt
  148. * Thu May 22 2003 Bill Nottingham <notting@redhat.com> 3.1.6-21
  149. - fix build with gcc-3.3
  150. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  151. - rebuilt
  152. * Tue Jan 7 2003 Jeff Johnson <jbj@redhat.com> 3.1.6-19
  153. - don't include -debuginfo files in package.
  154. * Sat Nov 02 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  155. - add further lib64 support, clean up spec file
  156. * Sat Oct 12 2002 Florian La Roche <Florian.LaRoche@redhat.de>
  157. - add 64bit patch
  158. * Thu Jul 18 2002 Bill Nottingham <notting@redhat.com>
  159. - don't strip binaries
  160. - fix buffering with esd output (#57154, <stssppnn@yahoo.com>)
  161. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  162. - automated rebuild
  163. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  164. - automated rebuild
  165. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  166. - automated rebuild
  167. * Fri Jul 20 2001 Bill Nottingham <notting@redhat.com>
  168. - add buildprereq for ncurses-devel (#49524)
  169. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  170. - Bump release + rebuild.
  171. * Thu Dec 7 2000 Bill Nottingham <notting@redhat.com>
  172. - fix %doc generation
  173. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  174. - automatic rebuild
  175. * Sat Jun 10 2000 Bill Nottingham <notting@redhat.com>
  176. - FHS fixes, etc.
  177. * Mon Apr 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  178. - rebuild with current ncurses
  179. - library 3.1.9
  180. - fix build when libmikmod is not already installed
  181. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  182. - gzip info page (Bug #9035)
  183. - Update URL and Source fields to present location
  184. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  185. - fix description
  186. - get rid of useless defines
  187. * Tue Jan 11 2000 Bill Nottingham <notting@redhat.com>
  188. - update lib to 3.1.8
  189. * Mon Aug 2 1999 Bill Nottingham <notting@redhat.com>
  190. - add more patches
  191. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  192. - update to 3.1.6/3.1.7
  193. * Mon Mar 22 1999 Cristian Gafton <gafton@redhat.com>
  194. - fixed spec file description and group according to sepcspo
  195. * Mon Mar 22 1999 Michael Maher <mike@redhat.com>
  196. - changed spec file, updated package
  197. - added libmikmod to the package
  198. * Mon Feb 15 1999 Miodrag Vallat <miodrag@multimania.com>
  199. - Created for 3.1.5
  200. * Tue Jan 24 1999 Michael Maher <mike@redhat.com>
  201. - changed group
  202. - fixed bug #145
  203. * Fri Sep 04 1998 Michael Maher <mike@redhat.com>
  204. - added patch for alpha
  205. * Wed Sep 02 1998 Michael Maher <mike@redhat.com>
  206. - built package; obsoletes the ancient tracker program.