scim-bridge-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306
  1. %define name scim-bridge
  2. %define version 0.4.16
  3. %define release 11%{?_dist_release}
  4. %define qt3_ver 3.3.8
  5. %define qt4_ver 4.6.3
  6. # build qt3 immodule ("--without qt3" to disable qt3)
  7. %bcond_without qt3
  8. # Qt3 version auto-detection -- inagaki
  9. %define _qt3_version %(rpm -q --queryformat "%%{version}" qt-devel 2>/dev/null || echo %{qt3_ver})
  10. %define _qt3_prefix %{_libdir}/qt-%{_qt3_version}
  11. %define _qt3_plugindir %{_qt3_prefix}/plugins
  12. # build qt4 immodule ("--without qt4" to disable qt4)
  13. %bcond_without qt4
  14. # Qt4 version auto-detection -- inagaki
  15. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  16. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
  17. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  18. Summary: yet another IM client of SCIM
  19. Summary(ja): もう一つ別の SCIM IM クライアント
  20. Name: %{name}
  21. Version: %{version}
  22. Release: %{release}
  23. Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
  24. # Patch from Fedora 10
  25. Patch0: scim-bridge-0.4.15-fix-gdm.patch
  26. Patch1: scim-bridge-0.4.15-bz461373.patch
  27. # Patch from Mandriva 2009
  28. Patch2: bug-351920-should-return-retval.patch
  29. Patch3: scim-bridge-0.4.15.2-linkage.patch
  30. # Patch from Fedora development
  31. Patch4: scim-bridge-0.4.15-EOF.patch
  32. Patch5: scim-bridge-0.4.15-hotkey-help.patch
  33. Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
  34. Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
  35. URL: http://www.scim-im.org/projects/scim_bridge
  36. License: GPL/LGPL
  37. Group: System Environment/Libraries
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. Prefix: %{_prefix}
  40. Requires: scim >= 1.4
  41. BuildRequires: scim-devel >= 1.4
  42. BuildRequires: pkgconfig >= 0.9.0
  43. BuildRequires: gtk2-devel >= 2.14.0
  44. %description
  45. Scim-bridge is yet another IM client of SCIM.
  46. The im-module of scim-bridge communicates with scim via socket.
  47. %description -l ja
  48. scim-bridge は、もう一つ別の SCIM IM クライアントです。
  49. scim-bridge の im-module はソケット経由で SCIM と通信します。
  50. %package gtk
  51. Summary: SCIM Bridge GTK IM Module
  52. Summary(ja): SCIM Bridge GTK IM モジュール
  53. Group: System Environment/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. Requires: gtk2 >= 2.14.0
  56. Requires(post): gtk2 >= 2.14.0
  57. Requires(postun): gtk2 >= 2.14.0
  58. Obsoletes: %{name} <= 0.1.7
  59. %description gtk
  60. This package provides the SCIM Bridge GTK IM module.
  61. %description -l ja gtk
  62. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  63. %if !%{without qt3}
  64. %package qt
  65. Summary: SCIM Bridge Qt IM Module
  66. Summary(ja): SCIM Bridge Qt IM モジュール
  67. Group: System Environment/Libraries
  68. Requires: %{name} = %{version}-%{release}
  69. Requires: qt = %{_qt3_version}
  70. BuildRequires: qt-devel
  71. %description qt
  72. This package provides the SCIM Bridge Qt IM module.
  73. %description -l ja qt
  74. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  75. %endif
  76. %if !%{without qt4}
  77. %package qt4
  78. Summary: SCIM Bridge Qt4 IM Module
  79. Summary(ja): SCIM Bridge Qt4 IM モジュール
  80. Group: System Environment/Libraries
  81. Requires: %{name} = %{version}-%{release}
  82. Requires: qt4 = %{_qt4_version}
  83. BuildRequires: qt4-devel
  84. %description qt4
  85. This package provides the SCIM Bridge Qt4 IM module.
  86. %description -l ja qt4
  87. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  88. %endif
  89. %prep
  90. %setup -q
  91. %patch0 -p1 -b .0-fix-gdm
  92. %patch1 -p1
  93. %patch2 -p1
  94. %patch3
  95. %patch4 -p1
  96. %patch5 -p1
  97. pushd client-gtk
  98. %patch6 -p0
  99. popd
  100. %patch7 -p1
  101. %build
  102. %if !%{without qt3}
  103. export QT3_PREFIX=%{_qt3_prefix}
  104. %endif
  105. %if !%{without qt4}
  106. export QT4_PREFIX=%{_qt4_prefix}
  107. %endif
  108. %configure --disable-static \
  109. %if %{without qt3}
  110. --disable-qt3-immodule \
  111. %else
  112. --enable-qt3-immodule \
  113. %endif
  114. %if %{without qt4}
  115. --disable-qt4-immodule \
  116. %else
  117. --enable-qt4-immodule \
  118. %endif
  119. --enable-gtk2-immodule
  120. %__make %{?_smp_mflags}
  121. %install
  122. %__rm -rf %{buildroot}
  123. #%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
  124. %__make DESTDIR=%{buildroot} install
  125. # remove unneeded files
  126. %__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
  127. %__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
  128. %__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
  129. %clean
  130. %__rm -rf %{buildroot}
  131. %post gtk
  132. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  133. %postun gtk
  134. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  135. %files
  136. %defattr(-,root,root)
  137. %doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
  138. %{_bindir}/scim-bridge
  139. %files gtk
  140. %defattr(-,root,root)
  141. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  142. %if !%{without qt3}
  143. %files qt
  144. %defattr(-,root,root)
  145. %{_qt3_plugindir}/inputmethods/*.so
  146. %endif
  147. %if !%{without qt4}
  148. %files qt4
  149. %defattr(-,root,root)
  150. %{_qt4_plugindir}/inputmethods/*.so
  151. %endif
  152. %changelog
  153. * Thu Jul 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-11
  154. - rebuilt with qt4-4.6.3
  155. * Tue Jun 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-10
  156. - used %{?_smp_mflags} macro on build
  157. - deleted in unused log in changelog
  158. - Patch8 was none, forgot to delete...
  159. * Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
  160. - added Patch6,7 from Fedora development
  161. - to fix Text input in firefox becomes increasingly sluggish (Patch6)
  162. - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
  163. - added configure --disable-static option
  164. * Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
  165. - updated Qt version detection macros to build properly
  166. * Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
  167. - rebuilt with qt4-4.6.1
  168. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
  169. - rebuilt with qt4-4.5.3
  170. * Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
  171. - cleaned up spec
  172. - renumbered patch
  173. - added Patch5 from Fedora
  174. * Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
  175. - rebuild with qt4-4.5.2
  176. * Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
  177. - dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
  178. * Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
  179. - rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
  180. * Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
  181. - new upstream release
  182. - dropt Pacth3,4,5 (these patches are merged)
  183. * Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
  184. - spec in UTF-8
  185. - fixed description in scim-bridge-qt4
  186. - added patch6,7 (import Fedora, Mandriva patches)
  187. * Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
  188. - new upstream release
  189. - added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
  190. * Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
  191. - rebuild with qt4-4.4.2
  192. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
  193. - add qt4 immodule
  194. - build gtk,qt3,qt4 immodule by default
  195. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
  196. - rebuild with gtk+-2.14
  197. * Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
  198. - new upstream release
  199. - apply new versioning policy
  200. * Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
  201. - drop unnecessary BuildRequires for qt3-immodule package
  202. - fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
  203. * Wed Jan 9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
  204. - new upstream release
  205. - drop unnecessary Qt fix patch ( Patch0 ): upstream merged
  206. - update BuildRequires
  207. - drop doxygen
  208. - add XOrg-gl-devel for building qt3-immodule
  209. - move libmng-devel for building qt3-immodule
  210. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
  211. - rebuild for Vine Linux 4.2.
  212. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
  213. - add patch0 to fix symbol lookup error with qt3.
  214. * Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
  215. - rebuild for Vine Linux 4.2.
  216. * Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
  217. - new upstrm release
  218. - detect qt version at build time.
  219. - add --disable-qt4-immodule configure option.
  220. - add BuildRequires libmng-devel.
  221. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
  222. - rebuild with libstdc++34
  223. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
  224. - new upstream release
  225. * Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
  226. - change License to GPL/LGPL
  227. - add doc/LICENSE.* as documents
  228. * Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
  229. - new upstream release
  230. - add BuildRequires: doxygen, qt-devel
  231. - add new sub-packages:
  232. - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
  233. - qt: Qt IM module
  234. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
  235. - new upstream release
  236. - add documents
  237. - running gtk-query-immodules-2.0 in post and postun scripts
  238. - add PreReq: gtk2 > 2.2
  239. * Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
  240. - new upstream release
  241. * Thu Apr 6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
  242. - initial release