sed-vl.spec 6.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200
  1. %ifos linux
  2. %define _bindir /bin
  3. %endif
  4. Summary: A GNU stream text editor.
  5. Summary(ja): GNU ストリームテキストエディタ
  6. Name: sed
  7. Version: 4.2.1
  8. Release: 2%{?_dist_release}
  9. License: GPLv2+
  10. Group: Applications/Text
  11. Source0: ftp://ftp.gnu.org/pub/gnu/sed/sed-%{version}.tar.bz2
  12. Patch0: sed-4.2.1-dummyparam.diff
  13. Patch1: sed-4.2.1-multibyte.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: glibc-devel
  16. BuildRequires: libacl-devel
  17. Requires(post,preun): /sbin/install-info
  18. %description
  19. The sed (Stream EDitor) editor is a stream or batch (non-interactive)
  20. editor. Sed takes text as input, performs an operation or set of
  21. operations on the text and outputs the modified text. The operations
  22. that sed performs (substitutions, deletions, insertions, etc.) can be
  23. specified in a script file or from the command line.
  24. %description -l ja
  25. sed (Stream Editor) エディタはストリームまたはバッチ(非インタラクティブ)
  26. エディタです。sed は入力としてテキストを用い、テキストの操作または
  27. 操作のセットをテキストとに対して行い、修正されたテキストを出力します。
  28. sed が行う操作 (置換、削除、挿入、その他) はスクリプトファイルか、
  29. コマンドラインから指定されます。
  30. %prep
  31. %setup -q
  32. %patch0 -p1
  33. %patch1 -p1 -b .mb
  34. %build
  35. export LANG=C
  36. %configure --without-included-regex
  37. make %{_smp_mflags}
  38. echo ====================TESTING=========================
  39. make check
  40. echo ====================TESTING END=====================
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. %makeinstall
  44. rm -f $RPM_BUILD_ROOT/%{_infodir}/dir
  45. %find_lang %{name}
  46. %post
  47. /sbin/install-info %{_infodir}/sed.info.gz %{_infodir}/dir
  48. %preun
  49. if [ $1 = 0 ]; then
  50. /sbin/install-info --delete %{_infodir}/sed.info.gz %{_infodir}/dir
  51. fi
  52. %clean
  53. rm -rf ${RPM_BUILD_ROOT}
  54. %files -f %{name}.lang
  55. %defattr(-,root,root)
  56. %doc BUGS NEWS THANKS README AUTHORS
  57. %{_bindir}/sed
  58. %{_infodir}/*.info*
  59. %{_mandir}/man*/*
  60. %changelog
  61. * Mon Dec 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-2
  62. - added Patch1 from Debian (#551075)
  63. Apply patch from WANG Yunfeng to treat incomplete multibyte
  64. sequences as a single-byte character.
  65. * Mon Nov 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.2.1-1
  66. - new upstream release, dropped Patch1 and 2
  67. - added Patch0 from Fedora
  68. * Mon Jun 29 2009 Jiri Moskovcak <jmoskovc@redhat.com>
  69. - added patch to maintain backwards compatibility for scripts using -c/--copy
  70. - Resolves: #502934
  71. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.1.5-3
  72. - rebuilt against current toolchain
  73. - spec in UTF-8
  74. * Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-2vl5
  75. - dropped Patch0
  76. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-1vl5
  77. - added Patch0-2 from Fedora
  78. * Mon Sep 4 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-5
  79. - Fix handling of relative symlinks (#205122)
  80. * Wed Aug 3 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-4
  81. - remove superfluous multibyte processing in str_append for UTF-8
  82. encoding (thanks Paolo Bonzini, #177246)
  83. * Thu Jun 29 2006 Petr Machata <pmachata@redhat.com> - 4.1.5-2
  84. - #185374:
  85. - Follow symlinks before rename (avoid symlink overwrite)
  86. - Add -c flag for copy instead of rename (avoid ownership change)
  87. * Sat Aug 25 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.1.5-0vl1
  88. - new upstream release
  89. - run 'make check' on non-English locale
  90. * Thu Mar 09 2006 Shu KONNO <owa@bg.wakwak.com> 4.1.2-0vl2
  91. - s/Copyright/License/
  92. - rebuilt for x86_64 architecture support
  93. * Wed Oct 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1.2-0vl1
  94. - new upstream release
  95. * Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-0vl1
  96. - new upstream release
  97. - remove obsolete patch
  98. * Sat Apr 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.8-4vl2
  99. - rebuilt for Vine
  100. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 4.0.8-3
  101. - if not -n, print current buffer after N command on the last line
  102. unless POSIXLY_CORRECT (#112952)
  103. - adjust XFAIL_TESTS for the improved glibc regex implementation
  104. (#112642)
  105. * Fri Nov 14 2003 Jakub Jelinek <jakub@redhat.com> 4.0.8-2
  106. - enable --without-included-regex again
  107. - use fastmap for regex searching
  108. * Sat Oct 25 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  109. - update to 4.0.8
  110. - simplify specfile
  111. - disable --without-included-regex to pass the testsuite
  112. * Sat Apr 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  113. - update to 4.0.7
  114. - use "--without-included-regex"
  115. - do not gzip info pages in spec file, "TODO" is not present anymore
  116. * Thu Jan 23 2003 Jakub Jelinek <jakub@redhat.com> 4.0.5-1
  117. - update to 4.0.5
  118. * Tue Oct 22 2002 Jakub Jelinek <jakub@redhat.com>
  119. - rebuilt to fix x86-64 miscompilation
  120. - run make check in %%build
  121. * Fri Apr 5 2002 Jakub Jelinek <jakub@redhat.com>
  122. - Remove stale URLs from documentation (#62519)
  123. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  124. - Bump release + rebuild.
  125. * Mon Dec 18 2000 Yukihiro Nakai <ynakai@redhat.com>
  126. - Update to 2000.11.28 patch
  127. - Rebuild for 7.1 tree
  128. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  129. - FHS packaging.
  130. * Mon Feb 7 2000 Jeff Johnson <jbj@redhat.com>
  131. - compress man pages.
  132. * Tue Jan 18 2000 Jakub Jelinek <jakub@redhat.com>
  133. - rebuild with glibc 2.1.3 to fix an mmap64 bug in sys/mman.h
  134. * Sat Oct 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.02_mb1.09-0vl1
  135. - mb patch updated to 1.09
  136. * Tue May 29 2001 <sagami@vinelinux.org>
  137. - 3.02_mb1.08-1vl2: use better macros
  138. * Fri Sep 08 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  139. - 3.02_mb1.08-1vl1
  140. - modified %files section to handle compressed man page(s)
  141. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  142. - auto rebuild in the new build environment (release 4)
  143. * Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
  144. - update to 3.02
  145. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  146. - update to 3.01
  147. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  148. - translations modified for de, fr, tr
  149. * Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
  150. - removed references to the -g option from the man page that we add
  151. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  152. - spec file cleanups
  153. - added BuildRoot
  154. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  155. - built against glibc