subversion-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466
  1. %define neon_version 0.25.5
  2. %define swig_version 1.3.29
  3. %define apache_dir /usr
  4. %define db_version 4.3.29
  5. %define swigdirs swig_pydir=%{python_sitearch}/libsvn swig_pydir_extra=%{python_sitearch}/svn
  6. # set to zero to avoid running test suite
  7. %define make_check 0
  8. Summary: Modern Version Control System
  9. Summary(ja): モダンなバージョン管理システム
  10. Name: subversion
  11. Version: 1.6.9
  12. Release: 2%{?_dist_release}
  13. License: ASL 1.1
  14. Group: Development/Tools
  15. URL: http://subversion.apache.org/
  16. SOURCE0: subversion-%{version}.tar.bz2
  17. SOURCE1: subversion.conf
  18. SOURCE2: httpd.davcheck.conf
  19. SOURCE3: filter-requires.sh
  20. Patch1: subversion-1.6.0-deplibs.patch
  21. Patch3: subversion-1.6.1-rpath.patch
  22. Patch6: subversion-1.5.0-pie.patch
  23. Patch10: subversion-1.5.7-update-neon-m4.patch
  24. Requires: db4 >= %{db_version}
  25. Requires: expat
  26. Requires: neon >= %{neon_version}
  27. BuildRequires: apache2-devel
  28. BuildRequires: apr-devel, apr-util-devel
  29. BuildRequires: autoconf >= 2.53
  30. BuildRequires: db4-devel >= %{db_version}
  31. BuildRequires: expat-devel
  32. BuildRequires: gdbm-devel
  33. BuildRequires: libtool >= 1.4.2
  34. BuildRequires: neon-devel >= %{neon_version}
  35. BuildRequires: openssl-devel
  36. BuildRequires: python
  37. BuildRequires: python-devel
  38. BuildRequires: swig >= %{swig_version}
  39. BuildRequires: texinfo
  40. BuildRequires: zlib-devel
  41. BuildRequires: openldap-devel
  42. BuildRequires: ruby >= 1.8.2
  43. BuildRequires: ruby-devel >= 1.8.2
  44. BuildRequires: perl >= 5.8.0
  45. BuildRequires: sqlite3-devel
  46. BuildRequires: krb5-devel
  47. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  48. %define __perl_requires %{SOURCE3}
  49. %description
  50. Subversion is a concurrent version control system which enables one
  51. or more users to collaborate in developing and maintaining a
  52. hierarchy of files and directories while keeping a history of all
  53. changes. Subversion only stores the differences between versions,
  54. instead of every complete file. Subversion is intended to be a
  55. compelling replacement for CVS.
  56. %package devel
  57. Group: Development/Libraries
  58. Summary: Development package for Subversion developers.
  59. Requires: subversion = %{version}-%{release}
  60. Requires: apr-devel, apr-util-devel
  61. %description devel
  62. The subversion-devel package includes the static libraries and include files
  63. for developers interacting with the subversion package.
  64. %package mod_dav_svn
  65. Group: System Environment/Daemons
  66. Summary: Apache server module for Subversion server.
  67. Requires: httpd >= %{apache_version}
  68. Requires: subversion = %{version}-%{release}
  69. %description mod_dav_svn
  70. The subversion-mod_dav_svn package adds the Subversion server Apache module to
  71. the Apache directories and configuration.
  72. %package tools
  73. Group: Development/Tools
  74. Summary: Tools for Subversion
  75. BuildRequires: perl >= 5.8.0
  76. Requires: perl >= 5.8.0
  77. Requires: subversion = %{version}-%{release}
  78. %description tools
  79. Tools for Subversion.
  80. %package perl
  81. Group: Development/Libraries
  82. Summary: Perl bindings to the Subversion libraries
  83. Requires: subversion = %{version}-%{release}
  84. Requires: perl >= 5.8.0
  85. %description perl
  86. This package includes the Perl bindings to the Subversion libraries.
  87. %package ruby
  88. Group: Development/Libraries
  89. Summary: Ruby bindings to the Subversion libraries
  90. Requires: subversion = %{version}-%{release}
  91. Requires: ruby >= 1.8.2
  92. %description ruby
  93. This package includes the Ruby bindings to the Subversion libraries.
  94. %package python
  95. Group: Development/Libraries
  96. Summary: Python bindings to the Subversion libraries
  97. Requires: subversion = %{version}-%{release}, python
  98. %description python
  99. This package includes the Python bindings to the Subversion libraries.
  100. %prep
  101. %setup -q
  102. %patch1 -p1 -b .deplibs
  103. %patch3 -p1 -b .rpath
  104. ## comment out: 1.6.9-1
  105. #%patch6 -p1 -b .pie
  106. ## comment out: 1.6.9-1
  107. #%patch10 -p1 -b .nola
  108. rm -rf neon apr apr-util db4
  109. %build
  110. ./autogen.sh
  111. # fix shebang lines, #111498
  112. perl -pi -e 's|/usr/bin/env perl -w|/usr/bin/perl -w|' tools/hook-scripts/*.pl.in
  113. # override weird -shrext from ruby
  114. export svn_cv_ruby_link="%{__cc} -shared"
  115. export svn_cv_ruby_sitedir_libsuffix=""
  116. export svn_cv_ruby_sitedir_archsuffix=""
  117. export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
  118. export CPPFLAGS="-DSVN_NEON_0_26 -DSVN_NEON_0_25"
  119. %configure --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
  120. --with-swig --with-neon=%{_prefix} \
  121. --with-ruby-sitedir=%{rarchdir} \
  122. --with-apxs=%{_bindir}/apxs \
  123. --disable-mod-activation --disable-static --disable-neon-version-check
  124. # 1.3.0 tarball ships with generated swig sources
  125. make extraclean-swig-headers
  126. make %{?_smp_mflags} all
  127. make swig-py swig-py-lib %{swigdirs}
  128. make swig-pl swig-pl-lib swig-rb swig-rb-lib
  129. %install
  130. echo %{rarchdir}
  131. rm -rf $RPM_BUILD_ROOT
  132. make install \
  133. install-swig-py \
  134. install-swig-pl-lib \
  135. install-swig-rb \
  136. DESTDIR=$RPM_BUILD_ROOT %{swigdirs}
  137. make pure_vendor_install -C subversion/bindings/swig/perl/native \
  138. PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  139. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/subversion
  140. # Add subversion.conf configuration file into httpd/conf.d directory.
  141. install -m 755 -d $RPM_BUILD_ROOT/etc/apache2/conf.d
  142. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/etc/apache2/conf.d
  143. # Set up tools package files.
  144. mkdir -p $RPM_BUILD_ROOT/usr/lib/subversion
  145. cp -r tools $RPM_BUILD_ROOT/usr/lib/subversion
  146. # Remove unpackaged files
  147. rm -rf $RPM_BUILD_ROOT%{_includedir}/subversion-*/*.txt \
  148. $RPM_BUILD_ROOT%{python_sitearch}/*/*.{a,la} \
  149. $RPM_BUILD_ROOT%{_libdir}/*.la
  150. # remove stuff produced with Perl modules
  151. find $RPM_BUILD_ROOT -type f \
  152. -a \( -name .packlist -o \( -name '*.bs' -a -empty \) \) \
  153. -print0 | xargs -0 rm -f
  154. # make Perl modules writable so they get stripped
  155. find $RPM_BUILD_ROOT%{_libdir}/perl5 -type f -perm 555 -print0 |
  156. xargs -0 chmod 755
  157. # unnecessary libraries for swig bindings
  158. rm -f $RPM_BUILD_ROOT%{_libdir}/libsvn_swig_*.{so,la,a}
  159. # Remove unnecessary ruby libraries
  160. rm -f $RPM_BUILD_ROOT%{rarchdir}/svn/ext/*.*a
  161. # Trim what goes in docdir
  162. rm -rf tools/*/*.in tools/test-scripts
  163. # Rename authz_svn INSTALL doc for docdir
  164. ln -f subversion/mod_authz_svn/INSTALL mod_authz_svn-INSTALL
  165. %clean
  166. rm -rf $RPM_BUILD_ROOT
  167. %post -p /sbin/ldconfig
  168. %postun -p /sbin/ldconfig
  169. %post tools -p /sbin/ldconfig
  170. %postun tools -p /sbin/ldconfig
  171. %files
  172. %defattr(-,root,root)
  173. %doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
  174. %doc subversion/LICENSE
  175. %{_bindir}/*
  176. %{_libdir}/libsvn_*.so.*
  177. %{_localedir}/*/*/subversion.mo
  178. %{_mandir}/man*/*
  179. %dir %{_sysconfdir}/subversion
  180. %exclude %{_mandir}/man*/*::*
  181. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  182. %exclude %{_libdir}/libsvn_swig_py*.so.*
  183. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  184. %files devel
  185. %defattr(-,root,root)
  186. %{_includedir}/subversion-1
  187. %{_libdir}/libsvn*.so
  188. %exclude %{_libdir}/libsvn_swig_perl*.so.*
  189. %exclude %{_libdir}/libsvn_swig_py*.so.*
  190. %exclude %{_libdir}/libsvn_swig_ruby*.so.*
  191. %files mod_dav_svn
  192. %defattr(-,root,root)
  193. %config(noreplace) /etc/apache2/conf.d/subversion.conf
  194. %{apache_dir}/%{_lib}/apache2/modules/mod_*.*
  195. %files tools
  196. %defattr(-,root,root)
  197. %{_prefix}/lib/subversion/tools
  198. %files perl
  199. %defattr(-,root,root,-)
  200. %{perl_vendorarch}/auto/SVN
  201. %{perl_vendorarch}/SVN
  202. %{_libdir}/libsvn_swig_perl*
  203. %{_mandir}/man*/*::*
  204. %files ruby
  205. %defattr(-,root,root,-)
  206. %{_libdir}/libsvn_swig_ruby*
  207. %{rarchdir}/svn
  208. %files python
  209. %defattr(-,root,root,-)
  210. %{_libdir}/libsvn_swig_py*
  211. %{python_sitearch}/libsvn
  212. %{python_sitearch}/svn
  213. %changelog
  214. * Tue Mar 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-2
  215. - fix <BTS:VineLinux:941>
  216. - using rpm macro: rarchdir
  217. - export svn_cv_ruby_sitedir_libsuffix and svn_cv_ruby_sitedir_archsuffix
  218. - using rpm macros: perl_vendorarch and python_sitearch
  219. - add BuildRequires: sqlite3-devel krb5-devel
  220. * Thu Feb 18 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  221. - new upstream release
  222. - update URL
  223. - update deplibs patch (Patch1) from Fedora 1.6.9-2.fc13
  224. - update rpath patch (Patch3) from Fedora 1.6.9-2.fc13
  225. - stop applying pia patch (Patch6): sync Fedora 1.6.9-2.fc13
  226. - stop applying update-neon-m4 patch (Patch10): sync Fedora 1.6.9-2.fc13
  227. * Wed Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.7-1
  228. - new upstream release
  229. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.2-1
  230. - new upstream release
  231. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.6-2vl5
  232. - rebuilt with python-2.5.2
  233. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.6-1vl5
  234. - new upstream release
  235. - rebuild with neon-0.28.2
  236. - dropped old-Patch10 by adding --disable-neon-version-check to %%configure
  237. - added Patch6, 8, 9, 10 from Fedora Core
  238. * Thu Feb 21 2008 Lubomir Kundrak <lkundrak@redhat.com> 1.4.6-5
  239. - Correct install location of java stuff (#433295)
  240. * Wed Aug 8 2007 Joe Orton <jorton@redhat.com> 1.4.4-3
  241. - fix build with new glibc open()-as-macro
  242. - build all swig code in %%build, not %%install
  243. * Fri May 21 2004 Joe Orton <jorton@redhat.com> 1.0.3-2
  244. - build /usr/bin/* as PIEs
  245. * Mon Feb 25 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  246. - rebuild with expat-2.0.1
  247. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-0vl1
  248. - new upstream release
  249. - add Patch10 to build with neon.
  250. 1.3.2-0vl5 does not support neon..
  251. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl4
  252. - rebuild with new neon
  253. * Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-0vl3
  254. - rebuilt with new toolchain and db4-4.3.x
  255. * Sat Mar 31 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.2-0vl2
  256. - modified %%files section for lib64 architecture
  257. * Tue Aug 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-0vl1
  258. - new upstream release
  259. - rebuild with new openldap-2.3.24
  260. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.1-0vl1
  261. - new upstream release
  262. - change Group to Develoment/Tools
  263. - build with apr-1.2.7/apr-util-1.2.7
  264. - require apr/apr-util instead of apache2-apr
  265. - build with swig-1.3.29
  266. - split {perl,python,ruby} related files to subpackage.
  267. * Tue Oct 18 2005 IWAI, Masaharu <iwai@alib.jp> 1.2.3-0vl1
  268. - new upstream release
  269. - add noreplace option for config file
  270. * Sun Jan 30 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl3
  271. - fix Requires and BuildPreReq.
  272. * Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.1.3-0vl2
  273. - new upstream release.
  274. - add swig-runtime to 'BuildPreReq:'.
  275. - fix %%files.
  276. * Sun Oct 17 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.0.6-0vl1.1
  277. - require neon version 0.24.7 for ra_dav
  278. - add BuildPreReq: openldap-devel
  279. - replace BuildPreReq: httpd to BuildPreReq: apache2
  280. - replace tools Requires: perl(:MODULE_COMPAT_version) to perl >= 5.8.0
  281. * Wed Jul 21 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.6-0vl1
  282. - new upstream release
  283. * Tue Jun 22 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.5-0vl1
  284. - new upstream release
  285. * Fri Jun 4 2004 Kazuhisa TAKEI <takei@vinelinux.org> 1.0.4-0vl1
  286. - new upstream release
  287. - clean up specfile.
  288. * Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32.1-0vl1
  289. - new upstream release
  290. - build with apache2-2.0.47
  291. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.20.0-0vl1
  292. - build Vine Linux
  293. * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
  294. - Enabled RA_DAV checking.
  295. Now requires httpd package to build because of RA_DAV tests.
  296. * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
  297. - Created tools package to hold the tools.
  298. * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
  299. - Now requires httpd >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains the new
  300. version of APR/APR-UTILS as of 2003.01.15.
  301. - Added svnversion command.
  302. * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
  303. - Create a svnadmin.static which is copied to svnadmin-version-release
  304. when the package is erased, so users can still dump/load their repositories
  305. even after they have upgraded the RPM package.
  306. * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
  307. - SWIG now builds so we can use cvs2svn.
  308. * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
  309. - Made cvs2svn conditional (at least until we can get it to build consistently
  310. and work).
  311. * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
  312. - Added SWIG dependencies to add cvs2svn capabilities.
  313. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
  314. - Now requires neon-0.22.0.
  315. * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
  316. - Took out loading mod_dav_svn from subversion.spec file and put it in
  317. subversion.conf file which goes into the apache conf directory.
  318. - Simplify what gets put into httpd.conf to only the include for the
  319. subversion.conf file.
  320. (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
  321. me to do this).
  322. * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
  323. - Updated to APR/APR-UTIL 2002-08-08.
  324. * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
  325. - Updated to APACHE/APR/APR-UTIL 2002-06-25.
  326. - Previous version had a few problems because of missing apache error/ files.
  327. * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
  328. - Updated to apache-2.0.40-0.3.
  329. - Updated to subversion-0.13.1-2318.
  330. * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
  331. - Updated for RedHat 7.3 (autoconf253).
  332. - Added a bunch of pre-requisites I didn't know were needed because I built a
  333. new machine that didn't have them already installed.
  334. - Fixed installation of man and info documentation pages.
  335. * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
  336. - Back to apache-libapr* stuff, hopefully to stay.
  337. * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
  338. - Fixed expat.patch to not have to make so many changes by writing a small
  339. shell script that changes libexpat to -lexpat.
  340. * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
  341. - Updated to neon-0.19.2.
  342. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
  343. - Back to using apr and apr-util separately from apache.
  344. * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
  345. - Updated to APR and APR-UTIL 2002.02.11.
  346. - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
  347. - Took out a (now non-existant) documentation file.
  348. - Moved SPEC file changelog to after all package definitions.
  349. * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
  350. - Updated to neon-0.18.5.
  351. - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
  352. apache-apr-utils, and apache-apr-utils-devel.
  353. - Updated apache to APR and APR-UTILS to 2002.02.03 version.
  354. * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
  355. - Now builds without the separate APR package as it is built into and
  356. "exported" from apache-2.0.31-0.3.
  357. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
  358. - Took out patches to install procedure now not required because of fixes
  359. in rev 1130.
  360. * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
  361. - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
  362. program was added.
  363. * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
  364. - Release M5-r340: Added the subversion-server package.
  365. * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
  366. - Release M5-r327: No longer need expat-lite. We can use the normal expat.
  367. * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
  368. - Release M3-r117: Initial Version.