yatex-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. Name: yatex
  4. Version: 1.74
  5. Release: 1%{?_dist_release}
  6. License: Distributable
  7. Source0: http://www.yatex.org/yatex%{version}.tar.gz
  8. #Source0: http://www.yatex.org/yatex10203151806.tar.gz
  9. Source1: %{name}-install.sh
  10. Source2: %{name}-remove.sh
  11. Source3: %{name}-init.el
  12. Source4: vine-default-%{name}.el
  13. ## pre-formatted info files here
  14. Source10: yatexe
  15. Source11: yatexj
  16. Source12: yahtmle
  17. Source13: yahtmlj
  18. ## Vine Patch(es)
  19. Patch0: yatex-info.diff
  20. Patch1: yatexhlp-emacs.diff
  21. Patch2: yatex-make.diff
  22. # based on a patch at http://www.nekolinux.2y.net/nekomemo/yahtml01.html
  23. # and modified to suit 1.70 release
  24. Patch3: yahtml-1.70-timestamp.patch
  25. URL: http://www.yatex.org/
  26. Group: Applications/Editors/Emacs
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. Summary: YaTeX - Yet Another TeX mode for Emacs
  29. Summary(ja): 野鳥(YaTeX) - Yet Another TeX mode for Emacs
  30. BuildArch: noarch
  31. PreReq: emacsen
  32. %prereq_ge emacsen-common
  33. BuildRequires: emacsen-common
  34. Obsoletes: yatex-xemacs
  35. Distribution: Vine Linux
  36. Vendor: Project Vine
  37. %description
  38. YaTeX is an intelligent, acquisitive and integrated package which reduces
  39. your efforts of composing LaTeX source on GNU Emacs.
  40. %description -l ja
  41. YaTeX(野鳥)とは、EmacsでLaTeXソースを書くときに生ずる手間を軽減
  42. してくれる、LaTeX 入力支援環境です。
  43. %prep
  44. %setup -n yatex%{version}
  45. %patch0 -p1
  46. %patch1 -p1
  47. %patch2 -p1
  48. %patch3 -p1
  49. %build
  50. ( cd docs
  51. chmod 644 *
  52. install -v -m 644 %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} .
  53. )
  54. %install
  55. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  56. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{name}
  57. mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  58. mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  59. mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
  60. #
  61. # install el files
  62. #
  63. cp -a *.el makefile help ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
  64. cp -a %{SOURCE3} %{SOURCE4} \
  65. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}/
  66. #
  67. # install info files
  68. #
  69. install -m 644 docs/{yahtmle,yahtmlj,yatexe,yatexj} \
  70. ${RPM_BUILD_ROOT}%{_infodir}
  71. #
  72. # install script (bytecompile el and install elc, remove)
  73. #
  74. %_installemacsenscript %{name} %{SOURCE1}
  75. %_removeemacsenscript %{name} %{SOURCE2}
  76. %clean
  77. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  78. %post
  79. #
  80. # bytecompile and install
  81. #
  82. if [ "$1" = 2 ] ; then
  83. %_emacsenPackageRemove %{name}
  84. fi
  85. %_addemacsenlist %{name}
  86. %_emacsenPackageInstall %{name}
  87. /sbin/install-info %{_infodir}/yatexe.gz %{_infodir}/dir \
  88. --section="Emacs"
  89. /sbin/install-info %{_infodir}/yatexj.gz %{_infodir}/dir \
  90. --section="Emacs"
  91. /sbin/install-info %{_infodir}/yahtmle.gz %{_infodir}/dir \
  92. --section="Emacs"
  93. /sbin/install-info %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  94. --section="Emacs"
  95. %preun
  96. if [ "$1" = 0 ]; then
  97. %_emacsenPackageRemove %{name}
  98. %_removeemacsenlist %{name}
  99. /sbin/install-info --delete %{_infodir}/yatexe.gz %{_infodir}/dir \
  100. --section="Emacs"
  101. /sbin/install-info --delete %{_infodir}/yatexj.gz %{_infodir}/dir \
  102. --section="Emacs"
  103. /sbin/install-info --delete %{_infodir}/yahtmle.gz %{_infodir}/dir \
  104. --section="Emacs"
  105. /sbin/install-info --delete %{_infodir}/yahtmlj.gz %{_infodir}/dir \
  106. --section="Emacs"
  107. fi
  108. %files
  109. %defattr(-,root,root)
  110. %doc 00readme install manifest yatex.new
  111. %doc docs
  112. %{_datadir}/emacs/site-lisp/yatex/
  113. %{_infodir}/*
  114. %{emacsen_pkgdir}/install/%{name}
  115. %{emacsen_pkgdir}/remove/%{name}
  116. %changelog
  117. * Mon Jan 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.74-1
  118. - new upstream release
  119. * Sun Oct 18 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.73-7
  120. - updated vine-default-yatex.el
  121. - dropped (setq YaTeX-no-begend-shortcut t)
  122. - use %{emacsen_pkgdir}
  123. * Sun May 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-6
  124. - updated vine-default-yatex.el
  125. - (setq tex-command "platex -kanji=utf8 -src-specials") [VineSeed:17572]
  126. * Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-5
  127. - updated yatex-install.sh
  128. - *-init.el: changed from hard copy to symbolic link
  129. on /etc/emacs-XX.YY/site-start.d
  130. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-4
  131. - fixed yatex-init.el
  132. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-3
  133. - added yatex-init.el, vine-default-yatex.el
  134. - updated yatex-install.sh, yatex-remove.sh for vine-default-yatex.el
  135. * Sun Mar 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.73-2
  136. - spec in utf8
  137. * Sat Jun 14 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73-1
  138. - applied new versioning policy
  139. * Wed Aug 08 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 1.73-0vl1
  140. - new upstream release
  141. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72-0vl2
  142. - s/Copyright/License/
  143. - changed Group to Applications/Editors/Emacs <BTS:VineLinux:163>
  144. * Sun Feb 01 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.72-0vl1
  145. - update yatex-1.72
  146. * Wed May 07 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.71-0vl1
  147. - update yatex-1.71
  148. * Fri Jul 17 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.70-0vl2
  149. - added Patch3 to add hhmts timestamp feature
  150. * Tue May 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.70-0vl1
  151. - update yatex-1.70
  152. * Tue May 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.69-0vl0.1
  153. - update yatex10203151806
  154. * Wed Mar 13 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.68-0vl4
  155. - fixed: bytecompile yatex19
  156. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.68-0vl3
  157. - now emacsen-common aware
  158. - FIXME: newer upstream 1.69.2 do not work fine with xemacs-21.1.14
  159. * Wed Oct 11 2000 Jun Nishii <jun@vinelinux.org>
  160. - 1.68-0vl2
  161. - no kanji code conversion of documents
  162. * Tue Sep 19 2000 T.R. Kobayashi <tkoba@ike-dyn.ritsumei.ac.jp>
  163. - 1.68-0vl1
  164. - update to 1.68
  165. * Wed Jul 05 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  166. - 1.67-6vl5
  167. - YATEXHLP.{jp,eng} moved to appropriate dir
  168. * Thu Jun 23 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  169. - 1.67-6vl3
  170. - rebuilt for emacs-20.7
  171. * Thu May 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  172. - 1.67-6vl2
  173. - oops ... fixed target dir for help files
  174. * Tue May 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  175. - 1.67-6vl1
  176. - rebuilt for emacs-20.6
  177. * Tue Jan 11 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  178. - 1.67-6
  179. - included forgotten info file for YaHTML
  180. * Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  181. - 1.67-5
  182. - updated for emacs-20.5a release
  183. * Wed Dec 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  184. - 1.67-4
  185. - change Group to Applications/Editors/EmacsLisp
  186. * Sun Nov 28 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  187. - 1.67-3
  188. - %post and %preun section modified
  189. * Thu Sep 23 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  190. - 1.67-2
  191. - fixed minor problem in the %files section
  192. * Sat Sep 18 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  193. - 1.67-1
  194. - updated to 1.67 release
  195. - rebuilt for emacs-20.4 on Vine Linux 1.9
  196. - updated URL for the new web site of YaTeX
  197. - some typo fix
  198. * Tue May 4 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  199. - Initial Release