chrony-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. Name: chrony
  2. Version: 2.2.1
  3. Release: 2%{?_dist_release}
  4. Summary: An NTP client/server
  5. Group: System Environment/Daemons
  6. License: GPLv2
  7. URL: http://chrony.tuxfamily.org
  8. Source0: http://download.tuxfamily.org/chrony/chrony-%{version}%{?prerelease}.tar.gz
  9. Source1: chrony.conf
  10. Source2: chrony.dhclient
  11. Source3: chronyd.sysconfig
  12. Source4: chronyd.init
  13. Source5: chrony.logrotate
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  15. BuildRequires: libcap-devel readline-devel ncurses-devel bison texinfo
  16. Requires(pre): shadow-utils
  17. Requires(post): chkconfig info
  18. Requires(preun): chkconfig initscripts info
  19. Requires(postun): initscripts
  20. Obsoletes: ntp < 4.2.6p5
  21. Obsoletes: networkmanager-dispatcher-chrony
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: tomop
  25. %description
  26. A client/server for the Network Time Protocol, this program keeps your
  27. computer's clock accurate. It was specially designed to support
  28. systems with intermittent internet connections, but it also works well
  29. in permanently connected environments. It can use also hardware reference
  30. clocks, system real-time clock or manual input as time references.
  31. %prep
  32. %setup -q -n %{name}-%{version}%{?prerelease}
  33. echo '# Keys used by chronyd for command and NTP authentication' > chrony.keys
  34. # regenerate the file from getdate.y
  35. rm -f getdate.c
  36. %build
  37. #CFLAGS="$RPM_OPT_FLAGS"
  38. #%ifarch %{sparc}
  39. #CFLAGS="$CFLAGS -pie -fPIE"
  40. #%else
  41. #CFLAGS="$CFLAGS -pie -fpie"
  42. #%endif
  43. #export CFLAGS
  44. #export LDFLAGS="-Wl,-z,relro,-z,now"
  45. %configure \
  46. --docdir=%{_docdir} \
  47. --with-user=chrony \
  48. --with-sendmail=%{_sbindir}/sendmail \
  49. --enable-forcednsretry
  50. make %{?_smp_mflags} all docs
  51. %install
  52. rm -rf $RPM_BUILD_ROOT
  53. make install install-docs DESTDIR=$RPM_BUILD_ROOT
  54. rm -rf $RPM_BUILD_ROOT%{_docdir}
  55. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/{sysconfig,logrotate.d}
  56. mkdir -p $RPM_BUILD_ROOT%{_initrddir}
  57. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/{lib,log}/chrony
  58. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d
  59. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d
  60. install -m 644 -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/chrony.conf
  61. install -m 640 -p chrony.keys $RPM_BUILD_ROOT%{_sysconfdir}/chrony.keys
  62. install -m 755 -p examples/chrony.nm-dispatcher \
  63. $RPM_BUILD_ROOT%{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
  64. install -m 755 -p %{SOURCE2} \
  65. $RPM_BUILD_ROOT%{_sysconfdir}/dhcp/dhclient.d/chrony.sh
  66. install -m 644 -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/chronyd
  67. install -m 755 -p %{SOURCE4} $RPM_BUILD_ROOT%{_initrddir}/chronyd
  68. install -m 644 -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/chrony
  69. touch $RPM_BUILD_ROOT%{_localstatedir}/lib/chrony/{drift,rtc}
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %pre
  73. getent group chrony > /dev/null || /usr/sbin/groupadd -r chrony
  74. getent passwd chrony > /dev/null || /usr/sbin/useradd -r -g chrony \
  75. -d %{_localstatedir}/lib/chrony -s /sbin/nologin chrony
  76. :
  77. %post
  78. /sbin/chkconfig --add chronyd
  79. /sbin/install-info %{_infodir}/chrony.info.gz %{_infodir}/dir &> /dev/null
  80. :
  81. %preun
  82. if [ "$1" -eq 0 ]; then
  83. /sbin/service chronyd stop &> /dev/null
  84. /sbin/chkconfig --del chronyd
  85. /sbin/install-info --delete %{_infodir}/chrony.info.gz \
  86. %{_infodir}/dir &> /dev/null
  87. fi
  88. :
  89. %postun
  90. if [ "$1" -ge 1 ]; then
  91. /sbin/service chronyd condrestart &> /dev/null
  92. fi
  93. :
  94. %files
  95. %defattr(-,root,root,-)
  96. %doc COPYING FAQ NEWS README chrony.txt examples/*
  97. %config(noreplace) %{_sysconfdir}/chrony.conf
  98. %config(noreplace) %verify(not md5 size mtime) %attr(640,root,chrony) %{_sysconfdir}/chrony.keys
  99. %config(noreplace) %{_sysconfdir}/sysconfig/chronyd
  100. %config(noreplace) %{_sysconfdir}/logrotate.d/chrony
  101. %{_initrddir}/chronyd
  102. %{_sysconfdir}/NetworkManager/dispatcher.d/20-chrony
  103. %{_sysconfdir}/dhcp/dhclient.d/chrony.sh
  104. %{_bindir}/chronyc
  105. %{_sbindir}/chronyd
  106. %{_infodir}/chrony.info*
  107. %{_mandir}/man[158]/%{name}*.[158]*
  108. %dir %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony
  109. %ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/drift
  110. %ghost %attr(-,chrony,chrony) %{_localstatedir}/lib/chrony/rtc
  111. %dir %attr(-,chrony,chrony) %{_localstatedir}/log/chrony
  112. %changelog
  113. * Mon Jul 11 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.2.1-2
  114. - Obsoletes: networkmanager-dispatcher-chrony
  115. * Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.1-1
  116. - new upstream release.
  117. * Fri Oct 23 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2-1
  118. - new upstream release.
  119. * Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  120. - new upstream release.
  121. * Tue Dec 23 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.31-1
  122. - new upstream release.
  123. * Sat Jun 7 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.29.1-1
  124. - new upstream release.
  125. - initial build for Vine Linux.
  126. * Fri Aug 09 2013 Miroslav Lichvar <mlichvar@redhat.com> 1.25-3
  127. - fix buffer overflow when processing crafted command packets (CVE-2012-4502)
  128. - don't send uninitialized data in command replies (CVE-2012-4503)
  129. * Thu May 19 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-2
  130. - remove timepps.h, NM and dhclient scripts
  131. - build with readline
  132. * Thu May 05 2011 Miroslav Lichvar <mlichvar@redhat.com> 1.25-1
  133. - update to 1.25
  134. - link with -Wl,-z,relro,-z,now options
  135. - use iburst, four pool servers, rtcsync, stratumweight in default config
  136. - suppress install-info errors
  137. * Thu Apr 29 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-4.20100428git73d775
  138. - update to 20100428git73d775
  139. - replace initstepslew directive with makestep in default config
  140. - add NetworkManager dispatcher script
  141. - add dhclient script
  142. - retry server/peer name resolution at least once to workaround
  143. NetworkManager race condition on boot
  144. - don't verify chrony.keys
  145. * Fri Mar 12 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-3.20100302git5fb555
  146. - update to snapshot 20100302git5fb555
  147. - compile with PPS API support
  148. * Thu Feb 04 2010 Miroslav Lichvar <mlichvar@redhat.com> 1.24-1
  149. - update to 1.24 (#555367, CVE-2010-0292 CVE-2010-0293 CVE-2010-0294)
  150. - modify default config
  151. - step clock on start if it is off by more than 100 seconds
  152. - disable client log
  153. - build with -fPIE on sparc
  154. * Tue Dec 15 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.24-0.1.pre1
  155. - update to 1.24-pre1
  156. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-7.20081106gitbe42b4
  157. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  158. * Fri Jul 17 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-6.20081106gitbe42b4
  159. - switch to editline
  160. - support arbitrary chronyc commands in init script
  161. * Mon Jun 08 2009 Dan Horak <dan[at]danny.cz> 1.23-5.20081106gitbe42b4
  162. - add patch with support for s390/s390x
  163. * Mon Mar 09 2009 Miroslav Lichvar <mlichvar@redhat.com> 1.23-4.20081106gitbe42b4
  164. - fix building with broken libcap header (#483548)
  165. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.23-3.20081106gitbe42b4
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  167. * Wed Nov 19 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-2.20081106gitbe42b4
  168. - fix info uninstall
  169. - generate random command key in init script
  170. - support cyclelogs, online, offline commands in init script
  171. - add logrotate script
  172. * Tue Nov 11 2008 Miroslav Lichvar <mlichvar@redhat.com> 1.23-1.20081106gitbe42b4
  173. - initial release