libcrystalhd-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159
  1. Summary: Broadcom Crystal HD device interface library
  2. Name: libcrystalhd
  3. Version: 3.5.1
  4. Release: 2%{?_dist_release}
  5. License: LGPLv2
  6. Group: System Environment/Libraries
  7. #Source: http://www.broadcom.com/docs/support/crystalhd/crystalhd_linux_20100703.zip
  8. # This tarball and README are inside the above zip file...
  9. Source0: crystalhd_07032010.tbz2
  10. Source1: README_07032010
  11. # We're going to use even newer firmware for now
  12. Source2: bcm70012fw.bin
  13. Source3: bcm70015fw.bin
  14. # LICENSE file is copy-n-pasted from http://www.broadcom.com/support/crystal_hd/
  15. Source4: LICENSE
  16. Requires: crystalhd-firmware
  17. URL: http://www.broadcom.com/support/crystal_hd/
  18. # Patch generated from http://git.wilsonet.com/crystalhd.git/
  19. Patch0: libcrystalhd-updates.patch
  20. # patch for ppc
  21. Patch1: libcrystalhd-ppc.patch
  22. ExcludeArch: s390 s390x
  23. BuildRequires: autoconf automake
  24. %description
  25. The libcrystalhd library provides userspace access to Broadcom Crystal HD
  26. video decoder devices. The device supports hardware decoding of MPEG-2,
  27. h.264 and VC1 video codecs, up to 1080p at 40fps for the first-generation
  28. bcm970012 hardware, and up to 1080p at 60fps for the second-generation
  29. bcm970015 hardware.
  30. %package devel
  31. Summary: Development libs for libcrystalhd
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. %description devel
  35. Development libraries needed to build applications against libcrystalhd.
  36. %package -n crystalhd-firmware
  37. Summary: Firmware for the Broadcom Crystal HD video decoder
  38. License: Redistributable, no modification permitted
  39. BuildArch: noarch
  40. Group: System Environment/Kernel
  41. Requires: %{name} = %{version}-%{release}
  42. %description -n crystalhd-firmware
  43. Firmwares for the Broadcom Crystal HD (bcm970012 and bcm970015)
  44. video decoders.
  45. %define majorminor 0.10
  46. %define _gst 0.10.30
  47. %define _gstpb 0.10.30
  48. %package -n gstreamer-plugin-crystalhd
  49. Summary: Gstreamer crystalhd decoder plugin
  50. Group: Applications/Multimedia
  51. Requires: %{name} = %{version}-%{release}
  52. Requires: gstreamer-plugins-base
  53. BuildRequires: gstreamer-devel >= %{_gst}
  54. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb}
  55. %description -n gstreamer-plugin-crystalhd
  56. Gstreamer crystalhd decoder plugin
  57. %prep
  58. %setup -q -n 07032010
  59. %patch0 -p1 -b .git
  60. %ifarch ppc
  61. %patch1 -p1 -b .ppc
  62. %endif
  63. cp %{SOURCE1} %{SOURCE4} .
  64. %build
  65. pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
  66. # FIXME: this doesn't work just yet...
  67. #make CPPFLAGS="%{optflags}" %{?_smp_mflags}
  68. make %{?_smp_mflags}
  69. popd > /dev/null 2>&1
  70. pushd filters/gst/gst-plugin/ > /dev/null 2>&1
  71. %configure
  72. make %{?_smp_mflags}
  73. popd > /dev/null 2>&1
  74. %install
  75. rm -rf $RPM_BUILD_ROOT
  76. pushd linux_lib/libcrystalhd/ > /dev/null 2>&1
  77. make install LIBDIR=%{_libdir} DESTDIR=$RPM_BUILD_ROOT
  78. popd > /dev/null 2>&1
  79. pushd filters/gst/gst-plugin/ > /dev/null 2>&1
  80. make install DESTDIR=$RPM_BUILD_ROOT
  81. rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-0.10/libgstbcmdec.{a,la}
  82. popd > /dev/null 2>&1
  83. cp -p %{SOURCE2} $RPM_BUILD_ROOT/lib/firmware/
  84. cp -p %{SOURCE3} $RPM_BUILD_ROOT/lib/firmware/
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %post -p /sbin/ldconfig
  88. %postun -p /sbin/ldconfig
  89. %files
  90. %defattr(-,root,root,0755)
  91. %doc README_07032010 LICENSE
  92. %{_libdir}/libcrystalhd.so.*
  93. %files devel
  94. %defattr(-,root,root,0755)
  95. %dir %{_includedir}/libcrystalhd
  96. %{_includedir}/libcrystalhd/*
  97. %{_libdir}/libcrystalhd.so
  98. %files -n crystalhd-firmware
  99. %defattr(-,root,root,0755)
  100. %doc LICENSE
  101. /lib/firmware/bcm70012fw.bin
  102. /lib/firmware/bcm70015fw.bin
  103. %files -n gstreamer-plugin-crystalhd
  104. %defattr(-,root,root,0755)
  105. %{_libdir}/gstreamer-%{majorminor}/*.so
  106. %changelog
  107. * Sun May 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.1-2
  108. - add Patch1 for ppc (libcrystalhd-ppc.patch)
  109. * Sun Feb 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 3.5.1-1
  110. - initial build based on Fedora rawhide
  111. * Sat Aug 28 2010 Jarod Wilson <jarod@redhat.com> - 3.5.1-1
  112. - Update to v3.5.1, now with nv12 support
  113. * Sun Jul 25 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-2
  114. - Tarball had object files in it, clean them out before building
  115. * Sat Jul 24 2010 Jarod Wilson <jarod@redhat.com> - 3.5.0-1
  116. - Rebase to 07032010 crystalhd sources
  117. - Large version-bump as driver and lib are now essentially 100%
  118. in sync with the Windows driver and lib
  119. - Ship firmware, now that Broadcom has posted a redistribution,
  120. no modification license to cover it
  121. - Build the gstreamer decoder plugin (will be moved to its own
  122. package sooner or later)
  123. * Sun Apr 04 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-4
  124. - Fix segfault on firmware upload
  125. * Fri Mar 26 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-3
  126. - Update to pre-0.9.26 libcrystalhd, which contains support
  127. for the new Broadcom BCM970015 Crystal HD decoder card
  128. * Thu Mar 11 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-2
  129. - Minor fixups to the as-yet-not-enabled firmware sub-package
  130. * Wed Jan 06 2010 Jarod Wilson <jarod@redhat.com> - 0.9.25-1
  131. - Initial package