chromium13-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. %define pkgname chromium
  5. #% define with_system_icu 1
  6. #% define with_system_v8 1
  7. #NOTE: src/third_party/ffmpeg/ffmpeg.gyp:
  8. # libvpx doesn't currently supply a pkg-config file, so we assume that
  9. # -lvpx is sufficient.
  10. %define with_system_vpx 1
  11. Name: chromium13
  12. #Name: chromium
  13. Summary: Google's opens source browser project
  14. Summary(ja): Googleのオープンソースウェブブラウザ
  15. #'
  16. Version: 13.0.782.88
  17. Release: 1%{?_dist_release}
  18. License: BSD
  19. Group: Applications/Internet
  20. Source0: %{pkgname}-%{version}.tar.xz
  21. # Script used to create the %{pkgname}-%{version}.tar.xz archive from
  22. # a official tarball:
  23. # http://build.chromium.org/official/chromium-13.0.782.XXX.tar.bz2
  24. Source3: pack_chromium13_source-vine.sh
  25. # Official ffmpeg headers
  26. Source8: ffmpeg-0.6-headers.tar.xz
  27. # Patch template which adds vendor to user agent
  28. ##!!Source20: chromium-vendor.patch.in
  29. Source20: chromium-vendor-vine.patch.in
  30. # Set default prefs
  31. ##!!Source30: master_preferences
  32. Source30: master_preferences.vine
  33. ##!!Source31: default_bookmarks.html
  34. #Source31: default_bookmarks.html.vine
  35. Source99: chrome-wrapper
  36. ##!!Source100: chromium-browser.sh
  37. Source100: chromium-browser-vine.sh
  38. ##!!Source101: chromium-browser.desktop
  39. Source101: chromium-browser-vine.desktop
  40. Source102: chromium-browser.xml
  41. Source103: chromium-browser-rpmlintrc
  42. ##!!Source104: chromium-icons.tar.bz2
  43. %{?nosrc:NoSource: 0}
  44. Provides: chromium-unstable = %{version}
  45. Conflicts: chromium-stable
  46. ## Start Patches
  47. # OpenSuse and Fedora
  48. # Many changes to the gyp systems so we can use system libraries
  49. #Patch1: chromium-gcc46.patch
  50. Patch4: chromium-no-sqlite-debug.patch
  51. Patch8: chromium-codechanges-zlib.patch
  52. Patch12: chromium-no-test-sources.patch
  53. Patch13: chromium-no-courgette.patch
  54. Patch14: chromium-master-prefs-path.patch
  55. Patch17: chromium-system-glew.patch
  56. Patch18: chromium-system-expat.patch
  57. Patch19: chromium-system-zlib.patch
  58. Patch20: chromium-6.0.425.0-ffmpeg-no-pkgconfig.patch
  59. Patch21: chromium-7.0.542.0-media-probe.patch
  60. Patch25: tcmalloc-factory.patch
  61. Patch26: chromium-remoting-build-fix.diff
  62. Patch28: chromium-7.0.500.0-system-speex.patch
  63. Patch29: chromium-7.0.510.0-system-ffmpeg.patch
  64. Patch32: chromium-7.0.542.0-system-libvpx.patch
  65. Patch34: chromium-7.0.542.0-codechanges-system-minizip-v8.patch
  66. Patch62: chromium-norpath.patch
  67. Patch63: chromium-6.0.406.0-system-gyp-v8.patch
  68. # Vine
  69. Patch100: chromium-13.0.782.13-no-tests.patch
  70. ##!!BuildRequires: Mesa-devel
  71. BuildRequires: mesa-libGLU-devel
  72. ##!!BuildRequires: alsa-devel
  73. BuildRequires: alsa-lib-devel
  74. BuildRequires: bison
  75. BuildRequires: cups-devel
  76. BuildRequires: desktop-file-utils
  77. BuildRequires: fdupes
  78. BuildRequires: flex
  79. BuildRequires: freetype2-devel
  80. BuildRequires: gcc gcc-c++
  81. BuildRequires: gperf
  82. BuildRequires: hunspell-devel
  83. ##!!BuildRequires: libbz2-devel
  84. BuildRequires: bzip2-devel
  85. BuildRequires: libevent
  86. ##!!BuildRequires: libexpat-devel
  87. BuildRequires: expat-devel
  88. ##!!BuildRequires: libgnutls-devel
  89. BuildRequires: gnutls-devel
  90. BuildRequires: libjpeg-devel
  91. BuildRequires: libpng-devel
  92. BuildRequires: libstdc++-devel >= 4.4
  93. %{?with_system_vpx:BuildRequires: libvpx-devel >= 0.9.5}
  94. BuildRequires: libxslt-devel
  95. BuildRequires: libzip-devel
  96. ##!!BuildRequires: lzma
  97. BuildRequires: xz
  98. ##!!BuildRequires: mozilla-nspr-devel
  99. BuildRequires: nspr-devel
  100. ##!!BuildRequires: mozilla-nss-devel
  101. BuildRequires: nss-devel
  102. BuildRequires: openssl-devel
  103. BuildRequires: pam-devel
  104. ##!!BuildRequires: perl(Switch)
  105. BuildRequires: perl
  106. ##!!BuildRequires: pkg-config
  107. BuildRequires: cairo-devel >= 1.6
  108. BuildRequires: dbus-devel
  109. ##!!BuildRequires: gconf2-devel
  110. BuildRequires: GConf2-devel
  111. BuildRequires: glib2-devel
  112. BuildRequires: gtk2-devel
  113. BuildRequires: libxml2-devel
  114. BuildRequires: python
  115. ##!!BuildRequires: python-xml
  116. BuildRequires: python-pyxml
  117. BuildRequires: sqlite3-devel
  118. ##!!BuildRequires: update-desktop-files
  119. %{?with_system_v8:BuildRequires: v8-devel = %{v8_ver}}
  120. ##!!BuildRequires: wdiff
  121. BuildRequires: zlib-devel
  122. BuildRequires: libgnome-keyring-devel
  123. BuildRequires: python-devel
  124. #BuildRequires: glew-devel
  125. BuildRequires: libevent-devel
  126. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  127. #BuildRequires: libjingle-devel >= 0.4.0-7
  128. #BuildRequires: srtp-devel
  129. BuildRequires: speex-devel
  130. ##Vine Linux
  131. #BuildRequires: libpaper-devel
  132. BuildRequires: libXScrnSaver-devel
  133. BuildRequires: libXtst-devel
  134. BuildRequires: libXdamage-devel
  135. BuildRequires: libXt-devel
  136. %ifarch x86_64
  137. Requires: nspluginwrapper
  138. %endif
  139. ##!!Requires: alsa
  140. Requires: alsa-lib
  141. Requires: xdg-utils
  142. %{?with_system_v8:Requires: v8 = %{v8_ver}}
  143. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  144. %description
  145. Chromium is the open-source project behind Google Chrome.
  146. We invite you to join us in our effort to help build a safer, faster,
  147. and more stable way for all Internet users to experience the web,
  148. and to create a powerful platform for developing a new generation of
  149. web applications.
  150. %description -l ja
  151. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  152. ウェブを体験しているすべてのインターネットユーザに対して
  153. より安全で、より速くて、より安定した方法を築き上げるのを補助するでしょう。
  154. そして、ウェブアプリケーションの新しい世代を発展させ、
  155. 強力なプラットホームを作成するために、
  156. 私たちの取り組みにぜひ参加してください。
  157. %prep
  158. #%setup -q
  159. [ -d %{pkgname}-%{version} ] && %__rm -rf %{pkgname}-%{version}
  160. xz -dc %{SOURCE0} | %__tar -xf - || exit 1
  161. %setup -D -T -n %{pkgname}-%{version}
  162. #%patch1 -p1
  163. %patch62 -p1
  164. %{?with_system_v8:%patch63 -p1}
  165. %patch100 -p1 -b .vine
  166. %patch4 -p1
  167. %patch8 -p1
  168. %patch12 -p1
  169. %patch13 -p1
  170. %patch14 -p1
  171. %patch17 -p1
  172. %patch18 -p1
  173. %patch19 -p1
  174. %patch20 -p1
  175. %patch21 -p1
  176. %patch25 -p1
  177. %patch26 -p1
  178. %patch28 -p1
  179. %patch29 -p1
  180. %{?with_system_vpx:%patch32 -p1}
  181. %{?with_system_v8:%patch34 -p1}
  182. pushd src/third_party/ffmpeg/
  183. %__tar xf %{SOURCE8} || exit 1
  184. ## built header file: avconfig.h
  185. [ -f ffmpeg-0.6-headers/libavutil/avconfig.h ] && exit 1
  186. cat > ffmpeg-0.6-headers/libavutil/avconfig.h <<EOF
  187. /* Generated by ffconf */
  188. #ifndef AVUTIL_AVCONFIG_H
  189. #define AVUTIL_AVCONFIG_H
  190. #define AV_HAVE_BIGENDIAN 0
  191. #endif /* AVUTIL_AVCONFIG_H */
  192. EOF
  193. popd
  194. #%__rm -rf src/third_party/libvpx/
  195. %__rm -rf src/third_party/speex/
  196. %__rm -rf src/third_party/nss src/third_party/nspr
  197. # apply vendor patch after substitution
  198. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  199. %build
  200. ## create make files
  201. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-ipa-cp -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  202. for i in src/build/common.gypi; do
  203. %__sed -i "s|'-march=pentium4',||g" $i
  204. %__sed -i "s|'-mfpmath=sse',||g" $i
  205. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  206. %__sed -i "s|'-m32',||g" $i
  207. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  208. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  209. done
  210. # '
  211. pushd src
  212. ./build/gyp_chromium -f make build/all.gyp \
  213. -Dlinux_sandbox_path=%{_libdir}/chromium/chrome-sandbox \
  214. -Dlinux_sandbox_chrome_path=%{_libdir}/chromium/chromium-browser \
  215. -Duse_openssl=0 \
  216. -Duse_system_ffmpeg=1 \
  217. -Duse_system_zlib=1 \
  218. -Duse_system_libpng=1 \
  219. -Duse_system_bzip2=1 \
  220. -Duse_system_libbz2=1 \
  221. -Duse_system_libjpeg=1 \
  222. -Duse_system_libxml=1 \
  223. -Duse_system_libxslt=1 \
  224. -Duse_system_libevent=1 \
  225. %{?with_system_vpx:-Duse_system_vpx=1} \
  226. %{!?with_system_vpx:-Duse_system_vpx=0} \
  227. -Dremove_webcore_debug_symbols=1 \
  228. %{?with_system_v8:-Duse_system_v8=1} \
  229. %{!?with_system_v8:-Duse_system_v8=0} \
  230. %{?with_system_icu:-Duse_system_icu=1} \
  231. %{!?with_system_icu:-Duse_system_icu=0} \
  232. %{?_with_shared_library:-Dlibrary=shared_library} \
  233. -Dproprietary_codecs=1 \
  234. -Djavascript_engine=v8 \
  235. -Dlinux_fpic=1 \
  236. %ifarch %{ix86}
  237. -Dtarget_arch=ia32 \
  238. -Ddisable_sse2=1 \
  239. %endif
  240. %ifarch x86_64
  241. -Dtarget_arch=x64 \
  242. %endif
  243. -Dno_strict_aliasing=1 \
  244. -Drelease_extra_cflags=-fPIC \
  245. %if %{?_dist_release} == "vl6"
  246. -Dgcc_version=44 \
  247. %endif
  248. ;
  249. #%__make -r %{?_smp_mflags} chrome BUILDTYPE=Release
  250. %__make -r %{?_smp_mflags} chrome V=1 BUILDTYPE=Release
  251. popd
  252. %install
  253. %{__rm} -rf %{buildroot}
  254. %__mkdir -p %{buildroot}%{_bindir}
  255. %__install -m 755 %{SOURCE100} %{buildroot}%{_bindir}/chromium
  256. # x86_64 capable systems need this
  257. %__sed -i "s|/usr/lib/chromium|%{_libdir}/chromium|g" %{buildroot}%{_bindir}/chromium
  258. %__mkdir -p %{buildroot}%{_libdir}/chromium/
  259. %__mkdir -p %{buildroot}%{_mandir}/man1/
  260. pushd src/out/Release
  261. %__cp -a chrome.pak locales resources xdg-settings %{buildroot}%{_libdir}/chromium/
  262. %__cp -a resources.pak %{buildroot}%{_libdir}/chromium/
  263. %__cp -a chrome %{buildroot}%{_libdir}/chromium/chromium
  264. %{?_with_shared_library:%__cp -a lib.target/lib*.so %{buildroot}%{_libdir}/chromium/}
  265. %{?_with_shared_library:%__cp -a lib.host/lib*.so %{buildroot}%{_libdir}/chromium/}
  266. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chrome.1
  267. %__cp -a chrome.1 %{buildroot}%{_mandir}/man1/chromium.1
  268. fdupes %{buildroot}%{_mandir}/man1/
  269. popd
  270. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  271. %__cp -a src/chrome/app/theme/chromium/product_logo_48.png %{buildroot}%{_datadir}/pixmaps/chromium-browser.png
  272. for i in 16 22 24 32 48 64 128 256; do
  273. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps
  274. %__cp -a src/chrome/app/theme/chromium/product_logo_${i}.png %{buildroot}%{_datadir}/icons/hicolor/${i}x${i}/apps/chromium-browser.png || exit 1
  275. done
  276. %__mkdir_p %{buildroot}%{_datadir}/applications/
  277. desktop-file-install --dir %{buildroot}%{_datadir}/applications %{SOURCE101}
  278. %__mkdir_p %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  279. %__cp -a %{SOURCE102} %{buildroot}%{_datadir}/gnome-control-center/default-apps/
  280. # # link to browser plugin path. Plugin patch doesn't work. Why?
  281. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  282. # pushd %{buildroot}%{_libdir}/%{pkgname}
  283. # %{__ln_s} %{_libdir}/browser-plugins plugins
  284. # popd
  285. pushd %{buildroot}%{_libdir}/%{pkgname}
  286. %ifarch x86_64
  287. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  288. %else
  289. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  290. %endif
  291. ## support ffmpeg libs
  292. touch %{buildroot}%{_libdir}/libavcodec.so.52
  293. %{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  294. touch %{buildroot}%{_libdir}/libavformat.so.52
  295. %{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  296. touch %{buildroot}%{_libdir}/libavutil.so.50
  297. %{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  298. popd
  299. # Install the master_preferences file
  300. %__mkdir_p %{buildroot}%{_sysconfdir}/%{pkgname}
  301. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}
  302. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{pkgname}/$(basename %{SOURCE30} .vine)
  303. #%__install -m 0644 %{SOURCE31} %{buildroot}%{_sysconfdir}/%{pkgname}
  304. %clean
  305. %{__rm} -rf %{buildroot}
  306. %post
  307. touch --no-create %{_datadir}/icons/hicolor
  308. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  309. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  310. fi
  311. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications || :
  312. %postun
  313. %{_bindir}/update-desktop-database --quiet %{_datadir}/applications
  314. touch --no-create %{_datadir}/icons/hicolor
  315. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  316. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  317. fi || :
  318. %files
  319. %defattr(-,root,root,-)
  320. %config %{_sysconfdir}/%{pkgname}
  321. %dir %{_datadir}/gnome-control-center
  322. %dir %{_datadir}/gnome-control-center/default-apps
  323. %dir %{_libdir}/chromium/
  324. %{_bindir}/chromium
  325. %{_libdir}/chromium/chromium
  326. %{_libdir}/chromium/plugins/
  327. %{_libdir}/chromium/resources/
  328. %{_libdir}/chromium/xdg-settings
  329. %{_mandir}/man1/chrom*
  330. %{_datadir}/pixmaps/chromium-browser.png
  331. %{_datadir}/icons/hicolor/*/apps/chromium-browser.png
  332. %{_datadir}/applications/*.desktop
  333. %{_datadir}/gnome-control-center/default-apps/chromium-browser.xml
  334. #%{_datadir}/icons/oxygen/
  335. %{_libdir}/chromium/chrome.pak
  336. %{_libdir}/chromium/resources.pak
  337. %{_libdir}/chromium/locales/
  338. %{?_with_shared_library:%{_libdir}/chromium/lib*.so}
  339. %{_libdir}/chromium/libavcodec.so.52
  340. %{_libdir}/chromium/libavutil.so.50
  341. %{_libdir}/chromium/libavformat.so.52
  342. %exclude %{_libdir}/libavcodec.so.52
  343. %exclude %{_libdir}/libavutil.so.50
  344. %exclude %{_libdir}/libavformat.so.52
  345. %changelog
  346. * Wed Jul 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 13.0.782.88-1
  347. - updated to 13.0.782.88
  348. - added BuildRequires: libzip-devel
  349. - added Provides: chromium-unstable = %%{version}
  350. - added Conflicts: chromium-stable
  351. * Thu Jun 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 12.0.742.93-1
  352. - fix user-agent string (chromium-vendor-vine.patch.in)
  353. - move vendor string (Vine/12.0.742.91-1vl6) to the end.
  354. * Sat Jun 11 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.93-1
  355. - updated to 12.0.742.93
  356. - fixed icon field of chromium-browser-vine.desktop
  357. * Wed Jun 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.91-1
  358. - updated to 12.0.742.91
  359. * Sun Jun 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.77-1
  360. - updated to 12.0.742.77
  361. * Sat May 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.63-1
  362. - updated to 12.0.742.63
  363. * Sun May 07 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.42-1
  364. - updated to 12.0.742.42
  365. * Sun Apr 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 12.0.742.6-1
  366. - updated to 12.0.742.6
  367. - dropped/upstreamed patches
  368. - updated our no-tests patch (chromium-12.0.742.6-no-tests.patch)
  369. * Wed Apr 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.50-1
  370. - updated to 11.0.696.50
  371. - dropped some Patches for MeeGo Netbook
  372. * Tue Apr 05 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.35-1
  373. - updated to 11.0.696.35
  374. * Wed Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.29-1
  375. - updated to 11.0.696.29
  376. - dropped "--no-first-run" in command line options of chromium-browser-vine.sh
  377. * Thu Mar 24 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.22-1
  378. - updated to 11.0.696.22
  379. - improved chromium-browser-vine.sh
  380. - merged from chromium-browser-vine.desktop of 11.0.696.17-1
  381. * Wed Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.20-1
  382. - updated to 11.0.696.20
  383. - improved chromium-browser-vine.desktop
  384. * Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.17-1
  385. - updated to 11.0.696.17
  386. * Sat Mar 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.15-1
  387. - updated to 11.0.696.15
  388. - ready for Vine Linux 6 release
  389. - dropped BuildRequires: v8-devel, libicu-devel
  390. * Wed Mar 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 11.0.696.5-1
  391. - updated to 11.0.696.5 with v8 3.2.0
  392. - added BuildRequires: pam-devel
  393. * Thu Feb 10 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 10.0.651.0-2
  394. - rebuilt with libevent-2.0.10
  395. * Sat Jan 29 2011 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.651.0-1
  396. - updated to 10.0.651.0 with v8 3.0.12
  397. - added BuildRequires:
  398. - libpaper-devel
  399. - python-devel
  400. - added built header file: libavutil/avconfig.h %%prep
  401. - unexport MOZ_PLUGIN_PATH in chromium-browser-vine.sh
  402. * Sun Dec 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.622.0-1
  403. - updated to 10.0.622.0
  404. - added BuildRequires: libXt-devel
  405. * Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 10.0.605.0-1
  406. - updated to 10.0.605.0
  407. - added BuildRequires:
  408. - libXdamage-devel
  409. - hunspell-devel
  410. * Sat Dec 04 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.598.0-1
  411. - updated to 9.0.598
  412. * Fri Nov 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.593.0-1
  413. - updated to 9.0.593
  414. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.582.0-1
  415. - updated to 9.0.582
  416. - added Requires: xdg-utils
  417. * Thu Nov 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.578.0-1
  418. - updated to 9.0.578
  419. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 9.0.569.0-1
  420. - updated to 9.0.569
  421. * Mon Oct 25 2010 tittiatcoke@gmail.com
  422. - Update to 9.0.564 build
  423. * Added specific patches for MeeGo.
  424. * We are now using shared libraries for Chromium
  425. * Spec-file cleanup (Thanks to prusnak)
  426. * Sat Oct 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.556.0-1
  427. - updated to snapshot 8.0.556
  428. * Sun Oct 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 8.0.551.0-1
  429. - updated to snapshot 8.0.551
  430. * Fri Sep 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.527.0-1
  431. - updated to snapshot 7.0.527
  432. * Thu Sep 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.519.0-1
  433. - updated to snapshot 7.0.519
  434. * Fri Sep 03 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.513.0-1
  435. - updated to snapshot 7.0.513
  436. - updated chromium-vendor-vine.patch.in
  437. * Sat Aug 28 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.507.0-1
  438. - updated to snapshot 7.0.507
  439. * Wed Aug 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 7.0.498.0-1
  440. - updated to snapshot 7.0.498
  441. * Sat Aug 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.493.0-1
  442. - updated to snapshot 6.0.493
  443. - used with_system_icu (for vl6)
  444. - added BuildRequires: libicu-devel
  445. * Thu Jul 22 2010 IWAI, Masaharu <iwai@alib.jp> 6.0.454.0-2vl5
  446. - build for Vine Linux 5.x
  447. - add BuildRequires: gnome-keyring-devel
  448. * Sat Jul 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.454.0-1
  449. - updated to snapshot 6.0.454
  450. - added BuildRequires:
  451. - sqlite3-devel
  452. - gnutls-devel
  453. - libgnome-keyring-devel
  454. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.431.0-1
  455. - updated to snapshot 6.0.431.0 r49253
  456. - added BuildRequires: cups-devel
  457. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  458. - updated to snapshot 6.0.405.0 r47263
  459. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  460. - unused with_system_icu (for vl6)
  461. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  462. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  463. - updated to snapshot 5.0.378.0 r44472
  464. - used with_system_icu (for vl6)
  465. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  466. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  467. - updated to snapshot 5.0.372.0 r43947
  468. - added BuildRequires: glew-devel
  469. - changed Group tag to Applications/Internet
  470. - added Summary(ja) and %%description -l ja
  471. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  472. - updated to snapshot 5.0.365.0 r42966
  473. - merged 5.0.353.0-4vl5
  474. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  475. - build on Vine Linux 5.1
  476. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  477. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  478. - updated to snapshot 5.0.364.0 r42779
  479. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  480. - updated to snapshot 5.0.359.0 r42116
  481. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  482. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  483. - fixed master_preferences.vine, little
  484. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  485. - fixed to install master_preferences
  486. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  487. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  488. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  489. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  490. - updated to snapshot 5.0.353.0 r41449
  491. * Wed Mar 10 2010 bgmerrell@novell.com
  492. - Add master_preferences source file and install it to /etc/chromium.
  493. - Create a new patch (chromium-master-prefs-path.patch) which tells
  494. chromium to look in /etc/chromium for the master_preferences file
  495. (instead of looking in the default directory, which is the same
  496. directory as the 'chrome' binary).
  497. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  498. - updated to snapshot 5.0.335.0 r39556
  499. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  500. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  501. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  502. - updated to snapshot 5.0.330.0 r39074
  503. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  504. - use_system_ffmpeg
  505. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  506. - added Requires: nspluginwrapper
  507. - fixed a symbolic link of plugins directory with nspluginwrapper
  508. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  509. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  510. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  511. - added BuildRequires: mesa-libGLU-devel
  512. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  513. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  514. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  515. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  516. - Update to 4.0.260
  517. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  518. - Update to 4.0.259
  519. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  520. - Update to 4.0.258
  521. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  522. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  523. changed to having an built-in v8
  524. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  525. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  526. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  527. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  528. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  529. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  530. - update to newer svn snapshot
  531. + Obsoletes fwrite patch (included upstream)
  532. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  533. - update to newer svn snapshot
  534. + Requires newer version of v8
  535. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  536. - do not force SSE on x86 (drop-sse.patch)
  537. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  538. - Update to newer svn snapshot
  539. - Fixed spec file in order to build
  540. - Included patch to build with system zlib
  541. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  542. - package renamed to chromium
  543. - cleaned up spec file
  544. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  545. - v8 is now built as a separate package, and is required
  546. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  547. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  548. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  549. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  550. - initial build
  551. #% changelog
  552. * Sun Jan 24 2010 prusnak@suse.cz
  553. - added vendor to user agent (chromium-vendor.patch.in)
  554. * Sun Nov 29 2009 prusnak@suse.cz
  555. - added --enable-sync to wrapper to enable bookmark sync
  556. * Sun Nov 29 2009 tittiatcoke@gmail.com
  557. - Update to 4.0.260
  558. * Fri Nov 27 2009 tittiatcoke@gmail.com
  559. - Update to 4.0.259
  560. * Thu Nov 26 2009 tittiatcoke@gmail.com
  561. - Update to 4.0.258
  562. * Tue Nov 24 2009 tittatcoke@gmai.com
  563. - In order to complete prevent the wrong v8 version to be used,
  564. the Chromium build has been changed to having an built-in v8
  565. * Tue Nov 24 2009 dbuck@example.com
  566. - Re-base patches.
  567. - Fixed a few patch errors.
  568. - Rename some patches to better correspond with function.
  569. - Removed some patches.
  570. - Minor SPEC changes.
  571. - I changed the v8 requirement to be exact, instead of greater than a specific version.
  572. * Fri Nov 13 2009 tittiatcoke@gmail.com
  573. - update to 247.0 svn 31928
  574. * Fri Oct 30 2009 tittiatcoke@gmail.com
  575. - update to 229.0 svn 30454
  576. + Fix regression where popups and app frames lost their titlebars.
  577. + Makes it so that when a folder is open on the bookmark bar
  578. and the mouse moves over another folder, the menu for that
  579. folder is shown.
  580. + Lazily create the find bar.
  581. + Polish to the gmail checker sample.
  582. * New, crisper icons that are exactly 19x19
  583. * Add a loading animation at the beginning before Gmail
  584. responds.
  585. * Fix a bug where we sometimes don't update the UI after a
  586. logout/login cycle.
  587. + Refactor widget methods to support desktop notifications,
  588. including GTK stubs.
  589. + Find-in-page should not ding while deleting characters.
  590. + Add SSL wrapper for linux and mac. This allows notifier to
  591. use chrome's SSL layer instead of OpenSSL.
  592. + Add three of the six extensions to PAC that Internet Explorer supports.
  593. + WebSocket support in chromium. (Run with --enable-web-sockets
  594. enables WebSocket features.)
  595. + Do not allow GTK File Chooser dialogs to return directories.
  596. + Fix the notifier SSL layer to make notifications work for
  597. Linux Bookmark sync.
  598. + linux: don't override mouse selection behavior in omnibox
  599. * Sun Oct 25 2009 tittiatcoke@gmail.com
  600. - Update to 224.4 svn 30027
  601. + First cut at new page and browser action docs based
  602. on new API. Deleted old stuff.
  603. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  604. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  605. + Minimize dependency of user scripts
  606. + Fixup the flip_framer eof-handling semantics now that we have
  607. the FIN bit in place
  608. + app depends on x11 because of active_window_watcher_x
  609. + Adding two images for the new Extension managment UI
  610. + Removing hard-coded Chrome Frame output path
  611. + Rearrange clipboard code
  612. + Fix crash bug when attempting to download a url with unsupported scheme,
  613. e.g. 'data:', by 'Alt + Click'
  614. + GTK: Change text for extension download UI
  615. + Ignore invalid urls on command line
  616. + Make dropped tabs animate from where they were dropped.
  617. + Make room for the full width of the tab placeholder.
  618. + Make tab dragging as smooth as glass.
  619. + Remove an annoying NOTIMPLEMNETED
  620. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  621. + If we're in the middle of a drag, don't allow the user to middle
  622. click to close or right click for the context menu
  623. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  624. + Remove +x bit from files that shouldn't have it
  625. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  626. + Adding new image needed for the managment UI
  627. + Fix a race bug where content scripts would not apply to the first page load
  628. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  629. + Fix bubbles deactivating the opaque frame
  630. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  631. + ake all pepper plugins default to windowless and transparent
  632. + Add styles for printing
  633. + Implement the new extension management UI
  634. + Add support for to automation interface load install and load extensions
  635. + GTK: theme the info bar border
  636. + Update V8 to version 1.3.16.1
  637. + Introduce WebSecurityPolicy for security related methods
  638. + New button scheme...borders are separate from the inner contents so
  639. that they can be highlighted / depressed independently
  640. + When opening Chrome maximized with an application window already
  641. running, the Chrome window was not activated
  642. + Fix compatibility problems with FileZilla FTP Server
  643. + Remove the extension shelf on Linux
  644. + Fix the proxy host and port string to start with http:// if it does not already
  645. + Enable HTML5 databases for all extension renderer processes
  646. * Sat Oct 24 2009 prusnak@opensuse.org
  647. - don't create desktop files in wrapper
  648. - fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  649. * Tue Oct 20 2009 tittiatcoke@gmail.com
  650. - update to newer svn snapshot
  651. + Obsoletes fwrite patch (included upstream)
  652. * Fri Oct 16 2009 tittiatcoke@gmail.com
  653. - update to newer svn snapshot
  654. + Requires newer version of v8
  655. * Thu Oct 15 2009 prusnak@suse.cz
  656. - do not force SSE on x86 (drop-sse.patch)
  657. * Tue Oct 13 2009 tittiatcoke@gmail.com
  658. - Update to newer svn snapshot
  659. - Fixed spec file in order to build
  660. - Included patch to build with system zlib
  661. * Mon Oct 12 2009 prusnak@suse.cz
  662. - package renamed to chromium
  663. - cleaned up spec file
  664. * Tue Oct 6 2009 dbuck@example.com
  665. - v8 is now built as a separate package, and is required
  666. - included many patches to use system libraries:
  667. v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  668. * Thu Oct 1 2009 dbuck@example.com
  669. - included a newer DEP than is in svn, native_client@823
  670. - things should compile cleanly now
  671. * Mon Aug 31 2009 dbuck@example.com
  672. - initial build