gstreamer-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478
  1. # keep in sync with the VERSION. gstreamer can append a .0.1 to CVS snapshots.
  2. %define major 0.10
  3. %define _glib2_ver 2.28.8
  4. %define _libxml2_ver 2.7.8
  5. %define _gtk_doc_ver 1.3
  6. %define _check_ver 0.9.2
  7. %define _python_ver 2.6
  8. %define po_package %{name}-%{major}
  9. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  10. Name: gstreamer
  11. Summary: GStreamer streaming media framework runtime.
  12. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  13. Version: 0.10.36
  14. Release: 1%{?_dist_release}
  15. Group: System Environment/Libraries
  16. License: LGPL
  17. URL: http://gstreamer.freedesktop.org/
  18. Source: http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: glib2-devel >= %{_glib2_ver}
  21. BuildRequires: libxml2-devel >= %{_libxml2_ver}
  22. BuildRequires: bison
  23. BuildRequires: gtk-doc >= %{_gtk_doc_ver}
  24. BuildRequires: flex
  25. BuildRequires: ghostscript
  26. BuildRequires: check >= %{_check_ver}
  27. BuildRequires: python >= %{_python_ver}, python-pyxml
  28. BuildRequires: gobject-introspection-devel
  29. Requires: glib2 >= %{_glib2_ver}
  30. Requires: libxml2 >= %{_libxml2_ver}
  31. Obsoletes: gstreamer-tools
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. Packager: inagaki, Takemikaduchi
  35. %description
  36. GStreamer is a streaming-media framework, based on graphs of filters which
  37. operate on media data. Applications using this library can do anything
  38. from real-time sound processing to playing videos, and just about anything
  39. else media-related. Its plugin-based architecture means that new data
  40. types or processing capabilities can be added simply by installing new
  41. plugins.
  42. %package devel
  43. Summary: Libraries/header files for GStreamer streaming media framework.
  44. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  45. Group: Development/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. Requires: glib2-devel >= %{_glib2_ver}
  48. Requires: libxml2-devel >= %{_libxml2_ver}
  49. %description devel
  50. GStreamer is a streaming-media framework, based on graphs of filters which
  51. operate on media data. Applications using this library can do anything
  52. from real-time sound processing to playing videos, and just about anything
  53. else media-related. Its plugin-based architecture means that new data
  54. types or processing capabilities can be added simply by installing new
  55. plugins.
  56. This package contains the libraries and includes files necessary to develop
  57. applications and plugins for GStreamer.
  58. # compat32
  59. %package -n compat32-%{name}
  60. Summary: GStreamer streaming media framework runtime.
  61. Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
  62. Group: System Environment/Libraries
  63. %description -n compat32-%{name}
  64. GStreamer is a streaming-media framework, based on graphs of filters which
  65. operate on media data. Applications using this library can do anything
  66. from real-time sound processing to playing videos, and just about anything
  67. else media-related. Its plugin-based architecture means that new data
  68. types or processing capabilities can be added simply by installing new
  69. plugins.
  70. %package -n compat32-%{name}-devel
  71. Summary: Libraries/header files for GStreamer streaming media framework.
  72. Summary(ja): GStreamer ストリーミングメディアフレームワークのライブラリ/ヘッダファイル
  73. Group: Development/Libraries
  74. Requires: compat32-%{name} = %{version}-%{release}
  75. Requires: %{name}-devel = %{version}-%{release}
  76. Requires: compat32-glib2-devel >= %{_glib2_ver}
  77. Requires: compat32-libxml2-devel >= %{_libxml2_ver}
  78. %description -n compat32-%{name}-devel
  79. GStreamer is a streaming-media framework, based on graphs of filters which
  80. operate on media data. Applications using this library can do anything
  81. from real-time sound processing to playing videos, and just about anything
  82. else media-related. Its plugin-based architecture means that new data
  83. types or processing capabilities can be added simply by installing new
  84. plugins.
  85. This package contains the libraries and includes files necessary to develop
  86. applications and plugins for GStreamer.
  87. %prep
  88. %setup -q
  89. %build
  90. %configure \
  91. --with-package-name='Vine Linux gstreamer package' \
  92. --with-cachedir=%{_var}/cache/gstreamer-%{major} \
  93. --enable-introspection=yes \
  94. --disable-docbook --enable-gtk-doc \
  95. --disable-static --disable-examples \
  96. --disable-tests --disable-debug
  97. make %{?_smp_mflags}
  98. %install
  99. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  100. make install DESTDIR=$RPM_BUILD_ROOT
  101. mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
  102. rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
  103. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  104. #rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
  105. %find_lang %{po_package}
  106. %clean
  107. [ -n $RPM_BUILD_ROOT -a $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
  108. %post -p /sbin/ldconfig
  109. %postun -p /sbin/ldconfig
  110. %post -n compat32-%{name} -p /sbin/ldconfig
  111. %postun -n compat32-%{name} -p /sbin/ldconfig
  112. %files -f %{po_package}.lang
  113. %defattr(-, root, root)
  114. %doc AUTHORS ChangeLog COPYING README NEWS RELEASE
  115. %doc TODO ABOUT-NLS
  116. %{_bindir}/*
  117. %dir %{_libdir}/gstreamer-%{major}
  118. %{_libdir}/gstreamer-%{major}/*.so*
  119. %{_libdir}/*.so.*
  120. %{_libdir}/girepository-1.0/*.typelib
  121. %dir %{_libexecdir}/gstreamer-%{major}
  122. %{_libexecdir}/gstreamer-%{major}/gst-plugin-scanner
  123. %{_mandir}/man1/*
  124. %dir %{_var}/cache/gstreamer-%{major}
  125. %files devel
  126. %defattr(-, root, root)
  127. %dir %{_includedir}/%{name}-%{major}
  128. %{_includedir}/%{name}-%{major}/*
  129. #{_libdir}/*.a
  130. %{_libdir}/*.so
  131. %{_libdir}/pkgconfig/gstreamer*.pc
  132. %{_datadir}/aclocal/*.m4
  133. %{_datadir}/gtk-doc/html/gstreamer-%{major}
  134. %{_datadir}/gtk-doc/html/gstreamer-libs-%{major}
  135. %{_datadir}/gtk-doc/html/gstreamer-plugins-%{major}
  136. %{_datadir}/gir-1.0/*.gir
  137. # compat32
  138. %if %{build_compat32}
  139. %files -n compat32-%{name}
  140. %defattr(-, root, root)
  141. %dir %{_libdir}/gstreamer-%{major}
  142. %{_libdir}/gstreamer-%{major}/*.so*
  143. %{_libdir}/*.so.*
  144. %files -n compat32-%{name}-devel
  145. %defattr(-, root, root)
  146. #{_libdir}/*.a
  147. %{_libdir}/*.so
  148. %{_libdir}/pkgconfig/gstreamer*.pc
  149. %endif
  150. %changelog
  151. * Tue Feb 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.36-1
  152. - new upstream release
  153. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.35-1
  154. - new upstream release
  155. * Sun Jan 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.32-1
  156. - new upstream release
  157. * Thu Dec 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.31-1
  158. - new upstream release
  159. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.30.2-1
  160. - new upstream release
  161. - add BuildRequires: gobject-introspection-devel
  162. - add configure option (--enable-introspection=yes)
  163. - fix %files
  164. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.10.30-2
  165. - build with rpm-4.8.1-1 for pkg-config file
  166. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.30-1
  167. - new upstream release
  168. * Sat May 01 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.29-1
  169. - new upstream release
  170. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.28-1
  171. - new upstream release
  172. - used make install instead of %%makeinstall
  173. * Sun Feb 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.26-1
  174. - new upstream release
  175. - built with new toolchain
  176. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.25-1
  177. - new upstream release
  178. * Sun Aug 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.24-1
  179. - new upstream release
  180. * Sat May 16 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.10.23-2
  181. - added compat32 package for x86_64 arch support
  182. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.23-1
  183. - new upstream release
  184. - removed static librairies from devel package
  185. - added Packager tag
  186. * Thu Mar 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.22-1
  187. - new upstream release
  188. - changed Group to System Environment/Libraries
  189. * Wed Oct 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.21-1vl5
  190. - new upstream release
  191. - spec in UTF-8
  192. * Thu Jun 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.20-1vl5
  193. - new upstream release
  194. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.19-1vl5
  195. - new upstream release
  196. * Sun Mar 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.18-1vl5
  197. - new upstream release
  198. * Sun Dec 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.15-0vl1
  199. - new upstream release
  200. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.14-0vl1
  201. - new upstream release
  202. * Sat Jun 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.13-0vl1
  203. - new upstream release
  204. * Sat Mar 10 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.12-0vl1
  205. - new upstream release
  206. - add Vendor/Distribution tag
  207. - add '-with-package-name' option to %%configure
  208. - use more macros
  209. * Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.11-0vl1
  210. - new upstream release
  211. * Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.10-0vl1
  212. - new upstream release
  213. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.9-0vl1
  214. - new upstream release
  215. * Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.8-0vl1
  216. - new upstream release
  217. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.6-0vl1
  218. - new upstream release
  219. * Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.comp> 0.10.5-0vl1
  220. - new upstream release
  221. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.4-0vl1
  222. - new upstream release
  223. * Fri Feb 10 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.3-0vl1
  224. - new upstream release
  225. * Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.2-0vl1
  226. - new upstream release
  227. * Tue Jan 17 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.10.1-0vl1
  228. - new upstream release
  229. - change major to 0.10
  230. - update URLs
  231. - update versions: glibc >= 2.8, gtk-doc >= 1.3
  232. - add BuildRequires: check >= 0.9.2, python >= 2.1, python-pyxml
  233. - remove from BuildRequires: popt, zlib-devel
  234. - remove obsolete options from %%configure
  235. - add --enable-gtk-doc to %%configure
  236. - add gtk-doc/html/gstreamer-* to gstreamer-devel package
  237. - add RELEASE to %%doc
  238. - remove REQUIREMENTS DOCBUILDING from %%doc
  239. - not exec gst-register-%%{major} at %%post
  240. * Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
  241. - new upstream release
  242. * Thu May 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
  243. - new upstream release
  244. * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
  245. - new upstream release
  246. - removed dependancy related to documentaion build
  247. * Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
  248. - new upstream release
  249. * Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
  250. - new upstream release
  251. * Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
  252. - update alpha-noWerror patch (Patch10)
  253. * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
  254. - new upstream release
  255. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  256. - new upstream release
  257. * Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
  258. - new upstream release
  259. * Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
  260. - build without -Werror on alpha (Patch10)
  261. * Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
  262. - new upstream release
  263. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
  264. - merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
  265. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
  266. - fix broken %files entries..
  267. * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
  268. - new upstream release
  269. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
  270. - build for Vine Linux
  271. * Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
  272. - Add patch1 to fix C++ plugins on ia64
  273. * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
  274. - %post -p was wrong
  275. * Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
  276. - explicitly add %{_libdir}/libgstreamer-{major}.so
  277. - explicitly add %{_libdir}/libgstcontrol-{major}.so
  278. * Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
  279. - bump release
  280. * Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
  281. - move .so files out of -devel
  282. * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
  283. - new version 0.5.0
  284. - require docbook-style-xsl
  285. - add gstreamer-tools package too
  286. - New patch to use the right docbook prefix.
  287. * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
  288. - downgrade to a release candidate. Should work better on other arches
  289. - build without Werror
  290. * Mon Dec 9 2002 Jonathan Blandford <jrb@redhat.com>
  291. - update to new version. Remove ExcludeArch
  292. * Tue Dec 3 2002 Havoc Pennington <hp@redhat.com>
  293. - excludearch some arches
  294. * Mon Dec 2 2002 Havoc Pennington <hp@redhat.com>
  295. - import into CVS and build "officially"
  296. - use smp_mflags
  297. - temporarily disable docs build, doesn't seem to work
  298. * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
  299. - 0.4.2
  300. * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
  301. - 0.4.1
  302. * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
  303. - minor cleanups
  304. * Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
  305. - moved header location
  306. * Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
  307. - added popt
  308. - removed .la
  309. * Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
  310. - added release of gstreamer to req of gstreamer-devel
  311. - changed location of API docs to be in gtk-doc like other gtk-doc stuff
  312. - reordered SPEC file
  313. * Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
  314. - moved html docs to gtk-doc standard directory
  315. * Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
  316. - move version defines of glib2 and libxml2 to configure.ac
  317. - add BuildRequires for these two libs
  318. * Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
  319. - put html docs in canonical place, avoiding %doc erasure
  320. - added devhelp support, current install of it is hackish
  321. * Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
  322. - Added documentation to build
  323. * Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
  324. - added libgstbasicscheduler
  325. - renamed libgst to libgstreamer
  326. * Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
  327. - Added configdir parameter as it seems the configdir gets weird otherwise
  328. * Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
  329. - split off gstreamer-editor from core
  330. - removed gstreamer-gnome-apps
  331. * Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
  332. - Cleaned up the spec file for the gstreamer core/plug-ins split
  333. - Improve spec file
  334. * Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
  335. - Split of more plugins from the core and put them into their own modules
  336. - Includes colorspace, xfree and wav
  337. - Improved package Require lines
  338. - Added mp3encode (lame based) to the SPEC
  339. * Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
  340. - Thomas merged mpeg plugins into one
  341. * Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
  342. - More minor cleanups including some fixed descriptions from Andrew Mitchell
  343. * Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
  344. - Added logging to the make statement
  345. * Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
  346. - Updated in preparation for 0.3.0 release
  347. * Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
  348. - Updated for 0.2.1 release
  349. - Split out the GUI packages into their own RPM
  350. - added new plugins (FLAC, festival, quicktime etc.)
  351. * Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
  352. - Visualisation plugins bundled out togheter
  353. - Moved files sections up close to their respective descriptions
  354. * Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
  355. - Split the package into separate RPMS,
  356. putting most plugins out by themselves.
  357. * Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
  358. - Updated with change suggestions from Dennis Bjorklund
  359. * Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
  360. - updated to build -devel package as well
  361. * Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
  362. - first draft of spec file