f-spot-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412
  1. Name: f-spot
  2. Version: 0.7.1
  3. Release: 1%{?_dist_release}
  4. Summary: Photo management application
  5. Summary(ja): 写真管理アプリケーション
  6. Group: Applications/Multimedia
  7. License: GPLv2+ and LGPLv2+ and CPL and MIT
  8. URL: http://f-spot.org/
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/f-spot/0.7/f-spot-%{version}.tar.bz2
  10. Patch1: f-spot-0.7.1-build-fixes.patch
  11. # unmount cameras before importing
  12. Patch3: 0002-enhance-the-f-spot-import-script.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: mono-devel mono-web mono-data mono-data-sqlite lcms-devel
  15. BuildRequires: libexif-devel gphoto2-devel >= 2.1.4
  16. BuildRequires: gtk-sharp2 libgnome-devel libgnomeui-devel
  17. BuildRequires: gtk2-devel mono-devel libjpeg-devel sqlite3-devel
  18. BuildRequires: gnome-sharp2 gnome-desktop-sharp2 gtk-sharp2-gapi
  19. BuildRequires: gconf-sharp2
  20. BuildRequires: gettext
  21. BuildRequires: autoconf, automake, libtool, intltool
  22. BuildRequires: perl-XML-Parser
  23. BuildRequires: gnome-doc-utils
  24. BuildRequires: ndesk-dbus-glib
  25. BuildRequires: mono-addins
  26. BuildRequires: desktop-file-utils
  27. BuildRequires: gnome-keyring-sharp-devel
  28. BuildRequires: unique-devel
  29. BuildRequires: flickrnet-devel
  30. Requires: sqlite3
  31. Requires: lcms
  32. Requires: dcraw
  33. Requires: hicolor-icon-theme
  34. Requires: yelp
  35. Requires(post): desktop-file-utils
  36. Requires(postun): desktop-file-utils
  37. # no mono available
  38. ExcludeArch: sparc64
  39. # Some compiler segfault on ia64:
  40. ExcludeArch: ia64
  41. # No libgphoto etc on s390
  42. ExcludeArch: s390
  43. %description
  44. F-Spot is an application designed to provide personal photo management
  45. to the GNOME desktop. Features include import, export, printing and advanced
  46. sorting and tagging of digital images.
  47. %package screensaver
  48. Summary: F-Spot gnome-screensaver plugin
  49. Summary(ja): F-Spot gnome-screensaver plugin
  50. Group: Applications/Multimedia
  51. Requires: %{name} = %{version}-%{release}
  52. Requires: gnome-screensaver
  53. Obsoletes: f-spot < 0.6.1.1
  54. %description screensaver
  55. F-Spot provides a plugin for gnome-screensaver which displays parts of the
  56. photo collection in a slideshow as a screensaver.
  57. %prep
  58. %setup -q
  59. %patch1 -p1 -b .buildfix
  60. %patch3 -p1 -b .gvfs-gphoto
  61. %build
  62. intltoolize --force --copy
  63. libtoolize --force --copy --automake
  64. aclocal -I build/m4/f-spot -I build/m4/shamrock -I build/m4/shave
  65. autoconf
  66. autoheader
  67. test -f config.h.in && touch config.h.in
  68. automake --gnu --add-missing --force --copy -Wno-portability
  69. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  70. %configure --disable-scrollkeeper
  71. make %{?_smp_mflags}
  72. %install
  73. rm -rf $RPM_BUILD_ROOT
  74. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  75. make install DESTDIR=$RPM_BUILD_ROOT
  76. rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
  77. rm $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la
  78. rm $RPM_BUILD_ROOT%{_libdir}/pkgconfig/f-spot.pc
  79. # only files marked executable are used to auto-generate the
  80. # requires/provides of the package
  81. find $RPM_BUILD_ROOT \( -name '*.exe' -or -name '*.dll' \) \
  82. -exec chmod a+x {} \;
  83. for file in $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
  84. do
  85. desktop-file-validate $file
  86. done
  87. %find_lang %name
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %pre
  91. if [ "$1" -gt 1 ]; then
  92. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  93. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
  94. fi
  95. %post
  96. update-desktop-database &> /dev/null ||:
  97. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  98. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  99. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
  100. %preun
  101. if [ "$1" -eq 0 ]; then
  102. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  103. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/f-spot.schemas > /dev/null || :
  104. fi
  105. %postun
  106. update-desktop-database &> /dev/null ||:
  107. if [ $1 -eq 0 ] ; then
  108. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  109. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  110. fi
  111. %posttrans
  112. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  113. %files -f %{name}.lang
  114. %defattr(-,root,root,-)
  115. %doc AUTHORS COPYING README NEWS
  116. %{_sysconfdir}/gconf/schemas/*
  117. %{_datadir}/applications/*.desktop
  118. %{_datadir}/gnome/help/f-spot/
  119. %{_datadir}/icons/hicolor/*/*/*.png
  120. %{_datadir}/f-spot/
  121. %dir %{_libdir}/f-spot/
  122. %{_libdir}/f-spot/*.dll
  123. %{_libdir}/f-spot/*.exe
  124. %{_libdir}/f-spot/*.addins
  125. %{_libdir}/f-spot/*.config
  126. %{_libdir}/f-spot/*.mdb
  127. %{_libdir}/f-spot/*.so
  128. %{_libdir}/f-spot/*.so.*
  129. %exclude %{_libdir}/f-spot/Extensions/FSpot.Exporters.ScreensaverConfig.dll*
  130. %{_libdir}/f-spot/Extensions/
  131. %{_bindir}/f-spot
  132. %{_bindir}/f-spot-import
  133. %{_bindir}/f-spot-sqlite-upgrade
  134. %files screensaver
  135. %defattr(-,root,root,-)
  136. %{_libdir}/f-spot/Extensions/FSpot.Exporters.ScreensaverConfig.dll
  137. %{_prefix}/libexec/gnome-screensaver/f-spot-screensaver
  138. %{_datadir}/applications/screensavers/f-spot-screensaver.desktop
  139. %changelog
  140. * Thu Aug 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.1-1
  141. - new upstream release
  142. - add patch1 to support parallel builds
  143. - add BR: unique-devel, flickrnet-devel
  144. * Sun May 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.1.5-1
  145. - initial build for Vine Linux
  146. * Mon Dec 14 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-2
  147. - Corrected the permission fix for all .exe and .dll files in order
  148. to generate the dependencies correctly (BZ 547063)
  149. * Sun Nov 08 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.5-1
  150. - Update to 0.6.1.5 (BZ 531955)
  151. - Build f-spot against system gnome-keyring-sharp library (BZ 442343)
  152. - Make all .dll and .exe files executable so that they are respected
  153. by the find-requires/find-provides scripts
  154. - Remove upstreamed patch
  155. * Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 0.6.1.3-2
  156. - ExcludeArch sparc64
  157. * Sun Oct 04 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.3-1
  158. - Update to 0.6.1.3 (BZ 526217)
  159. - Remove two upstreamed patches
  160. - Use a slightly different fix for the cairo-devel dependency
  161. (suggested by upstream)
  162. * Wed Sep 30 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-3
  163. - Add patch to fix f-spot crash when using "soft focus" and cairo-devel
  164. was not installed (BZ 526563)
  165. - Minor spec file beautification
  166. * Tue Sep 22 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-2
  167. - Add upstream patches (
  168. commit b87604bc9782bf92f053aaf3ceb739a32f44ea13
  169. commit 807dab4344ecdadc7e46793369821de8b49692e5 )
  170. to fix crash in facebook exporter (BZ 524860)
  171. * Thu Sep 17 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.2-1
  172. - Update to 0.6.1.2 (BZ 519290)
  173. * Fri Aug 28 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-2
  174. - Move the screensaver plugin into a sub-package (BZ 519640)
  175. - Let f-spot-screensaver obsolete older f-spot version so that it
  176. is pulled in during update (fresh installations of f-spot will not
  177. pull in gnome-screensaver)
  178. * Wed Aug 26 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.1.1-1
  179. - Update to 0.6.1.1
  180. - Remove upstreamed patch
  181. - Updated use-system-Mono.Addins-if-available patch
  182. - Add a patch to enable parallel build
  183. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-3
  184. - Build arch ppc64.
  185. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-2
  186. - Fix Icon Cache script in %%post section
  187. * Sun Aug 09 2009 Christian Krause <chkr@fedoraproject.org> - 0.6.0.0-1
  188. - Update to new upstream version 0.6.0.0
  189. - Cleanup spec file
  190. * Sat Jul 25 2009 Christian Krause <chkr@fedoraproject.org> - 0.5.0.3-9
  191. - Avoid showing f-spot twice for photo imports
  192. - Make f-spot-import work with gvfs
  193. - Minor indentation fix
  194. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-8
  195. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  196. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.0.3-7
  197. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  198. * Sun Feb 8 2009 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.5.0.3-6
  199. - Rebuild against new mono stack to fix broken deps
  200. * Thu Dec 4 2008 Matthias Clasen <mclasen@redhat.com> - 0.5.0.3-5
  201. - Update to 0.5.0.3
  202. * Fri Nov 21 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-8
  203. - Better URL
  204. - Tweak %%description
  205. * Tue Oct 28 2008 Orion Poplawski <orion@cora.nwra.com.com> - 0.4.4-7
  206. - Run desktop-file-validate against desktop files
  207. * Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-6
  208. - rebuild against new gnome-sharp
  209. * Thu Oct 2 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.4-5
  210. - Use a standard icon name instead of a non-existing one
  211. * Mon Jul 14 2008 Nigel Jones <dev@nigelj.com> - 0.4.4-4
  212. - Remove Tom's patch in -2, there is a gtk-sharp 2.12.1, just nobody bothered
  213. packaging it.
  214. - Patch Makefile{.in,am} to use DESTDIR for the gio-sharp.dll, this is
  215. effectively a backport of r4010 Upstream.
  216. - Patch libfspot/Makefile{.in,am} to remove -DGTK_DISABLE_DEPRECATED per
  217. recommendation of upstream.
  218. - Re-add patch to use system mono-addins
  219. - Include GIO stuff for now (until it appears in gtk-sharp)
  220. * Wed Jul 5 2008 Alex Lancaster <alexlan[AT] fedoraproject org> - 0.4.4-3
  221. - gtkhtml dependency now provided by gnome-desktop-sharp-devel
  222. rather than gnome-sharp-devel, so add as BuildRequires
  223. * Wed Jun 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-2
  224. - Fix it to not look for non-existant glib-sharp-2.12.1
  225. * Wed Jun 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4.4-1
  226. - update to 0.4.4
  227. - fix license tag
  228. * Tue May 13 2008 Matthias Clasen <mclasne@redhat.com> - 0.4.3.1-1
  229. - Update to 0.4.3.1
  230. * Tue Apr 15 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.4.2-5
  231. - Add patch from Debian to use system mono-addins (from #442343)
  232. * Sat Mar 1 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-4
  233. - Require dcraw
  234. * Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> - 0.4.2-3
  235. - Fix the build
  236. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.4.2-2
  237. - Autorebuild for GCC 4.3
  238. * Thu Feb 14 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.2-1
  239. - Update to 0.4.2
  240. * Fri Jan 18 2008 Matthias Clasen <mclasen@redhat.com> - 0.4.1-2
  241. - Add support for content-types
  242. * Thu Dec 6 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.1-1
  243. - Update to 0.4.1
  244. * Sat Nov 17 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-4
  245. - Remove comments from ExclusiveArch line (#388581)
  246. * Tue Oct 2 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-3
  247. - Add alpha to ExclusiveArch
  248. * Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 0.4.0-2
  249. - Rebuild for build ID
  250. * Sat Aug 4 2007 Matthis Clasen <mclasen@redhat.com> - 0.4.0-1
  251. - Update to 0.4.0
  252. * Mon Jul 2 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-3
  253. - Hack to get screensavers to work again (#221546)
  254. * Fri Apr 13 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-2
  255. - Now with validated desktop files!
  256. * Wed Mar 7 2007 Christopher Aillon <caillon@redhat.com> - 0.3.5-1
  257. - Update to 0.3.5
  258. * Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  259. - Update to 0.3.4
  260. * Tue Feb 13 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.3-1
  261. - Update to 0.3.3
  262. * Tue Jan 23 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  263. - Update to 0.3.2
  264. * Fri Oct 20 2006 Christopher Aillon <caillon@redhat.com> - 0.2.2-1
  265. - Update to 0.2.2
  266. * Mon Oct 16 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.1-2
  267. - Fix a directory ownership issue (#211009)
  268. * Wed Sep 13 2006 Christopher Aillon <caillon@redhat.com> - 0.2.1-1
  269. - Update to 0.2.1
  270. * Tue Sep 12 2006 Matthias Clasen <mclasen@redhat.com> - 0.2.0-2
  271. - Add libgphoto2_port version to dll config (#205302)
  272. * Mon Sep 4 2006 Christopher Aillon <caillon@redhat.com> - 0.2.0-1
  273. - Update to 0.2.0
  274. * Fri Aug 18 2006 Alexander Larsson <alexl@redhat.com> - 0.1.11-5
  275. - Rebuild with new mono and gtk-sharp2
  276. * Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 0.1.11-4
  277. - Fix dbus-sharp BR
  278. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.1.11-3.1
  279. - rebuild
  280. * Sun Jun 24 2006 Jesse Keating <jkeating@redhat.com> 0.1.11-3
  281. - Add missing BR gettext
  282. * Wed May 31 2006 Alexander Larsson <alexl@redhat.com> 0.1.11-2
  283. - Rebuild for gmime update
  284. * Fri Mar 17 2006 Christopher Aillon <caillon@redhat.com> 0.1.11-1
  285. - Update to 0.1.11
  286. * Fri Feb 24 2006 Christopher Aillon <caillon@redhat.com> 0.1.10-1
  287. - Update to 0.1.10
  288. * Tue Feb 21 2006 Karsten Hopp <karsten@redhat.de> 0.1.9-2
  289. - add BuildRequires libgnome-devel libgnomeui-devel
  290. gtk2-devel mono-devel libjpeg-devel sqlite-devel
  291. * Fri Feb 17 2006 Christopher Aillon <caillon@redhat.com> - 0.1.9-1
  292. - Update to 0.1.9
  293. * Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-3
  294. - Rebuild
  295. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.8-2.1
  296. - rebuilt for new gcc4.1 snapshot and glibc changes
  297. * Wed Feb 1 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-2
  298. - Add sqlite3.patch to ensure that sqlite3 is used if both
  299. sqlite2 and sqlite3 are installed.
  300. * Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 0.1.8-1
  301. - Update to 0.1.8
  302. - Use sqlite3 instead of sqlite2
  303. * Tue Jan 31 2006 Ray Strode <rstrode@redhat.com> - 0.1.5-3
  304. - don't blindly run f-spot from current working directory
  305. (bug 177407)
  306. * Tue Jan 10 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-2
  307. - Add lcms depencency
  308. * Mon Jan 9 2006 Alexander Larsson <alexl@redhat.com> - 0.1.5-1
  309. - Update to 0.1.5
  310. * Thu Dec 8 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-3
  311. - Use sqlite2 to avoid problems with beagle
  312. * Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 0.1.3-2
  313. - Make exes and dlls executable to pick up dependencies
  314. - Remove .a and .la files
  315. * Wed Nov 16 2005 Alexander Larsson <alexl@redhat.com> - 0.1.3-1
  316. - Initial version