git-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719
  1. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  2. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  3. # Pass --without docs to rpmbuild if you don't want the documentation
  4. Name: git
  5. Version: 1.7.1
  6. Release: 2%{?_dist_release}
  7. Summary: Core git tools
  8. Summary(ja): Core git ツール
  9. License: GPLv2
  10. Group: Development/Tools
  11. URL: http://git-scm.com/
  12. Source: http://kernel.org/pub/software/scm/git/%{name}-%{version}.tar.bz2
  13. Source1: git-init.el
  14. Source2: git.xinetd
  15. Source3: git.conf.httpd
  16. Source10: %{name}-install.sh
  17. Source11: %{name}-remove.sh
  18. Patch0: git-1.5-gitweb-home-link.patch
  19. # Patch10: git-1.6_git-daemon-fix.patch
  20. # Security
  21. Patch100: git-1.7.x-CVE-2010-2542.patch
  22. BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel,
  23. BuildRequires: expat-devel, gettext, asciidoc
  24. BuildRequires: xmlto
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  26. Requires: perl-Git = %{version}-%{release}
  27. Requires: zlib
  28. Provides: git-core = %{version}-%{release}
  29. Obsoletes: git-core <= 1.5.4.3
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. # Packager:
  33. %description
  34. Git is a fast, scalable, distributed revision control system with an
  35. unusually rich command set that provides both high-level operations
  36. and full access to internals.
  37. The git rpm installs the core tools with minimal dependencies. To
  38. install all git packages, including tools for integrating with other
  39. SCMs, install the git-all meta-package.
  40. %package all
  41. Summary: Meta-package to pull in all git tools
  42. Summary(ja): すべての git ツール
  43. Group: Development/Tools
  44. Requires: git = %{version}-%{release}
  45. Requires: git-svn = %{version}-%{release}
  46. Requires: git-cvs = %{version}-%{release}
  47. %if "%{?_dist_release}" != "vl4"
  48. Requires: git-arch = %{version}-%{release}
  49. %endif
  50. Requires: git-email = %{version}-%{release}
  51. Requires: gitk = %{version}-%{release}
  52. Requires: git-gui = %{version}-%{release}
  53. Requires: perl-Git = %{version}-%{release}
  54. Requires: emacs-git = %{version}-%{release}
  55. Obsoletes: git <= 1.5.4.3
  56. %description all
  57. Git is a fast, scalable, distributed revision control system with an
  58. unusually rich command set that provides both high-level operations
  59. and full access to internals.
  60. This is a dummy package which brings in all subpackages.
  61. %package daemon
  62. Summary: Git protocol daemon
  63. Summary(ja): Git プロトコルデーモン
  64. Group: Development/Tools
  65. Requires: git = %{version}-%{release}
  66. %description daemon
  67. The git daemon for supporting git:// access to git repositories
  68. %package -n gitweb
  69. Summary: Simple web interface to git repositories
  70. Summary(ja): git リポジトリへのシンプルな Web インタフェース
  71. Group: Development/Tools
  72. Requires: git = %{version}-%{release}
  73. %description -n gitweb
  74. Simple web interface to track changes in git repositories
  75. %package svn
  76. Summary: Git tools for importing Subversion repositories
  77. Summary(ja): Subversion リポジトリを git へインポートするためのツール
  78. Group: Development/Tools
  79. Requires: git = %{version}-%{release}, subversion, perl(Term::ReadKey)
  80. Requires: perl(SVN::Core)
  81. %description svn
  82. Git tools for importing Subversion repositories.
  83. %package cvs
  84. Summary: Git tools for importing CVS repositories
  85. Summary(ja): CVS リポジトリを git へインポートするためのツール
  86. Group: Development/Tools
  87. Requires: git = %{version}-%{release}, cvs, cvsps
  88. %description cvs
  89. Git tools for importing CVS repositories.
  90. %if "%{?_dist_release}" != "vl4"
  91. %package arch
  92. Summary: Git tools for importing Arch repositories
  93. Summary(ja): Arch リポジトリを git へインポートするためのツール
  94. Group: Development/Tools
  95. Requires: git = %{version}-%{release}, tla
  96. %description arch
  97. Git tools for importing Arch repositories.
  98. %endif
  99. %package email
  100. Summary: Git tools for sending email
  101. Summary(ja): Eメールを送るための git ツール
  102. Group: Development/Tools
  103. Requires: git = %{version}-%{release}, perl-Git = %{version}-%{release}
  104. %description email
  105. Git tools for sending email.
  106. %package gui
  107. Summary: Git GUI tool
  108. Summary(ja): Git の GUI ツール
  109. Group: Development/Tools
  110. Requires: git = %{version}-%{release}, tk
  111. %description gui
  112. Git GUI tool.
  113. %package -n gitk
  114. Summary: Git revision tree visualiser
  115. Summary(ja): Git リビジョンツリー可視化ツール
  116. Group: Development/Tools
  117. Requires: git = %{version}-%{release}, tk
  118. %description -n gitk
  119. Git revision tree visualiser.
  120. %package -n perl-Git
  121. Summary: Perl interface to Git
  122. Summary(ja): Git の perl インタフェース
  123. Group: Development/Libraries
  124. Requires: git = %{version}-%{release}, perl(Error)
  125. %if "%{?_dist_release}" == "vl4"
  126. Requires: perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
  127. %else
  128. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  129. %endif
  130. #BuildRequires: perl(Error), perl(ExtUtils::MakeMaker)
  131. %description -n perl-Git
  132. Perl interface to Git.
  133. %package -n emacs-git
  134. Summary: Git version control system support for Emacs
  135. Summary(ja): Emacs の Git サポート
  136. Group: Applications/Editors
  137. Requires: git = %{version}-%{release}, emacsen-common
  138. %description -n emacs-git
  139. %{summary}.
  140. %package devel
  141. Summary: Header files for git-core
  142. Summary(ja): git-core 用ヘッダファイル
  143. Group: Development/Libraries
  144. %description devel
  145. Header files for git-core.
  146. %prep
  147. %setup -q
  148. %patch0 -p1
  149. # %patch10 -p1 -b .git-daemon-fix
  150. %patch100 -p1 -b .CVE-2010-2542
  151. %build
  152. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" \
  153. ETC_GITCONFIG=/etc/gitconfig \
  154. prefix=%{_prefix} all %{!?_without_docs: doc}
  155. %install
  156. rm -rf $RPM_BUILD_ROOT
  157. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
  158. prefix=%{_prefix} mandir=%{_mandir} \
  159. ETC_GITCONFIG=/etc/gitconfig \
  160. NO_PYTHON=1 \
  161. INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
  162. # perl-Git
  163. # Error.pm provide by perl-Error package
  164. rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
  165. # emacs-git
  166. mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
  167. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
  168. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
  169. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  170. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  171. # install el files
  172. install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  173. # install site-start file
  174. install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  175. # install script( bytecompile el and install elc , remove )
  176. %_installemacsenscript git %{SOURCE10}
  177. %_removeemacsenscript git %{SOURCE11}
  178. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
  179. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
  180. mkdir -p $RPM_BUILD_ROOT/var/www/git
  181. install -m 644 -t $RPM_BUILD_ROOT/var/www/git gitweb/*.png gitweb/*.css
  182. install -m 755 -t $RPM_BUILD_ROOT/var/www/git gitweb/gitweb.cgi
  183. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
  184. install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
  185. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  186. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  187. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  188. (find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
  189. (find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
  190. %if %{!?_without_docs:1}0
  191. (find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
  192. %else
  193. rm -rf $RPM_BUILD_ROOT%{_mandir}
  194. %endif
  195. mkdir -p $RPM_BUILD_ROOT/srv/git
  196. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
  197. install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
  198. # header files and lib
  199. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  200. install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
  201. install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  202. install libgit.a $RPM_BUILD_ROOT%{_libdir}
  203. install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
  204. %clean
  205. rm -rf $RPM_BUILD_ROOT
  206. %post -n emacs-git
  207. # bytecompile and install
  208. if [ "$1" = 2 ]; then
  209. %_emacsenPackageRemove git
  210. fi
  211. %_addemacsenlist git
  212. %_emacsenPackageInstall git
  213. %preun -n emacs-git
  214. if [ "$1" = 0 ]; then
  215. %_emacsenPackageRemove git
  216. %_removeemacsenlist git
  217. fi
  218. %files -f bin-man-doc-files
  219. %defattr(-,root,root)
  220. %{_bindir}/git
  221. %{_bindir}/git-receive-pack
  222. %{_bindir}/git-upload-archive
  223. %{_bindir}/git-upload-pack
  224. %{_bindir}/git-shell
  225. %{_datadir}/git-core/
  226. %doc README COPYING Documentation/*.txt contrib/hooks
  227. %{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
  228. %{!?_without_docs: %doc Documentation/howto Documentation/technical}
  229. %{_sysconfdir}/bash_completion.d
  230. %files svn
  231. %defattr(-,root,root)
  232. %{_libexecdir}/git-core/*svn*
  233. %doc Documentation/*svn*.txt
  234. %{!?_without_docs: %{_mandir}/man1/*svn*.1*}
  235. %{!?_without_docs: %doc Documentation/*svn*.html }
  236. %files cvs
  237. %defattr(-,root,root)
  238. %doc Documentation/*git-cvs*.txt
  239. %{_bindir}/git-cvsserver
  240. %{_libexecdir}/git-core/*cvs*
  241. %{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
  242. %{!?_without_docs: %doc Documentation/*git-cvs*.html }
  243. %if "%{?_dist_release}" != "vl4"
  244. %files arch
  245. %defattr(-,root,root)
  246. %doc Documentation/git-archimport.txt
  247. %{_libexecdir}/git-core/git-archimport
  248. %{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
  249. %{!?_without_docs: %doc Documentation/git-archimport.html }
  250. %endif
  251. %files email
  252. %defattr(-,root,root)
  253. %doc Documentation/*email*.txt
  254. %{_libexecdir}/git-core/*email*
  255. %{!?_without_docs: %{_mandir}/man1/*email*.1*}
  256. %{!?_without_docs: %doc Documentation/*email*.html }
  257. %files gui
  258. %defattr(-,root,root)
  259. %{_libexecdir}/git-core/git-gui*
  260. %{_libexecdir}/git-core/git-citool
  261. %{_datadir}/git-gui/
  262. %{!?_without_docs: %{_mandir}/man1/git-gui.1*}
  263. %{!?_without_docs: %doc Documentation/git-gui.html}
  264. %{!?_without_docs: %{_mandir}/man1/git-citool.1*}
  265. %{!?_without_docs: %doc Documentation/git-citool.html}
  266. %files -n gitk
  267. %defattr(-,root,root)
  268. %doc Documentation/*gitk*.txt
  269. %{_bindir}/gitk
  270. %{_datadir}/gitk
  271. %{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
  272. %{!?_without_docs: %doc Documentation/*gitk*.html }
  273. %files -n perl-Git -f perl-files
  274. %defattr(-,root,root)
  275. %files -n emacs-git
  276. %defattr(-,root,root)
  277. %{_datadir}/emacs/site-lisp/git
  278. #%{_libdir}/emacsen-common/packages/install/git
  279. #%{_libdir}/emacsen-common/packages/remove/git
  280. %{emacsen_pkgdir}/install/git
  281. %{emacsen_pkgdir}/remove/git
  282. %files daemon
  283. %defattr(-,root,root)
  284. %{_libexecdir}/git-core/git-daemon
  285. %config(noreplace)%{_sysconfdir}/xinetd.d/git
  286. /srv/git
  287. %files -n gitweb
  288. %defattr(-,root,root)
  289. /var/www/git/
  290. %config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
  291. %files devel
  292. %defattr(644,root,root,755)
  293. %{_includedir}/git
  294. %{_libdir}/libgit.a
  295. %{_libdir}/libgit_xdiff.a
  296. %files all
  297. # No files for you!
  298. %changelog
  299. * Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
  300. - add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
  301. * Wed Jun 9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
  302. - new upstream release
  303. - fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
  304. - disable building of unused python remote helper libs
  305. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
  306. - new upstream release with security fix
  307. - drop patch10 (included in new release)
  308. * Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
  309. - new upstream release
  310. - add patch10 git daemon extra arg parsing fix
  311. * Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
  312. - fix install script for Emacs Lisp: <BTS:VineLinux:685>
  313. - update git-install.sh (Source10) using contributed patch
  314. * Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
  315. - new upstream release
  316. * Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
  317. - delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
  318. - spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
  319. - fix summary and description in daemon sub package
  320. * Sun Feb 1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
  321. - drop Error.pm: provide by perl-Error package
  322. * Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
  323. - new upstream relase
  324. - update URL tag
  325. - add Requires: perl(SVN::Core) for svn subpackage
  326. * Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
  327. - add git-shell in git package
  328. - do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
  329. * Mon Jan 5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
  330. - added BuildRequires: xmlto
  331. * Mon Jan 5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
  332. - new upstream release
  333. - add devel subpackage (see [wishes:0165])
  334. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
  335. - new upstream release
  336. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
  337. - new upstream release
  338. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
  339. - new upstream release
  340. * Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
  341. - use %%emacsen_pkgdir macro
  342. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  343. - new upstream release
  344. * Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6.4-1
  345. - initial build for Vine Linux
  346. * Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
  347. - git-1.5.6.4
  348. * Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
  349. - git-1.5.6
  350. * Tue Jun 3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
  351. - use tar.bz2 instead of tar.gz
  352. * Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
  353. - git-1.5.5.3
  354. * Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
  355. - git-1.5.5.2
  356. * Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
  357. - git-1.5.5.1
  358. * Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
  359. - git-1.5.5
  360. * Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
  361. - Remove the last two requires on git-core.
  362. * Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
  363. - Remove a patch that's already upstream.
  364. * Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
  365. - git-1.5.4.5
  366. * Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
  367. - Own /etc/bash_completion.d in case bash-completion isn't installed.
  368. * Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
  369. - Include the sample hooks from contrib/hooks as docs (bug 321151).
  370. - Install the bash completion script from contrib (bug 433255).
  371. - Include the html docs in the 'core' package again (bug 434271).
  372. * Wed Mar 19 2008 James Bowes 1.5.4.4-2
  373. - Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
  374. * Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
  375. - git-1.5.4.4
  376. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
  377. - rebuild for new perl (again)
  378. * Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
  379. - Do not silently overwrite /etc/httpd/conf.d/git.conf
  380. * Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
  381. - git-1.5.4.3
  382. - Include Kristian Høgsberg's changes to rename git-core to
  383. git and git to git-all.
  384. * Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
  385. - git-1.5.4.2
  386. * Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
  387. - Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
  388. gitweb rss feeds point be commitdiffs instead of commit
  389. * Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
  390. - git-1.5.4.1
  391. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
  392. - rebuild for new perl
  393. * Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  394. - Add BuidRequires on gettext.
  395. * Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  396. - git-1.5.4
  397. * Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
  398. - git-1.5.3.8
  399. * Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
  400. - Have git metapackage require explicit versions (bug 247214)
  401. * Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
  402. - git-1.5.3.7
  403. * Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
  404. - git-1.5.3.6
  405. - git-core requires perl(Error) (bug 367861)
  406. - git-svn requires perl(Term:ReadKey) (bug 261361)
  407. - git-email requires perl-Git (bug 333061)
  408. * Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
  409. - git-Perl requires Error package
  410. * Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
  411. - git-1.5.3.4
  412. * Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
  413. - git-1.5.3.3
  414. * Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
  415. - git-1.5.3.2
  416. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
  417. - Include git-gui and git-citool docs
  418. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
  419. - git-1.5.3.1-1
  420. * Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
  421. - git-1.5.2.5-1
  422. * Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
  423. - git-1.5.2.4-1
  424. * Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
  425. - Add git-daemon and gitweb packages
  426. * Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
  427. - Add emacs-git package (#235431)
  428. * Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
  429. - git-1.5.2.2
  430. * Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
  431. - git-1.5.2.1
  432. * Tue May 13 2007 Quy Tonthat <qtonthat@gmail.com>
  433. - Added lib files for git-gui
  434. - Added Documentation/technical (As needed by Git Users Manual)
  435. * Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
  436. - Added howto files
  437. * Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
  438. - git-1.5.0.6
  439. * Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
  440. - git-1.5.0.5
  441. * Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
  442. - git-1.5.0.3
  443. * Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
  444. - BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
  445. * Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
  446. - git-1.5.0.2
  447. * Mon Feb 13 2007 Nicolas Pitre <nico@cam.org>
  448. - Update core package description (Git isn't as stupid as it used to be)
  449. * Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
  450. - Add git-gui and git-citool.
  451. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
  452. - no need to install manpages executable (bz 216790)
  453. - use bytes for git-cvsserver
  454. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
  455. - git-1.4.4.2
  456. * Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
  457. - rebuild against the new curl
  458. * Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
  459. - git-1.4.2.4
  460. * Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
  461. - git-1.4.2.3
  462. * Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
  463. - git-1.4.2.1
  464. * Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
  465. - git-1.4.2
  466. * Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
  467. - git-1.4.1
  468. * Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
  469. - git-1.4.0
  470. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
  471. - git-1.3.3
  472. - enable git-email building, prereqs have been relaxed
  473. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
  474. - git-1.3.2
  475. * Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
  476. - git-1.3.1
  477. * Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
  478. - git-1.3.0
  479. * Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
  480. - git-1.2.6
  481. * Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
  482. - git-1.2.5
  483. * Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
  484. - git-1.2.4
  485. * Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
  486. - git-1.2.3
  487. * Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
  488. - git-1.2.2
  489. * Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
  490. - git-1.2.1
  491. * Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
  492. - git-1.2.0
  493. * Tue Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
  494. - git-1.1.6
  495. * Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
  496. - git-1.1.4
  497. * Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
  498. - git-1.1.2
  499. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
  500. - git-1.1.1
  501. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
  502. - Update to latest git-1.1.0 (drop git-email for now)
  503. - Now creates multiple packages:
  504. - git-core, git-svn, git-cvs, git-arch, gitk
  505. * Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
  506. - Change subpackage names to git-<name> instead of git-core-<name>
  507. - Create empty root package which brings in all subpackages
  508. - Rename git-tk -> gitk
  509. * Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
  510. - zlib dependency fix
  511. - Minor cleanups from split
  512. - Move arch import to separate package as well
  513. * Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
  514. - Move programs with non-standard dependencies (svn, cvs, email)
  515. into separate packages
  516. * Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
  517. - parallelize build
  518. - COPTS -> CFLAGS
  519. * Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
  520. - update to 0.99.6
  521. * Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  522. - Linus noticed that less is required, added to the dependencies
  523. * Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  524. - Updated dependencies
  525. - Don't assume manpages are gzipped
  526. * Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
  527. - drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
  528. - use RPM_OPT_FLAGS in spec file, drop patch0
  529. * Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
  530. - use dist tag to differentiate between branches
  531. - use rpm optflags by default (patch0)
  532. - own %{_datadir}/git-core/
  533. * Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
  534. - update spec file to fix Buildroot, Requires, and drop Vendor
  535. * Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  536. - Redid the description
  537. - Cut overlong make line, loosened changelog a bit
  538. - I think Junio (or perhaps OSDL?) should be vendor...
  539. * Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
  540. - Add the man pages, and the --without docs build option
  541. * Wed Jul 7 2005 Chris Wright <chris@osdl.org>
  542. - initial git spec file